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RS Automation 

X8 Series  

X8_Xnet Serial 
 Supported version TOP Design Studio V1.0 or higher  

 

 

CONTENTS 

We would like to thank our customers for using M2I's "Touch 

Operation Panel (M2I TOP) Series". Read this manual and familiarize 

yourself with the connection method and procedures of the “TOP and 

external device”. 

 

 

 

1. System configuration Page 2 

 

 

Describes the devices required for connection, the setting of 

each device, cables, and configurable systems. 

2. External device selection  Page 3 

 Select a TOP model and an external device. 

3. TOP communication setting Page 4 

 Describes how to set the TOP communication. 

4. External device setting Page 9 

 Describes how to set up communication for external devices. 

5. Cable table Page 10 

 Describes the cable specifications required for connection. 

6. Supported addresses Page 11 

 Refer to this section to check the addresses which can 

communicate with an external device. 
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1. System configuration 

The system configuration of TOP and “RS Automation – X8 Series” is as follows: 
 

Series CPU Link I/F 
Communication 

method 
System setting Cable 

X8 

X8-M32DDT 

X8-M14DDT 

X8-M16DDR 

CPU Port 

 

RS–232C 

 

3.1 Settings example 1 

(Page 4) 

5.1. Cable table 1 

(Page 5) 

 

RS–485 

(2 wire) 

 

3.2 Settings example 2 

(Page 4) 

5.1. Cable table 2 

(Page 5) 

 

■ Connection configuration 
 

ㆍ1:1 (one TOP and one external device) connection – configuration which is possible in RS232C/485 communication. 

 

ㆍ1:N (one TOP and multiple external devices) connection – configuration which is possible in RS422 communication. 

 

ㆍN:1 connection (multiple TOPs and one external device) connection – configuration which is possible in RS422 MultiLink 

communication. 

 



 

 External device connection manual for TOP Design Studio 3 / 11 

2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 
 

 

Settings Contents 

TOP Model Check the TOP display and process to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Select “RS Autoamtion”. 

PLC Select an external device to connect to TOP. 
 

Select “X8 Xnet”.  

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [Project > Project Property > TOP Setting] → [Project Option > “Use HMI Setup” Check > Edit > Serial] 

– Set the TOP communication interface in TOP Design Studio. 

 
 

 
 

Items TOP External device Remarks 

Signal Level (port) RS-232C RS-422 RS-485 
RS-232C 

RS-422/485 
 

Baud Rate 115200  

Data Bit 8  

Stop Bit 1  

Parity Bit none  

* The above settings are examples recommended by the company. 

 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [Project > Project Property > Device Setting > COM > “PLC1 : X8 Series”] 

– Set the options of the RS Automation X8 Series communication interface in TOP Design Studio. 

 

 

Items Settings Remarks 

Interface Select “Serial”. 
Fixed 

Protocol Select the serial communication protocol between the TOP and an external device. 

TimeOut Set the time for the TOP to wait for a response from an external device.  

SendWait Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
 

PLC Node address Configure the external device node.  

HMI Node address Configure the TOP node.  
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3.2. Communication setting in TOP  

* This is a setting method when "Use HMI Setup" in the setting items in "3.1 TOP Design Studio" is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

   

(1) Communication interface setting 

■ [Main Screen > Control Panel > Serial] 
 

 

Items TOP External device Remarks 

Signal Level (port) 
RS-232C RS-422 RS-485 

RS-232C 

RS-422/485 
 

Baud Rate 115200  

Data Bit 8  

Stop Bit 1  

Parity Bit none  

* The above settings are setting examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device. 

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [Main Screen > Control Panel > PLC] 
 

 

Items Settings Remarks 

Interface Select “Serial”. 
Fixed 

Protocol Select the serial communication protocol between the TOP and an external device. 

TimeOut Set the time for the TOP to wait for a response from an external device.  

SendWait Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
 

PLC Node address Configure the external device node.  

HMI Node address Configure the TOP node.  
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch "Communication diagnostics" in [Control Panel > PLC]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  

OK NG 

6. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 
 

Set as below using “X8 Series Ladder Software XGPC”. 

Reboot the external device after downloading the configuration 

For a more detailed setting method than described in this example, refer to the user manual of the external device. 
 

 
Check the node address and line control method. 

 

Step 1. Upload the PC and XGPC S/W. 

 

Step 2.  From the tool bar left of the XGPC S/W, double click Channel Configuration. 

       ( X8-M Toolbar → ‘Comms Config’ → ‘Channel Configuration’ ) 

 

 

 

 

 

 

 

 

 

 

 

 

 

Step 3.  From the Channel Configuration window, configure the Parameter.  

      ▣ Channel Configuration Settings : Xnet Slave 

       ▣ Port Config  

       - Buadrate : 115.2K 

       - Parity : NONE 

       - Stop Bits : 1 

       - Data Bits : 8 

       - Line Control: No Handshaking (During RS 232 communication) 

       ▣ Protocol Control 

       - Node Address : 1 (PLC node number) 

        - Duplicate Packet Detect : Detect 

       - Pre Transmit Delay (x1 ms) : 0 

 

 

        

         Check the above information and press confirm. 

 

Step 4.  From the top tool bar go to ‘Online’ → Click ‘Download’. 
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5. Cable table 

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. 

(The cable diagram described in this section may differ from the recommendations of “RS Automation X8 Series”) 
 

5.1. Cable table 1 

■ RS-232C (1:1 connection) 

(A) TOP COM Port (9 pin) 

TOP COM 

Cable connection 

“X8 Series” 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

CD 1  1 CD 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin female 

(male, convex) 

RD 2 2 RD 

SD 3 3 SD 

DTR 4 4 485P+ 

SG 5 5 SG 

DSR 6 6 485N- 

RTS 7 7 RTS 

CTS 8 8 CTS 

NC 9 9 NC 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

■  RS-485 (connection) 

 

(B) TOP COM Port (9 pin) 

TOP COM 

Cable connection 

“X8 Series” 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  1 CD 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin female 

(male, convex) 

 2 2 RD 

 3 3 SD 

RDB 4 4 485P+ 

 5 5 SG 

SDA 6 6 485N- 

 7 7 RTS 

 8 8 CTS 

SDB 9 9 NC 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

■ RS-485 (1:1 connection) 

COM 

Cable connection 

External device 

Pin arrangement 
Signal 

name 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

+  1 CD 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin female 

(male, convex) 

- 2 RD 

SG 3 SD 

 4 485P+ 

 5 SG 

 6 485N- 

 7 RTS 

 8 CTS 

 9 NC 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 
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6. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

 

Contents Bit Address Word Address 32 Bit Remarks 

Input X 1.0.0.0 ~ 1.1535.0.15 1.0.0 ~ 1.1535.0   

Output Y 0.0.0.0 ~ 0.1535.0.15 0.0.0 ~ 0.1535.0   

Input(by slot) X(by slot) 1.0.0.0 ~ 1:96.511.15 1.0.0 ~ 1.96.511  *Note 1) 

Output(by slot) Y(by slot) 0.0.0.0 ~ 0.96.511.15 0.0.0 ~ 0.96.511  *Note 1) 

System Register SR 2.0.0.0 ~ 2.127.0.15 2.0.0 ~ 2.127.0   

Binary B 3.0.0.0 ~ 1535.1535.0.15 3.0.0 ~ 1535.1535.0   

Integer N 3.0.0.0 ~ 1535.1535.0.15 3.0.0 ~ 1535.1535.0   

Floating Point F – 3.0.0 ~ 1535.1535.0   

Long L 3.0.0.0 ~ 1535.1535.0.15 3.0.0 ~ 1535.1535.0   

ASCII A 3.0.0.0 ~ 1535.1535.0.15 3.0.0 ~ 1535.1535.0   

String ST – 3.0.0 ~ 1535.799.41   

Timer TM 3.0.0.0 ~ 1535.1535.4.15 3.0.0 ~ 1535.1535.4  *Note 2) 

Timer Preset TM Preset 3.0.1.0 ~ 1535.1535.1.31 3.0.1 ~ 1535.1535.1 ∨  

Timer Accumulator TM Accumulator 3.0.3.0 ~ 1535.1535.3.31 3.0.3 ~ 1535.1535.3 ∨  

Counter CT 3.0.0.0 ~ 1535.1535.4.15 3.0.0 ~ 1535.1535.4  *Note 3) 

Counter Preset CT Preset 3.0.1.0 ~ 1535.1535.1.31 3.0.1 ~ 1535.1535.1 ∨  

Counter Accumulator CT Accumulator 3.0.3.0 ~ 1535.1535.3.31 3.0.3 ~ 1535.1535.3 ∨  

Control CR 3.0.0.0 ~ 1535.1535.4.15 3.0.0 ~ 1535.1535.4  *Note 4) 

Control Length CR Length 3.0.1.0 ~ 1535.1535.1.31 3.0.1 ~ 1535.1535.1   

Control Position CR Position 3.0.3.0 ~ 1535.1535.3.31 3.0.3 ~ 1535.1535.3   

 

*Note 1) X (by slot), Y (by slot) Device Format 

Ex) Configurations for 1, 2, 3, and 4 of X (by slot) are as follows: (Same for Y (by slot).) 

Notation X 1 .2 .3 .4 

Description Device Name Table Address Slot Number Word Offset Bit Position 

 

*Note 2) TM Address Details 

Details for each bit of the 16 bit data of the TM address are as follows. 

8th Bit 9th Bit 13th Bit 14th Bit 15th Bit 

Time Base 0 Time Base 1 Done Timer Timing Enable 

 

*Note 3) CT Address Details 

Details for each bit of the 16 bit data of the CT address are as follows. 

11th Bit 12th Bit 13th Bit 14th Bit 15th Bit 

Underflow Overflow Done Count Down Count Up 

 

*Note 4) CR Address Details 

Details for each bit of the 16 bit data of the CR address are as follows. 

8th Bit 9th Bit 10th Bit 11th Bit 

Found Inhibit Unload Error 

12th Bit 13th Bit 14th Bit 15th Bit 

Empty Done Enable. Unload Enable 

 

 


