KEYENCE.
KV Series Loader

Serial Driver

Supported version  TOP Design Studio V1.0 or higher {Rl

TOP

"

CONTENTS

We would like to thank our customers for using M2l's "Touch

Operation Panel (M2 TOP) Series". Read this manual and familiarize
yourself with the connection method and procedures of the "TOP and

external device”.

1. System configuration Page 2

Describes the devices required for connection, the setting of

each device, cables, and configurable systems.

2. External device selection Page 3

‘ Select a TOP model and an external device.

3. TOP communication setting Page 4

Describes how to set the TOP communication.

4. External device setting Page 9

Describes how to set up communication for external devices.

5. Cable table Page 10

Describes the cable specifications required for connection.

6. Supported addresses Page 11

Refer to this section to check the addresses which can

communicate with an external device.
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1. System configuration

The system configuration of TOP and “Keyence KV Series Loader” is as follows:

Link I/F Communication method Communication setting
KV-700 o
. 3. TOP communication
. KV-1000 series -
KV Series . o setting
KV-3000 series Built-in RS-232C port RS-232C ) 5.1. Cable table 1
Loader 4. External device

KV-5000 series

settin
KV-7000 series =

W Connection configuration

+ 1:1 (one TOP and one external device) connection
k[=1.]

=
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device H
PLC select [COM1]
Filter : |[AII] v‘ Search : I:I
@ Model (O Vendor
Vendor Model

T (0 e
Digital Electronics C i &,
gital Hectronics Corporation '4' Kv-700/1000//3000/5000/7000/8000

HONEYWELL
Barcode Reader BL Series

MISUMI
& KV NANO Series

PARKER HAMMIFIN Corporation
TOSHIBA

ATLAS COPCO

TOSHIBA MACHINE Co., Ltd
GREEN POWER

ROOTECH

CKD Carparation

CSCAM

IDEC Corporation

HAWF HYDR AL TK &

4_Back | B Next *® Cancel

Select Device n

PLC Setting[ KV-700/1000/3000/5000/7000/3000 ]

Alizs Mame @ |PLCL

Interface : | CPU Direct ~

Protocol : | CPU Direct ~ Comm Manual
String Save Mode : |First LH HL Change

[ use Redundancy
AND v

Primary Option

Timeout 300 &|| msec
Send Wait msec
Retry 5 -

@ Back + OK * Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.

External device | Vendor

Select the vendor of the external device to be connected to TOP.
Select "KEYENCE > KV Series Loader".

PLC

Select an external device to connect to TOP.

Interface Protocol

KEYENCE KV Series Loader Serial CPU Direct

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting
M [Project > Project Property > TOP Setting] — [Project Option > “"Use HMI Setup” Check > Edit > Serial]

— Set the TOP communication interface in TOP Design Studio.

Project Option

I crenoe Hi

W AadPc ST Change PLCIC]

l ~ [} TOP Setting I

~ -l Option Module Setting
: W FieldBus (0)
- RFID (0)
W -igg Device Setting
v g COM1(1)

--fg¥ COM2 (0)
~-fg® COM3 (0)

- Ethernet (0)
g Wireless (0}
-l USBDevice (0)

-~ PLC1 : KV-700/1000/3000|

E] Delete PLCDI

Date [ Time Sync.

Screen Option

Screen Change

HmiSetup

Unit Convert

Global Lock & Touch

Project Style

Splash  PLC Buffer Sync.

Initialization

Edit |

Project Setting

HMIDisable=0

Project Name=Mew project
Start Mode=Menu

Start Screen No. =1

Latch Use=0

Latch Set=0~0

Communication Error Message =0
USBErrorMessage =0

-

Control Panel

System mnevices @Service =* Option

—
[re—r—— ———— o Serjal =
1l y (™
PLC Security Date/Tine Serial Port:  COMI T
Signal Level
(®) R5-232C (O R5-422(4) (O RS-485(2)
L |
E Baud Rate: 115200 <
'- o
(L - :
Data Bit: 8 S
Et hernet Serial HOk | i
Stop Bit: |1 S
— Parity Bit: MNone -
Sl % Flow: |0ff
L _A . Ping
; ; e 1 Auto Search |Loopback Test
Diagnost ic File Ping
Manager
Apply | Cancel
Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C
Baud Rate 115200
Data Bit 8
Stop Bit 1
Parity Bit Even

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [ Project > Project Property > Device Setting > COM > PLC1: KV Series Loader]

Set the options of the communication driver in TOP Design Studio.

ERI2 e B X
Touch Qperation Panel

Praject Option

-Change HMIH]

’ Add PLC [A] "n Change PICIC] | [I] Delete PLCID]

v - TOP Setting
| L[} SYS :RD0820S

-l FieldBus (0)

& RFID (0)

v gy Device Setting
v 158 COM1 (1)

=® COM2 (1)

+® COM3 (0)
48 Ethernet (0)
% Wireless (0)
W8 USBDevice (0)

8 Option Module Setting

g PLCY : KV-700/1000/3000

PLC Setting[ KV-700/ 1000/ 3000/ 5000/ 7000/ 8000 ]
Alias Name
Protocol : i
String Save Mode : m Change

[J use Redundancy
AMND

4

4]

Primary Option

Timeout -

-

msec

300

Send Wait

Retry

.

Comm Manual

Apply Close

Items Settings Remarks

Interface Configure the communication interface between the TOP and an external device. Refer to "2. External
Protocol Configure the communication protocol between the TOP and an external device.

device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP’s receiving a response from an external device and
sending the next command request.
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3.2. Communication

setting in TOP
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* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

PLC
o @ o
LI
Ethernet Serial

Diagnost ic

[System]

Conikrel Panel

- ] Serial

Serial Port: [ COM1

Signal Level
® RS-232C () RS-422(4) O BS-485(2)

Baud Rate: | 115200
Data Bit: | 8

Stop Bit: | 1

Parity Bit: | Ever
Flow: [ Of f

[Auto Search] lLoopback Testl

 Aeply | Cancel |

Close

r-l'

___-‘

Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C

Baud Rate 115200

Data Bit 8

Stop Bit 1

Parity Bit Even

* The above settings are setting

examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device. (COM3 supports
only RS-485.)

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting
M [Main Screen > Control Panel > PLC]

ERI2 e B X
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Dr iver (COMT) l PLCT{KY=700/ 1000/ 3000/ 5000/ 7000/ 80007

Interface | CPU Direct [~]
Protocol | CPU Direct -]
Timeout 300 3 msec
Send Wait msec
[,J'l-.] Retry E
(A0
Ethernet

™

Diagnost ic

[System] [ Diagnostic

— gl

Items Settings Remarks
Interface Configure the communication interface between the TOP and an external device. Refer to "2. External
Protocol Configure the communication protocol between the TOP and an external device. device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP's receiving a response from an external device and

sending the next command request.
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3.3 Communication diagnostics

W Check the interface setting status between the TOP and external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the port (COM1/COM2/COMS3) settings you want to use in [Control Panel > Serial] are the same as those of the external

device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

OK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

[tems Contents Check Remarks
System How to connect the system oK NG ) )
) ) - 1. System configuration
configuration Connection cable name oK NG
TOP Version information OK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) OK NG . -
diagnostics 3. Communication setting
Serial Parameter Transmission
oK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name OK NG
Communication port name (module
OK NG
name)
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings oK NG 4. External device setting
Serial Parameter Transmission
oK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting
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4.1 KV 1000/3000/5000 series

No additional settings need to be configured for the external device.

4. 2 KV-7000 series

As shown in the figure below, the Unit Editor's setup unit configures the KV Studio mode.
[ b
e Unit Editor - Edit mode o | B e

File(F) Edit(E) Conwvert(F) View(V) Option(C) Window(W) Help(H)

N R o W A
Linit a
Select unit(l Setup unit(2) |

iE +- [0] EV-7300

El Built-in aerial

Operation mode EV STUDIO mode (*) -
Interface BE-Z3ZC(*)

Baud rate Butomatic{*)

Data bit length 8 bita(*)

Start bit 1 bBit(*

Stop bit 1 bit(*

Parity Ewven(*
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5. Cable table
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This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.

5.1. Cable table 1

m RS-232C (1:1 connection)

COM Main Controller
. Signal Pin Cable connection Pin Signal .
Pin arrangement*Note 1) Pin arrangement*Note 1)
name number number | name
RS422 1 1
1 3 RXD 2 2 TXD
(o} o}
TXD 3 3 SG
@) O
6 9 RS422 4 4 RXD
Based on communication SG 5 5
cable connector front, RS422 6 6
D-SUB 9 Pin male (male, 5V 7 123456
convex) GND 8 RJ-12 6-pin connector
RS422 9

*Note 1) Pin arrangement is depicted as facing the interface of the cable connector in this figure. Unused pins are not connected.
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6. Supported addresses

The devices available in TOP are as follows:

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Device Bit Address Word Address Remarks
Data Memory DM0000.00 — DM65534.15 DMO0000 — DM65534
Control Memory CMO0000.00 — CM5999.15 CMO0000 - CM5999
Temporary Memory TM000.00 — TM511.15 TMO000 — TM511
Expansion Data Memory EM00000.00 — EM65534.15 EM00000 — EM65534
File Register — Current Bank FM00000.00 — FM32767.15 FMO00000 - FM32767
Work Memory VM00000.00 — VM59999.15 VMO00000 — VM59999
Link Register W000.00 — W999.15 W000 — W999
Digital Timer TRMO0.00 — TRM7.15 TRMO - TRM7
Index Register Z000 - 712 32bit
Link Register WO0000 — WFFFF
High-Speed Counter Current Value CTHO — CTH1 32bit
High-Speed Counter Comparator CTCO - CTC3 32bit
File Register
— Consecutive Number mode ZF000000 — 2F131071
Input/Output R0O0000 — R99915 R000 — R999
Control Relay CRO000 - CR3915 CROO - CR39
Internal Auxiliary Relay MRO0000 — MR99915 MRO00 - MR999
Latch Relay LRO0000 — LR99915 LROOO - LR999
Link Relay BOOOO — BFFFF
Timer contact TOO0O0 - T511 —
current — TCO00 — TC511 32bit
setting — TS000 — TS511 32bit
Counter contact C000 - C511 —
current — CC000 - CC511 32bit
setting — CS000 — CS511 32bit
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