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HYOSUNG 

VADAL  

Welding Controller 
 Supported version TOP Design Studio V1.4.9.52 or higher  
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We want to thank our customers who use the Touch Operation Panel. 
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Refer to this section to check the data addresses which can 

communicate with an external device. 
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1. System configuration 

The system configuration of TOP and “VADAL Welding Controller” is as follows. 

 

Series CPU Link I/F 
Communication 

method 
System setting Cable 

VADAL 
RS-485 Port 

on the board 
RS–485 

3. TOP 

communication 

setting 

4. External device 

setting 

5. Cable table 

 

■ Connectable configuration 

ㆍ1:1 connection 
 

                      

 

 

ㆍ1:N connection 
 

                          ∙∙∙    
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 
 

Settings Contents 

TOP Model Select the TOP model. 

External device Vendor Select the vendor of the external device to be connected to the TOP. 

Select “HYOSUNG”. 

PLC Select the external device to be connected to the TOP. 
 

Model Interface Protocol 

HYOSUNG VADAL Serial VADAL Protocol 
 

 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP-R main menu. The communication should be set in the same way as 

that of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [Project] → [Property] → [TOP Setting] → [HMI Setup] → [Use HMI Setup Check] → [Edit] → [Serial] 

– Set the TOP communication interface in TOP Design Studio.  
 

 

 

 

 

Items TOP External device Remarks 

Signal Level RS-485 RS-485  

Baud Rate 38400  

Data Bit 8  

Stop Bit 1  

Parity Bit Even  

* The above settings are examples recommended by the company. 

 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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(2) Communication option setting 

■ [Project] → [Project properties] → [PLC settings > COM > PLC1 : HYOSUNG VADAL] 

– Set the options of the communication driver of HYOSUNG VADAL in TOP Design Studio. 

 
 

Items Settings Remarks 

Interface Select “Serial”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

String Save Mode Set the byte order of data when entering the string data.  

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) 
Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
 

Retry 
Set the number of request retries when the data request result is no 

response/negative response. 
 

Station Set (1:N): Request data with the entered station number. 

Search (1:1): Search for external devices. It sends “QV” command from 1 to 15, and 

when it receives a response, it stops searching and starts data 

communication.  

 

Stataion Save 

Address 

Set the TOP internal address where the station number of the external device is saved. 

If you select the Station item as Search (1:1), you can change the value of this internal 

address to change the station number of the external device during the Run. 

 

Type Offset (A Dev.) Set the TOP internal address that sets the series number when requesting data (welder 

data) for address A. 
*Note 1) 

Type Offset (P Dev.) Set the TOP internal address that sets the series number when requesting data (welder 

data) for address P. 
*Note 1) 

Timer No. Set the TOP internal address that sets the timer no. when sending a timer no change 

command (‘N’) that uses the address N. 
*Note 2) 

Data Copy Setting for address C operation  

Src No. Set the TOP internal address to enter the source series number.  

Dst No. Begin Set the TOP internal address to enter the destination starting series number  

Dst No. End Set the TOP internal address to enter the destination end series number  

*Note 1) Command composition method: X[TOP internal address value] Y[Address] QB 

*Note 2) Command composition method: N[TOP internal address value]  
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

   

(1) Communication interface setting 

■ [Control Panel] → [Serial]  
 

 

Items TOP External device Remarks 

Signal Level RS-485 RS-485  

Baud Rate 38400  

Data Bit 8  

Stop Bit 1  

Parity Bit Even  

* The above settings are examples recommended by the company. 

 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device. 

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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(2) Communication option setting 

■ [Control Panel] → [PLC] 
 

 

Items Settings Remarks 

Interface Select “Serial”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

String Save Mode Set the byte order of data when entering the string data.  

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) 
Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
 

Retry Set the number of request retries when the data request result is no response/negative response.  

Station Set (1:N): Request data with the entered station number. 

Search (1:1): Search for external devices. It sends “QV” command from 1 to 15, and when 

it receives a response, it stops searching and starts data communication.  

 

Stataion Save 

Address 

Set the TOP internal address where the station number of the external device is saved. If 

you select the Station item as Search (1:1), you can change the value of this internal 

address to change the station number of the external device during the Run. 

 

Type Offset (A Dev.) Set the TOP internal address that sets the series number when requesting data (welder 

data) for address A. 
*Note 1) 

Type Offset (P Dev.) Set the TOP internal address that sets the series number when requesting data (welder 

data) for address P. 
*Note 1) 

Timer No. Set the TOP internal address that sets the timer no. when sending a timer no change 

command (‘N’) that uses the address N. 
*Note 2) 

Data Copy Setting for address C operation  

Src No. Set the TOP internal address to enter the source series number.  

Dst No. Begin Set the TOP internal address to enter the destination starting series number.  

Dst No. End Set the TOP internal address to enter the destination end series number.  

*Note 1) Command composition method: X[TOP internal address value] Y[Address] QB 

*Note 2) Command composition method: N[TOP internal address value]  
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check that the settings of the connected ports in [Control Panel] → [Serial] are the same as the settings of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel] → [PLC]. 

- Check whether communication is connected or not. 
 

Communication 

diagnostics 

succeeded 

Communication setting normal 

Error message Communication setting abnormal 

- Check the cable, TOP, and external device settings. (Refer to Communication diagnostics sheet.) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 
 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Cable OK NG 

TOP Version OK NG 

2. External device selection 

3. Communication setting 

Communication port OK NG 

Communication driver and protocol OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External device CPU OK NG 

 

Communication port OK NG 

Protocol OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  

OK NG 

5. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 
 

Refer to the vendor’s user manual to identically configure the communication settings of the external device to that of the TOP. 
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5. Cable table 

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. 

(The cable diagrams in this section may differ from the external device vendor’s recommendations.) 

 

■ RS-485 (1:1 connection) 
 

COM 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 
 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA(+) 1  +  

 2 - 

 3 

 

RDB(-) 4 

SG 5 

SDA(+) 6 

 7 

 8 

SDB(-) 9 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-485 (1:1 connection) 
 

COM 

Cable connection 

External device 

Pin arrangement 
Signal 

name 

Signal 

name 
 

 

 
 

+  +  

- - 

SG 

 
 

 

■ RS-485  (1:N connection) 
 

TOP Cable connection and signal 

direction 

Device Cable connection and signal 

direction 

Device 

Signal name Signal name Signal name 

RDA(+)  +  + 

RDB(-) - - 

SDA(+) 

  SDB(-) 

SG 

 

  



 

 External device connection manual for TOP Design Studio 11 / 11 

6. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

 

Device Description Bit Word Read/Write Remarks 

D Welder data D000:00.00 ~ D255:99.15 D000:00 ~ D255:99 R/W *Note 1) 

A Welder data A00.00 ~ A99.15 A00 ~ A99 R/W *Note 2) 

P Welder data P00.00 ~ P99.15 P00 ~ P99 R/W *Note 3) 

T Welding mode T0.00 ~ T0.15 T0 R/W *Note 4) 

V Version - V0 ~ V1 R *Note 5) 

G 
Welding in progress 

Operation startng series number 
- G0 R  

HX 
When data errors 

Series number 
- HX0 R  

HY 
When data errors 

Item number 
- HY0 R  

ZI Input signal ZI0.00 ~ ZI0.15 ZI0 R  

ZO Output signal ZO0.00 ~ ZO0.15 ZO0 R  

E Error code - E0 ~ E4 R  

Q Data change flag - Q0 R  

S Welder status S0.00 ~ S0.15 S0 R *Note 6) 

C Series data copy C0.00 C0 W *Note 7 

N Timer No. change N0.00 N0 W *Note 8 

I Welding condition initialization I0.00 I0 W  

R Status reset - R0 W  

*Note 1) D[Series]:[Item] 

*Note 2) The address of the A device enters the items of the welder data, and the value of the TOP internal address set in the communication option 

‘Type Offset (A Dev.)’ is applied as a series. 

*Note 3) The address of the P device enters the items of the welder data, and the value of the TOP internal address set in the communication option 

‘Type Offset (P Dev.)’ is applied as a series. 

*Note 4) 

Value Status 

0 Welding mode 

1 Test mode 

3 
Pressurized 

mode 
 

*Note 5) 

 

 

*Note 6) 

Bit 15~4 3 2 1 0 

Status 

Reserved 

area 

Stepper done Number of 

hitting point 

done 

Alarm Abnormal 

 

*Note 7) Transmit the series data copy command (‘C’) when Writing operation of data to the C device. Parameters required for command transmission 

are applied as the value of TOP internal address set in the communication option ‘Data Copy’. 

*Note 8) Transmit the timer no change command (‘N’) when Writing operation of data to the N device. Transmitted timer no. is applied as the value of 

TOP internal address set in the communication option ‘Timer No.’ 

Address Data 

0 Version 

1 
Software 

number 


