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HITACHI 

EH-150/MICRO-EH Series 
 Supported version TOP Design Studio  V1.4.11.10 or higher  
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1. System configuration 

The system configuration of TOP and “HITACHI EH-150/ MICRO-EH Series” is as follows: 
 

Series CPU Link I/F 
Communication 

method 
System setting Cable 

HITACHI 

EH-150/ 

MICRO-

EH Series 

MICRO-EH 

CPU Port 

 

RS–232C 

RS-422 

RS–485 

(2 wire) 

 

3. TOP 

communication 

setting 

4. External device 

setting 

5. Cable table EH-150 CPU316A 

EH-150 Misc. 

 

■ Connectable configuration 
 

ㆍ1:1 connection 

 

 

 

 

 

ㆍ1:N connection 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 
 

 

Settings Contents 

TOP Model Check the display and process of TOP to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Select “HITACHI IES”. 

PLC Select an external device to connect to TOP. 

Select “EH-150/MICRO-EH Series”.  

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [ Project > Project Property > TOP Setting ] → [ Project Options > “Use HMI Setup” Check > Edit > Serial] 

– Set the TOP communication interface in TOP Design Studio. 

 

 

 

 

Items TOP External device Remarks 

Signal Level RS-232C RS-422 RS-485 
RS-232C 

RS-422/485 
 

Baud Rate 38400  

Data Bit 7  

Stop Bit 1  

Parity Bit EVEN  

* The above settings are examples recommended by the company. 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [ Project > Project Property > Device Settings > COM > “PLC1 : EH-150/MICRO-EH Series”] 

– Set the options of the HITACHI EH-150/MICRO-EH Series communication interface option in TOP Design Studio. 

 

 

Items Settings Remarks 

Interface Select “Serial”.  

Protocol Select “COMM”.  

TimeOut Set the time for the TOP to wait for a response from an external device.  

SendWait 
Set the waiting time between TOP’s receiving a response from an external 

device and sending the next command request. 
 

Retry Configure the amount of redelivery attempts from TOP to external device.  

Station No. Prefix  

Hardware Flow Control Set whether flow control exists in hardware.  Check CTS *Note 1) 

*Note 1) Confirm used communication port pin CTS.
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

   

(1) Communication interface setting 

■ [ Main Screen > Control Panel > Serial ] 
 

 

Items TOP External device Remarks 

Signal Level (port) RS-232C RS-422 RS-485 
RS-232C 

RS-422/485 
 

Baud Rate 38400  

Data Bit 7  

Stop Bit 1  

Parity Bit EVEN  

* The above settings are setting examples recommended by the company. 

 

 

 

 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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(2) Communication option setting 

■ [ Main Screen > Control Panel > PLC ] 
 

 

Items Settings Remarks 

TimeOut Set the time for the TOP to wait for a response from an external device. 
 

 
SendWait Set the waiting time between TOP’s receiving a response from an external 

device and sending the next command request. 

Retry Configure the amount of redelivery attempts from TOP to external device.  

Station No. Prefix  

Hardware Flow Control Set whether flow control exists in hardware. Check CTS *Note 1) 

*Note 1) Confirm used communication port pin CTS.  
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC ]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  

OK NG 

6. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 
 

For more detailed setting method than that described in this example, refer to the PLC user manual. 

1. For communication with MICRO EH Series  

 

 

 

In the MICRO EH Series, the 10-point base unit does not have a DIP switch, 

so the transmission speed is fixed at 38400 bps. 

 

- For use of port 1, you must set WRF01A register as follows: 

15 14 13 12 11 10 9 8 7 6 5 4 3 2 1

a b c d eWRF03D f g h i
 

- For use of port 2 (RS-422/RS-485), you must set WRF03D register as follows:. 

15 14 13 12 11 10 9 8 7 6 5 4 3 2 1

a b c d eWRF03D f g h i
 

 

bit value 

a 0: Port 0, 1: Port 2 

b 0 : Transmission control procedure 1, 1 : Transmission control procedure 2 

c 0 : do not use prefix, 1 : use prefix (not used for port 1) 

d, e, f Not used 

g, h 00 : 4800 bps, 01 : 9600 bps, 10 : 19200 bps, 11 : 38400 bps 

i Prefix (BCD 00 - 31) (not used for port 1) 

※ Transmission Control Procedure (Procedure) 1 fixed. 

 

2. For communication with EH-150 Series 

 

8

7

6

5

4

3

2

1

OFF ON
 
15 14 13 12 11 10 9 8 7 6 5 4 3 2 1

a b c d eWRF037 f g h i
 

 

bit value 

a 1 

b 0 : Transmission control procedure 1, 1 : Transmission control procedure 2 

c 0 : do not use prefix, 1 : use prefix (not used for port 1) 

d Not used 

e, f 00 

g, h 00 : RS-232, 01 : RS-422, 10 : RS-485 

i Prefix (BCD 00–31) 

※ EH-150 CPU316A : Transmission Control Procedure (Procedure) 2, other : Transmission Control Procedure (Procedure) 1 Fixed.  

Number 1 2 3 4 
Transmission 

Speed (bps) 

DIP 

Switch 

ON OFF ON OFF 38400 

ON OFF OFF OFF 19200 

OFF OFF ON OFF 9600 

 Transmission Speed 1 2 3 4 5 6 T 

Port1 

9600   off on on   

19200   on off on   

38400   off off on   

Port2 

9600      on off 

19200      off on 

38400      on on 
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5. Cable table 

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. 

(The cable diagram described in this section may differ from the recommendations of “EH-150/MICRO-EH Series”) 

 

■  RS-232C [MICRO-EH, EH-150 misc.] 

TOP 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

   1 SG1 

 

RD 2   

SD 3   

  4 CD1(DCD) 

SG 5 5 SD1(TXD) 

  6 RD1(RXD) 

  7 DR1(DSR) 

CTS 8 8 RS1(RTS) 

    

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-232C [EH-150 : CPU316A] 

TOP 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

   1 SG1 

 

RD 2   

SD 3   

  4 CD1(DCD) 

SG 5 5 SD1(TXD) 

  6 RD1(RXD) 

  7 DR1(DSR) 

    

    

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-485 [MICRO-EH] 

TOP 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  10 RDN 

 

    

    

RDB 4 11 RDP 

    

SDA 6 12 SDN 

    

    

SDB 9 13 SDP 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 
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■ RS-422 [MICRO-EH] 

TOP 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  13 SDP 

 

    

    

RDB 4 12 SDN 

    

SDA 6 11 RDP 

    

    

SDB 9 10 RDN 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-485 [EH-150] 

TOP 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  4 TX 

 

    

    

RDB 4 5 TXN 

    

SDA 6 7 RX 

    

    

SDB 9 6 RXN 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-422 [EH-150] 

TOP 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  4 TX 

 

    

    

RDB 4 5 TXN 

    

SDA 6 7 RX 

    

    

SDB 9 6 RXN 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 
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6. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

 

Device Bit address Word address Remarks 

X X0000 ~ X4007 WX000 ~ WX400 External input 

Y Y0100 ~ Y4021 WY010 ~ WY401 External output 

R R0000 ~ R07BF WR000 ~ WRFFF Internal output 

M M0000 ~ M3FFF WM000 ~ WM3FF Data area 

L L0000 ~ L3FFF WL000 ~ WL3FF Link area 

TC TC0000.00 ~ TC2047.15 TC0000 ~ TC2047 Timer/Counter current value 

CL CL0000.00 ~ CL2047.15 CL0000 ~ CL2047 Counter clear 

CU CU0000 ~ CU2047 - Up counter 

RCU RCU0000 ~ RCU2047 - Ring counter 

CTU CTU0000 ~ CTU2047 - Updown counter - Up input 

CTD CTD0000 ~ CTD2047 - Updown counter - Down input 

TD TD0000 ~ TD1023 - Delay timer 

SS SS0000 ~ SS1023 - Single short timer 

WDT WDT0000 ~ WDT1023 - Watchdog timer 

MS MS0000 ~ MS1023 - Monostable timer 

TMR TMR0000 ~ TMR1023 - Watchdog timer 


