Rockwell Automation, Inc.
MicroLogix, SLC-500 Series

Ethernet Driver

Supported version TOP Design Studio V1.0 or higher {Rl

TOP

"

CONTENTS

We would like to thank our customers for using M2l's "Touch

Operation Panel (M2] TOP) Series". Read this manual and familiarize
yourself with the connection method and procedures of the "TOP and

external device".

1. System configuration Page 2

Describes the devices required for connection, the setting of

each device, cables, and configurable systems.

2. External device selection Page 3

Select a TOP model and an external device.

3. TOP communication setting Page 4

Describes how to set the TOP communication.

4. External device setting Page 9

Describes how to set up communication for external devices.

5. Supported addresses Page 10

Refer to this section to check the addresses which can

communicate with an external device.
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1. System configuration

The system configuration of TOP and “Rockwell Automation, Inc. — SLC500/MicroLogix Series EthernetlP” is as follows:

Communication

Series CPU Link I/F System setting
method
MicroLoigx 1000
MicroLoigx 1100 3.2 Settings example 2
. . 1761-NET_ENI Ethernet(TCP)
. ) MicroLogix 1200 (Page 5)
MicroLogix . .
MicroLogix 1500
) ) ) 3.1 Settings example 1
MicroLoigx 1100 CPU Direct Ethernet(TCP) Twisted pair cable
(Page 4)
*Note 1)
. 3.1 Settings example 1
SLC 5/05 CPU Direct Ethernet (TCP)
(Page 4)
SLC500 SLC 5/03 .
3.2 Settings example 2
SLC 5/04 1761-NET-ENI Ethernet (TCP) o 5)
age
SLC 5/05

*Note 1) Twisted pair cable
- Refer to STP (Shielded Twisted Pair Cable) or UTP (Unshielded Twisted Pair Cable) Category 3, 4, 5.
- Depending on the network configuration, you can connect to components such as the hub and transceiver, and in this case, use a

direct cable.

W Connectable configuration
+ 1:1 connection (one TOP and one external device) connection

Tor =
‘ = [ ]
m ;

— | HUB '
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device n

PLC select [Ethernet]

Filter : |[A\|] v| Search : l:l

@ Model () vendor

Vendor Model
M2I Corporation ~ & Control {Compactiogix Series
. . 5
s R Coersten
OMRON Industrial Automation
S5LC-500 Series
L5 Industrial Systems
& Control/CompactLogix Series {Import User Tag)
MODBUS Crganization
SIEMENS AG.

Rodowell Automation

GE Fanuc Automation
PANASONIC Electric Works
YASKAWA Electric Corporation
YOKOGAWA Electric Corporation

Schneider Electric Industries

KDT Systems
RS Automation hd
‘ Back | . Mext ® Cancel
Select Device B
PLC Setting[ MicroLogix Series ]
Alias Name BndIP: Auto
Interface : | Ethernet ~
Protocol : | Ethernet/lp ~ Comm Manual

String Save Mode @ |First HL HL Change

[] use Redundancy

AND ~
. -
-

C Edi
Primary Option
d o 5| = & f [ &
Ethernet Protocol TCP
Port 44818 =

Timeout msec
Send Wait msec

@ Back v OK #® Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.

External device

Vendor Select the vendor of the external device to be connected to TOP.
Select “Rockwell Automation (AB)".
PLC Select the external device to be connected to the TOP.

Interface Protocol

MicroLogix Series Ethernet Ethernet/IP

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting i

n TOP Design Studio

(1) Communication interface setting
M [Project > Project Property > TOP Setting] — [Project Option > "Use HMI Setup” Check > Edit > Ethernet]

— Set the TOP communication interface in TOP Design Studio.

Project Option =
- Change HILH] | | Add PLC [ ST ChangePLCl | [ Delete PLCID)
ngi;e;nﬂgﬂlswx Date / Time Sync.  Screen Option Unit Convert
M '.___‘2";';;";::‘[3)5“"9 Project Option | Screen Change = HmiSetup | Global Lock & Touch  Project Style | Splash | PLC Buffer Sync.
-4 RFID {0} se HMI Setup I_I
v f_f::vzg;elﬁ[lg)g Hmi >eup Option Initialization Edit
% COM2 (0) Project Setting ~
g% COM3 (0) HMIDisable=0
v g Ethernet (1) Proiect:daerleM:el‘;l"iw project
.IIVHEEITIE.ESI[L;'I\UDLUQD( Series ;gti%sf:ig e
-4 USBDevice (0) Latch Set=0~0
Communication Error Message =0
USEErrorMessage=0
StorageErrorMessage=1
DatabaseMessage=1
Control Panel
£ " | @
System Devices m @ Ethemnet x
-Port |
Ethernet Port *ETH1 ~ 0 <
1l I 7 u Link Speed :|Auto @
RLL Secur ity T MAC Address 00:00:00:00:00:00
IP Address :|  192.168.0.50
Subnet Mask ! 255.255.255.0
_ " Gateway |  192.168.0.1
"III" m tj‘ Default Gateway
, DNS (1) ]
Et herrnet Serial HOM | In
- DNS (2) ¢
- — - Ethernet
| Tl & Primary IP ©  192.168.0.50 ~
o - al
L—A ® Fing Cable Status
Diagnost ic File Fin i , .
c Manager | Bridge Hode : LIUse Bridoe
Check duplicate | Apply | Cancel
Items TOP External device Remarks
IP Address*Note 1) Note 2) 192.168.0.50 192.168.0.51
Subnet Mask 255.255.255.0 255.255.255.0
Gateway 192.168.0.1 192.168.0.1
*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 168 . 0 . 0) should match.
*Note 2) Do not use duplicate IP addresses over the same network.
* The above settings are examples recommended by the company.
Items Description
IP Address Set an IP address to be used by the TOP to use over the network.
Subnet Mask Enter the subnet mask of the network.
Gateway Enter the gateway of the network.
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(2) Communication option setting

M [Project > Project Property > Device Setting > ETHERNET > “PLC1 : MicroLogix Series"]

— Set the options of the MicroLogix Series Ethernet communication driver in TOP Design Studio.

ERI2 e B X
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Project Option

- Change HMI[H] ' AddPLC[A] | THTM) Change PLCIC | [] Delete PLCID]

v -3 TOF Setting

8 FieldBus (0)
- RFID ()
Device Setting

3 5YS : RD1520%
Option Module Setting

Ethernet (11

PLC Setting[ MicroLogix Series ]

Alizs Name : [PLC1 BndIP: |aute v
Interface : |Ethernet ~
Protocol : |Ethernet/Ip ~

String Save Mode : (First HL HL Change

[] use Redundancy

Ireless

4§ USBDevice (0)

-4 PLC1 : MicroLogix Series AND (v

Ak

ST Edi
Primary Option

P [2 | 68 B0 FH [ F

Ethernet Protocol TCP

Port 44318 [

Timeout msec
Send Wait msec

Comm Manual

Apply Close
* The above settings are examples recommended by the company.

Items Settings Remarks

Interface Select “Ethernet”. Refer to "2. External

Protocol Select “Ethernet/IP". device selection”.

IP Enter the IP address of the external device.

Ethernet Protocol Selects the Ethernet protocol “TCP” between the TOP and an external device. Fixed

Port Enter "44818", which is the Ethernet communication port number of the external Fixed

device.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP's receiving a response from an external device
and sending the next command request.
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3.2. Communication setting in TOP

* This is a setting method when "Use HMI Setup” in the setting items in "3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

B [Main Screen > Control Panel > Ethernet]

@ "ﬁ. Ethernet

Run

YHC
Yiewer

[System] [Check duplicatel l Apop | v [ Cance| l Close r
|

@ Svstem et Dption
Ethernet Port :| ETHI |~/[0 |+
n ! Link Speed :[ Auto ‘v] q’»
MAC Address @ 000150 10:05:38:Ch
5

IP Address :[  132.166.0.50 Sound
Subnet Mask (|  255.255.255.0
o Gateway :| 192 .168.0.1 o —
I - [ Default Gateway ~
Ethernet DS (1) ;|
ONS (20

-Ethernet m

Primary IP : l]EIE.]EEl.O.ED -]
MR

Cable Status ! ETHT Connected Analysis
Bridae Mode ! [IlUse Bridae

Diagnost ic

1 ] I

Items TOP External device Remarks
IP Address*Note 1) Note 2) 192.168.0.50 192.168.0.51

Subnet Mask 255.255.255.0 255.255.255.0

Gateway 192.168.0.1 192.168.0.1

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IR 192 . 168 . 0 . 0) should match.

*Note 2) Do not use duplicate IP addresses over the same network.

* The above settings are examples recommended by the company.

Items Description

IP Address Set an IP address to be used by the TOP to use over the network.
Subnet Mask Enter the subnet mask of the network.

Gateway Enter the gateway of the network.
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(2) Communication option setting
M [Main Screen > Control Panel > PLC]

®

Run

YNC
Yiewer

Screen
shot

i
o il PLC

@ Swvstel Driver(ETH) l PLCI(Micrologix Series) 'l

Interface | Ethernet [~]
!h' | Protocol | Ethernet/lp Rd
PLE Bind IP [LAuto -]

Ip [192 5] [esls] [0 [ (51 |5
m Ethernet

ERI2 e B X
Touch Qperation Panel

Ethernet Fort :@
Timeout 300 15 msec
m send Wait 0 2 msec
Diagnost ic
[System] [ Diagnostic HDing Tesfl ‘ bpp |y §|[Cance| l

* The above settings are examples recommended by the company.

|

Items Settings Remarks
Interface Select "Ethernet”. Refer to "2. External
Protocol Select "Ethernet/IP". device selection”.
IP Enter the IP address of the external device.
Ethernet Protocol Selects the Ethernet protocol “TCP" between the TOP and an external device. Fixed
Port Enter "44818", which is the Ethernet communication port number of the external Fived
device.
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.
SendWait (ms) Set the waiting time between TOP's receiving a response from an external device and
sending the next command request.
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3.3 Communication diagnostics

W Check the interface setting status between the TOP and an external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the port (ETH1/ETH2) settings you want to use in [Control Panel > Ethernet] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch "Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
configuration Connection cable name OK NG 1. System configuration
TOP Version information oK NG
Port in use oK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG 2. External device selection
Communication 3. Communication setting
diagnostics oK NG
Ethernet port setting IP Address oK NG
Subnet Mask oK NG
Gateway OK NG
External device CPU name oK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix OK NG ) )
Other detailed settings oK NG 4. External device setting
Ethernet port setting IP Address oK NG
Subnet Mask oK NG
Gateway OK NG
Check address range 5. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

4.1 External device setting 1 (1761-NET-ENI)

Use [ENI/ENIW Utility] for communication settings to configure as shown below.

For more detailed setting method than that described in this example, refer to the PLC user manual.

Step 1. From the [ENI IP Addr] tab of [ENI/ENIW Utility], configure the “IP Address : 192.168.0.51" and other settings.

Step 2. Download the configurations for 1761-NET-ENI.

4.2. External device setting 2 (CPU Direct)

Set as below using “MicroLogix Series” Ladder Software “RSLogix500".

For more detailed setting method than that described in this example, refer to the PLC user manual.

Step 1. Create a new project at “RSLogix500".
Step 2. From the Project tree, go to [Controller] > Select “Open” for [Channel Configuration].

Step 3. From the [Chan — 1 system] tab of [Channel Configuration] dialog box, configure the “IP Address : 192.168.0.51" and other
settings.

Step 4. Download the configurations.

External device connection manual for TOP Design Studio 9/ 10



TOR =32 I
5. Supported addresses

The devices available in TOP are as follows:
The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address
range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

A Device notation

= Device Name : File Number : Element

Device Bit Address Word Address Remarks
Input file 1:00.000/00 ~ 1:63.255/15 1:00.000 ~ 1:63.255
Output file 0:00.000/00 ~ 0:63.255/15 0:00.000 ~ 0:63.255
Status file S:000/00 ~ S:163/15 S:000 ~ S:163
Bit file B003:000/00 ~ B003:255/15 B003:000 ~ B003:255
B009:000/00 ~ B255:255/15 B009:000 ~ B255:255
Timer file EN Enable
p— Timing T004:000/13 ~ T004:255/15 T004:000 ~ T004:255
T009:000/13 ~ T255:255/15 T009:000 ~ T255:255
DN Done
PRE | Preset TP004:000 ~ TP004:255
) TP009:000 ~ TP255:255
ACC | Accumulated TA004:000 ~ TA004:255
) TA009:000 ~ TA255:255
Counter file cu Up enable
CcD Down enable
DN Done C005:000/10 ~ C005:255/15 C005:000 ~ C005:255
oV Overflow C009:000/10 ~ C255:255/15 C009:000 ~ C255:255
UN Underflow
UA Update Acc
PRE Preset CP005:000 ~ CP005:255
_ CP009:000 ~ CP255:255
ACC | Accumulated CA005:000 ~ CA005:255
) CA009:000 ~ CA255:255
Control file EN Enable
EU Enable unload
DN Done
EM Empty R006:000/10 ~ R006:255/15 R006:000 ~ R006:255
ER Error R009:000/10 ~ R255:255/15 R009:000 ~ R255:255
UL Unload
IN Inhibit comp.
FD Found
LEN | Length RLO06:000 ~ RLO06:255
' RL009:000 ~ RL255:255
POS | Position RP006:000 ~ RP006:255
) RP009:000 ~ RP255:255
Integer file NO007:000/10 ~ N007:255/15 N007:000 ~ N007:255
N009:000/10 ~ N255:255/15 N009:000 ~ N255:255
Floating point file None F008:000 ~ F255:255
String file None ST009:000 ~ ST255:255
Long word file L009:000/00 ~ L255:255/31 L009:000 ~ L255:255
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