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MITSUBISHI Electric Corporation 

MELSEC iQ-R Series  

Ethernet Driver 
 Supported version TOP Design Studio V1.4.11.28 or higher  

 

 

 

CONTENTS 

We would like to thank our customers for using M2I's "Touch Operation 

Panel (M2I TOP) Series". Read this manual and familiarize yourself with 

the connection method and procedures of the “TOP and external device”. 

 

 

 

1. System configuration Page 2 

 

 

Describes the devices required for connection, the setting of each 

device, cables, and configurable systems. 

2. External device selection  Page 3 

 Select a TOP model and an external device. 

3. TOP communication setting Page 4 

 Describes how to set the TOP communication. 

4. External device setting Page 9 

 Describes how to set up communication for external devices. 

5. Supported addresses Page 11 

 Refer to this section to check the addresses which can 

communicate with an external device. 
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1. System configuration 

The system configuration of TOP and “MITSUBISHI Electric Corporation - MELSEC IQ-R Ethernet” is as follows. 

 

Series CPU Link I/F 
Communication 

method 

Communication 

setting 
Cable 

MELSEC iQ-R 

R00CPU R01CPU 

R02CPU R04CPU 

R08CPU R16CPU 

R32CPU 

R120CPU 

R04ENCPU 

R08ENCPU 

R16ENCPU 

R32ENCPU 

R120ENCPU 

R08PCPU 

R16PCPU 

R32PCPU 

R120PCPU 

R08SFCPU 

R16SFCPU 

R32SFCPU 

R120SFCPU 

R08PSFCPU 

R16PSFCPU 

R32PSFCPU 

R120PSFCPU 

Ethernet Port on 

CPU Unit 

Ethernet 

(TCP/UDP) 

3. TOP 

communication 

setting 

4. External device 

setting 

Twisted pair cable*Note 1) 

RJ71EN71 

*Note 1) Twisted pair cable 

- Refer to STP (Shielded Twisted Pair Cable) or UTP (Unshielded Twisted Pair Cable) Category 3, 4, 5. 

- Depending on the network configuration, you can connect to components such as the hub and transceiver, and in this case, use a 

direct cable. 

 

 

■ Connectable configuration 
 

ㆍ1:1 connection 
 

                      

 

 

ㆍ1:N connection 
 

                          ∙∙∙    
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 
 

 

Settings Contents 

TOP Model Check the TOP display and process to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Please select “MITSUBISHI Electric Corporation”. 

PLC Select the external device to be connected to the TOP. 
 

Model Interface Protocol 

MELSEC IQ-R Series Ethernet Set Users 
 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 

Supported Protocol 

SLMP 3E Binary SLMP 3E Ascii MELSOFT Connection 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [Project] → [Property] → [TOP Setting] → [HMI Setup] → [Use HMI Setup Check] → [Edit] → [Ethernet] 

– Set the TOP communication interface in TOP Design Studio. 
 

 

 

 

 
 

Items TOP External device Remarks 

IP Address*Note 1) Note 2) 192.168.0.100 192.168.0.50  

Subnet Mask 255.255.255.0 255.255.255.0  

Gateway 192.168.0.1 192.168.0.1  

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 168 . 0 . 0) should match. 

*Note 2) Do not use duplicate IP addresses over the same network. 

* The above settings are examples recommended by the company. 

 

Items Description 

IP Address Set an IP address to be used by the TOP to use over the network. 

Subnet Mask Enter the subnet mask of the network. 

Gateway Enter the gateway of the network. 
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(2) Communication option setting 

■ [ Project > Project properties > PLC setting > ETHERNET > “PLC1 : MELSEC-IQ-R Series”] 

– Set the options of the communication driver of MELSEC IQ-R Series Ethernet in TOP Design Studio. 

 

 

Items Settings Remarks 

Interface Select “Ethernet”. Refer to “2. External 

device selection”. Protocol Select a communication protocol between TOP and the external device. 

IP Enter the IP address of the external device.  

Ethernet Protocol Select an Ethernet protocol between TOP and the external device.  

Port Enter the Ethernet communication port number of an external device. Reference the 

table below 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

Password Enter the password set in the external device. *Note 1) 
 

*Note 1) It can be set only in SLMP 3E Protocol. 

 

MELSOFT Connection communication port number 

 

SLMP 3E Binary, Ascii communication port number 

Protocol Port number Remarks 

TCP 5007  Fixed 

UDP 5006  Fixed 

Protocol Port number Remarks 

TCP / UDP 1025 ~ 65535   
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen.  

   

(1) Communication interface setting 

■ [Control Panel] → [Ethernet] 
 

 

 

Items TOP External device Remarks 

IP Address*Note 1) Note 2) 192.168.0.100 192.168.0.50 *Note *Note 2) 

Subnet Mask 255.255.255.0 255.255.255.0  

Gateway 192.168.0.1 192.168.0.1  

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 168 . 0 . 0) should match. 

*Note 2) Do not use duplicate IP addresses over the same network. 

* The above settings are examples recommended by the company. 

 

 

Items Description 

IP Address Set an IP address to be used by the TOP to use over the network. 

Subnet Mask Enter the subnet mask of the network. 

Gateway Enter the gateway of the network. 
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 (2) Communication option setting 

■ [Control Panel] → [PLC] 
 

 

 

Items Settings Remarks 

Interface Select “Ethernet”. Refer to “2. External 

device selection”. Protocol Select a communication protocol between TOP and the external device. 

IP Enter the IP address of the external device.  

Ethernet Protocol Select an Ethernet protocol between TOP and the external device.  

Port Enter the Ethernet communication port number of an external device. Reference the 

table below 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

Password Enter the password set in the external device. *Note 1) 

*Note 1) It can be set only in SLMP 3E Protocol. 

 

MELSOFT Connection communication port number 

 

SLMP 3E Binary, Ascii communication port number 

Protocol Port number Remarks 

TCP 5007  Fixed 

UDP 5006  Fixed 

Protocol Port number Remarks 

TCP / UDP 1025 ~ 65535   
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check whether the port setting is correct in [Control panel] → [Ethernet]. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel] → [PLC]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Ethernet port setting IP Address OK NG 

Subnet Mask OK NG 

Gateway OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Ethernet port setting IP Address OK NG 

Subnet Mask OK NG 

Gateway OK NG 

Check address range  

OK NG 

5. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 

 



 

 

External device connection manual for TOP Design Studio 9 / 17 

4. External device setting 

4.1 GX Works3 Connection Settings 

Set as below using MELSEC Series Ladder Software "GX Works3”. For more detailed setting method than that described in this 

example, refer to the PLC user manual. 
 

 

⚫ The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 

168 . 0 . 0) should match. 

⚫ Do not use duplicate IP addresses over the same network. 
 

 

4.1.1 Ethernet Port on CPU Unit 
 

Step 1. In [GX Works3] software project window [Parameter] – [relevant CPU model name] double-click and bring up [Module 

parameter] pop-up window 
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Step 2. In [Module parameter], select [Basic Settings] tab and set as follows: 

.  

 

Items Settings 

IP address IP MELSEC-iQ-R CPU Ethernet Port Assignment IP 

 Subnet mask pattern Set when using subnet mask 

 Default router IP Set when using router 

Enable/Disable Online Change When using SLMP 3E Protocol, Enable All (SLMP) 

When using MELSOFT Connection, Disable All (SLMP) 

Communication data code When using SLMP 3E Binaray, Binaray 

When using SLMP 3E Ascii, Ascii 

When using MELSOFT Connection, Binaray 
 

Step 3. Click [External Device Configuration] > [Detailed Setting]. 

When using MELSOFT Connection  

Select Ethernet Device (General) -> MELSOFT Connection Module on the right, and drag and add to the right. 
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When using SLMP 3E Protocol  

Select Ethernet Device (General) -> SLMP Connection Module on the right, and drag and add to the right. 

 

 

 

Items Description 

Protocol TCP or UDP 

PLC Port No 1025 ~ 65535 

 

Step 4 Download the [Online] → [Write to PLC] execution program and reset. 
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4.1.2 Ethernet Link Uint (RJ71EN71) 
 

Step 1. Pop-up the [Module Information] – [Module parameter] window in the [GX Works3] software’s project window. 
 

 
 

Step 2. In [Module parameter], select [Basic Settings] tab and set as follows: 

.  
 

Items Settings 

IP address IP MELSEC-iQ-R CPU Ethernet Port Assignment IP 

 Subnet mask pattern Set when using subnet mask 

 Default router IP Set when using router 

Enable/Disable Online Change When using SLMP 3E Protocol, Enable All (SLMP) 

When using MELSOFT Connection, Disable All (SLMP) 

Communication data code When using SLMP 3E Binaray, Binaray 

When using SLMP 3E Ascii, Ascii 

When using MELSOFT Connection, Binaray 
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Step 3. Click [External Device Configuration] > [Detailed Setting]. 

 

When using MELSOFT Connection  

Select Ethernet Device (General) -> MELSOFT Connection Module on the right, and drag and add to the right. 
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When using SLMP 3E Protocol  

Select Ethernet Device (General) -> SLMP Connection Module on the right, and drag and add to the right. 

 

  

 

Items Description 

Protocol TCP or UDP 

PLC Port No 1025 ~ 65535 

 

Step 4 Download the [Online] → [Write to PLC] execution program and reset. 
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※ Remote Password (Optional) Only available for SLMP 3E Procotol 
 

① Navigation window → [Parameter] → [Remote Password] 
 

 

 

② Set the password. 
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③ Select a module to apply the password to. 
 

 

 

④ Select a connection to apply the password to in the Remote Password Detail Setting window. 
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5. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use.  
 

Device Bit Address Word Address Remarks 

Input Relay X0000 ~ X3FFF(HEX) X0000 ~ X3FF0(HEX)  

Output Relay Y0000 ~ Y3FFF(HEX) Y0000 ~ Y3FF0(HEX)  

Internal Relay M0 ~ M99999999 M0 ~ M99999984  

Link Relay B0 ~ B9A61FFF(HEX) B0 ~ B9A61FF0(HEX)  

Special Link Relay SB0 ~ SB9A61FFF(HEX) SB0 ~ SB9A61FF0(HEX)  

Annunciator F0 ~ F32767 F0 ~ F32752  

Edge Relay V0 ~ V32767 V0 ~ V32752  

Timer 

Contact TS0 ~ TS 8993439   

Coil TC0 ~ TC 8993439   

Current  TN ~ TN 8993439  

Aggregate Timer 

Contact SS0 ~ SS 8993439   

Coil SC0 ~ SC 8993439   

Current  SN ~ SN 8993439  

Counter 

Contact CS0 ~ CS 8993439   

Coil CC0 ~ CC 8993439   

Current  CN0 ~ CN8993439  

Long Timer 

Contact LTS0 ~ LTS 2529407  *Note *Note 2) 

Coil LTC0 ~ LTC 2529407  *Note *Note 2) 

Current  LTN ~ LTN 2529407 *Note 2) 

Long  

Aggregate 

Timer 

Contact LSS0 ~ LSS 2529407  *Note *Note 2) 

Coil LSC0 ~ LSC 2529407  *Note *Note 2) 

Current  LSN ~ LSN 2529407 *Note 2) 

Long Counter 

Contact LCS0 ~ LCS 4761215  *Note 2) 

Coil LCC0 ~ LCC 4761215  *Note 2) 

Current  LCN0 ~ LCN 4761215 *Note 2) 

Data Register D0.00 ~ D10117631.15 D0 ~ D10117631  

Link Register W0.00 ~ W9A61FF.15(HEX) W0 ~ W9A61FF(HEX)  

Link Special Register SW0.00 ~ SW9A61FF.15(HEX) SW0 ~ SW9A61FF(HEX)  

Latch Relay L0 ~ L32767 L0 ~ L32752  

Special Relay SM0 ~ SM4095 SM0 ~ SM4080  

Special Data Register SD0.00 ~ SD4095.15 SD0 ~ SD4095  

Index Register Z0.00 ~ Z23.15 Z0 ~ Z23 *Note 2) 

Long Index Register  LZ0.00 ~ LZ11.31 LZ0 ~ LZ11 *Note 2) 

File Register R0.00 ~ R32767.15 R0 ~ R32767 *Note 2) 

Extension File Register ZR0.00 ~ ZR10027007.15 ZR0 ~ ZR10027007 *Note 2) 

Link Direct Input  JX 001-0000 ~ JX 255-3FFF(HEX) JX 001-0000 ~ JX 255-3FF0(HEX) *Note 2) 

Link Direct Output  JY 001-0000 ~ JY 255-3FFF(HEX) JY 001-0000 ~ JY 255-3FF0(HEX) *Note 2) 

Link Direct Relay JB 001-0000 ~ JB 255-7FFF(HEX) JB 001-0000 ~ JB 255-7FF0(HEX) *Note 2) 

Link Direct Special Relay JSB 001-0000 ~ JSB 255-1FF(HEX) JSB 001-0000 ~ JSB 255-1F0(HEX)  *Note 2) 

Link Direct Register JW 001-0000.00 ~ JW 255-1FFFF.15(HEX) JW 001-0000 ~ JW 255-1FFFF(HEX) *Note 2) 

Link Direct Special Register JSW 001-0000.00 ~ JSW 255-1FF.15(HEX) JSW 001-0000 ~ JW 255-1FFFF(HEX) *Note 2) 

Module Access Device UG 000-00000000.00 ~ UG 255-99999999.15 UG 000-00000000 ~ UG 255-99999999 *Note 2) 

CPU Buffer Memory  

Access Device 
U3E0G 00000000.00 ~ U3E3G 99999999.15 U3E0G 00000000 ~ U3E3G 99999999 *Note 2) 

CPU Buffer Memory 

Fixed Scanned Communications Area 
U3E0HG 00000.00 ~ U3E3HG 12287.15 U3E0HG 00000 ~ U3E3HG 12287 *Note 2) 

*Note 1) For SLMP 3E Protocol, only Read is possible. 

*Note 2) It is a device that can be available only when it is set separately in the GX Works3 program. Refer to the PLC manual. 


