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MITSUBISHI Electric Corporation 

MELSEC Q Series  

CPU Ethernet Driver 
 Supported version TOP Design Studio V1.0 or higher  

 

 

CONTENTS 

We would like to thank our customers for using M2I's "Touch 

Operation Panel (M2I TOP) Series". Read this manual and familiarize 

yourself with the connection method and procedures of the “TOP and 

external device”. 

 

 

1. System configuration Page 2 

 

 

Describes the devices required for connection, the setting of 

each device, cables, and configurable systems. 

2. External device selection  Page 3 

 Select a TOP model and an external device. 

3. TOP communication setting Page 4 

 Describes how to set the TOP communication. 

4. External device setting Page 9 

 Describes how to set up communication for external devices. 

5. Supported addresses Page 11 

 Refer to this section to check the addresses which can 

communicate with an external device. 
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1. System configuration 

The system configuration of TOP and “MITSUBISHI Electric Corporation - MELSEC Q CPU Ethernet” is as follows. 

 

Series CPU Link I/F 
Communication 

method 

Communication 

setting 
Cable 

MELSEC-Q 

QUDE 

QUDEH 

QUDV 

CPU Built-in Ethernet 
Ethernet 

(TCP/UDP) 

3. TOP 

communication 

setting 

4. External device 

setting 

Twisted pair cable*Note 1) 

*Note 1) Twisted pair cable 

- Refer to STP (Shielded Twisted Pair Cable) or UTP (Unshielded Twisted Pair Cable) Category 3, 4, 5. 

- Depending on the network configuration, you can connect to components such as the hub and transceiver, and in this case, use a 

direct cable. 

 

■ Connection configuration 
 

ㆍ1:1 (one TOP and one external device) connection 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 
 

 

Settings Contents 

TOP Model Check the TOP display and process to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Please select “MITSUBISHI Electric Corporation”. 

PLC Select the external device to be connected to the TOP. 
 

Model Interface Protocol 

MELSEC Q Series CPU Ethernet Set Users 
 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 

Supported Protocol 

MC Protocol 3E (BINARY) MC Protocol 3E (ASCII) MELSOFT Connection 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [ Project > Project properties > TOP settings] → [Project option > Check “Use HMI settings” > Edit > Ethernet ] 

– Set the TOP communication interface in TOP Design Studio. 
 

 
 

 
 

Items TOP External device Remarks 

IP Address*Note 1) Note 2) 192.168.0.100 192.168.0.50  

Subnet Mask 255.255.255.0 255.255.255.0  

Gateway 192.168.0.1 192.168.0.1  

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 168 . 0 . 0) should match. 

*Note 2) Do not use duplicate IP addresses over the same network. 

* The above settings are examples recommended by the company. 

 

Items Description 

IP Address Set an IP address to be used by the TOP to use over the network. 

Subnet Mask Enter the subnet mask of the network. 

Gateway Enter the gateway of the network. 
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(2) Communication option setting 

■ [ Project > Project properties > PLC settings > ETHERNET > “PLC1 : MELSEC-Q Series”] 

– Set the options of the communication driver of MELSEC Q Series CPU Ethernet in TOP Design Studio. 

 
 

 

Items Settings Remarks 

Interface Select “CPU Ethernet”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

IP Enter the IP address of the external device.  

Ethernet Protocol Select the Ethernet protocol between the TOP and an external device.  

Port Enter the Ethernet communication port number of an external device. Reference the table 

below 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external 

device and sending the next command request. 
 

 

MELSEC Q Series CPU communication port number 

Protocol Port number Remarks 

MC Protocol 3E (UDP) 

(recommended) 

Port number given in [Built-in Ethernet Port Setting > Open Setting] 
 

MC Protocol 3E (TCP) (N:1) When using multiple TOPs, it is recommended to use TCP to avoid mistakes.  

MELSOFT Connection (UDP) QnUDEH : 5006 DEC  QnUDV/QnUDPV : 5001 DEC Fixed 

MELSOFT Connection (TCP) 5007 DEC Fixed 
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen.  

   

(1) Communication interface setting 

■ [ Main screen > Control panel > Ethernet ] 
 

 

 

Items TOP External device Remarks 

IP Address*Note 1) Note 2) 192.168.0.100 192.168.0.50  

Subnet Mask 255.255.255.0 255.255.255.0  

Gateway 192.168.0.1 192.168.0.1  

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 168 . 0 . 0) should match. 

*Note 2) Do not use duplicate IP addresses over the same network. 

* The above settings are examples recommended by the company. 

 

 

Items Description 

IP Address Set an IP address to be used by the TOP to use over the network. 

Subnet Mask Enter the subnet mask of the network. 

Gateway Enter the gateway of the network. 
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 (2) Communication option setting 

■ [ Main screen > Control panel > PLC ] 
 

 

 

Items Settings Remarks 

Interface Select “CPU Ethernet”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

IP Enter the IP address of the external device.  

Ethernet Protocol Select the Ethernet protocol between the TOP and an external device.  

Port Enter the Ethernet communication port number of an external device. Reference the table 

below 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external 

device and sending the next command request. 
 

 

MELSEC Q Series CPU communication port number 

Protocol Port number Remarks 

MC Protocol 3E (UDP) 

(recommended) 

Port number given in [Built-in Ethernet Port > Open Setting] 
 

MC Protocol 3E (TCP) (N:1) When using multiple TOPs, it is recommended to use TCP to avoid mistakes.  

MELSOFT Connection (UDP) QnUDEH : 5006 DEC QnUDV/QnUDPV : 5001 DEC Fixed 

MELSOFT Connection (TCP) 5007 DEC Fixed 
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check whether the port (ETH1/ETH2) settings you want to use are the same as those of the external device in [Control panel > 

Ethernet]. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC ]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Ethernet port setting IP Address OK NG 

Subnet Mask OK NG 

Gateway OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Ethernet port setting IP Address OK NG 

Subnet Mask OK NG 

Gateway OK NG 

Check address range  

OK NG 

5. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 

4.1 MC Protocol 3E (Binary / Ascii) setting 

Use the MELSEC series Ladder Software "GX Developer or GX Works” to set as follows. For more detailed setting methods than 

described in this example, refer to the PLC user manual. 
 

 

⚫ The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 

168 . 0 . 0) should match. 

⚫ Do not use duplicate IP addresses over the same network. 
 

Step 1. Double-click [Parameter] – [PLC parameter] in the [GPPW] software project window to open the [Q parameter setting]. 

Step 2. Select the [Built-in Ethernet port] tab in the [Q parameter setting] window to configure as below. 

.  

 

Items Description 

IP address IP MELSEC-Q CPU Ethernet port assigned IP 

 Subnet mask pattern Set when using subnet mask 

 Default router IP Set when using router 

Communication data code User settings (Binary code / ASCII code) 

Enable online change (FTP, MC protocol) Enable 

Disable direct connection to MELSOFT Not used 

Do not resposd to search for CPU(Built-In Ethernet Port)on network Not used 
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Step 3. Click [Open setting] in [Built-in Ethernet port] tab of the [Q parameter setting] window to set the following matters. 

 

※ Add PLC ports as many as TOP units. 

▶ It is recommended to use UDP (MC Protocol) in the wireless TOPRH Series or in a noisy environment. 

 

 

 

 

 

 

 

 

 

 

 

 

 

It must be the same as TOP’s communication option 

settings. (Remark) 

 

 

※ The picture below is an example of communicating with TOP 16 units. However, the communication speed is reduced to 1/16. 

▶ As shown in the picture below, when multiple TOPs are connected to the CPU, set “Send Wait (ms)” to “10~20 ms” in the 

TOP’s communication option to reduce the load on PLC. 

▶ As CPU Ethernet communication cannot designate the Destination IP/Port, it is easy for the user to make a serious mistake of 

using the same PLC port for N TOPs in case of N:1 communication. To prevent this, we recommend using TCP. In case of Ethernet 

communication card, it is possible to designate the Destination IP / Port, so it is faster to use UDP. 

 

 

Step 4. After transmitting the parameters set in [Online] > [Write to PLC], reset PLC. 

 

Items Description Remarks 

IP Address or Port No 

Input Format 

Select “DEC” (decimal).  

Protocol Set the external device’s 

Ethernet protocol to UDP. 

(TCP for N:1 

communication) 

Set Users 

Open system Select “MC Protocol”. Fixed 

Host station port No  

(PLC port number) 

Set the external device’s 

Ethernet communication 

port number. 

Set Users 

Decimal 

N:1 Communication=TCP 

* CPU Ethernet communication 

cannot designate Destination 

IP/Port; TCP is recommended 

when using N:1 communication 

* Ethernet communication card 

cannot designate Destination 

IP/Port; it is faster to use UCP 
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4.2 MELSOFT Connection setting 

Use the MELSEC series Ladder Software "GX Developer or GX Works” to set as follows. For more detailed setting methods than 

described in this example, refer to the PLC user manual. 
 

 

⚫ The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 

168 . 0 . 0) should match. 

⚫ Do not use duplicate IP addresses over the same network. 
 

Step 1. Double-click [Parameter] – [PLC parameter] in the [GPPW] software project window to open the [Q parameter setting]. 

Step 2. Select the [Built-in Ethernet port] tab in the [Q parameter setting] window to configure as below. 

.  

Items Settings 

IP address IP MELSEC-Q CPU Ethernet port assigned IP 

 Subnet mask pattern Set when using subnet mask 

 Default router IP Set when using router 

Communication data code Binary code (fixed) 

Enable online change (FTP, MC protocol) Enable 

Disable direct connection to MELSOFT Not used 

Do not resposd to search for CPU(Built-In Ethernet Port)on network Not used 
 

Step 3. Click [Open setting] in the [Built-in Ethernet port] tab of the [Q parameter setting] window to set the following matters. 

 
 
 

Items Description Remarks 

Protocol Set the external device’s Ethernet protocol. Set Users 

Open system Select “MELSOFT connection”. Fixed 

※ It must be the same as TOP’s communication option setting. (Remark) 
 

Step 4. After transmitting the parameters set in [Online] > [Write to PLC], reset PLC. 



 

 External device connection manual for TOP Design Studio 12 / 12 

5. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 
 

Device Bit Address Word Address Word Address NOTE 32 BIT 

Input Relay X0000 ~ X1FFF (HEX) X0000 ~ X1FF0 (HEX) X***0 *Note 1) 

L/H *Note 3) 

Output Relay Y0000 ~ Y1FFF (HEX) Y0000 ~ Y1FF0 (HEX) Y***0 *Note 1) 

Internal Relay M0000 ~ M61439 M0000 ~ M61424 M0000 + 16*n *Note 2) 

Special Relay SM0000 ~ SM2047 SM0000 ~ SM2032 SM0000 + 16*n *Note 2) 

Latch Relay L0000 ~ L32767 L0000 ~ L32752 L0000 + 16*n *Note 2) 

Annunciator F0000 ~ F32767 F0000 ~ F32752 F0000 + 16*n *Note 2) 

Edge Relay V0000 ~ V32767 V0000 ~ V32752 V0000 + 16*n *Note 2) 

Step Relay S0000 ~ S8191 S0000 ~ S8176 S0000 + 16*n *Note 2) 

Link Relay B0000 ~ BEFFF (HEX) B0000 ~BEFF0 (HEX) B***0 *Note 1) 

Special Link Relay SB0000 ~ SB7FF0 (HEX) SB0000 ~ SB7FF0 (HEX) SB***0 *Note 1) 

Timer 

(contact) 
TS00000 ~ TS25471 TS00000 ~ TS25456  

Timer 

(coil) 
TC00000 ~ TC25471 TC00000 ~ TC25456  

Aggregate Timer 

(contact) 
SS00000 ~ SS25471 SS00000 ~ SS25456  

Aggregate Timer 

(coil) 
SC00000 ~ SC25471 SC00000 ~ SC25456  

Counter 

(contact) 
CS00000 ~ CS25471 CS00000 ~ CS25456  

Counter 

(coil) 
CC00000 ~ CC25471 CC00000 ~ CC25456  

Timer 

(current value) 
TN00000.0 ~ TN25471.15 TN00000 ~ TN25471  

Aggregate Timer 

(current value) 
SN00000.0 ~ SN25471.15 SN00000 ~ SN25471  

Counter 

(current value) 
CN00000.0 ~CN25471.15 CN00000 ~ CN25471  

Data Register 
D0000000.0 ~ D4212223.15 D0000000 ~ D4212223 Binary Protocol 

D000000.0 ~ D999999.15 D000000 ~ D999999 ASCII Protocol 

Special Data 

Register 
SD0000.0 ~ SD2255.15 SD0000 ~ SD2255  

Link Register W000000.0 ~ W4045FF.F W000000 ~ W4045FF  

Link Special SW0000.0 ~ SW7FFF.F SW0000 ~ SW7FFF  

Index Z00.0 ~ Z19.15 Z00 ~ Z19  

File Register  Custom range  
 

*Note 1) For bit addresses with hexadecimal “0~F” notations, use the initial 0 bit as the word address 

*Note 2) When using a bit address that uses decimals, use a word address in units of “16” 

*Note 3) The lower 16 BIT data of 32 BIT data is saved in the address whose screen has been registered, and the upper 16 BIT data 

is saved in the address next to the address whose screen has been registered. 

   (Ex) When saving 32BIT data hexadecimal data 12345678 in address D00100, it is saved in 16BIT device address as follows. 

Items 32BIT 16BIT 

Address D00100 D00100 D00101 

Input data 

(hexadecimal) 
12345678 5678 1234 

 


