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SIEMENS AG.

SIMETIC S7 3964(R)/RK512
Compatible version OS Over 4.0

XDesignerPlus Over 4.0.0.0

CONTENTS
Thank you for using M2I’s ¡°Touch Operation Panel(M2I TOP) Series¡. 

Please read out this manual and make sure to learn connection 

method and process of TOP – External device”

1. System configuration Page 2

It explains device for connection, setup of, cable and structural 

system.

Please choose proper system referring to this point.

2. Selecting TOP model and 

external devices
 Page 3

Select TOP model and external device..

3. Example of system settings Page 4

It explains setup example for communication connection 

between the device and external terminal. 

Select example according to the system you choose in “1. 

System structure”

4. Communication settings details Page 12

It explains the way of configuring TOP communication. 

If external setup is changed, make sure to have same setup of 

TOP with external device by referring to this chapter.

5. Cable diagram Page 15

Explains cable specifications required for access.

Select proper cable specifications according to the system you 

chose in “1. System configuration”.

6. Support address Page 17

Check available addresses to communicate with external devices 

referring to this chapter.
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Series CPU Link I/F Method System settings Cable

SIMETIC

S7-300

CPU312 IFM

CPU313

CPU314 

CPU314 IFM 

CPU315 

CPU315(F)-2 DP 

CPU315(F)-2 PN/DP 

CPU316 

CPU316-2 DP 

CPU317-2 DP

CPU317F-2

CPU318-2 

CPU317-2 PN/DP 

CPU319-3 PN/DP

CPU614

CPU388

CP341 RS-232C

3.1 설정 예제 13.1 

Setting Example 1

( Page 4 )

5.1 Cable Diagram 1

( Page 15 )

CP341 RS-422 ( 4 wire )

3.2 설정 예제 23.2 

Setting Example 1

( Page 8 )

5.2 Cable Diagram 2

( Page 16 )

SIMETIC

S7-400

CPU412-1

CPU412-2 DP

CPU413-1

CPU413-2 DP

CPU414-1

CPU414-2 DP

CPU414-3 DP

CPU416-1

CPU416-2 DP

CPU416-3 DP

CPU417-4

CPU414-3PN/DP 

CPU416-3PN/DP

CPU417

CPU486

CP441-2

RS-232C

3.1 설정 예제 13.1 

Setting Example 1

( Page 4 )

5.1 Cable Diagram 1

( Page 15 )

RS-422 ( 4 wire )

3.2 설정 예제 23.2 

Setting Example 1

( Page 8 )

5.2 Cable Diagram 2

( Page 16 )

1. System configuration
The system configuration of TOP and “SIEMENS AG. - SIEMETIC S7 3964(R)/RK512” is as below.

■ Connection configuration

ㆍ1:1 connection (TOP 1 vs. external device) 
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Setting details Contents

TOP Series

Series Version name

XTOP / HTOP V4.0

Select the name of a TOP series that is to be connected to PLC.

Before downloading the settings, install the OS version specified in the table below according to 

TOP series.

Name Select the model name of TOP product.

External device Manufacturer Select the manufacturer of external devices to be connected to TOP.

Select “SIEMENS AG”.

PLC Select the model series of external devices to be connected to TOP.

Please choose “SIEMETIC S7 3964(R)/RK512”. 

Please check, in the “1. System configuration”, if the relevant external device is available to set a 

2. Selecting TOP model and external devices
Select the external devices to connect to TOP.
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system configuration.
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Details TOP SIEMTIC S7 Series Remark

Serial level (port/channel) RS-232C (COM2) RS-232C User settings

Serial baud rate [BPS] 76800 User settings

Serial data bit [Bit] 8 User settings

Serial stop bit [Bit] 1 User settings

Serial parity bit [Bit] EVEN User settings

Motion mode RK512 User settings

■  [ Project > Project property > Project > Settings > TOP Name ]

Set the communication interface of TOP tool.

- From right window [ HMI Setup > check Use HMI Setup > Device Manager ] 

■ External device settings

Setup communication driver of “SIMETIC S7-200 Series PPI”.

– PLC Node No. : Input Node address of External device.

3. Example of system settings
The setup of communication interface between TOP and SIEMTIC S7 is recommended as below.

3.1 Example of settings 1

The system is set as below.

((1) XDesignerPlus setup

After setting the below details in [Project > Project Settings], download the detailed settings using TOP tool.
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Setup PLC node address lower than “Highest Node Address”. 

Details Contents

Staion number 2 ( Default )

Transmission rate 187500bps ( Default )

(2) External device settings

Setup as below using SIEMTIC S7 Ladder Software STEP 7. Please refer the PLC user manual for more detailed information if you 

need.

1. Create a new project in [New Project] at upper bar of main menu of [SIMETIC Manager].

2. Select menu [Insert] > [Station] > [1 SIMETIC 400 Station] or [2 SIMETIC 300 Station]. 

3. Double click added “[SIMETIC 400(1)]” or [SIMETIC 300(1)] CPU > Relevant CPU [Hardware] ( New [HW Config] window appears.

4. Open “[SIMATIC 400] > [RACK-400]” or “[SIMATIC 300] > [RACK-300]” at left tree window in [HW Config], select Base unit model, 

and register it using Drag & Drop to the right bottom.

5. Select [SIMATIC 400] > [PS-400] or [PS-300] and then appropriate power supply unit, and drag & drop it to the current Rack.

6. Select [SIMATIC 400] > [CPU-400] or [CPU-300] and then appropriate CPU unit and drag& drop it to the current Rack.

(If [Properties] – PROFIBUS interface DP] windows appears, press [Cancel] to finish).

7. Select [SIMATIC 400] > [CPU-400] or [CPU-300] and then appropriate CPU unit and drag& drop it to the current Rack.

8. Double click registered CPU name. → A new relevant CPU [Properties] window appears.

9. Select [Interface] > [Properties] at [General] tap in [Properties] to popup [Properties - MPI interface CPU xxx-xxx ] window.

10. Setup MPI port station number and transmission rate as below at [Properties - MPI interface CPU xxx-xxx ] window’s 

[Parameter] tap, (Transmission speed change: Click [Properties] > [Properties] window [Network Settings] tap)

11. Click [OK] to save the setting details on the [Properties] window.

12. Double click serial communication unit that is registered before on [HW Config] window. ( A new [Properties] window will be 
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appeared.)
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Details Setting Information Details Setting Information

With Block Check Check Stop Bits 1

Use Default Values Check Parity Even

Transmission Rate 76800 bps Priority Low

13. This confirms the Input Start Address from [Inputs]>[Start] in [Properties] > [Addresses] Tap.

14. Click [Parameter...] key in the down side of [Properties] window. 

(A new [Assigning Parameter to Point-To-Point Connections] window will be appeared.)

15. Set the [Protocol] to [RK512] from [Assigning Parameter to Point-To-Point Connections] window.

16. Input as below on [RK512] Protocol detail settings after double clicking [Protocol] box in the middle of screen.

17. After saving settings by following [File] > [Save], execute [Assigning Parameter to Point-To-Point Connections] turn off the 

window.
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18. Save hardware setting information by selecting [Station] > [Save and Compile].
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[Language for selected Blocks] > [STL] [Language for selected Blocks] > [LAD]

(예) [Libraries] > [CP 341] > [FB7 P_RCV_RK CP341]

CALL“P_RCV_RK” , DB7

EN_R

R

LADDR

DB_NO

DBB_NO

L_TYP

L_NO

L_OFFSET

L_CF_BYT

L_CF_BIT

NDR

ERROR

LEN

STATUS

:=TRUE

:=FALSE

:=256

:=

:=

:=

:=

:=

:=

:=

:=

:=

:=

:=

Details Contents

DB7 DB number that P_RCV_RK will apply for communication receiving.

EN_R Communication can be possible when ‘EN_R' sets to ON

R Input Reset

LADDR Input Start Address number that has been confirmed on sequence 13th

DB_NO Input DB that will be used. Read and Write on communication where it has been given.

19. [SIMATIC Manager] on window project tree, select [Name of the CPU that is registered in HW Config] and select [Blocks], 

double click [OB1]. (If [Properties] window pops up, click [ok].) (Run Ladder software [LAD/STL/FBD])

20. Set the parameter from Ladder software [LAD/STL/FBD]. Please set up after selecting one of examples below following by 

[Language for selected Blocks] > [STL] or [LAD].

◆ Description

21. Compile by selecting [Station] > [Save and Compile], and download setup details into PLC.
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Details TOP SIEMTIC S7 Series Remark

Serial level (port/channel) RS-422 ( 4 wire, COM2 ) RS-422 User settings

Serial baud rate [BPS] 76800 User settings

Serial data bit [Bit] 8 User settings

Serial stop bit [Bit] 1 User settings

Serial parity bit [Bit] EVEN User settings

Motion mode RK512 User settings

■  [ Project > Project property > Project > Settings > TOP Name ]

Set the communication interface of TOP tool.

- From right window [ HMI Setup > check Use HMI Setup > Device Manager ] 

■ External device settings

Setup communication driver of “SIMETIC S7-200 Series PPI”.

– PLC Node No. : Input Node address of External device.

3.2 Example of Settings 2

The system is set as below.

(1) XDesignerPlus setup

After setting the below details in [Project > Project Settings], download the detailed settings using TOP tool.
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Setup PLC node address lower than “Highest Node Address”. 

Details Contents

Staion number 2 ( Default )

Transmission rate 187500bps ( Default )

(2) External device settings

Setup as below using SIEMTIC S7 Ladder Software STEP 7. Please refer the PLC user manual for more detailed information if you 

need.

1. Create a new project in [New Project] at upper bar of main menu of [SIMETIC Manager].

2. Select menu [Insert] > [Station] > [1 SIMETIC 400 Station] or [2 SIMETIC 300 Station]. 

3. Double click added “[SIMETIC 400(1)]” or [SIMETIC 300(1)] CPU > Relevant CPU [Hardware] ( New [HW Config] window appears.

4. Open “[SIMATIC 400] > [RACK-400]” or “[SIMATIC 300] > [RACK-300]” at left tree window in [HW Config], select Base unit model, 

and register it using Drag & Drop to the right bottom.

5. Select [SIMATIC 400] > [PS-400] or [PS-300] and then appropriate power supply unit, and drag & drop it to the current Rack.

6. Select [SIMATIC 400] > [CPU-400] or [CPU-300] and then appropriate CPU unit and drag& drop it to the current Rack.

(If [Properties] – PROFIBUS interface DP] windows appears, press [Cancel] to finish).

7. Select [SIMATIC 400] > [CPU-400] or [CPU-300] and then appropriate CPU unit and drag& drop it to the current Rack.

8. Double click registered CPU name. → A new relevant CPU [Properties] window appears.

9. Select [Interface] > [Properties] at [General] tap in [Properties] to popup [Properties - MPI interface CPU xxx-xxx ] window.

10. Setup MPI port station number and transmission rate as below at [Properties - MPI interface CPU xxx-xxx ] window’s 

[Parameter] tap, (Transmission speed change: Click [Properties] > [Properties] window [Network Settings] tap)

11. Click [OK] to save the setting details on the [Properties] window.

12. Double click serial communication unit that is registered before on [HW Config] window. ( A new [Properties] window will be 
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appeared.)
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Details Setting Information Details Setting Information

With Block Check Check Stop Bits 1

Use Default Values Check Parity Even

Transmission Rate 76800 bps Priority Low

13. This confirms the Input Start Address from [Inputs]>[Start] in [Properties] > [Addresses] Tap.

14. Click [Parameter...] key in the down side of [Properties] window. 

(A new [Assigning Parameter to Point-To-Point Connections] window will be appeared.)

15. Set the [Protocol] to [RK512] from [Assigning Parameter to Point-To-Point Connections] window.

16. Input as below on [RK512] Protocol detail settings after double clicking [Protocol] box in the middle of screen.

17. After saving settings by following [File] > [Save], execute [Assigning Parameter to Point-To-Point Connections] turn off the 

window.
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18. Save hardware setting information by selecting [Station] > [Save and Compile].
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[Language for selected Blocks] > [STL] [Language for selected Blocks] > [LAD]

(예) [Libraries] > [CP 341] > [FB7 P_RCV_RK CP341]

CALL“P_RCV_RK” , DB7

EN_R

R

LADDR

DB_NO

DBB_NO

L_TYP

L_NO

L_OFFSET

L_CF_BYT

L_CF_BIT

NDR

ERROR

LEN

STATUS

:=TRUE

:=FALSE

:=256

:=

:=

:=

:=

:=

:=

:=

:=

:=

:=

:=

Details Contents

DB7 DB number that P_RCV_RK will apply for communication receiving.

EN_R Communication can be possible when ‘EN_R' sets to ON

R Input Reset

LADDR Input Start Address number that has been confirmed on sequence 12th

DB_NO Input DB that will be used. Read and Write on communication where it has been given.

19. [SIMATIC Manager] on window project tree, select [Name of the CPU that is registered in HW Config] and select [Blocks], 

double click [OB1]. (If [Properties] window pops up, click [ok].) (Run Ladder software [LAD/STL/FBD])

20. Set the parameter from Ladder software [LAD/STL/FBD]. Please set up after selecting one of examples below following by 

[Language for selected Blocks] > [STL] or [LAD].

◆ Description

21. Compile by selecting [Station] > [Save and Compile], and download setup details into PLC.
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■  [ Project > Project property > Project > Settings > TOP Name ]

Set the communication interface of TOP tool.

- From right window [ HMI Setup > check Use HMI Setup > Device Manager ] 

- From right window [ HMI Setup > check Use HMI Setup > PLC Setup ] 

■ External device settings

Setup communication driver of “SIMETIC S7-200 Series PPI”.

Details Contents

Signal level External device – select serial communication method between TOPs. (COM1 supplies RS-232C 

only)

Baud rate External device – select serial communication speed between TOPs.

Data bit External device – select serial communication data bit between TOPs.

Stop bit External device – select serial communication stop bit between TOPs.

Parity bit External device – select serial communication parity bit check method between TOPs.

Time out [ x100 mSec ] Set up TOP’s response waiting time from external device at [ 0 – 5000 ] x 1 mSec.

Transmitting Delay Time [ x10 

mSec]

Receiving Wait Time [ x10 

mSec]

Set up TOP’s waiting time between response receiving – next command request transmission from 

external device at [ 0 – 5000 ] x 1 mSec.

PLC address [0~65535] Address of other device. Select between [0 - 65535].

4. Communication settings details
Communication settings are available at XDesignerPlus or TOP main menu. Communication settings must be identical with the 

external devices.

4.1 XDesignerPlus settings details

Select [Project > Project property] to show the below window.

■ Communication Interface Settings
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PLC setup

PLC Address : 00 Communication Interface 

Timeout : 1000 [mSec] Settings

Delay time of transmission : 0 [mSec]

TOP COM 2/1 : RS – 232C , 76800 , 8 , 1 , NONE

 TOP COM 2/1 setup   communication test

Details Contents

PLC address [0~65535] Address of other device. Select between [0 - 65535].

Timeout [ x1 mSec ] Set up TOP’s response waiting time from external device at [ 0 – 5000 ] x 1 mSec.

Delay time of transmission [ 

x1 mSec ]

Set up TOP’s waiting time between response receiving – next command request transmission 

from external device at [ 0 – 5000 ] x 1 mSec.

TOP COM 2/1 TOP’s Interface setup to external device.

Port Settings

* Serial communication COM 1 Port

 + COM-1 Port Communication Interface 

  - Baud rate : 76800 [BPS] Settings

  - Data bit : 8 [BIT]

  - Stop bit : 1 [BIT]

  - Parity bit : NONE [BIT]

  - Signal level : RS – 232C

 + COM-2 Port COM-2 Port

  - Baud rate : 76800 [BPS] Communication Interface 

  - Data bit : 8 [BIT] Settings

  - Stop bit : 1 [BIT]

  - Parity bit : NONE [BIT]

  - Signal level : RS – 232C

Details Contents

Baud rate External device – select serial communication speed between TOPs.

Data bit External device – select serial communication data bit between TOPs.

Stop bit External device – select serial communication stop bit between TOPs.

Parity bit External device – select serial communication parity bit check method between TOPs.

Signal level External device – select serial communication method between TOPs.

4.2 TOP main menu setup item

 - When a buzzer is on during the power reset, touch 1 spot at the upper LCD to move to "TOP Management Main" display.

- Set up driver interface at TOP according to below Step1 → Step2.

(Press “TOP COM 2/1 setup” in Step 1 to change setup at Step 2.)

Step 1. [ PLC setup ] - Setup driver interface.

Step 1–Reference.

Step 2. [ PLC setup ] >[ TOP COM2/COM1 setup ] – Setup relevant port’s serial parameter.

Step 2–Reference.
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OK! Communication setting succeeded

Time Out Error! Communication setting error

- Error in the setting situation of Cable and TOP / External device

(reference : Communication Diagnosis sheet)

Designer Version O.S Version

Details Contents Confirm

System 

configuration

Name of CPU
OK NG

Name of confront port that is 

communicating
OK NG

System Connection Method 1:1 1:N N:1 OK NG

Connection 

Cable

Name of Cable
OK NG

PLC setup Setup address OK NG

Serial baud rate                               [BPS] OK NG

Serial data bit                               [BIT] OK NG

Serial Stop bit                               [BIT] OK NG

Serial parity bit                               [BIT] OK NG

Assigned Address Limit OK NG

TOP setup Setup port COM 1 COM 2 OK NG

Name of Driver OK NG

Confront Address Project Property Setup OK NG

Diagnosing Communication OK NG

Serial baud rate                               [BPS] OK NG

Serial data bit                               [BIT] OK NG

Serial Stop bit                               [BIT] OK NG

Serial parity bit                               [BIT] OK NG

4.3 Communication diagnosis

■ TOP - Confirming interface setting condition between external devices 

- Move to Menu by clicking the top side of LCD screen as resetting the power of TOP.

- Confirms if Port [COM 2 or COM 1] setting that is willing to use in [Communication Settings] matches with the setting of external 

devices.

■ Port Communication Issue Diagnosis

- PLC Setup > TOP [ COM 2 or COM 1 ] click "Communication Diagnosis" button.

- Diagnosis dialog box will pop up on the screen, you can judge by following information that are shown on box no. 3 section.

■ Communication Diagnosis Sheet 

- Please refer to the information below if you have a problem between external devices and communication connection.
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XTOP COM2

Cable Connection

External device

pin arangement * 

caution 1)

Name 

of 

Signal

Pin 

Number

Pin 

Number

Name 

of 

Signal

pin arangement * 

caution 1)

Front View of

D-SUB 9 Pin male 

(Male, convex)

CD 1 1 CD

Front View of

D-SUB 9 Pin male 

(Male, convex)

RD

2 2

RD

SD 3 3 SD

DTR 4 4 DTR

SG 5 5 SG

DSR 6 6 DSR

RTS 7 7 RTS

CTS 8 8 CTS

9 9 RI

XTOP COM2 Cable Connection External device

pin arangement * 

caution 1)

Name 

of 

Signal

Pin 

Number

Pin 

Number

Name 

of 

Signal

pin arangement * 

caution 1)

Front View of

D-SUB 15 Pin 

male(Male convex)

CD 1 1 CD

Front View of

D-SUB 9 Pin male 

(Male, convex)

RD 2 2 RD

SD 3 3 SD

DTR 4 4 DTR

SG 5 5 SG

DSR 6 6 DSR

RTS 7 7 RTS

CTS 8 8 CTS

9 9 RI

XTOP/ATOP COM 1 Port

Cable Connection

External device

pin arangement * 

caution 1)

Name 

of 

Pin 

Number

Pin 

Number

Name 

of 

pin arangement * 

caution 1)

5. Cable diagram 
This Chapter is to introduce the Cable diagram for regular communication between TOP and relative devices. (The Cable diagram 

which are going to be introduced in this chapter might be different than what "SIEMENS AG." recommends.)

5.1 Cable diagram 1

■ 1 : 1 Connection

(A) XTOP COM 2 Port (9 pin)

*Caution1) Pin arrangement is shown from connecting face in cable connection connecter.

(B) XTOP COM 2 Port (15 pin)

*Caution1) Pin arrangement is shown from connecting face in cable connection connecter.

(C) XTOP/ATOP COM 1 Port ( 6 Pin)



22 / 25

Signal Signal

Front View of

D-SUB 6 Pin male 

(Male, convex)

1 1 CD

Front View of

D-SUB 9 Pin male 

(Male, convex)

RD

2 2

RD

SG 3 3 SD

4 4 DTR

5 5 SG

SD 6 6 DSR

7 RTS

8 CTS

9

*Caution1) Pin arrangement is shown from connecting face in cable connection connecter.



23 / 25

XTOP COM2

Cable Connection

External device

pin arangement * 

caution 1)
Signal Pin Pin Signal

pin arangement * 

caution 1)

Front View of

D-SUB 9 Pin male 

(Male, convex)

RDA

1 1

Front View of

D-SUB 15 Pin 

male(Male convex)

2 2 T(A)

3 3

RDB 4 4 R(A)

SG 5 5

SDA 6 6

7 7

8 8 GND

SDB 9 9 T(B)

10

11 R(B)

XTOP COM2 Cable Connection External device

pin arangement * 

caution 1)

Signal Pin Pin Signal pin arangement * 

caution 1)

Front View of

D-SUB 15 Pin male

(Male convex)

– 1 1

Front View of

D-SUB 15 Pin male

(Male convex)

(생략) 2 T(A)

3

4 R(A)

5

– 10 6

RDA 11 7

RDB 12 8 GND

SDA 13 9 T(B)

SDB 14 10

5.2 Cable diagram 2

■ 1 : 1 Connection

(A) XTOP COM 2 Port (9 pin)

*Caution1) Pin arrangement is shown from connecting face in cable connection connecter.

(B) XTOP COM 2 Port (15 pin)
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SG 15 11 R(B)

XTOP COM2

Cable Connection

External device

pin arangement * caution 1) Signal Pin Signal
pin arangement * 

caution 1)

Front View of

Terminal Block 5 Pin

RDA 1

Front View of

D-SUB 15 Pin male

(Male convex)

RDB 2 T(A)

SDA 3

SDB 4 R(A)

SG 5

6

7

8 GND

9 T(B)

10

11 R(B)

*Caution1) Pin arrangement is shown from connecting face in cable connection connecter.

(C) ATOP COM 2 Port ( Terminal Block 5 pin )

*Caution1) Pin arrangement is shown from connecting face in cable connection connecter.
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Support address Support address 32 bits Remark

External Input 

Relay

* caution1)

I00000.0 –

I00127.7

E00000.0 –

E00127.7

IW00000 –

IW00126

EW00000 –

EW00126

H/L

*caution4caution5)

Not 

writable

External Output 

Relay

* caution2)

Q00000.0 

–

Q00127.7

A00000.0 –

A00127.7

QW00000 –

QW00126

AW00000 –

AW00126

Not 

writable

Data length DB00001 : DBX00000 –

DB65535 : DBX65533.7

DB00001 : DBW00000 –

DB65535 : DBW65532

—

Internal Memory M00000.0 – M00511.7 MW00000 – MW00510 Not 

writable

Timer*caution3) — T00000 – T00255 Not 

writable

Counter*caution3) — C00000 – 

C00255

Z00000 – 

Z00255

Not 

writable

6. Support address
Devices that are usable with TOP is as below. 

There might be difference in the range of device (address) by type / series of CPU module TOP series supports the maximum 

address range that external device series use Please refer each CPU module user manual carefully for devices that you desired to use 

to prevent not getting out of range.

*Caution1) Input Device (I,IW) might not be able to input read on the address of IW0 ~ IW2 because depends on the type of CPU, it 

becomes subordinate in the integrated I/O. Please refer to the PLC Manual.

*Caution2) Output Device (Q, QW, QD) can write value only in the Run Mode. Output value will be reset if it's STOP Mode.

*Caution3) Device Restricted to Read only

*Caution 4) Regarding on Word device, 32 but Data will be saved in the order of from High / Low, 16 bit each.

(Example) VW00000 (32bit data, 0x12345678) è VW00000(16bit, 0x1234) VW00002(16bit, 0x5678)

*Caution5) Checks "Word Swap" function when Double word address is being used.


