KEYENCE.
KV-700/1000/3000/5000/5500 Series
Computer Link(MC Protocol)

Supported version  TOP Design Studio V1.0 or higher {Rl

TOP

"

CONTENTS

We would like to thank our customers for using M2I's "Touch

Operation Panel (M2] TOP) Series". Read this manual and familiarize
yourself with the connection method and procedures of the "TOP and

external device”.

1. System configuration Page 2

Describes the devices required for connection, the setting of

each device, cables, and configurable systems.

2. External device selection Page 3

‘ Select a TOP model and an external device.

3. TOP communication setting Page 4

Describes how to set the TOP communication.

4. External device setting Page 9

Describes how to set up communication for external devices.

5. Cable table Page 10

Describes the cable specifications required for connection.

6. Supported addresses Page 11

Refer to this section to check the addresses which can

communicate with an external device.
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1. System configuration

The system configuration of TOP and “Keyence KV Series Loader” is as follows:
Series CPU Link I/F Communication method System setting Cable

RS-232C

(Port 1)
RS-232C

(Port 2)
RS-422(4 wire)
(Port 2)
RS-485(2 wire)
(Port 2)
RS-232C

(Port 1)
RS-232C
KV-L20R (Port 2) -
KV-1000 KV-1000 X setting 5. Cable table
KV-L20V RS-422(4 wire)
(Port 2)
RS-485(2 wire)
(Port 2)
RS-232C

(Port 1)
RS-232C

(Port 2)
RS-422(4 wire)
(Port 2)
RS—485(2 wire)
(Port 2)

KV-L20
KV-700 KV-700 KV-L20R
Kv-L20V

3. TOP

communication.

4. External device

setting

KV-3000 KV-3000
KV-5000 KV-5000 Kv-L20V
KV-5500 KV-5500

H Connection configuration

+ 1:1 (one TOP and one external device) connection — configuration which is possible in RS232C/422/485 communication.

+ 1:N (one TOP and multiple external devices) connection — configuration which is possible in RS422/485 communication.
) (] S—

{J M]EE«] ' ;';«Zl .........
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device n

PLC select [COM1]

Filter : ‘[A\I'] v| Search : l:l

(O Model (@) Vendor

Vendor Model
A
SANGII Precision Co., Ltd. & KV-10/16/24/40
DEVA &,
"’ KV-700/1000/3000/5000/7000,8000
OPTICON
Barcode Reader BL Series

TOHMNICHI
& KV NANO Series

Giddings & Lewis Motion Control
DELTA TAU Data Systems
Digital Electronics Corporation
HONEYWELL

MISUMI

PARKER. HANNIFIM Corporation

TOSHIBA
ATLAS COPCO
TOSHTRA MACHTNF Co.. |t ©
M8_Back | B Next ® Cancel
Select Device [« |

PLC Setting[ KV-700/1000/3000/ 5000/ 7000/ 8000 ]

Alizs Mame : [PLC1
igle=g Rl Computer Link ~

Protocol : |MC Protocol 1C (Format1) ~ Comm Manual
String Save Mode : |First LHHL Change

[] use Redundancy
AND ~

4k

Primary Option

Timeout 300 4| msec
Send Wait msec
Station Num

4 Back « oK *® Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select "KEYENCE".
PLC Select an external device to connect to TOP.

Interface Protocol

KV-700/1000/3000/5000/7000 | Computer Link Computer Link

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting
M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Serial]

— Set the TOP communication interface in TOP Design Studio.
Project Option hs

. Change HMI[H] ' Add PLC[A] | 7T Change PLCIC | 1] Delete PLCID]

TOP Seth
I - — Im Date / Time Sync. | Scresn Option | Unit Convert

* - Option Module Setting Praject Option | Screen Change | HmiSetup | JGlobal Lock & Touch ~ Project Style  Splash | PLC Buffer Sync.

i W RFID(0) Use HMI Setup
W i Device Setting

v 158 COM1 (1) Hmi Setup Option Initialization I Edit I

* PLC1: KV-700/1000/3000)

H Start Mode =Menu -
gl COM2 (D) Start Screen No.=1

Ta¥ COM3 (0) Latch Use=0

A Ethernet (0) Latch Set=0~0

s Communication Error Message=0
T Wireless (0) USBErrorMessage =0
-4 USBDevice (0) StorageErrorMessage=1
DatabaseMessage=1
SystemMessage=1
DisplaylLockIcon=0
DisplayPermissionIcon=0
DarkDraw=0
DrawTouchPos=0
TOPID=1

AutoRun=0

Language =English

Project Advanced Setting
HMIDisable =0
RunSleep=50
EffectSleep=50
CommunicationSleep=1
ProjectLoadType=1
InitDataPrevScreen=1
ErrorLogWrite=0
BlinkTime =0
WatchDog=0
SDCoverOption=0
TaskMonitor=1
CommSleepChgllse =0
CommSleepChg=1000
MomentaryBitActionTime =20
CommunicationRatio=0

Ethernet

HMIDisable=0

ETH1=1

IP1=192.168.0.100

Subnet1=255.255.255.0

Gateway1=192,168.0.1

Speed1=0

DefaultGatewavi=1 L

Apply Close

Centrol Panel

System Devices [uﬂ Service ;' Option

s Serial *

p Serial Port: @ COM1 <
- | =E D E
il 1~ - . Signal Level
FLC Security Dat e/Time Display Tauch Sound @ HS—ZSECO RS-A422(4) O RS-485(2)
\ _ Baud Rate: 115200 M
- . ) —
g - Data Bit: & e
Ethernet Serial HOH1 I_nziat \ianlni Sensor Wi-Fi
— 0 Stop Bit: 1 w2
E—] [~
I:I M .m} ' | @ Parity Bit: Ewven 7
Diagnost ic MaFnial;Er Fing EE%’?SE Top Menu An!??;gis F | ow_ Uf f
Auto Search  Loopback Test

[System]

Get HMI Setup oK Cancel Apply  Cancel
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Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C

Baud Rate 115200

Data Bit 8

Stop Bit 1

Parity Bit Even

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.

(2) Communication

option setting

M [ Project > Project Property > Device Setting > COM1 > PLC1:KV-700/1000/3000/5000/7000]
Set the options of the communication driver in TOP Design Studio.

Praject Opticn

B crenoe i)

W faarc i T Change PLCIC)

[ Delete PLCID]

~ -] TOP Setting

i L[] SY5:RD1520%
Option Module Setting
8 FieldBus (0)

W RFID (0)

~ i Device Setting

r

o™
i il PLC1 : KV-700/1000,3000)

¥ COM3 (D)
Ethernet (0)
¥ Wireless (0)

- USBDevice (0)

Interface : | Computer Link ~

Protocol : | MC Pratocol 1C (Formati)

String Save Mode : |First LH HL Change

[ use Redundancy

AMND v
o -
0 -
Primary Option
imeout 300 & | msec
Fend Wait msec

PLC Setting[ Kv-700/1000/3000/5000/ 7000/ 8000 ]

Alias Mame : PLC1

Comm Manual

Apply Close
Items Settings Remarks
Interface Configure the communication interface between the TOP and an external device. Refer to "2. External
Protocol Configure the communication protocol between the TOP and an external device.

device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

and sending the next command request.

Set the waiting time between TOP’s receiving a response from an external device

Station Num

Enter the prefix of an external device.
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* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

Bun

YHC
Yiewer

(i

Ethernet

Diagnost ic

Serial

=
S

Manager

Conikroll Panel

Serial Port: [ COM1

Signal Level

® R5-232C O R5-422(4) O R5-485(2)
Baud Rate: | 115200 |~
Data Bit: | 8
Stop Bit: | 1

Parity Bit: | Even

Flow: [ 0f f

[Auto Search] lLoopback Testl

| Apply

| cancel |

4 HI

“ [System]

LTO

r-'

Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C

Baud Rate 115200

Data Bit 8

Stop Bit 1

Parity Bit Even

* The above settings are setting

examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.

External device connection manual for TOP Design Studio

6/ 11



TO tHRIRUE &3y -
Touch Qperation Panel

(2) Communication option setting

B [Main Screen > Control Panel > PLC]

B
o s PLC

@ Syste [Driver(COMI) | PLC1(KV—TDDHDUDISDDUIEDDDITUDDIBUUU)é vl
Run [
Interface | Computer Link Rd
!I|'| Protocol | MC Protocol 1C (For|~|
‘ PLC Timeout 300 |2 msec
NC send Wait msec
e T R s E_1
FEmyg g (=]
[ ] Ethernet Station _ﬂ
4©°
Emmd
Screen m
shot
Diagnost ic
[System] [ Diagnostic l Ao |y ” Cancel ]

el
Items Settings Remarks
Interface Configure the communication interface between the TOP and an external device. Refer to "2. External
Protocol Configure the communication protocol between the TOP and an external device. device selection”.
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.
SendWait (ms) Set the waiting time between TOP's receiving a response from an external device and

sending the next command request.

Station Num Enter the prefix of an external device.
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3.3 Communication diagnostics

W Check the interface setting status between the TOP and external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system oK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information (0] ¢ NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting OK NG
Communication 2. External device selection
) ) oK NG L .
diagnostics 3. Communication setting
Serial Parameter Transmission
(0] ¢ NG
Speed
Data Bit oK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name oK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix OK NG
Other detailed settings oK NG . .
4. External device setting
Serial Parameter Transmission
oK NG
Speed
Data Bit oK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

4.1 KV 1000/3000/5000 series

KV 1000/3000/5000 Series do not have additional settings that need to be configured.

4. 2 KV-7000 series

As shown in the figure below, the Unit Editor’'s setup unit configures the port number operation mode to ‘Protocol mode 1.

Unit a
Select unit(l)  Setup unit(2)
iE 7= By [1] EV-L2*V
E Basze

Leading DM No. DM10000

Number of DMs in use 1

Leading relay No. (set chan... R30000

Number of relays in use 32

Node No. a{*)
B Port 1

Detail —={*)

Interface R5-232C(*

Baudrate Se00bps(*)

Data bit length 8 bits(¥*)

Start bit 1 bits({*)

Stop bit 1 bits(*)

Parity Even(*)

Checksum none (*)

R5/C5 flow control OFF(*)
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This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.

W RS-232C (1:1 connection)

COM1 / COM2 Main Controller
. Signal Pin Cable connection Pin Signal .
Pin arrangement*Note 1) Pin arrangement*Note 1)
name | number number | name
RS422 1 1
1 5 RXD 2 2 TXD
Q Qo
TXD 3 3 SG
@) O
6 9 RS422 4 4 RXD
Based on communication SG B 5
cable connector front, RS5422 6 6
D-SUB 9 Pin male (male, 5V 7 123456
convex) GND 8 RJ-12 6-pin connector
RS422 9

*Note 1) Pin arrangement is depicted as facing the interface of the cable connector in this figure. Unused pins are not connected.
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6. Supported addresses

The devices available in TOP are as follows:
The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address
range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Device Bit Address Word Address Remarks
Input/Output R0O0000 — R99915 RO00 — R999
Link Relay BOOOO — BFFFF BOO0OO — BFFFO
Internal Auxiliary Relay MR00000 — MR99915 MRO00 — MR999
Latch Relay LR0O0000 — LR99915 LROOO — LR999
Control Relay CRO000 - CR3915 CROO - CR39
Control Memory CMO0000.00 — CM5999.15 CMO0000 - CM5999
Data Memory DMO0000.00 — DM65534.15 DMO0000 — DM65534
Expansion Data Memory EM00000.00 — EM65534.15 EMO00000 — EM65534
File Register — Current Bank FM00000.00 — FM32767.15 FMO00000 - FM32767
File Register ZF00000 - ZF131071.15 ZF00000 - ZF131071
Link Register W000.00 — W999.15 WO000 - W999
Timer contact TOO0O - T511 —
setting — TS000 — TS511
Counter contact C000 - C511 —
setting — CS000 — CS511
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