LS MECAPION Co., Ltd.
MXQ SERIAL Driver

Supported version  TOP Design Studio V1.0 or higher {Rl

CONTENTS

We would like to thank our customers for using M2l's "Touch

Operation Panel (M2 TOP) Series". Read this manual and familiarize
yourself with the connection method and procedures of the "TOP and

external device".

1. System configuration Page 2

Describes the devices required for connection, the setting of

each device, cables, and configurable systems.

2. External device selection Page 3

Select a TOP model and an external device.

3. TOP communication setting Page 4

Describes how to set the TOP communication.

4. External device setting Page 9

Describes how to set up communication for external devices.

5. Cable table Page 10

Describes the cable specifications required for connection.

6. Supported addresses Page 11

Refer to this section to check the addresses which can

communicate with an external device.
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1. System configuration

The system configuration of TOP and “LS MECAPION Co., Ltd. - MXQ" is as follows:

Series ‘ CPU Link I/F Communication method System setting

3. TOP communication

settin
MXQ MXQ-20,21,40,41 RS-232C,485 = 5. Cable table

4. External device

setting

B Connection configuration

+ 1:1 (one TOP and one external device) connection — configuration which is possible in RS232C communication.
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device H
PLC select [COM2]
Filter : |[AII] v‘ Search : I:I
@ Model (O Vendor
Vendor Model

S A
LS MECAPION & Anypack Series
TR o L _

EMOTIONTEK

RKC Instrument Inc.
HANYOUMG MUX
SAMWONTECH

SICK AG.

FUII Electric Co., Ltd.
SANGII Predsion Co., Ltd.
DEVA

OPTICON

TOHNICHL

Giddings & Lewis Motion Control

DFITA TAll Nata Sveteme %

4_Back | B Next *® Cancel

Select Device n

PLC Setting[ MXQ ]

Alizs Mame @ |PLCL

Interface : | Serial ~
Protocol : |MODBUS RTU ~ Comm Manual
String Save Mode : |First LH HL Change
[ use Redundancy
AND ~
Co Edi
Primary Option
Timeout 300 &|| msec
Send Wait msec
Retry 5 =
Slave Equipment No. DI
Read Boundary 125 =
Write Boundary
Write Function
@ Back + OK * Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select “LS MECAPION (Metronix)".
PLC Select an external device to connect to TOP.

Protocol
MODBUS RTU

Interface

MXQ SERIAL

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.

External device connection manual for TOP Design Studio

3/ 1



3. TOP communication setting
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting

M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Serial]
— Set the TOP communication interface in TOP Design Studio.

Project Option

- Change HMI[H] ' Add PLC[A] | THTal Change PLCICI | [ Delete PLC[D]
D TCP Settng Date / Time Sync.  Screen Option Unit Convert
Option Module Setting Project Option =~ Screen Change = HmiSetup  Global Lock & Touch  Project Style = Splash  PLC Buffer Sync.
F . Use HMI Setup
EivEeO ;elti(l;)g Himi Setup Option Initialization Edit
CoM2 (1) Start Mode =Menu I3
8 PLCL: MYQ [1] Start Screen No. =1
a8 COM3 (D) Lag ;ls:=é)m0
: Ethernet (0) Lz et=
: USBDevice (0) Sgggﬂ:;‘g;;:’é Message=0
StorageErrorMessage=1
DatabaseMessage=1
Control Panel
. |
System m Devices | . sen: X
Serial Port:  COM1 <
— -
il l 7 Y Signal Level
(® R5-232C (O R5-422(4) (O RS-485(2)
PLC Securit Dat e/ Time I
¥ Baud Rate: 38400 =
Data Bit: 8 -
st Bit: 1 "
T e o it '
Parity Bit: MNone &
Et hernet Serial HOK | Flow: 0ff
. Auto Search  Loopback Test
—
[—|~_- “ Apply | Cancel
L sl Ping
Diagnost ic File Ping keypad Top Menu R4
Manager Opt ion analysis
Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C
Baud Rate 38400
Data Bit 8
Stop Bit 1
Parity Bit None.

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [ Project > Project Property > Device Setting > COM > “PLC1 : MXQ"]
— Set the options of the LS MECAPION Co., Ltd. — MXQ Series SERIAL communication driver in TOP Design Studio.

ERI2 e B X
Touch Qperation Panel

Project Option

- Change HMIH]

W Acd PLC Al Tl Change PLCIC)

[ Delete PLCID)

~ ] TOP Setting

| L[ 5Y5:RDO810S
Option Module Setting
¥ FieldBus (0)

- RFID (0)

w Device Setting

o® COM1(0)

< Haa wXkil

PLC Setting[ MXQ ]

Alizs Name : [PLC1

Interface : | Serial ~

Protocol : |MODBUS RTU ~

String Sawve Mode : |First LHHL Change

..... 4 PLC1: MXQ [1]

o8 COM3 (0)
-4 Ethernet (0)

..... W% USBDevice (0)

[ use Redundancy

Condition ( Edit
Primary Option
Timeout
Send Wait
Refry

Slave Equipment MNo.

Read Boundary 125 =
Write Boundary 100 =
Write Function

Function Ox10 ~

Comm Manual

Items Settings Remarks
Interface Select "Computer Link”". Refer to "2. External
Protocol Select the communication protocol between the TOP and an external device.

device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP’s receiving a response from an external device and

sending the next command request.

Station Num

Enter the prefix of an external device.

Write Function

Configure the write command.
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3.2. Communication setting in TOP
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* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

Conitrol

-

Panel

Serial

Bun —
Serial Port: l[][]h-H |vl
Signal Level
‘ ® PS-232C (O RS-422(4) O RS-485(2) l
Baud Rate: | 38400 -
¥NC L
Viewer i A D Data Bit: [ 8 H
puny Stop Bit: | 1 ~|
N E Ethernet Serial : :
' Parity Bit: | None -~
T P :
g B Flow: | [ff v
g;ggn m 1 = l | l
oi . : lAuto Searchl [Loopback Testl
iagnost ic File
Mariager
/ [ App |y “ Cancel l -
[System] Close r
Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C
Baud Rate 38400
Data Bit 8
Stop Bit 1
Parity Bit None.

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting
M [Main Screen > Control Panel > PLC]

M

Ethernet

Diagnost ic

diil)

Driver (COMZ)

PLCT(HKD) |

[System]

Interface | Serial R
Protocol | MODBUS RTU R
Timeout 300 5] msec
send Wait msec
Retry
Slave Eau =
Read Bour
Write Bol 100 |3
Write Fur Functior|~
Diagnostic ]

TO,
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>
| Aeply || Cancel |

— |

Items Settings Remarks
Interface Select “SERIAL". Refer to "2. External
Protocol Select the communication protocol between the TOP and an external device. device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP’s receiving a response from an external device and

sending the next command request.

Station Num

Enter the prefix of an external device.

Write Function

Configure the write command.
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3.3 Communication diagnostics

W Check the interface setting status between the TOP and external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information oK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG . .
diagnostics 3. Communication setting
Serial Parameter Transmission
oK NG
Speed
Data Bit oK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name oK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings OK NG . .
4. External device setting
Serial Parameter Transmission
oK NG
Speed
Data Bit oK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
oK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

Refer to the manual of the external device and configure the communication options.
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5. Cable table
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This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.

(The cable diagram described in this section may differ from the recommendations of “LS MECAPION Co., Ltd.")

W RS-232C (1:1 connection)

COM PLC
Pin Signal Pin Cable connection Pin Signal Pin
arrangement*Note 1) name number number | name | arrangementNote 1)
1 5 CcDh 1
Q Q
6 9 SD 3 TXD
Based on DTR 4
communication SG 5
cable connector DSR 6
front, RTS 7
D-SUB 9 Pin male CTS 8 SG
(male, convex) 9 SG
*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
m RS-485
COM PLC
Pin Signal Pin Cable connection Pin Signal Pin
arrangement Note 1) name number number | name | arrangement Note 1)
1 5 RDA 1 : SDA
Q o)
6 9
Based on RDB 4 S SDB
communication RDB
cable connector SDA 6
front,
D-SUB 9 Pin male
(male, convex) SDB 9
*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
m RS-422
COM PLC
Pin Signal Pin Cable connection Pin Signal Pin
arrangement Note 1) name number number | name | arrangement Note 1)
1 5 RDA 1 SDA
Q ®)
6 9
Based on RDB 4 RDA
communication RDB
cable connector SDA 6
front,
D-SUB 9 Pin male
(male, convex) SDB 9
*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
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6. Supported addresses
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The devices available in TOP are as follows:

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Device Bit address Word address Remarks
L LBOOOO-LB199F LWO000- LW199 R/W

| IBOO-IB7F IWO-IW7 R

] OB00-OB7F OWO0-OW7 R/W

G GB0000-GB299F GWO000-GW299 R/W

F FBOOOO-FB299F FW000-FW299

S SBO000-SB511F SWO000-SW511

P PBO0000-PB2047F PW0000-PW2047

M MBO00000-MB9999F MWO0000-MW9999 R/W

C CB0O000-CB63F CWO00-CW63 R
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