Delta Tau Data System Inc.
PMAC Series CRUISER SERIES

Serial Driver

Supported version  TOP Design Studio V1.0 or higher {Rl

TOP

"

CONTENTS

We would like to thank our customers for using M2l's "Touch

Operation Panel (M2l TOP) Series". Read this manual and familiarize
yourself with the connection method and procedures of the "TOP and

external device".

1. System configuration Page 2

Describes the devices required for connection, the setting of

each device, cables, and configurable systems.

2. External device selection Page 3

Select a TOP model and an external device.

3. TOP communication setting Page 4

Describes how to set the TOP communication.

4. External device setting Page 9

Describes how to set up communication for external devices.

5. Cable table Page 10

Describes the cable specifications required for connection.

6. Supported addresses Page 11

Refer to this section to check the addresses which can

communicate with an external device.
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1. System configuration

The system configuration of TOP and “PANASONIC Electric Works — FP Series Computer Link” is as follows:

Series ‘ CPU ‘ Link I/F Communication method ‘ System setting

3. TOP communication

settin
PMAC CRUISER CPU built-in RS232C RS-232C = 5.1. Cable table 1

4.1. External device

setting 1

W Connection configuration

*+ 1:1 (one TOP and one external device) connection — configuration which is possible in RS232C communication.
k[=1:]

il

+ 1:N (one TOP and multiple external devices) connection — configuration which is possible in RS422 communication.
(=1

A R bl

|
il
]
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device n

PLC select [COM1]

Filter : |[.q||] V‘ Search : l:l

@ Model () Vendor

Vendor
EMOTIONTEK 2

RKC Instrument Inc.
HANYOUNG MUX
SAMWONTECH

SICK AG.

FUI Electric Co., Ltd.

SANGII Predsion Co., Ltd.
DEVA

OPTICON

TOHNICHI

Giddings & Lewis Motion Control

DELTA TAU Data Systems

KEYENCE Corporation

Dinital Flertronirs Cornaration

‘ Back | . Next ® Cancel

Select Device n

PLC Setting[ PMAC Series ]

Alias Name : PLC1

Interface : | (Vs ey ~
Protocol : | PMAC e Comm Marnual

String Save Mode : |First HL HL Change

[J use Redundancy

Primary Option
Timeout 300 &|| msec
Send Wait

StationMo.

@ Back « OK *® Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.

Select “Delta Tau Data System Inc”.

PLC Select an external device to connect to TOP.

Interface Protocol

PMAC Computer Link PMAC PROTOCOL

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting

M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Serial]

— Set the TOP communication interface in TOP Design Studio.

Project Cption
-cnange HMI[H)

t {3 TOP Setting I

~ - Option Module Setting

W 2caPicy TR change PLCIC)

Date / Time Sync.

Project Option

Screen Change

Screen Option

E3 DeletePLCD)

Unit Convert

HmiSetup | Global Lock & Touch Project Style  Splash

PLC Buffer Sync.

.4 USBDevice (0)

- Fieldsus (0)
-4 RFID (0) Use HMI Setup
-, Device Setting
v 1g¥ COM1 (1) T
i -W# PLC1: PMAC Series [0] Start Mode =Menu
s COM2 (0) Start Saeen No, =1
58 COM3 (0) Latch Use=0
L4 Ethernet (1) Latch Set=0~0

Communication Error Message=0
USBErrorMessage =0

StorageErrorMessage=1
Sirizimta)

-

Control Panel

Svstem m Devices

:na Service /=*' Option

o Serial x|
1l l (8 Serial Port:  COM1 v
FLC Security  Date/Time Signal Level
(@) RS—232C () RS-422(4) () BS-485(2)
Baud Rate: 33400 w2
T K LJ Data Bit: § -
Ethernst Serial HOM | Stop Bit: |1 -
Parity Bit: |None <
= % Flow: (i
L - '
1 = ® Ping Auto Search  Loopback Test
Diagnost ic File Fing
Manager
Apply | Cancel
Items TOP External device Remarks
Signal Level (port RS-232C
g (port) RS-232C
RS-485
Baud Rate 38400
Data Bit 8
Stop Bit 1
Parity Bit NONE

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [ Project > Project Property > Device Setting > COM > "PLC1 : FP Series"]

— Set the options of the FP Series Computer Link communication driver in TOP Design Studio.

Project Option X

- Change HMI[H] ’ AddPLCIA] | THITel Change PLCIC | [T] Delete PLCID]

v -3 TOP Setting
i [ 5Y5:RDO0B103
Option Module Setting Alizs Name : |PLC1

& Ficldbus (0) Interface : | CPU Direct ~

PLC Setting[ PMAC Series ]

Protocol : | PMAC ~ Comm Manual
String Save Mode : (First HL HL Change

[ use Redundancy

i
[a
4

Primary Option
Timeout msec

Retry 5 z

Apply Close
Items Settings Remarks
Interface Select "Computer Link". Refer to "2. External
Protocol Select the serial communication protocol between the TOP and an external device. device selection”.
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.
SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device

and sending the next command request.

Station Num Enter the prefix of an external device.

Command Header Configure the header for the Computer Link protocol.
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3.2. Communication setting in TOP

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting
M [Main Screen > Control Panel > Serial]

-‘6 Control Panel
@ System m Devi
Run —
= Serial Port: [CUM1 ‘v]
!li.l 4 signal Level
oLE secority  matel | ® FB-23ZC O RS-422(4) O AS-485(2) ]
Baud Rate: | 38400 -
| -
fewer ' - Data Bit: | § -
0 o -
R T e "
X ﬁ Ethernet Serial Stop Bit: [ 1 ‘v]
e Parity Bit: | None -
Am—— -
el - IS Flow: (06|
Diagnost ic File P [Auto Search] lLoopback Test]

Manager

crose r

| Apply | Cancel | |

[System]

—— |
Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C
Baud Rate 38400
Data Bit 8
Stop Bit 1
Parity Bit none
* The above settings are setting examples recommended by the company.
Items Description
Signal Level Select the serial communication method between the TOP and an external device.
Baud Rate Select the serial communication speed between the TOP and an external device.
Data Bit Select the serial communication data bit between the TOP and an external device.
Stop Bit Select the serial communication stop bit between the TOP and an external device.
Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

B [Main Screen > Control Panel > PLC]

ety
o — PLC

@ Systq Driver(COMI) | PLCT(PMAC Series) |
Run —
Interface LCPU Direct A
‘ !Iil | Protocol | PMAC [-]
PLC Timeout 300 |3 msec
YNC send Wait 0 3 msec
Yiewer
] | " E_1
rumyg . =
. Ethernet | Stationblc =
L}
Bmma
screen
shot
Diagnost ic
[Systeﬂl Diagnostic l Ao |y “Cancel ]
Items Settings Remarks
Interface Select "Computer Link". Refer to "2. External
Protocol Select the serial communication protocol between the TOP and an external device. device selection”.
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.
SendWait (ms) Set the waiting time between TOP's receiving a response from an external device and
sending the next command request.
Station Num Enter the prefix of an external device.
Command Header Configure the header for the Computer Link protocol.
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3.3 Communication diagnostics

W Check the interface setting status between the TOP and external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information OK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG L .
diagnostics 3. Communication setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name OK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings OK NG . .
4. External device setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

Configure the communication settings of the external device by referring to the vendor’s user manual.
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This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.
(The cable diagram described in this section may differ from the recommendations of "CRUISER")

5.1. Cable table 1

m RS-232C (1:1 connection)

COM PLC
. Signal Pin Cable connection Pin Signal :
Pin arrangement Note 1) Pin arrangement*Note 1)
name | number number | name
D 1
1 5 C 9 SG
[ o} RD 2 3 TXD
o ®) SD 3 5 RXD
Based on SG 5 E 7 psr | 19 2
icati RS 232
communication cable DSR 6 E 4 TS
connector front, RTS 7 6 RTS
D-SUB 9 Pin male
CTS 8 9 -
(male, convex) 9
*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
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The devices available in TOP are as follows:

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Device Bit Address Word Address 32 Bit Remarks
I-Device 10000.00 - 18191.15 10000 - 18191 R/W
P-Device P0000.00 - P8191.15 PO00O - P8191 RA)
Note 1

Q-Device Q0000.00 - Q8191.15 Q0000 - Q8191 R/W
M-Device M0000.00 - M8191.15 MO0000 - M8191 R/W
POS - 0 R
VEL - 0 R
FEL - 0 32BIT R
JOG - 04 w
J: - 0 w
J= - 0 W
N - 0 w
RUN - 0 w
HLT - 0 W
K 0 w

Note 1) P P-Device is FLOAT DATA
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