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LS Industrial Systems Co., Ltd. 

XCode RFID HF Reader Series 

XCode RFID   
 Supported version TOP Design Studio  V1.4.11.11 or higher  

 

 

 

 

 

CONTENTS 

We would like to thank our customers for using M2I's "Touch 

Operation Panel (M2I TOP) Series". Read this manual and familiarize 

yourself with the connection method and procedures of the “TOP and 

external device”. 

 

1. System configuration Page 2 

 

 

Describes the devices required for connection, the setting of 

each device, cables, and configurable systems. 

2. External device selection  Page 3 

 Select a TOP model and an external device. 

3. TOP communication setting Page 4 

 Describes how to set the TOP communication. 

4. External device setting Page 11 

 Describes how to set up communication for external devices. 

5. Cable table Page 12 

 Describes the cable specifications required for connection. 
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1. System configuration 

The system configuration of TOP and “LS Industrial Systems – XCode RFID” is as follows: 
 

Series CPU Link I/F 
Communication 

method 
System setting Cable 

XCode 

Series 

XCode – 1307 

XCode – 1306 

RS 232 Port RS–232C 3. TOP communication 

setting 

4. External device 

setting 

5.1. Cable table Terminal Block 4 Pin RS–422 

Terminal Block 4 Pin RS–485 

 

■ Connection configuration 
 

ㆍ1:1 (one TOP and one external device) connection – configuration which is possible in RS232C/422/485 communication. 

 
 

 

■ Driver Action Properties 

If the driver option's trigger address (bit) is "on", it receives data from the XCode RFID HF Reader Series and forwards it to an 

external device connected to the COM1 / Ethernet channel. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

External 

Device 

COM1 / Ethernet channel COM2 channel 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 

 

Settings Contents 

TOP Model Check the display and process of TOP to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Please select “LS Industrial Systems”. 

PLC Select an external device to connect to TOP. 
 

Model Interface Protocol 

XCODE RFID HF Reader 

 Series IH-1306/1307 

Serial ISO tag Control Protocol 

 

 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [Project > Project Property > TOP Setting] → [Project Option > “Use HMI Setup” Check > Edit > Serial] 

– Set the TOP communication interface in TOP Design Studio. 
 

 

 

 
 

Items TOP External device Remarks 

Signal Level (port) RS-232C/RS422/RS485 RS-232C/RS422/RS485  

Baud Rate 9600  

Data Bit 8  

Stop Bit 1  

Parity Bit None  

* The above settings are examples recommended by the company. 

 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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(2) Communication option setting 

■ [Project > Project Property > Device Setting > COM > “XCODE RFID”] 

– Set the options of the communication driver in TOP Design Studio. 
 

 

 

Items Settings Remarks 

Interface Configure the communication interface between the TOP and an external device. Refer to “2. External 

device selection”. Protocol Configure the communication protocol between the TOP and an external device. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
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■ Communication interface setting 

 

 

 

Items Settings Remarks 

Read Command Set Set the prefix of XCODE RFID.  

Trigger Configures the Bit address for executing Tag recognition.  

OK Configures the enabled Bit address upon successful Tag recognition.  

NG Configures the enabled Bit address upon failed Tag recognition.  

Data Configures the address and word length for entering Tag data. Other PLC address use 

function 
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. ※ No Tag Message 

Enter designated message for “No tag” error 

Message Input by Direct Configure to enable or disable.  

Message Message  

Destination Enter to data storage address.  

Enter reference message for “No tag” error 

Message Input by Address Configure to enable or disable.  

Message Message reference address *Note 1) 

Destination Message input address  

Size Configures the buffer size of the message reference/input address Word 
 

 

※ Tag Read Error Message 

Enter designated message for “Tag read” error 

Message Input by Direct Configure to enable or disable.  

Message Message  

Destination Enter to data storage address.  

Enter reference message for “Tag read” error 

Message Input by Address Configure to enable or disable.  

Message Message reference address *Note 1) 

Destination Message input address  

Size Configures the buffer size of the message reference/input address Word 

 

*Note 1) Only internal system buffer addresses can be used 

 

※ Caution: The first word in the saved address is the address that stores the error code. It is marked 0x8000 without tag, 0x4000 

with BCC error, 0x2000 with communication error, and 0x0001 with normal operation. The actual data storage address is saved from 

the following word. 
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

   

(1) Communication interface setting 

■ [Main Screen > Control Panel > Serial] 
 

 

Items TOP External device Remarks 

Signal Level (port) RS-232C/RS422/RS485 RS-232C/RS422/RS485  

Baud Rate 9600  

Data Bit 8  

Stop Bit 1  

Parity Bit None  

* The above settings are setting examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [Main Screen > Control Panel > PLC] 
 

  

 

Items Settings Remarks 

Interface Configure the communication interface between the TOP and an external device. Refer to “2. External 

device selection”. Protocol Configure the communication protocol between the TOP and an external device. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  

OK NG 

6. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 

Configure the RFID switch communication settings as follows. For more detailed setting methods than described in this example, 

please refer to the 

PLC user manual. 

 

LS XCode communication settings can be modified by altering the parameters. 

For a more detailed setting method than described in this example, refer to the user manual of the external device. 
 

– Default Setting – 

Baudrate 9600 [Bps] 

Data Bit 8 [Bit] 

Stop Bit 1 [Bit] 

Parity None 

Data type ASCII 

 

 

– RS 232C / 422 / 485 Select DIP Switch – 

1. For RS 232C communication 

 

2. For RS 422 communication 

 

3. For RS 485 communication 

 

4. For Hyper terminal hardware setting 
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5. Cable table 

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. 

(The cable diagram described in this section may differ from the recommendations of “XCODE RFID”) 

■ RS232C 

TOP COM 

Cable connection 

“XCode RFID 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

     

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RD 2 2 SD 

SD 3 3 RD 

    

SG 5 5 SG 

    

    

    

    

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

■ RS-422 
 

TOP COM 

Cable connection 

“XCode RFID” 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 
Pin arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  TXD+ 

 

Based on communication 

cable connector 

front 

Terminal Block 4 Pin 

RDB 4 TXD- 

SDA 6 RXD+ 

SDB 9 RXD- 

   

   

   

   

   

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

■ RS-485 
 

 

TOP COM 

Cable connection 

“XCode RFID” 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 
Pin arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  TXD+ 

 

Based on communication 

cable connector 

front 

Terminal Block 4 Pin 

 2 TXD- 

 3 RXD+ 

RDB 4 RXD- 

 5  

SDA 6  

 7  

 8  

SDB 9  

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 


