LS Industrial Systems
XGK / XBM / XBC Series
CPU Direct Driver

Supported version TOP Design Studio V1.0 or higher {Rl

TOP

"
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We would like to thank our customers for using M2l's "Touch

Operation Panel (M2] TOP) Series". Read this manual and familiarize
yourself with the connection method and procedures of the "TOP and

external device".

1. System configuration Page 2

Describes the devices required for connection, the setting of

each device, cables, and configurable systems.

2. External device selection Page 3

Select a TOP model and an external device.

3. TOP communication setting Page 4

Describes how to set the TOP communication.

4. External device setting Page 9

‘ Describes how to set up communication for external devices.

5. cable table Page 10

‘ Describes the cable specifications required for connection.

6. Supported addresses Page 11

Refer to this section to check the addresses which can

communicate with an external device.
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1. System configuration

The system configuration of TOP and “LS Industrial Systems Co., Ltd — XGK / XBM / XBC Series CPU Direct” is as follows:

. . Communication )
Series CPU*Note 1) Link I/F System setting
method
XGK-CPUH
XGK-CPUA
XGK XGK-CPUS PADT connector (9 pin) *Note 2) RS232 3. TOP
XGK-CPUE communication
XGK-CPUU setting 5. Cable table
XBM-DI116S 4. External device
XBM-DL1325 , setting
XGB PADT connector (6 pin) *Note 2) RS232
XBC-D[132H
XBC-DL164H

*Note 1) Check that the CPU unit is labeled as version V 1.1 or higher.

*Note 2) PADT Access connector: the PLC CPU connector used to connect to the PC Ladder S/W XG5000

B Connection configuration (TOP connection—-External device connection)

+ 1:1 (one TOP and one external device) connection — configuration which is possible in RS232C communication.
AL

H TIHE
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device H

PLC select [COM1]

Filter : |[AII] v‘ Search : I:I

@ Model (O Vendor

Vendor Wodel
~
M2I Corporation & XGL/XGR/XEC Series
MITSUBISHI Electric C i &
ectric Corporation " XGK/XBM/XBC Series
OMRON Industrial Automation
GLOFA-GM Series

(@ MASTER-K(805/1205/2005/3005/10005) Series

MODBUS Organization

& STARVERT Series
SIEMENS AG.

(@ XCODE RFID HF Reader Series IH-1306/1307
Rockwell Automation

GE Fanuc Automation & MASTER-K(500H/1000H) Series
PANASONIC Electric Works (@ MASTER-K 105, 1051 Series
‘YASKAWA Electric Corporation
YOKOGAWA Electric Corporation
Schneider Electric Industries

KDT Systems

RS Autnmation

4_Back | B Next *® Cancel

Select Device n

PLC Setting[ XGK/XBM/XBC Series ]

Alizs Mame @ |PLCL

Interface : | CPU Direct ~
Protocol : | CPU ~ Comm Manual

String Save Mode : |First LH HL Change

[ use Redundancy

AND ~
Condition - Edi
Primary Option
Timeout 300 &|| msec
Send Wait msec
@ Back + OK * Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select “LS Industrial Systems”.
PLC Select an external device to connect to TOP.

Interface Protocol

XGK / XBM / XBC Series CPU Direct CPU

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting
M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Serial]
— Set the TOP communication interface in TOP Design Studio.

Project Option he
-ChangeHMllﬂ] R Ao PLC ST Change Pl | [ Delete PLCID)
%swx Date [ Time Sync. =~ Screen Option Unit Convert
h '.nfﬂhsnlggd”‘(z)semng Project Option = Screen Change HmiSetup = Global Lock & Touch  Project Style  Splash  PLC Buffer Sync.
-8 RFID (0)
V-E_’[::vggsit?;vf Initialization | Edit |
- PLC1 : XGK/XBM/XBC Serif Project Setting -
~ g% COMZ (0) HMIDisable=0
g COM3 (0) Project. NdEFFIEM:NEW project
erne Start Mode=Menu
o S startSreen o -1
-4 USBDevice (0) Latch Set=0nd
Communication Error Message =0
USBErrorMessage=0
StorageErrorMessage=1
DatabaseMessage=1
Caontrol Panel
System m Devices L4 Service =% Option
i Serial *
T r(& Serial Port: | COMI -
PLC Security Date/Time Signal Level
(® RS-232C () RS-422(4) O RS-485(2)
Baud Rate: 115200 '
[ 0 —
"III" L LJ Data Rit: 8 -
Et hernet Serial HOK | Stop Bit: i -
— Parity Bit: [None e
= % Flow: (ff
. Ping
. . e . Auto Search  Loopback Test
Diagnost ic File Fing
Manager
Apply = Cancel
Items TOP External device Remarks
) RS-232C )
Signal Level (port) RS-232C Fixed
(CPU port)
Baud Rate 115200 Fixed
Data Bit 8 Fixed
Stop Bit 1 Fixed
Parity Bit None. Fixed
* The above settings are examples recommended by the company.
Items Description
Signal Level Select the serial communication method between the TOP and an external device.
Baud Rate Select the serial communication speed between the TOP and an external device.
Data Bit Select the serial communication data bit between the TOP and an external device.
Stop Bit Select the serial communication stop bit between the TOP and an external device.
Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [Project > Project Property > Device Setting > COM > "PLC1 : XGK/XBM/XBC Series"]

— Set the options of the XGK / XBM / XBC Series CPU Direct communication driver in TOP Design Studio.

Project Option

- Change HMI[H] ' AddPLC[A] | THTM) Change PLCIC | [] Delete PLCID]

~ ] TOFP Setting

| L[ 5Y5:RD1520%
Option Module Setting
B FieldBus (0)

.. RFID (0)

W -igy Device Setting

s¥ COM3 (0)
8 Ethernet (0)
™ Wireless (0)
i USBDevice (0)

PLC Setting[ XGK/XBM/XBC Series ]
Alizs Name : [PLC1 |

Interface : | CPU Direct ~

Protocol : |CPU ~

M String Save Mode : [First LH HL Change
© | PLC : XGK/XBMXBC Seritl
L)

[] use Redundancy

AND v
TimeO L o
e0 5 -
Conditio Edi
Primary Option
Timeout msec
Send Wait msec
Retry 5 z

Comm Manual

>
Apply Close
Items Settings Remarks
Interface Select “CPU Direct". Refer to “2. External
Protocol Select "CPU".

device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP’s receiving a response from an external device and
sending the next command request.
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* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

B Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the

main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

Conikroll Panel

serial

Run
Serial Port: [C[]h-H |vl
Signal Level
‘ ® RS-232C (O RS-422(4) O R5-485(2) l
PLC Security
Baud Rate: 115200  -|
¥HC L
Viewer i A D Data Bit: [ g H
puny Stop Bit: | | ~|
1 ﬁ Ethernet Serial
' Parity Bit: | None -
T —
Screen m l% Flow: [ 0f f |vl
shot h
oi . , lAuto Search] lLoopback Testl
iagnost ic File
Manager
/ l Apply “ Cancel l —
[System] Close r
— |
Items TOP External device Remarks
. RS-232C )
Signal Level (port) RS-232C Fixed
(CPU port)
Baud Rate 115200 Fixed
Data Bit 8 Fixed
Stop Bit 1 Fixed
Parity Bit None. Fixed

* The above settings are setting examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

[Main Screen > Control Panel > PLC]

(>) T

PLCT (HGK/HBM/HBC Series)

@ Swst| Driver(COMI)
Bun I
Interface
!”l | Protocol
‘ PLC Timeout
AC Send Wait
Yiewer [ln] Retry
. i
] Et hernet
[]
|
hatli ™
Diagnost ic

TO hEQIRE E AT
Touch Qperation Panel

d

| CPU Direct

-]

[CRU

-]

[Systeq l Diagnostic

| Aeply || Cancel |

Items Settings Remarks
Interface Select "CPU Direct”. Refer to "2. External
Protocol Select "CPU". device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

sending the next command request.

Set the waiting time between TOP’s receiving a response from an external device and
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3.3 Communication diagnostics

W Check the interface setting status between the TOP and external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information OK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG L .
diagnostics 3. Communication setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name OK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings OK NG . .
4. External device setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

+ Loader port communication interface of the “XGK / XBM / XBC Series” is fixed as the target configuration value of the following

example.
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5. Cable table

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.

(The cable diagram described in this section may differ from the recommendations of “LS Industrial Systems Co., Ltd.")

B XGK RS-232C Port on CPU Unit (1:1 connection)

front, front,

cT1s D-SUB 9 Pin male

(male, convex)

D-SUB 9 Pin male cTs

(male, convex)

TOP COM XGK RS-232C Port on CPU Unit
Pin Signal Pin Cable connection Pin Signal Pin
arrangementNote 1) name number number name arrangement-Note 1)
1 5 CD 1 1 CcD 1 5
g g SD 3 3 D g S’
Based on DTR 4 4 DTR Based on
communication 56 > > 56 communication
cable connector DSR 6 6 DSR cable connector
RTS 7 7 RTS
8 8
9 9

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.

m XGB (XBM/XBC) RS-232C Port on CPU Unit (1:1 connection)

TOP COM XGB RS-232C Port on CPU Unit
Pin Signal Pin Cable connection Pin Signal Pin
arrangement:note 1) name number number name arrangement*Note 1)
5 CcD 1 1
:CI; o) RD 2 —? 2 RD
5D 3 r 3 5G
6 9 DTR 4 4
Based on SG 5 ] 5
communication DSR 6 6 D Based on
cable connector RTS 7 communication
front, cTS 8 cable connector
D-SUB 9 Pin male 9 front,
(male, convex) D-SUB 6 Pin male
(male, convex)

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
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6. Supported addresses
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The devices available in TOP are as follows:

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Device Bit Address Word Address Remark
Input/Output Relay PO — P4095F PO — P4095
Auxiliary Relay MO — M4095F MO — M4095
Keep Relay KO — K4095F KO — K4095
Special Relay FO — FA095F FO — FA095 Canhot be
written
Timer(Contact) TO — T8191 I
Counter(Contact) CO — C8191 —
Timer(Elapsed Value) _— TO — T8191
Counter(Elapsed Value) —_— CO — C8191
Special Module Register U0.0.0 - U7F31.F U0.0 — U7F.31
Index Register —_— Z0 — 7255
Step Controller —_— SO — S255
Link Relay LO — L11263F LO - L11263
Communication Register —_— NO — N21503
Data Register D0.0 — D524287.F DO — D524287
File Register R0.0 — R32767.F RO — R32767
File Register ZRO — ZR524287.F ZRO — ZR524287

*The lower 16 BIT data of 32 BIT data is saved in the address whose screen has been registered, and the upper 16 BIT data is saved

in the address next to the address whose screen has been registered.

Ex. When saving 32 BIT data hexadecimal data 12345678 in address DO0100, it is saved to 16 BIT device address as follows:

Items 32BIT 16BIT
Address D00100 D00100 D00101
Input data
. 12345678 5678 1234
(hexadecimal)
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