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1. System configuration
The system configuration of TOP and “ESCO Co., Ltd. — ESCO IGBT Rectifier Computer Link" is as follows:

Communication Communication

NS Link I/F

method setting
3. TOP

communication

IGBT Series Built-in RS-485 port RS-485 setting 5.1. Cable table 1
4. External device

setting

IGBT
Rectifier

W Connection configuration

+ 1:1 (one TOP and one external device) connection

-

+ 1:N (one TOP and multiple external devices) connection — configuration which is possible in RS-485 communication.

AP

I ' c-j ' 1’5«] .........
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device H
PLC select [COM1]
Filter : |[AII] |v‘ Search : I:I

@ Model (O Vendor

Vendor Model
N ~
FANUC Co., Ltd. & ASI Systems ; ASIC/2 Series

73

@%  ESCO:1GBT Rectifier
(@ OKY : DVC

& ILSHINBIO : FD FRONT

SHINSUNG E&G : MCUL32 Series

MINEBEA Co., Ltd.
Azbil Corporation
KORO TECHNOLOGY
ROBOSTAR
Ebmpapst

SPEEDTECH : PUI-2000 Series
CoDeSys Automation Alliance

Ophir Optronics Solutions Ltd. JISANG : Rectifier

SERVOMEX
Tiger Optics, LLC

B &R Automation

Peripheral Device

OTHERS Manufacture

ASN : T8H Sensor

SNC : Flow Meter

SEORIM : PMC3000

MEMORY MAP SLAVE

WILLINGS : Master K
v

22 AR AR AR

4_Back | B Next *® Cancel
Select Device n
PLC Setting[ ROBO CYLINDER (MODBUS -CON,RC Series) ]
Interface : | Computer Link ~
Protocol : |Computer Link ~ Comm Manual
String Save Mode : |First LH HL Change
[ use Redundancy
AND ~
Conditio Edi

Primary Option

Timeout

Send Wait

Retry

Station No

Set Voltage LATCH « |oo0 E

Set Current LATCH ool =

@ Back + OK * Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select "OTHERS Manufacture”.
PLC Select an external device to connect to TOP.

Protocol

Interface

Esco IGBT Rectifier Computer Link Computer Link

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting
M [Project > Project Property > TOP Setting] — [Project Option >

— Set the TOP communication interface in TOP Design Studio.

“Use HMI Setup” Check > Edit > Serial]

Project Option
-ChangeHMllﬂ] -Md PLC[A) | TR Change Picicl | [ Delete PLCID)
%mx Date / Time Sync. = Screen Option Unit Convert
A -2";”3;‘1“‘(;;53@”9 Project Option = Screen Change HmiSetup = Global Lock & Touch  Project Style  Splash  PLC Buffer Sync.
v V;,[::Vézsﬁltfln)g e Initialization Edit
W PLC1 : ESCO : IGBT Rect] T -
59 COM2 (0) HMIDisable=0
159 COM3 () Project NdamE;NEw project
thernet (0) Start Mode=Menu
; S‘iirelesst[ﬂn) E;B&Su‘:s'::g te.=1
8 USBDevice (0) Latch Set=0~0
Communication Error Message =0
USBErrorMessage=0
StorageErrorMessage=1
DatabaseMessage=1
Control Panel
. [ac | ol
System m Devices :
mu Serial X
s - Serial Port: | COMI1 o
T £~
Signal Level
PLC Security Date/Tins () RS-232C (O RAS-422(4) @ RS-485(2)
Baud Rate: (13200 M
i-i - Data Bit: & -
LY
. Stop Bit: |1 <
Et hernet Serial HOK |
Parity Bit: [None v
Flow: [ff
= N
L_; Ping| Auto Search  Loopback Test
Diagnost ic File Fing
Manager
s Apply || Cancel
Items TOP External device Remarks
Signal Level (port) RS-485 RS-485
Baud Rate 19200
Data Bit 8
Stop Bit 1
Parity Bit None.

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [Project > Project Property > Device Setting > COM > "ESCO IGBT Rectifier”]

ERI2 e B X
Touch Qperation Panel

TOP (|

— Set the options of the ESCO IGBT Rectifier Computer Link communication driver in TOP Design Studio.

Project Option

Change HMIH]

v TOP Setting

-3 5Y5 ¢ RD1520%

Option Module Setting

-4 FieldBus (0)

- RFID (0)

W - Device Setting
'~ FaatEREN

PLC1: ESCO : IGET Rectil I

8 Ethernet (0)
® Wireless (0)
9 USBDevice (0)

“ AddPLC[A] | THITal Change PLCIC)

m Delete PLC[D]

PLC Setting[ ESCO : IGBT Rectifier ]

Alias Mame

Interface :

Protocol :

String Save Mode

t[PLca |
Computer Link ~
Computer Link w

: [First LH HL Change

[ use Redundancy

Primary Option
Timeout
Send Wait
Retry
Station Mo
Set Voltage

Set Current

M LaTcH -~ |000 Zlle)
M aTcH  ~ [o01 2l

Comm Manual

Apply Close
Items Settings Remarks
Interface Configure the communication interface between the TOP and an external device. Refer to "2. External
Protocol Configure the communication protocol between the TOP and an external device.

device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP’s receiving a response from an external device and

sending the next command request.

Station No

Enter the prefix of an external device.

Set Voltage

Set the LATCH area where you want to enter the set voltage value.

Set Current

Set the LATCH area where you want to enter the set voltage value.
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3.2. Communication setting in TOP
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* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

Run

YHC
Yiewer

Screen
shot

@ Svstem

&

I!lill
FLLC

Security

i

(i

Ethernet

Serial

—
'EfT:?'E
I!EII !;;;4 |
Diagnost ic File
Mariager

Panel

Conitrol

o serial

Serial Port: [ COMA

Signal Level
() BS-232C O RS-422(4) @ RS-485(2)

Baud Rate: 19200
Data Bit: | §
Stop Bit: | 1

Parity Bit: | None
Flow: [ Of f

[Auto Search] lLoopback Testl

 Aeply | Cancel |

[System]

Close

(

__.‘

Items TOP External device Remarks
Signal Level (port) RS-485 RS-485

Baud Rate 19200

Data Bit 8

Stop Bit 1

Parity Bit None.

* The above settings are setting

examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting
M [Main Screen > Control Panel > PLC]

. YS9 priver(com)  [PLCI(ES®D : IGBT Rectifier) M
Interface | Computer Link |+
‘ I Frotocol | Computer Link [*
~ Timeout (300 2] msec
o Send Wait 0 2 msec
. [ﬁ|;|l|~|.] Retry 5 =
Ethernet | Station No
Set Yoltage  LATCH:000:16:16:DEC: RN
Qzﬂ Set Current LATCH: 001:16: 16: DEC: RW
-
Diagnostic @

Items Settings Remarks
Interface Configure the communication interface between the TOP and an external device. Refer to "2. External
Protocol Configure the communication protocol between the TOP and an external device. device selection”.

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and

sending the next command request.

Station No Enter the prefix of an external device.

Set Voltage Set the LATCH area where you want to enter the set voltage value.

(The communication can be set only in TOP Design Studio.)

Set Current Set the LATCH area where you want to enter the set voltage value.

(The communication can be set only in TOP Design Studio.)
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3.3 Communication diagnostics

B Check the interface setting status between the TOP and an external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information OK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG L .
diagnostics 3. Communication setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name OK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings OK NG . .
4. External device setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)

External device connection manual for TOP Design Studio 8/ 1



TO BRI HE B X
Touch Qperation Panel

4. External device setting

Set the equivalent communication settings to that of the TOP by referring to the ESCO's IGBT (Intelligent) rectifier manual.
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5. Cable table

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.

(The cable diagram described in this section may differ from the recommendations of “ESCO Co., Ltd.")

5.1. Cable table 1

M RS-485 (1:1 connection)

TOP IGBT Rectifier
Pin Signal Pin Cable connection Pin Signal Pin
arrangement*Note 1) name number number name arrangement*Note 1)
1 5 RDA 1 1 SG
z z
o Q
6 9 3 3 Based on
Based on RDB 4 1 4 communication
communication SG 5 5 cable connector
cable connector SDA 6 6 (+) front,
front, 7 7
D-SUB 9 Pin male 8 8 (-)
(male, convex) SDB 9 9
*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
W RS-485 (1:1 connection)
TOP IGBT Rectifier
) Signal Cable connection Pin Signal Pin
Pin arrangementNote 1)
name number name arrangement*Note 1)
(+) 1 SG
(-) 7 2
O SG 3 Based on
LI SG 4 communication
' 1B 5 cable connector
+ 6 (+) front,
O 7
i 8 (-)
9
B RS-485 (1:N connection) — Refer to 1:1 connection to connect in the following way.
TOP . . o PLC Cable connection and signal PLC
—————— Cable connection and signal direction - o -

Signal name Signal name direction Signal name
RDA(+) (+) ’ (+)
RDB(-) (-) J (-)
SDA(+) —

SDB(-)
SG SG SG
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6. Supported addresses
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The devices available in TOP are as follows:

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Device Bit Address Word Address Description Remarks

VOLTAGE VOLTAGE Current voltage value of rectifier Read-only
CURRENT CURRENT Current value of rectifier Read-only
POWER POWER POWER Power status of rectifier Read-only
WORK WORK WORK Work status of rectifier Read-only
ON/START ON/START ON/START Turn rectifier power on or start rectifier operation Write-only
OFF OFF OFF Turn off rectifier Write-only
STOP STOP STOP Stop rectifier Write-only

X Write-only Device Use Method

@ Pop-up window for object's property — @ Effect and action— 3 Setting Conditions — @Action setting

When setting up action, you add data by setting it up to enter data on relevant device. (Data value irrelevant)

I8 Rectangle Property X
PREVIEW
o Shape Text Effect & Action
No Condition Effect Action
1 Touch Down MNone [PLC1:ON/START: 1:DEC] =ON group:0

% Upu] | & Down[Ql F Add[A] | # Modify[M]| % Delete [D]
Condition Effect Action
Max Excute Count : |1 +|(0=c0) Interval : (100ms) Delay Time : |0 =/ (100ms) -+
D:1 SEQ: 0 B PLC1I v |0I'l!‘?TART |: e .
= = - *
X 3|358 - | Y:[202 5 . 0) 0 Group Index : |D =
= = Bit @ @ 0© '
width:[70 2] Height:[e9 |2 3 L 9 @ @ ™ E ¥
Security Level : [0 5
[]create Security Log
Dlgnore GlobalLock
le Security level is low then
Hide Object
[ visible InterLock Icon
[“]visible Pemission Icon
[ Ipisplay on top when changed
Memo :
oK Cancel
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