CSCAM
GX Series
TBUS

Supported version TOP Design Studio V1.4.2 or higher {Rl
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1. System configuration
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The system configuration of TOP-R and CSCAM's GX Series TBUS is as follows:

. . Communication
Series Link I/F
method

Communication

setting

GX All CPU - RS-232C

3. TOP-R

Communication 5.1. Cable table 1

setting

W Connection configuration

+ 1:1 (one TOP-R and one external device) connection — configuration which is possible in RS232C/422/485 communication.

k(=]

] TIWE -]
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2. External device selection

W Select a TOP-R model and a port, and then select an external device.

Select Device H
PLC select [COM2]
Filter : |[AII] v‘ Search : I:I

@ Model (O Vendor

Vendor
KEYENCE Corporation &

Digital Electronics Corporation
HONEYWELL

MISUMI

PARKER HAMMIFIN Corporation
TOSHIBA

ATLAS COPCO

TOSHIBA MACHINE Co., Ltd
GREEN POWER

ROOTECH

CKD Carparation

IDEC Corporation

HAWF HYDRALN TK 4
4_Back | B Next *® Cancel
Select Device n
PLC Setting[ CSCAM GX ]
Interface : | Serial ~
Protocol : | TBUS ~ Comm Manual
String Save Mode : |First LH HL Change
[ use Redundancy
AND ~
Primary Option
Timeout msec
Send Wait msec
Retry 5 =
@ Back + OK * Cancel
Settings Contents
TOP-R Model Check the TOP-R display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP-R.
Select "CSCAM".
PLC Select an external device to connect to TOP-R.

Interface Protocol

CSCAM CPU Direct TBUS

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP-R Communication setting

The communication can be set in TOP Design Studio or TOP-R main menu. The communication should be set in the same way as

that of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting
M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Serial]

— Set the TOP communication interface in TOP-R Design Studio.

Project Opticn x
- Change HMIlH] | | Add PLC 1] T changeFLCl | [ Delete PLCID)
—
D 6 Setting X Date [/ Time Sync. = Screen Option Unit Convert
+ -l Option Module Setting Screen Change  HmiSetup = Global Lock & Touch = Project Style  Splash | PLC Buffer Sync.
- FieldBus (0)
*. g RFID (0)
M \'Ei"geo;‘alt‘(’g)g Initialization | Edit |
v fg® coMz (1) Project Setting '~
| W PLC1: CSCAM GX [0] HMIDisable =0
g8 COM3 (0) Project Name =New project
i USBDevice (0) Latch Set=0n~0
Communication Error Message=0
USBErrorMessage=0
StorageErrorMessage=1
DatabaseMessage=1
Control Panel
System m Devices | _ ...
_{ Serial Port: | COMZ =
1 °
Signal Level
PLLC Security Dat e/ Timg (@ RS—232C () RS-422(4) () B5-485(2)
Baud Rate: 38400 <
Data Bit: |8 v
o - | B—
[ .
Stop Bit: 1 ~
Et hernet Serial HOM |
Parity Bit: |None <
i Flow: [ff
| B N
L | ® ping| Auto Search  Loopback Test
Diagnost ic File Ping
Manager
J Apply | Cancel
Items TOP-R External device Remarks
Signal Level (port) RS-232C RS-232C
Baud Rate 38400
Data Bit 8
Stop Bit 1
Parity Bit None

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP-R and an external device.

Baud Rate Select the serial communication speed between the TOP-R and an external device.

Data Bit Select the serial communication data bit between the TOP-R and an external device.

Stop Bit Select the serial communication stop bit between the TOP-R and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP-R and an external device.
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(2) Communication option setting

M [Project > Project Property > Device Setting > COM1 > “CSCAM GX"]

— Set the options of the Computer Link

communication driver in TOP Design Studio.

TOP

ERI2 e B X
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Project Option

- Change HMI[H] ' Add PLC[A] | THiTal Change PICIO | 1] Delete PLCID]

TOP Setting a
’ PLC Setting[ CSCAM GX
| L[ sYS:RD1520% 9l !
v -l Option Module Setting Alizs Name : [PLC1
W FieldBus (0) Interface @ |Serial ~
W RFD (@)
Device Setting Protocol : | TBUS ~ Comm Manual
-~ TgW COM1{(0) String Save Mode : [First LH HL Change
e Wala TR kAl
g8 PLC1: CSCAM GX [0] |
% COM3 (0) [ use Redundancy
8 Ethernet (0) AND ~
- Wireless (0) _ - ~
W USBDevice (0) . hd
C Edi
Primary Option
Timeout 200 &1 | msec
Send Wait msec
Retry 5 z
Apply Close
Items Settings Remarks
Interface Configure the communication interface between the TOP-R and an external device. Refer to "2. External
Protocol Configure the communication protocol between the TOP-R and an external device. device selection”.

TimeOut (ms)

Set the time for the TOP-R to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP-R's receiving a response from an external device

and sending the next command request.
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3.2. Communication setting in TOP-R

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP-R screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting
M [Main Screen > Control Panel > Serial]

@ Conit:roll Panel
1= il

Serial Port: [ COM1

Signal Level
[0) RS-232C ) RS-422(4) (O RS-485(2)

Baud Rate: [ 38400
YNC

Viewer pe—— Data Bit 8
L) o
o] | =2 | §

|

- |

Stop Bit: | 1 ]
2| l

|

Ethernet Serial

Parity Bit None

m = | Flow: [0ff
q

Dl sghasTT Fils [Auto Search] iLoopback Test] IV

 Apply | Cancel | |—

Close

e O e

[System]

TOPRX - TOPRX0800S A  2021-09-01 10:42:56 AM
Items TOP-R External device Remarks
Signal Level (port) RS-232C RS-232C
Baud Rate 38400 Fixed
Data Bit 8
Stop Bit 1
Parity Bit None

* The above settings are setting examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP-R and an external device.

Baud Rate Select the serial communication speed between the TOP-R and an external device.

Data Bit Select the serial communication data bit between the TOP-R and an external device.

Stop Bit Select the serial communication stop bit between the TOP-R and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP-R and an external device.
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(2) Communication option setting
B [Main Screen > Control Panel > PLC]

o0} PILC

@ System | Driver(COMZ) | PLC2(CSCAM GX) |+

Interface | Serial v
m Q Protocol | TBUS e

‘ PLC sq Timeout 300 |3 msec

Send Wait msec

Retry
Node 1D =

¥YNC

Viever [TI'I'";.]

Ethernet

[e

‘0

[

oy Diagnost ic

[System] [ Diagnostic [ Apply ”Cancel ]
! 3
OPR OPRX0800 1 09-0 i A4
Items Settings Remarks
Interface Configure the communication interface between the TOP-R and an external device. Refer to "2. External
Protocol Configure the communication protocol between the TOP-R and an external device. device selection”.
TimeOut (ms) Set the time for the TOP-R to wait for a response from an external device.
SendWait (ms) Set the waiting time between TOP-R’s receiving a response from an external device
and sending the next command request.
NODE ID Configure the node ID for target device.
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3.3 Communication diagnostics

M Check the interface setting status between the TOP-R and an external device.
- Touch the top of the TOP-R screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal
- Check the cable, TOP-R, and external device setting status. (Reference: Communication diagnostics
sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

[tems Contents Check Remarks
System How to connect the system oK NG ) )
) ) - 1. System configuration
configuration Connection cable name oK NG
TOP-R Version information OK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) OK NG . -
diagnostics 3. Communication setting
Serial Parameter Transmission
oK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name OK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings oK NG . .
4. External device setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

Set as below using “GX-Builder’. For more detailed setting method than that described in this example,
refer to the PLC user manual.

1. Go to “Register Editor, and select D (Device Parameter).
2. Double-click “CPU device" on the list of available devices.

3. Configure the device settings as shown below.

Contents For [RS232_1] - RS-232A For [RS232_2] - RS-232B
Master/Slave RegNo 151 SLAVE RegNo 162 SLAVE
Communication protocol RegNo 152 T-Bus RegNo 163 T-Bus
Baudrate RegNo 154 38400 RegNo 155 38400
Data Bit RegNo 154 8 RegNo 155 8
Parity Bit RegNo 154 NONE RegNo 155 NONE
Stop Bit RegNo 154 1 RegNo 155 1
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5. Cable table

This chapter introduces a cable diagram for normal communication between the TOP-R and the corresponding device.
(The cable diagram described in this section may differ from the recommendations of “"CSCAM GX Series TBUS")

5.1. Cable table 1

M 1:1 connection
TOP COM Port (9 pin)

TOP COM External device
Pin Signal Pin Cable connection Pin Signal Pin
arrangement*Note 1) name number number name arrangement*Note 1)
1 5 CD 1 1 CD 1 5
o o —————— e e
Based on DTR 4 4 DTR Based on
communication SG 5 E) SG communication
cable connector DSR 6 6 DSR cable connector
front, RTS 7 7 RTS front,
D-SUB 9 Pin male CTS 8 8 CTS D-SUB 9 Pin male
(male, convex) 9 9 (male, convex)

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
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6. Supported addresses

The devices available in TOP-R are as follows:
The device range (address) may differ depending on the CPU module series/type. The TOP-R series supports the maximum address
range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Device Name Bit Address Word Address Remarks
. *Note 1)
R Register 0.00 ~ 3999.31 0 ~ 3999
*Note 2)
) *Note 1)
U Register 0.00 ~ 3999.31 0 ~ 3999
*Note 2)
) *Note 1)
X Register 0.00 ~ 100.31 0~ 100
*Note 2)
. *Note 1)
Y Register 0.00 ~ 100.31 0 ~ 100
*Note 2)
. *Note 1)
G Register 0.00 ~ 659.31 0 ~ 659
*Note 2)
) *Note 1)
F Register 0.00 ~ 659.31 0 ~ 659
*Note 2)
. *Note 1)
Q Register 5.00 ~ 52.31 5~52
*Note 2)
. *Note 1)
S Register 0.00 ~ 3999.31 0 ~ 3999
*Note 2)
. *Note 1)
D Register 0.00 ~ 25599.31 0 ~ 25599
*Note 2)
. *Note 1)
P Register 0.00 ~ 44999.31 0 ~ 44999
*Note 2)

*Note 1) 32 bit device

* Note 2) Unusable ranges are included in each device and address area.
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