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SICK AG 

RFH6 – RFID Driver 
 Supported version TOP Design Studio V1.4.11.11 or higher  

 

 

 

 

 

 

CONTENTS 

We want to thank our customers who use the Touch Operation Panel. 
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each device, cables, and configurable systems. 
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 Select a TOP model and an external device. 
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 Describes the cable specifications required for connection. 
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 Describes how to set up communication for external devices. 
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1. System configuration 

The system configuration of TOP and “SICK-RFH6 Series” is as follows. 

 

Series Link I/F 
Communication 

method 
System setting Cable 

RFH6 Series Port on CPU RS-232C 

3.1 Example of 

setting  

(Page 4) 

4 Cable table  

(Page 12) 

 

 

 

■ Connection configuration 
 

ㆍ1:1 (one TOP and one external device) connection 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 

 

 
 

 

 

Settings Contents 

TOP Model Check the TOP display and process to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Select “OTHERS Manufacture”. 

PLC Select the external device to be connected to the TOP. 
 

Model Interface Protocol 

SICK-RFH6 Series Serial SOPAS Private 
 

 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 

 
 

3. TOP communication setting 
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [ Project > Project properties > TOP settings] → [Project option > Check “Use HMI settings” > Edit > Serial ] 

– Set the TOP communication interface in TOP Design Studio. 
 

 

 

 

 

 

Items TOP External device Remarks 

Signal Level (port) RS-232 RS-232  

Baud Rate 57600 Fixed 

Data Bit 8 Fixed 

Stop Bit 1 Fixed 

Parity Bit none Fixed 

* The above settings are setting examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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(2) Communication option setting 

■ [ Project > Project properties > PLC setting > COM > “PLC1 : RFH6xx Series”] 

– Set the options of the communication driver of SICK-RFH6 in TOP Design Studio. 
 

 
 

 

• Basic communication option 
 

Items Settings Remarks 

Interface Select “Serial”. Refer to “2. External 

device selection”. Protocol Select “SOPAS Private”. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

Retry Set the number of retries in case of no tag, tag read failure.  

Channel Total No. Enter the number of RFID channels to be used.  
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■Communication interface setting.  

 

 

 

Items Settings Remarks 

RFID No Set the RFID number to be used.  

Trigger Configures the Bit address for executing Tag recognition.  

OK Configures the enabled Bit address upon successful Tag recognition.  

NG Configures the enabled Bit address upon failed Tag recognition.  

Data Configures the address and word length for entering Tag data.  
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※ Scan Error Message 

Enter designated message for “No tag” error 

Message Input by Direct Configure to enable or disable.  

Message Message  

Destination Enter to data storage address.  

Enter reference message for “No tag” error 

Input a message from address Configure to enable or disable.  

Message Message reference address  

Destination Message input address  

Size Configures the buffer size of the message reference/input address Unit: word 
 

 

※ Tag Time Out Message 

Enter designated message for “Tag read” error 

Message Input by Direct Configure to enable or disable.  

Message Message  

Destination Enter to data storage address.  

Enter reference message for “Tag read” error 

Input a message from address Configure to enable or disable.  

Message Message reference address  

Destination Message input address  

Size Configures the buffer size of the message reference/input address Word 
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen.  

   

(1) Communication interface setting 

■ [ Main screen > Control panel > Serial ] 
 

 

Items TOP External device Remarks 

Signal Level (port) RS-232 RS-232  

Baud Rate 57600 Fixed 

Data Bit 8 Fixed 

Stop Bit 1 Fixed 

Parity Bit none Fixed 

* The above settings are setting examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device. 

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [ Main screen > Control panel > PLC ] 
 

 
* The above settings are examples recommended by the company. 

 

• Basic communication option 
 

Items Settings Remarks 

Interface Select “Serial”. Refer to “2. External 

device selection”. Protocol Select “SOPAS Private”. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

Retry Set the number of retries in case of no tag, tag read failure.  

Channel Total No. Enter the number of RFID channels to be used.  
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC ]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  

OK NG 

6. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. Cable table 

 

■ 1:1 connection 

■ RS-232C wiring  
 

COM PORT 

Cable connection 

PLC 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

CD 1  1  

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RD 2 2 232 Rx 

SD 3 3 232 Tx 

DTR 4 4  

SG 5 5 GND 

DSR 6 6  

RTS 7 7  

CTS 8 8  

 9 9  

 

  



 

 External device connection manual for TOP Design Studio 12 / 18 

5. External device setting 

 

This is an example of setting using SICK’s software “SOPAS Engineering Tool”. 

For more detailed setting methods than described in this example, refer to the user manual of Seyeon 

Technology. 

Step 1. Connect RFH630 to SOPAS Engineering Tool. 

Step 2. Performance Optimization setting 

 

 

 

Select Parameter >> Performance Optimization >> Air interface. 

■ Preset for transponder IC: The IC type of the tag to be used can be set automatically/manually. 

■ HF-Field: In case of During request only, HF-field is activated when the trigger signal is applied. In case 

of Always on, it is always on standby status without trigger. TOP only supports During request only. 
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Step 3. Transponder communication - CrossLink setting 

 

 

 

■ RFID TAG data processed according to evaluation condition and output format #1. (manual 

setting when deactivated) 

 

Step 4. Object trigger control setting 

 

 

 

■ Start/Stop of Object Trigger 

– Control – Time controlled 

– Set the delay time after applying tag recognition start/end time and synchronization 

start/end signal.  

– Set as Start condition = Command. 

– Set as Stop condition = Trigger source, Good Read 

– Check Trigger echo ON. 
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Step 5. Data processing /Output control setting 

 

  

 

■ End of trigger: Data transmission after satisfying the termination condition set in the object trigger 

control menu  

 

Step 6. Transponder access setting 

 

 

 

■Scan the TAG scan in the area. 
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Step 7. OUTPUT FORMAT setting(1) 

 

 

 

 

■  Create a 

 condition by left-clicking the window, and press  to pop-up the window below.  

 

■add variable or constant 

 

Select BLC – Block content. 

■ Double-click  to open the attribute settings window. 
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■attribute settings 

 

 

Block number - Step 6 start address 

Block count - Number from the block number 

Format – Communication format (Select ASCII )  
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Step 8. OUTPUT FORMAT setting(2) 

■add variable or constant 

 

 

  

Select 

 

 

 

 

 

In SOPAS program, it is possible to set up many types of data formats, but in TOP, it is 

developed with the above settings. 

  

It does not support other kinds of data formats. 
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Appendix, Description on No tag, and tag read failure 
 

1. Description on TOP operation of No tag, and tag read failure error situation 

 When the operation condition bit set by the user turns ON, TOP sends a tag read request to the RFID reader. 

After that, if there is no response to the read request within the timeout set time from the RFID, a request is made again. This 

situation is the Tag Read Error message. After that, if there is no DATA (tag value) response within the timeout set time, it is the No 

Tag message. 

 

2. Tag Read Error message 

(When TOP timeout is set to 4 seconds) 

 

TOP                                   RFID 

 Operation condition ON  

 

 

 

 

 

 

• 

• 

• 

 

 

 

 

Request: Read a tag  

  

First request again after 4 seconds  

  

Second request again after 4 

seconds 
 

  

  

  

  

Last request again  

  

Handling of tag read failure error 

after 4 seconds 

 
 

 

2. No Tag message(No tag), Example of data flow of the tag read failure error situation 

(When TOP timeout is set to 4 seconds) 
 

                               TOP                                   RFID 

 Operation condition ON  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Request: Read a tag  

 
Connection response 

 

 Operation condition ON  

Request: Read a tag 
Connection response 

 

  

 Operation condition ON 
Connection response 

Request: Read a tag 

  

 Operation condition ON  

Request: Read a tag Connection response 

  

  

  

  

 

Request is attempted again in all cases other than normal response after tag read request, and OK Set Bit is ON when normal 

response processing is completed. 

 

 


