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TOHO Electronics Inc. 
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Serial Driver 
 Supported version TOP Design Studio V1.4.3 or higher  

 

 

 

CONTENTS 
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1. System configuration 

The system configuration of TOP and “TOHO Electronics Inc. – TTM-000 Series” is as follows. 

 

Series Model name Interface 
Communication 

method 

Communication 

setting 
Cable 

TTM-000 

TTM-002 

TTM-004 

TTM-005 

TTM-006 

TTM-007 

TTM-009 

Serial RS-485 ( 2 wire ) 

3. TOP 

communication 

setting 

4. External device 

setting 

5. Cable table 

 

 

■ Connection configuration 
 

ㆍ1:1 (one TOP and one external device) connection 
 

                        

 

 

ㆍ1:N (one TOP and multiple external devices) connection 
 

                         ∙∙∙  
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 
 

 

Settings Contents 

TOP Model Check the TOP display and process to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Select “TOHO Electronics Inc.”. 

PLC Select an external device to connect to TOP. 
 

Model Interface Protocol 

TTM-000 Series Serial TOHO Protocol 
 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [ Project > Project properties > TOP settings] → [Project option > Check “Use HMI settings” > Edit > Serial ] 

– Set the TOP communication interface in TOP Design Studio. 
 

 

 

 

 

Items TOP External device Remarks 

Signal Level (port) RS-485 RS-485 Fixed 

Baud Rate 9600  

Data Bit 8  

Stop Bit 2  

Parity Bit None.  

* The above settings are examples recommended by the company. 

 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device. 

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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(2) Communication option setting 

■ [ Project > Project properties > PLC settings > COM1 > “PLC1 : TTM-000 Series” ] 

– Set the options of the communication driver of TTM-000 Series in TOP Design Studio. 

 

 

Items Settings Remarks 

Interface Select “Serial”. Refer to “2. External 

device selection”. Protocol Select “TOHO Protocol”. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

Comm. Address Set the external device communication address (prefix).  
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen.  

   

(1) Communication interface setting 

■ [ Main screen > Control panel > Serial ] 
 

 

Items TOP External device Remarks 

Signal Level (port) RS-485 RS-485 Fixed 

Baud Rate 9600  

Data Bit 8  

Stop Bit 2  

Parity Bit None.  

* The above settings are setting examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device. 

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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(2) Communication option setting 

■ [ Main screen > Control panel > PLC ] 
 

 

 

Items Settings Remarks 

Interface Select “Serial”. Refer to “2. External 

device selection”. Protocol Select “TOHO Protocol”. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
 

Comm. Address Set the external device communication address (prefix).  
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC ]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  

OK NG 

6. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 
 

The communication setting method of TTM-000 Series is as follows. 

For details, refer to the manufacturer’s user manual. 

 

After pressing the MODE button for 2 seconds 

or more, it changes to the communication 

setting screen. 

Set the PRT value to “0”. (Essential) 

Contents: TOHO Protocol 

Set the COM value to b8n2. 

Contents:  

With checksum(Essential) / Data bit 8 

/ Parity bit none / Stop bit 2 

Set the BPS value to “9.6”. 

Contents: Baud Rate 9600 bps 

Set the ADR value to “1”. 

Contents: Communication address (station 

number) 1 

Set the AWT value to “0”. 

Contents: response delay time 0 ms 

Set the MOD value to “rw”. 

Contents: Read/Write 

63. Communication configuration screen 

<SET6: Communication SET> 

Communication configuration mode 

Call screen 

MODE Key 

MODE Key 

64. Communication protocol configuration 

MODE Key 

65. Communication parameter configuration screen 

<Data Bit> <BCC Check> <Stop Bit> <Parity Bit> 

66. Communication speed configuration screen 

MODE Key 

Configuration range: 1–99 

Configuration range: 0~250mS 

MODE Key 

Read Communication (R) 

Read, Write communication (RW) 

67. Communication address configuration screen 

68. Response latency configuration screen 

69. Communication mode configuration screen 

MODE Key 

N/A 

N/A 

N/A 

Odd 

Even 
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5. Cable table  

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. 

(The cable diagram described in this section may differ from the recommendations of “TOHO Electronics Inc.”.) 
 

■ RS-485 (1:1 connection) 

COM 

Cable connection 

TTM-000 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 
 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  + 

  

 2 - 

 3  

RDB 4 

SG 5 

SDA 6 

 7 

 8 

SDB 9 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-485 (1:1 connection) 

COM 

Cable connection 

TTM-000 

Pin arrangement 
Signal 

name 

Signal 

name 
 

 

+  +  

- - 

SG 

 
 

 

■ RS-485 1 : N - Refer to 1:1 connection to connect in the following method. 

TOP Cable connection and signal 

direction 

TTM-000 Cable connection and signal 

direction 

TTM-000 

Signal name Signal name Signal name 

+  +  + 

- - - 

 

  



 

 External device connection manual for TOP Design Studio 11 / 13 

6. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

 

Device Name Bit address Word address Read/Write Remarks 

PV1 Measures (PV)  PV1 Read  

SV1 Measures (SV) SV1.00 ~ SV1.15 SV1 Read/Write *Note 1) 

PR1 Priority screen function setting 1  PR1 Read/Write *Note 1) 

PR2 Priority screen function setting 2  PR2 Read/Write *Note 1) 

PR3 Priority screen function setting 3  PR3 Read/Write *Note 1) 

PR4 Priority screen function setting 4  PR4 Read/Write *Note 1) 

PR5 Priority screen function setting 5  PR5 Read/Write *Note 1) 

PR6 Priority screen function setting 6  PR6 Read/Write *Note 1) 

PR7 Priority screen function setting 7  PR7 Read/Write *Note 1) 

PR8 Priority screen function setting 8  PR8 Read/Write *Note 1) 

PR9 Priority screen function setting 9  PR9 Read/Write *Note 1) 

INP Input type setting  INP Read/Write  

PVG PV compensation gain setting  PVG Read/Write  

PVS PV compensation zero setting  PVS Read/Write  

PDF Input filter setting  PDF Read/Write  

DP Decimal point setting DP DP Read/Write  

FU Function key feature setting  FU Read/Write  

LOC Key lock setting  LOC Read/Write  

SLH SV limit upper limit setting  SLH Read/Write  

SLL SV limit lower limit setting  SLL Read/Write  

MD Zero mode setting MD.00 ~ MD.01 MD Read/Write  

CNT Control type setting  CNT Read/Write  

DIR Forward/backward operation conversion 

setting 
 DIR Read/Write  

MV1 Output 1 manipulative volume  MV1 Read/Write  

TUN Tuning type setting  TUN Read/Write  

ATG AT coefficient  ATG Read/Write  

ATC AT sensitivity  ATC Read/Write  

P1 Output 1 proportional band setting  P1 Read/Write  

I1 Output 1 integral time setting  I1 Read/Write  

D1 Output 1 differential time setting  D1 Read/Write  

T1 Output 1 proportional cycle setting  T1 Read/Write  

ARW Anti-reset wind-up  ARW Read/Write  

MH1 Output 1 manipulative volume limit 

upper limit setting 
 MH1 Read/Write  

ML1 Output 1 manipulative volume limit 

lower limit setting 
 ML1 Read/Write  

C1 Output 1 control sensitivity setting  C1 Read/Write  

CP1 Output 1 OFF point position setting  CP1 Read/Write  

MV2 Output 2 manipulative volume  MV2 Read/Write  

P2 Output 2 proportional band setting  P2 Read/Write  

T2 Output 2 proportional cycle setting  T2 Read/Write  

MH2 Output 2 manipulative volume limit 

upper limit setting 
 MH2 Read/Write  
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Device Name Bit address Word address Read/Write Remarks 

ML2 Output 2 manipulative volume limit 

lower limit setting 
 ML2 Read/Write  

PBB Manual reset  PBB Read/Write  

C2 Output 2 control sensitivity setting  C2 Read/Write  

CP2 Output 2 OFF point position setting  CP2 Read/Write  

DB Dead band setting  DB Read/Write  

E1F PV event output 1 function setting  E1F Read/Write  

E1H Event output 1 upper limit setting  E1H Read/Write  

E1L Event output 1 lower limit setting  E1L Read/Write  

E1C Event output 1 sensitivity setting  E1C Read/Write  

E1T Event output 1 delay timer setting  E1T Read/Write  

E1B Special event output 1 function setting  E1B Read/Write  

E1P Event output 1 polarity setting  E1P Read/Write  

CM1 CT input monitor  CM1 Read  

CT1 Event output 1 current error setting  CT1 Read/Write  

E2F PV event output 2 function setting  E2F Read/Write  

E2H Event output 2 upper limit setting  E2H Read/Write  

E2L Event output 2 lower limit setting  E2L Read/Write  

E2C Event output 2 sensitivity setting  E2C Read/Write  

E2T Event output 2 delay timer setting  E2T Read/Write  

E2B Special event output 2 function setting  E2B Read/Write  

E2P Event output 2 polarity setting  E2P Read/Write  

CM2 CT input monitor  CM2 Read/Write  

CT2 Event output 2 current error setting  CT2 Read  

DIF DI input function setting  DIF Read/Write  

DIP DI polarity setting  DIP Read/Write  

SV2 Control setting 2 SV2.00 ~ SV2.15 SV2 Read/Write  

COM Communication parameter setting  COM Read/Write *Note 1) 

BPS Communication speed setting  BPS Read/Write  

ADR Communication address setting  ADR Read/Write  

AWT Reponse delay time setting  AWT Read/Write  

MOD Communication mode conversion 

setting 
MOD MOD Read/Write  

TMO Timer output location setting  TMO Read/Write  

TMF Timer function setting  TMF Read/Write  

H/M Timer unit conversiong  H/M Read/Write  

TSV Timer SV start permission width setting  TSV Read/Write  

TIM Timer time setting  TIM Read/Write  

TIA Timer remaining time monitor  TIA Read  

TST Timer start/stop TST TST Write  

OM1 Output monitor  OM1 Read  

AT AT operate/release AT AT Read/Write  

STR Data retention STR STR Write  
 

*Note 1) String data 
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※ Write-only (command) device execution method 

① Pop-up the object’s property window → ② Effects and actions → ③Condition setting → ④Action setting 

When setting an action, set to input data to the device. 

 

The picture below is an example of setting an action that sends an STR command once to a square object with touchdown as the 

action condition. 
 

 


