OMRON Industrial Automation
V680 RFID Controller Series

Supported version TOP Design Studio V1.4.11.11 or higher{Rl
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The system configuration of TOP and “"OMRON V680 RFID" is as follows.

Series

RFID

CPU

V680-CA5D01-V2/-CA5D02-V2

Link I/F

RS-232C Port

Communication
method

. RS-232C
on CPU unit
RS-422,485 Port | RS-422/485
on CPU unit

System setting

3.1 Settings
example 1
(Page 4)

4. External device

setting
(Page 7)

5.1. Cable table 1

B Connection configuration

+ 1:1 connection

Out

Device

+ 1: N connection - Available in RS422 communication.

Out

Device

Out

Device
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device H

PLC select [COM1]

Filter : |[AII] w ‘ Search :
@ Model (O Vendor
vendor Wodel
~
MZI Corporation & SYSMAC CSfCIfCP Series

MITSUBISHI Electric Corporation

83 SYSMAC C/CV Series
‘r 580 RFID Series

LS Industrial Systems
& COMPOWAY/F

MODBUS Organization

SIEMENS AG.

Rockwell Automation

GE Fanuc Automation
PAMASONIC Electric Works
‘YASKAWA Electric Corporation
YOKOGAWA Electric Corporation

Schneider Electric Industries

KDT Systems
RS Automation %
4_Back | B Next *® Cancel
Select Device n

PLC Setting[ V680 RFID Series ]

Alizs Mame @ |PLCL

Interface : | Serial ~
Protocol : | V680 ~ Comm Manual
[ use Redundancy
AND ~
Primary Option
Timeout msec ~
Send Wait msec
Controller(Station) No.
CH Total No.
CH1
CHMo.
Trinner | Pyv—— =y —] e
@ Back + OK * Cancel
Settings Contents
TOP Model Check the display and process of TOP to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Please select “"OMRON Industrial Automation”.
PLC Select an external device to connect to TOP.

Protocol
V680 RFID Series Serial V680

Interface

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting

M [ Project > Project properties > TOP settings] — [HMI settings > Check “Use HMI settings” > Edit > Serial ]

— Set the TOP communication interface in TOP Design Studio.

Project Option

- Change HMI[H]

R Ao PLC ST Change PLCI

E3 Delete PLCD)

TOP Settin
-} 5¥5 : RD1220X
~ -l Option Module Setting
-l FieldBus (0)
-8 RFID {0}
v -igg, Device Setting
w128 COM1 (1)

-1g¥ COM2 (0)
-1g¥ COM3 (0)
-l Ethernet (0)
-~ Wireless (0)
-l USBDevice {0)

-~ PLC1: V&80 RFID Series

Date / Time Sync. = Screen Option  Unit Convert

HmiSetup = Global Lock & Touch Project Style  Splash = PLC Buffer Sync.

Project Option

Screen Change

Use HMI Setup

Hmi Setup Cption

Initialization | Edit |

Project Setting
HMIDisable=0

Project Name=New project
Start Mode=Menu

Start Screen No.=1

Latch Use=0

Latch Set=0~0

Communication Error Message =0
USBErrorMessage=0
StorageErrorMessage=1
DatabaseMessage=1

~

Control Panel

Svystem m Devices

;_?Service _'—'"'.' Option

o Serial *
s y—
I l 7 0 Serial Port: COMI =
PLC Security Dat e /Time Signal Level
(®) RS-232C (O Rs-422(4) O Rs-485(2)
_ Baud Rate: 9600 i
oo )
L Data Bit: 7 -
Et hernet Serial HOK | Stop Bit: o .
ey \ Parity Bit: Ewen w2
= Flow: [ff
L aanl .“\F‘inn
Diagnost ic File Fing Auto Search  Loopback Test
Manager
Apply Cancel
Items TOP External device Remarks

Signal Level (port)

RS-232C / RS-422 / RS-485 RS-232C / RS-422 / RS-485

Baud Rate 9600
Data Bit 7
Stop Bit 2
Parity Bit Even

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [ Project > Project properties > Device setting > COM > "PLC1 : V680 RFID Series"]
— Set the options of the communication driver of V680 RFID Series in TOP Design Studio.

Project Option *
- Change HMI[H] ' AddPLC[A] | THTM) Change PLCIC | [] Delete PLCID]
v {JTOPSettng PLC Setting[ V680 RFID Series ]
L[ sYs:RD1220X
Option Module Setting Alizs Mame ¢ |PLC1
& FieldBus (0) Interface : | Serial s
.. RFID (0)
v & Device Setting Protocol : | V680 ~ Comm Manual
¥ COM1(1)
{w® PLC1: V680 RFID Series
[] use Redundancy
8 Ethernet (0) AND w
™ Wireless (0) TimeOut 5 -
.4 USBDevice (0) T . i
Conditior Edi
Primary Option
Timeout m msec "
Send Wait msec
Retry 5 z
Controller(Station) Mo,
CH Total No.
CH1
Trigger svs5 v |oooo0.00 (5|55
OK 5Y5 v |oooo0.01 (5|55
NG 5ys v |ooo00.02 (5|5
Data oy « |oo100 = B Words
* Error Message
W Mn Tan @ Tnnut the snecified messane W
Apply Close
Items Settings Remarks
Interface Select “Serial”. Refer to “2. External
Protocol Select "V680". device selection”.
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.
SendWait (ms) Set the waiting time between TOP's receiving a response from an external device and
sending the next command request.
Retry Configure the amount of redelivery attempts from TOP to external device.
Controller No. Set the station number of the controller that communicates with TOP. Station No.
CH Total No. Set total number of channels.
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CH1

CH Mo,
Trigger svs - ’W* .-E'
o 55 “ ’W‘: )
G 55 “ ’W‘: )
Data ayg « |oo100 = .-E" 25 - Words
* Error Message
¥ Mo Tag : Input the specified message
- Message Mo Tag
- Destination Data Address

Mo Tag : Input a message from address
- Message sYs - W‘: -_f\"
- Destination sYs - W‘: .-E'
- Size Words
+ Read Error : Input the specified message
- Message Read Error
- Destination Data Address

Read Error : Input a message from address
- Message avs - ’W‘: B
- Destination avs - ’W‘: B
- Sige Words

B Communication interface setting

Items Details Contents

CH No. RFID antenna number

Trigger Conditional bit configuration required to execute RFID reading.

oK Corresponding address turns on when RFID reading is normal
User must manually turn off, since off operation does not occur

NG Corresponding address turns on when an error occurs
User must manually turn off, since off operation does not occur

Data Address for storing loaded RFID data (Other PLC address can be used)
Designate maximum words for loaded RFID data

Direct Input Method used to make an entered message appear by default on the

Error message

processing method

(Input the specified message ) drawing screen when an error occurs.

Address variable Method that allows users to designate a set amount of words as a

(Input a message from address) variable for the designated address when an error occurs.

Direct Message Enter the tag error message to be used as default.
Input Destination Stores the data address.

No Tag Message Message content to be stored when tag error occurs
Ad(.iress Destination Address for storing message when tag error occurs.
variable Size Maximum words of a message to be stored when tag error occurs
Direct | Message Enter the communication error message to be used as default.
Input Destination Stores the data address.

Read Error Message Message content to be stored when communication error occurs
Address | Destination Address for storing message when communication error occurs.
variable | Maximum words of a message to be stored when communication error

size occurs
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3.2. Communication setting in TOP

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [ Main screen > Control panel > Serial ]

Conitroll Panel

o serial
Bun —
i Serial Port: [CUI#H |*l
Signal Level
‘ 0 @ P5-232C () RS-422(4) O RS-485(2) l
Baud Rate: [ 9600 |vl
Viower [.J'l-.] : | Data Bit: | 7 |
owm o
R T sten 51t [ B
] Ethernet Serial
:g Parity Bit: | Even M
Screen m T Flow: [ Of f |vl
shot 1
Dlagnost I File [Auto Search] lLoopback Testl
Manager
| Apply ” Cancel l —

[System]

Close r

Items TOP External device Remarks
Signal Level RS-232C / RS-422 / RS-485 RS-232C / RS-422 / RS-485

Baud Rate 9600

Data Bit 7

Stop Bit 2

Parity Bit Even

* The above settings are setting examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

®

Run

YHC
Yiewer

W [ Main screen > Control panel > PLC ]
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[

|

Screen

CH

o :
@ Syste Driver(COMI) | PLCICYEED RFID Series) vl
Interface | Serial R4
!II' | Protocol | ¥BBO R
PLC Timeout 300 E Msec
send Wait 0 3 msec
[-""-] Retry =
i Control le o =
Ethernet
CH Total
Diagnost ic CH No. ﬂ
[ |
[System l

[ bpp |y HCancell

Items Settings Remarks
Interface Select “Serial”. Refer to "2. External
Protocol Select "V680". device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP’s receiving a response from an external device

and sending the next command request.

Retry Configure the amount of redelivery attempts from TOP to external device.

Controller No. Set the station number of the controller that communicates with TOP. Station No.

CH Total No. Set total number of channels.
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3.3 Communication diagnostics

W Check the interface setting status between the TOP and an external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC ].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information OK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG L .
diagnostics 3. Communication setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name OK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings OK NG . .
4. External device setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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Configure the RFID switch communication settings as follows. For more detailed setting methods than described in this example,

please refer to the PLC user manual.

1. SW 1, SW 2 (Controller Number): Set to 0 as follows.

SWA1 SWwaz
Upper digit | Lower digit Controller No.
0 0 a
0 1 1
0 2 2
a 3 3
] 4 4
0 5 5
0 & ]
4] T T
Q 8 |
0 L] g
1 0 10
1 1 1
2 - 29
a 0 a0
3 1 ]
3 2 Setting prohibited
3 3 Setting prohibited
g 9 Setting prohibited
2. SW3, PIN 1 (SW Enable Switch): Set to OFF.
SW3, pin 1 Description
QFF DIF switch enabled
OM Intarmal sattings enabled
3. SWS3, Pin 2 (Reserved by System): Set to OFF.
4. SW3, Pins 3 and 4 (Baud Rate): Set both pin 3 and 4 to OFF.
SW3, pin 3 | SW3, pin4 Description
OFE OFF 9,600 bps
ON 18,200 bps
on OFF | 38,400 bps
ON 115,200 bps
5. SW3, Pin 5 (Data Length): Set to OFF.
SW3, pin 5 Description
OFF 7 bits
oM 8 bils
6. SW3, Pins 6 and 7 (Parity): Set both pin 6 and 7 to OFF.
SW3, ping | SW3, pin T Description
FF OFF | Ewven
O MNone
ON COFF Odd
OM Even
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SW3, pin 8 Description
OFF 2 bits
ON 1 bit

8. SW3, Pin 9 (Communications Protocol): Set to ON.

SW3, pin 9 Description
OFF 11
OM TN

9. SWS3, Pin 10 (Command System): Set to OFF>

SW3, pin 10 Description
OFF VE80 commands
OM VB0 commands

10. sW4, Pins 1, 2, and 3 (Maintenance Mode Switch Settings): Set all of pin 1, 2, and 3 to OFF.

SW4, | SW4, | SwW4,

pin 1 pin 2 pin 3 S

OFF OFF | Distance Level Measurement Mode

OM | Tag Communications Test Mode

OFF '
OFF | Spaead Level Measuremant Mode, Raad

O

OM | Speed Level Measuremant Mode, Write

OFF OFF | Moize Level Measurement Mode

OM OFF | Communications Success Rate Measurement Made

ON
OM | Host Communications Monitor Mode

11. SW4, Pin 4 (Antenna Specification): Set the antenna number you want to use as follows.

SW4, pin 4 Description
OFF Antenna 1
O Antenna 2

12. SW4, Pin 5 (Write Verification): Set to ON.

SW4, pin 5 Description
OFF With write varification
OM Without write verification

13. SW4, Pin 6 (Lower Trigger Execution): Set to OFF.

SW4, pin & Description
OFF Mane
oM Enabled {on rising adge)

14. SW4, Pin 7 (Write Protection Function): Set to ON.

SW4, pin 7 Dascription
OFF Enabled
O Disabled

15. Sw4, pin 8 (V680-HO1 Antenna connection setting): Set the antenna type you want to use as follows.

SWd, pin B Description
OFF Connection to antennas other than the VER0-HMM
OM Allows connection of the VE80-HO1 Antenna.

16. SW4, Pin 9 (Run Mode): Set to OFF.

SW4, pin & Drescription
OFF Command Execution Mode
O Self-axecution Made
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17. SW4-10 (High-speed Data Transmission setting): Set to OFF.

TO hEQIRE E AT
Touch Qperation Panel

SW4 pin 8 ~ Description
OFF Mormal mode
ON High-speed mode
18. SW 5 (Mode Switch Setting): Set to OFF.
SWS Description
OFF Run Mode
OM Maintenance Mode
19. SW 6 (Terminating Resistance): Set to OFF.
SWeE Description
OFF Terminating resistance OFF
On Terminating resistance ON
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This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.

(The cable diagram described in this chapter may differ from the recommendations of “Omron V680 RFID".)

M 1:1 connection
TOP COM Port (9 pin)

TOP RFID
Pin Signal Pin Cable connection Pin Signal Pin
arrangement+Note 1) name number number name arrangement*Note 1)
1 5 CD 1 1 NC 1 5
(@ Q) RD 2 2 SD (@ Q)
g g ) 3 3 RD g g
DTR 4 4 RS
Based on [ Based on
. SG 5 5 (&) L
communication communication
DSR 6 6 NC
cable connector cable connector
front, RTS ’ j ’ NC front,
D-SUB 9 Pin male c1s 8 8 NC D-SUB 9 Pin male
(male, convex) 9 9 SG (male, convex)
*Note 1) The pin arrangement is seen from the contact side of the cable connector.
M 1: N connection
TOP COM Port (9 pin)
TOP RFID
Pin Signal Pin Cable connection Pin Signal Pin
arrangement*Note 1) name number number name arrangement*Note 1)
1 3 RDA ! >< 4 SDB
(@ o) RDB 4 T3 SDA
Q o SDA 6 2 RDB @ il @
6 5 I
SDB 9 r 1 RDA
Based on Tanighe T 2 3 013
communication Based on

cable connector

communication

front, cable connector
D-SUB 9 Pin male front,
(male, convex)
*Note 1) The pin arrangement is seen from the contact side of the cable connector.
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