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HANYOUNGNUX CO.,LTD. 

Temperature Controller 

- NX/PX/UX100/RT9/NP100/NP200 Series 

PC Link Driver  
 Supported version TOP Design Studio V1.0 or higher  

 

 

CONTENTS 

We would like to thank our customers for using M2I's "Touch 

Operation Panel (M2I TOP) Series". Read this manual and familiarize 

yourself with the connection method and procedures of the “TOP and 

external device”. 

 

1. System configuration Page 2 

 

 

Describes the devices required for connection, the setting of 

each device, cables, and configurable systems. 

2. External device selection  Page 3 

 Select a TOP model and an external device. 

3. TOP communication setting Page 4 

 Describes how to set the TOP communication. 

4. External device setting Page 9 

 Describes how to set up communication for external devices. 

5. Cable table Page 10 

 Describes the cable specifications required for connection. 

6. Supported addresses Page 12 

 Refer to this section to check the addresses which can 

communicate with an external device. 
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1. System configuration 

The system configuration of TOP and “HANYOUNGNUX CO.,LTD – Temperature Controller Series” is as follows: 

 

Series CPU Link I/F 
Communication 

method 
System setting Cable 

NP200 
NP200–□1 

NP200–□3 

Terminal Port 

on CPU unit 

RS485 

(2 wire) 
3.1 Settings example 1 5.1. Cable table 1 

NP100 
NP100–□2 

NP100–□3 

Terminal Port 

on CPU unit 

RS485 

(2 wire) 
3.1 Settings example 1 5.1. Cable table 1 

NX NX9–□1 
Terminal Port 

on CPU unit 

RS485 

(2 wire) 
3.1 Settings example 1 5.1. Cable table 1 

 

NX7–□1 

NX3–□2 

NX2–□2 

Terminal Port 

on CPU unit 

RS485 

(2 wire) 
3.1 Settings example 1 5.2. Cable table 2 

PX PX9–□1 
Terminal Port 

on CPU unit 

RS485 

(2 wire) 
3.1 Settings example 1 5.1. Cable table 1 

 
PX7–□1 

PX7–□2 

Terminal Port 

on CPU unit 

RS485 

(2 wire) 
3.1 Settings example 1 5.2. Cable table 2 

RT9 

RT9–□□3 

RT9–□□4 

RT9–□□5 

Terminal Port 

on CPU unit 

RS485 

(2 wire) 
3.1 Settings example 1 5.2. Cable table 2 

UX100 UX100–□1 
Terminal Port 

on CPU unit 

RS485 

(2 wire) 
3.1 Settings example 1 5.2. Cable table 2 

 

 

■ Connectable configuration 
 

ㆍ1:1 (one TOP and one external device) connection – configuration which is possible in RS232C/422/485 communication. 

 
 

ㆍ1:N (one TOP and multiple external devices) connection – configuration which is possible in RS422/485 communication. 
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2. Select external devicesetting 

■ Select a TOP-R model and a port, and then select an external device. 
 

 
 

 
 

 

Settings Contents 

TOP Model Check the TOP display and process to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Select “Hanyoung Nux”. 

PLC Select an external device to connect to TOP. 
 

Model Interface Protocol 

Temperature Controller Series Computer Link PC Link 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [Project > Project Property > TOP Setting] → [Project Option > “Use HMI Setup” Check > Edit > Serial] 

– Set the TOP communication interface in TOP Design Studio. 
 

 
 

 
 

Items TOP External device Remarks 

Signal Level (port) RS-485 RS-485  

Baud Rate 9600  

Data Bit 8  

Stop Bit 1  

Parity Bit None.  

* The above settings are examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [ Project > Project Property > PLC Setting > COM > “PLC1 : Temperature Controller Series”] 

– Set the options of the Temperature Controller Series communication driver in TOP Design Studio. 

 

 

Items Settings Remarks 

Interface Select “Computer Link”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
 

Station No Enter the prefix of an external device.  

Checksum  Select Checksum use status.   
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

   

(1) Communication interface setting 

■ [Main Screen > Control Panel > Serial] 
 

 

Items TOP External device Remarks 

Signal Level (port) RS-485 RS-485  

Baud Rate 9600  

Data Bit 8  

Stop Bit 1  

Parity Bit None.  

* The above settings are setting examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device. 

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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(2) Communication option setting 

■ [Main Screen > Control Panel > PLC] 
 

 

 

Items Settings Remarks 

Interface Configure the communication interface between the TOP and an external device. Refer to “2. External 

device selection”. Protocol Configure the communication protocol between the TOP and an external device. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
 

Station No Enter the prefix of an external device.  

Checksum  Select Checksum use status.   
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC ]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  

OK NG 

6. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 

 

Configure the communication setting of the external device by referring to its user manual.  
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5. Cabletable 

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. 

(The cable diagram described in this section may differ from the recommendations of  “Hanyoung Nux - Temperature Controller 

Series”) 

4.1 Cable table 1 

 

■ 1:1 connection 
 

COM 

Cable connection 

Temperature Controller 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 
Pin arrangement 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  SDA 

 

 2 SDB 

 3 RDA 

RDB 4 RDB 

SG 5 SG 

SDA 6  

 7 

 8 

SDB 9 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ 1:N connection – Refer to 1:1 connectionto connect in the following way. 

 

TOP Cable connection and signal 

direction 

External device Cable connection and signal 

direction 

External device 

Signal name Signal name Signal name 

RDA 

 

SDA 

 

SDA 

RDB SDB SDB 

SDA RDA RDA 

SDB RDB RDB 

SG SG SG 
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4.2 Cable table 2 

 

■ 1:1 connection 
 

COM 

Cable connection 

Temperature Controller 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 
Pin arrangement 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  RTX(+) 

 

 2 RTX(-) 

 3 SG 

RDB 4  

SG 5  

SDA 6  

 7  

 8  

SDB 9  

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 
 

 

■ 1:N connection – Refer to 1:1 connection to connect in the following way. 

 

TOP Cable connection and signal 

direction 

External device Cable connection and signal 

direction 

External device 

Signal name Signal name Signal name 

RDA  RTX(+)  RTX(+) 

RDB RTX(-) RTX(-) 

SDA SG SG 

SDB   

SG   
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6. Supported Address 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

 

Device Bit Address Word Address Remarks 

D Register D0001.00 – D9999.15 D0001 – D9999  

I Register I0000 – I9999 –––––  

 

 

Reference: D Register Configuration Overview (see the User's Manual distributed by Hanyoung Nux Co., Ltd.) 

Register Contents 

0001 – 0099 

Configured as read-only range, user range 

0001(NPV) Current PV value 

0002(NSV) Current driving SV value 

0003(NRSV) Current Remote SV value 

0005(MVOUT) Current output value 

0006 - 0007(CH1,2OUT) HC-type output value 

0008(PIDNO) Current driving PID no. 

0009(ALMSTS) Current alarm status (BIT information) 

0010(STEPNO) Current step no. for program drive 

0011(BRSEGTM) Current step no. remaining time for program drive 

0014-0015(HC1,2_CUR) Heater Cut value 

0016(ADESTS) Input processing error information (bit information) 

0017(ERRSTS) Input and AT Error information (bit information) 

0018(MODSTS) Current drive status information (bit information) 

0050-0099 User section (Read/Write possible) 

0100 – 0199 

Drive status confirm / Change element 

0100 (OPMODE) 0 : Local, 1 : Program, 2 : Remote 

0101(PROG) 0 : Reset, 1 : Program Run 

0102(ZOM) 0 : Zone Off, 1 : Zone On 

0103(FUZY) 0 : Fuzzy Off, 1 : Fuzzy On 

0104(ARW) 0 : ARW Off, 1 : ARW On 

0106(DIS) Select DI 

0200 – 0299 Programming 

0300 – 0399 SV settings and PID settings 

0400 – 0499 Alarm Parameters settings 

0500 – 0599 
Identification of parameters related to transmission and remote and parameters related to communication 

(0510 - 0516 : Read Only) 

0600 – 0699 Input/output parameters settings 

 


