LS Industrial Systems
MASTER-K 10S1 Series
LOADER Driver

Supported version  TOP Design Studio V1.0 or higher {Rl

TOP

"

CONTENTS

We would like to thank our customers for using M2l's "Touch

Operation Panel (M2] TOP) Series". Read this manual and familiarize
yourself with the connection method and procedures of the "TOP and

external device”.

1. System configuration Page 2

Describes the devices required for connection, the setting of

each device, cables, and configurable systems.

2. External device selection Page 3

‘ Select a TOP model and an external device.

3. TOP communication setting Page 4

Describes how to set the TOP communication.

4. Cable table Page 9

Describes the cable specifications required for connection.

5. Supported addresses Page 10

Refer to this section to check the addresses which can

communicate with an external device.
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1. System configuration

The system configuration of TOP and “LS Industrial Systems — MASTER-K Series 10S1" is as follows:

Link 1/F Communication method System setting
. 3.1 Settings example 1 5.1. Cable table 1
10S1 K14P1-DRS CPU Direct RS-232C
(Page 4) (Page 9)

W Connection configuration

+ 1:1 (one TOP and one external device) connection

j ----.-
|

* 1:N (one TOP and multiple external devices) connection

(<] -
™ [
I
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2. External device selection

H Select a TOP model and a port, and then select an external device.
(1) TOP setting

Select Device n

PLC select [COM2]

e 7 D —
@ Model  (O) Vendor
Vendor Model
i A

M21 Corporation & WGI/NGRMEC Series
MITSUBISHI Electric C i

Seiic Lorparation & GK/XBM/XBC Series
OMRON Industrial Automation

GLOFA-GM Series

LS Industrial Systems
& MASTER-K(B0S/1205/2005/3005/10005) Series

MODBUS Organization

& STARVERT Series
SIEMENS AG.

& XCODE RFID HF Reader Series [H-1306/1307
Rockwell Automation

GE Fanuc Automation & MASTER-K(500H,1000H) Series
" MASTER-K 105,1051 Series
PANASONIC Electric Works ' - Sl =
YASKAWA Electric Corporation
YOKOGAWA Electric Corporation

Schneider Electric Industries

KDT Systems
RS Automatinn 7
‘ Back | . Next ® Cancel
Select Device [ = |

PLC Setting[ MASTER-K 105,1051 Series ]

Alias Mame : [PLC1
gt gl CPU Direct ~

Protocel : |MASTER-K 1051 CPU Serie v Comm Manual
String Save Mode : |First LHHL Change

[] use Redundancy

Primary Option

Timeout 300 1| msec

Send Wait msec

4 Back « OK * Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select “LS Industrial Systems".
PLC Select an external device to connect to TOP.

Interface Protocol

MASTER-K(10S1)Series Loader MASTER-CPU

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that
of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting
M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Serial]

— Set the TOP communication interface in TOP Design Studio.

Project Option x

- Change HMI[H] ' AddPIC[A] | THal Change PICIC] | [ Delete PLCID)

TOP Setti
\?ED'S:F';QDILSZDS{ Date / Time Sync.  Screen Option | Unit Convert

Option Module Setting Project Option ~ Screen Change  HmiSetup = Global Lock & Touch  Project Style  Splash | PLC Buffer Sync.
8 FieldBus (0)
Device Setting - - P .
= CoM1 () Hmi Setup Option Initialization Edit
v 15 COM2 (1) Project Setting ~
% PLC1: MASTERK 108, 10¢ HMIDisable=0
W COM3 (0) Project Name=Mew project
88 Ethernet (0) Start Mode=Menu
® Wireless (0) f:tg]%csr:ig el
8 USBDevice (0) Latch Set=0n~0

Communication Error Message=0
USBErrorMessage =0
StorageErrorMessage=1

Control Panel

System -l Devices @Service ._;""_'Uptinn

—
M B | e = Serjal bod
T y (&

PLC Security Dat e Time

Serial Port: COMZ <

Siagnal Level
® F5-232C () Bs-42204) () R3-485(2)

v . Baud Rate: 3600

4

Data Bit: 3 M
Et hernet Serial HOH | Stop Bit: 1 -
Parity Bit: None -
E— % Flow: [(ff
_l: b @ - Autosearch Loopback Test
Diagrost ic File Fimg
Wanager Apply  Cancel
Items TOP External device Remarks
Signal Level (port) RS-232C .
RS-232C Fixed
(CPU port)
Baud Rate 9600 Fixed
Data Bit 8 Fixed
Stop Bit 1 Fixed
Parity Bit None. Fixed

* The above settings are examples recommended by the company.

External device connection manual for TOP Design Studio 4/ 10



(2) Communication option setting

M [ Project > Project Property > Device Setting > COM > "PLC1 : MASTER- LINK"]

— Set the options of the MASTER- LINK Series communication driver in TOP Design Studio.

ERI2 e B X
Touch Qperation Panel

TOP (|

Project Option

- Change HMIH]

“ AddPLC[A] | THITal Change PLCIC)

m Delete PLC[D]

TOP Setting

-3 5Y5 ¢ RD1520%
Option Module Setting
-4 FieldBus (0)

- RFID (0)

Device Setting

=8 COM1 (D)

8 Ethernet (0)
® Wireless (0)
9 USBDevice (0)

-
l % PLC1: MASTER-K 105,10

PLC Setting[ MASTER-K 10S,1051 Series ]

Alizs Name : [PLC1

Interface : ~

CPU Direct

Protocol : | MASTER-K 1051 CPU Serie

: [First LH HL Change

[ use Redundancy

String Save Mode

Primary Option

Timeout 200 &1 | msec
Send Wait msec
Retry 5 z

Comm Manual

£ >
Apply Close
Items Settings Remarks
Interface Select "Computer Link". Refer to "2. External
Protocol Select "MASTER- LINK Series".

device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP’s receiving a response from an external device

and sending the next command request.

Retry

Select amount of redelivery attempts upon communication failure.
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3.2. Communication setting in TOP
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* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

B

Control Panel

o
System m Deviii Soriu
Run =
i Serial Port: |COM2 H
!lxlll ~Signal Level
‘ P seurity 0 |® PS-232C O RS-422(4) O Rs-dasiz_) I
Baud Rate: |
¥HC
Yiever m '.-. ‘ Data Bit:
Fumyg A
[ ] Ethernet Serial Stop Bit:
] p ix.
Parity Bit: [None |7
Screen = Flow: | (0ff -
| B B o
Disgnost ic File Auto Search| Loopback Test
Manager - 3
/ [ App |y :I Cancel ]
[System] CTose r
—
Items TOP External device Remarks
Signal Level (port) RS-232C )
RS-232C Fixed
(CPU port)
Baud Rate 9600 Fixed
Data Bit 8 Fixed
Stop Bit 1 Fixed
Parity Bit None. Fixed

* The above settings are setting examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting
B [Main Screen > Control Panel > PLC]

® -El' i) PLC
@ Svystem

Or iver (COM2) ‘ PLCT(MASTER-K 105,1051 Series) v]
R .
an Interface | CPU Direct [~]
nlll Protocol _ MASTER-K 10S1 CPU &|~
‘ PLD 4 Timeout 300 E msec
WHe send Wait msec
Viever [-""-] d Retry 5 5
. I
Ethernet
foii™
Diagnost ic 1
[System] l Diagnostic l dipp |y ”Cancel]
A
Items Settings Remarks
Interface Select "Computer Link". Refer to "2. External
Protocol Select "MASTER-K Link Series". device selection”.
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.
SendWait (ms) Set the waiting time between TOP's receiving a response from an external device and
sending the next command request.
Retry Select amount of redelivery attempts upon communication failure.
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3.3 Communication diagnostics

W Check the interface setting status between the TOP and external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) .
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information OK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG L .
diagnostics 3. Communication setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name OK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings OK NG . .
4. External device setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. Cable table
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This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.

(The cable diagram described in this section may differ from the recommendations of “LS Industrial Systems Co., Ltd.")

m RS-232C (1:1 connection)

CoM pLC
Pin Signal Pin Cable connection Pin Signal Pin
arrangement*Note 1) | name | number number | name | arrangement*Note 1)
CcD 1 1 RD
1 5 RD 2 2
(© ) SD 3 3
Q S DTR 4 4 SD
. 2 SG 5 5
Based on _ 
R DSR 6 6 SG
communication cable Based on
tor front RTS 7 .
connector front, s . communication cable
D-SUB 9 Pin male 5 connector front,

(male, convex)

D-SUB 6 Pin male

(male, convex)

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.

External device connection manual for TOP Design Studio

9/10



5. Supported addresses
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The devices available in TOP are as follows:

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Bit Address Word Address 32 bits Remarks
Input / Output Relay PO00 — P63F P00 — P63
Auxiliary Relay MO000 - M191F MO0 - M191
Keep Relay KOO0 — K31F KOO - K31
Special Relay FOOO - F63F FOO — F63 L *Note 1) Cannot be written
Timer T0000.00 - T1255.15 T0000 - T1255
Counter €0000.00 - C1255.15 C0000 — C1255
Step Relay S0000 — S0099

Data Register

D0000.00 - D9999.15

D0000 — D9999

*Note 1) The lower 16BIT data of 32BIT data is saved in the address whose screen has been registered, and the upper 16BIT data is

saved in the address next to the address whose screen has been registered.

Ex. When saving 32BIT data hexadecimal data 12345678 in address D00100, it is saved to 16BIT device address as follows:

Items 32BIT 16BIT
Address D00100 D00100 D00101
Input data
) 12345678 5678 1234
(hexadecimal)
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