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LS Industrial Systems Co., Ltd.

XGT(XGI-CPU/XGR-CPU), XGB(XEC-CPU) Series

FENET Driver
Support version OS V4.0 이상 

XDesignerPlus 4.0.0.0 이상

CONTENTS
Thank you for using TOP series of M2I corporation.

Please read this manual carefully to know connection methods and 

procedures of “TOP to External device”

1. System configuration Page 2

A section for showing connectable external devices, serial signal 

types, connection configurations. Refer this section to select the 

right system configuration.

2.Selection of TOP, External device  Page3

A section for selecting a Top model and the external device.

3. Example of system setting Page 4

A section for explaining examples to connect communications of 

TOP to External Device.

Select the correct example in your case according to “1. System 

configuration”.

4. Communication setting Page 8

A section for Communication setting.

The setting should be the same with the external device.

5. Usable address Page 10

A section for usable address to communicate with external 

device.
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Series CPU Link I/F Communication type System setting cable

XGI

XGR

XGI-CPUE

XGI-CPUH

XGI-CPUS

XGI-CPUU

XGI-CPUU/D

XGR-CPUH

XGL-EFMT

Ethernet (UDP)  setting ex 1

( 4 page )

Twist pair cable
 *1)

Ethernet (TCP)  setting ex 2

( 6 page )

XGB
XEC-D□32H

XEC-D□64H
XGL-EMTA

Ethernet (UDP)  setting ex 1

( 4 page )

Ethernet (TCP)  setting ex 2

( 6 page  )

1. System configuration
System configuration of TOP and “LS Industrial Systems Co., Ltd – XGT(XGK), XGB(XBC/XBM) Series” is as below.

*1) Twist pair cable

- It means STP(shield  twist pair cable) or UTP(shieldless twist pair cable) category 3, 4, 5.

- It can connect to hub, transceiver etc. according to network composition and use direct cable in this case.

■ Connection configuration

ㆍ1 : 1 connection (TOP 1 unit to External device 1 unit)

ㆍ1 : N connection (TOP 1 unit to External device several units)
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Setting Items Description

TOP Series

Series OS Version

XTOP / HTOP V4.0

Select a TOP series which is communicated with external device.

Install an OS file v3.1 as diagram below before download a project file you have made.

Name Select a TOP model which is communicated with external device.

External Device Vendor Select vendor of the external device which is communicated with TOP.

Select “LS Industrial Systems Co., Ltd”.

PLC Select a model name of the external device which is communicated with TOP.

Select “XGT(XGI/XGR), XGB(XEC) Series”.

Check whether the external device you want to use is connectable or not

in “1. System configuration”.

2. Selection of TOP, External device
Select a external device which is communicated to the TOP.
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Item TOP XGT(XGI/XGR), XGB(XEC) Series Note

IP Address*1)2) 192.168.0.50 192.168.0.51 User Set

Protocol UDP XGT server*3) User Set

Port 1024 2005 User Set

Protocol TCP/IP UDP/IP MODBUS TCP

Port number 2004 2005 502

■ [ Project > Project property > project > TOP Setting > TOP’s Name ]

Set communication interface of TOP.

- From right window [ HMI Setup > check Use HMI Setup > Device Manager ] 

- From right window [ HMI Setup > check Use HMI Setup > PLC Setting ]

■ External Device Settings

Set up the “XGT(XGI/XGR), XGB(XEC) Series FENET” communication option

- IP Address (PLC): Type the IP address that the external device was given.

- Reading port / writing port: Choose the port number that will be used for ethernet 

communication. Please input the port number that [GPPW] issued.

- - Device reading method : It is for selecting protocol method that will attempt 

3. System setting
Set Communication interface of TOP and external device as below. 

3.1 Example 1

Set your system as below.

*1) Network address TOP and external device must be same. (IP's three place : 192.168.000 )

*2) Don't use same address in same network. 

*3) XGT driver private port of FEnet I/F module admits communication to specified port number/protocol to appropriate IP.

(1) XDesignerPlus Setting

[Project >Project property] of XDesignerPlus as below and download it to TOP machine.
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to communicate to external device.

Don't use overlapping IP address in unit network.

Item Contents Note

TCP/IP setting High speed 

link station number

 0 Set station number when it communicated to high 

speed between XGT PLC FEnet I/F module and 

module.

Media AUTO Select media.

IP address 192.168.0.51 Set IP address of FEnet I/F module. Required 

setting

Subnet mask 255.255.255.0 Subnet mask

Gateway 192.168.0.1 Gateway address(Router address)

DNS server 0.0.0.1 Domain name server

DHCP OFF (default) If you use automatically assigned IP, check "ON". Required 

setting

Receive Wait time 15 (default)

Personal connection 

unit

3 (default) Maximum number of private service that can 

connect simultaneously.

Driver(server) setting Driver XGT server Required 

setting

(2) External device setup

Run "XG-PD Editor" program for communication setting and set as below. 

If you want to change communication interface, modify refer to PLC manual. 

1. Run File > New File”. Select CPU Type and push OK button refer to “1. system configuration”.

2. Connect CPU LOADER port of XGT Series and serial port of PC by serial cross cable.

(If there is USB port in CPU, connect USB.)

3. Run [Online] > [Connection settings] menu. Select [Connection settings->Type] and click [Connect] button.

4. Run [Online] > [I/O Information] and read slot number. Run [Online] > [Read Parameter] and read parameter information of slot 

of communication card.

5. Double click slot of Cnet card in [Project Window], show dialog box of [Default settings].

Set [Connection] and [Run Mode] as below and click [OK].
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Host table setting Unable

Host table

OFF Module of registered IP address is only admitted 

connection to FEnet I/F.(If it is unable, unregistered 

client can't connect.)

Required 

setting

6.  Transfer setting contents to CPU at [Online] > [Parameter Write].

7.  Reset PLC at [Online] > [Reset] > [Reset PLC].
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Item TOP XGT(XGI/XGR), XGB(XEC) Series Note

IP Address*1)2) 192.168.0.50 192.168.0.51 User set

Protocol TCP XGT server*3) User set

Port 1024 2004 User set

Protocol TCP/IP UDP/IP MODBUS TCP

Port number 2004 2005 502

■ [ Project > Project property > project > TOP Setting > TOP’s Name ]

Set communication interface of TOP.

- From right window [ HMI Setup > check Use HMI Setup > Device Manager ] 

- From right window [ HMI Setup > check Use HMI Setup > PLC Setting ]

■ External Device Settings

Set up the “XGT(XGI/XGR), XGB(XEC) Series FENET” communication option

- IP Address (PLC): Type the IP address that the external device was given.

- Reading port / writing port: Choose the port number that will be used for ethernet 

communication. Please input the port number that [GPPW] issued.

- Device reading method : It is for selecting protocol method that will attempt to 

communicate to external device.

3.2 Example 2

Set your system as below.

*1) Network address TOP and external device must be same. (IP's three place : 192.168.000 )

*2) Don't use same address in same network. 

*3) XGT driver private port of FEnet I/F module admits communication to specified port number/protocol to appropriate IP.

 (1) XDesignerPlus setting

[Project >Project property] of XDesignerPlus as below and download it to TOP machine.
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Don't use overlapping IP address in unit network.

Item Contents Note

TCP/IP setting High speed 

link station number

 0 Set station number when it communicated to high 

speed between XGT PLC FEnet I/F module and 

module.

Media AUTO Select media.

IP address 192.168.0.51 Set IP address of FEnet I/F module. Required 

setting

Subnet mask 255.255.255.0 Subnet mask

Gateway 192.168.0.1 Gateway address(Router address)

DNS server 0.0.0.1 Domain name server

DHCP OFF (default) If you use automatically assigned IP, check "ON". Required 

setting

Receive Wait time 15 (default)

Personal connection 

unit

3 (default) Maximum number of private service that can 

connect simultaneously.

Driver(server) setting Driver XGT server Required 

setting

Host table setting Unable

Host table

OFF Module of registered IP address is only admitted 

connection to FEnet I/F.(If it is unable, unregistered 

client can't connect.)

Required 

setting

(2) External device setup

Run "XG-PD Editor" program for communication setting and set as below. 

If you want to change communication interface, modify refer to PLC manual. 

1. Run File > New File”. Select CPU Type and push OK button refer to “1. system configuration”.

2. Connect CPU LOADER port of XGT Series and serial port of PC by serial cross cable.

(If there is USB port in CPU, connect USB.)

3. Run [Online] > [Connection settings] menu. Select [Connection settings->Type] and click [Connect] button.

4. Run [Online] > [I/O Information] and read slot number. Run [Online] > [Read Parameter] and read parameter information of slot 

of communication card.

5. Double click slot of Cnet card in [Project Window], show dialog box of [Default settings].

Set [Connection] and [Run Mode] as below and click [OK].
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6.  Transfer setting contents to CPU at [Online] > [Write].

7.  Reset PLC at [Online] > [Reset PLC].
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■ [ Project > Project property > project > TOP Setting > TOP’s Name ]

Set communication interface of TOP.

- From right window [ HMI Setup > check Use HMI Setup > Device Manager ] 

- From right window [ HMI Setup > check Use HMI Setup > PLC Setting ]

■ External Device Settings

Set up the “XGT(XGI/XGR), XGB(XEC) Series FENET” communication option

■ Setting communication Interface

item Description

Serial Signal Level Setup signal level(RS-232C/422/485) of PLC connected with COM2/1 port. (COM1 only RS-232C)

Serial Baud Rate Setup [communications Baud rate] of PLC connected with COM2/1 port. 

Serial Data Bit Setup [Data Bit] of PLC connected with COM2/1 port.                                    

Serial Stop Bit Setup [Stop Bit] of PLC connected with COM2/1 port.

Serial Parity Bit Setup [Parity Bit] of PLC connected with COM2/1 port.

Time Out [ x100 mSec ] Setup [Time Out] of PLC connected with COM2/1 port.  (Timeout:: waiting time for answer of PLC)

Send Wait [ x10 mSec ] Setup [Send Wait] of PLC connected with COM2/1 port.

(Send Wait: communicate after waiting setting time when touch screen requires communications.)

Station Num. in Diag.[0~31] Setup [Station Num.(0~31)] using "4.3 Communication Diagnosis”

4. Communication setting
Communication setup can be set on XDesignerPlus or TOP Main Menu. The setting should be the same with the external device. 

(1) XDesignerPlus setup – register information of external device
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PLC setup

PLC IP : 192 . 168 . 0 . 51 Communication Interface

Protocol : UDP Settings

PLC Read Port : 2005

PLC Write Port : 2005

TOP Port : 1024

PLC Address : 00

Timeout : 1000 [mSec]

Delay time of transmission : 0 [mSec]

TOP IP : 192 . 168 . 0 . 50

 TOP Ethernet setting communication diagnosis

Details Contents

PLC IP It is an IP address that external device was given.

Protocol Select the protocol method either UDP or TCP.

PLC Read Port It is the port address that will be used for ethernet of external device.

PLC Write Port It is the port address that will be used for ethernet of external device.

TOP port Setting the TOP port number to connect with external device.

PLC address [0~65535] Address of other device. Select between [0 - 65535].

Timeout [ x1 mSec ] Set up TOP’s waiting time from external device at [0 - 5000] x 1mSec.

Delay Time before

transmitting [ x1 mSec]

Set up TOP’s waiting time between response receiving – next command request transmission 

from external device at [ 0 – 5000 ] x 1 mSec.

TOP IP Setup the IP address that TOP receives in the network.

Port Settings

* Ethernet Communication Ethernet Port

 + Network setting Communication Interface

  - MAC : 00 - 15 - ID - 00 - 30 - 52  (each device has different address) Settings

  - IP Address : 192. 168 . 0 . 50

  - Subnet mask : 255 255 . 255 . 0

  - Gateway : 192 168 . 0 . 1

Details Contents

MAC Physical official address in the network.

IP Address Setup the IP address that TOP receives in the network.

Subnet mask An address that divides the network ID and host ID regarding of IP address.

Gateway An address that connects a network to another network.

4.2 TOP main menu setup item

 - When a buzzer is on during the power reset, touch 1 spot at the upper LCD to move to "TOP Management Main" display.

- Set up driver interface at TOP according to below Step1 → Step2.

(Press “TOP ethernet setup” in Step 1 to change setup at Step 2.)

Step 1. [ PLC setup ] .Setup driver interface.

Step 1–Reference.

Step 2. [PLC Setup] > [TOP Ethernet Setup] - Setup the serial parameter of correspond port.

Step 1–Reference.
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OK! Communication setting succeeded

Time Out Error! Communication setting error

- Error in the setting situation of Cable and TOP / External device

(reference : Communication Diagnosis sheet)

Details Contents Confirm

TOP Version Information xDesignerPlus : O.S : 

Name of Driver OK NG

External device

information

IP Address
OK NG

(xDesignerPlus Subnet mask OK NG

Project setting) Gateway OK NG

TOP Information Protocol UDP/IP TCP/IP OK NG

(Main Device 

Menu Setting)

IP Address
OK NG

Subnet mask OK NG

Gateway OK NG

Other specified setting info OK NG

System 

configuration

System Connection Method
1:1 1:N N:1 OK NG

Name of cable (Hub usage) Direct (Use Hub) Cross (No Hub) OK NG

External 

device

Name of CPU
OK NG

Name of communication device OK NG

Protocol(mode) OK NG

Other specified setting info OK NG

IP Address (Local) (Destination) OK NG

Port number (Local) (Destination) OK NG

Subnet mask OK NG

Gateway OK NG

Address range confirm (other docs) OK NG

4.3 Communication diagnosis

■ TOP - Confirming interface setting condition between external devices 

- Move to Menu by clicking the top side of LCD screen as resetting the power of TOP.

- [Main Menu >Communication setting] Confirm if detail in number 20~24 is identical to the setup information of “■Setup exercise 

1”.

- PLC Setup > Click the button in "Communication diagnosis" of TOP Ethernet.

- Diagnosis dialog box will pop up on the screen, you can judge by following informations that are shown on box no. 3 section.

■ Communication Diagnosis Sheet 

- Please refer to the information below if you have a problem between external devices and communication connection.
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Device Bit Address Word Address Double Word Address 32 Bit

Input Relay IW000.00.0.00 – IW127.15.3.15 IW000.00.0 – IW127.15.3 – L/H
*1)

Output Relay QW000.00.0.00 – QW127.15.3.15 QW000.00.0 – QW127.15.3 –

R Memory RW00000.00 – RW32768.15 RW00000 – RW32768 –

W Memory WW00000.00 – WW65535.15 WW00000 – WW65535 –

M Memory MW000000.00 – MW131071.15 MW000000 – MW131071 MD000000 – MD131070

MX0000000 – MX2097136

Item 32BIT 16BIT

address D00100 D00100 D00101

Input data(Hex) 12345678 5678 1234

5. Available address
The available address of device are as below.

Device(address) range might be different according to series/type of CPU. TOP Series are capable of supporting maximum address 

range which is available in external Device.

Be careful get out of address range.

*1) Low 16BIT of 32BIT data is saved address input by touch program, high 16Bit of 32BIT data is saved next address input by touch 

program.

(Ex) If you input [12345678] of hex 32bit data at address [D00100], save as below. 


