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LS Industrial Systems Co., Ltd.

GLOFA-GM Series 

FENET Driver
Support version OS V4.0 and over 

XDesignerPlus 4.0.0.0 and over

CONTENTS
Thank you for using TOP series of M2I corporation.

Please read this manual carefully to know connection methods and 

procedures of “TOP to External device”.

1. System configuration Page 2

A section for showing connectable external devices, serial signal 

types, connection configurations. Refer this section to select the 

right system configuration.

2. Selection of TOP, External device Page 3

A section for selecting a Top model and the external device.

3. Example of system setting Page 4

A section for explaining examples to connect communications of 

TOP to External Device.

Select the correct example in your case according to “1. System 

configuration”.

4. Communication setting Page 10

A section for cable to connect to external device.

Select a suitable cable diagram for your system.

5. Usable address Page 12

A section for usable address to communicate with external 

device.
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Series CPU Link I/F Comm. Type System setting Cable

GMR
GMR-CPUA

GMR-CPUB
G3L-EUTB

Ethernet (UDP)
3.1 setting ex 1

( 4 Page )

Twist pair cable *1)

Ethernet (TCP)
3.2 setting ex 2

( 7 Page )

GM1
GM1-CPUA

GM1-CPUB
G3L-EUTB

Ethernet (UDP)
3.1 setting ex 1

( 4 Page )

Ethernet (TCP)
3.2 setting ex 2

( 7 Page )

GM2
GM2-CPUA

GM2-CPUB
G3L-EUTB

Ethernet (UDP)
3.1 setting ex 1

( 4 Page )

Ethernet (TCP)
3.2 setting ex 2

( 7 Page )

GM3 GM3-CPUA G3L-EUTB
Ethernet (UDP)

3.1 setting ex 1

( 4 Page )

Ethernet (TCP)
3.2 setting ex 2

( 7 Page )

GM4

GM4-CPUA

GM4-CPUB

GM4-CPUC

G4L-EUTB
Ethernet (UDP)

3.1 setting ex 1

( 4 Page )

Ethernet (TCP)
3.2 setting ex 2

( 7 Page )

GM6

GM6-CPUA

GM6-CPUB

GM6-CPUC

G6L-EUTB
Ethernet (UDP)

3.1 setting ex 1

( 4 Page )

Ethernet (TCP)
3.2 setting ex 2

( 7 Page )

1. System configuration
System configuration of TOP and “LS Industrial System Co., Ltd – GLOFA-GM Series FENET”.

*1) Twist pair cable

- It means STP(shield  twist pair cable) or UTP(shieldless twist pair cable) category 3, 4, 5.

- It can connect to hub, transceiver etc. according to network composition and use direct cable in this case.

■ Connection configuration

ㆍ1 : 1 connection (TOP 1 unit to External device 1 unit)

ㆍ1 : N connection (TOP 1 unit to External device several units)
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Setting Items Description

TOP Series

Series OS Version

XTOP / HTOP V4.0

Select a TOP series which is communicated with external device.

Install an OS file v3.1 as diagram below before download a project file you have made.

Name Select a TOP model which is communicated with external device.

External Device Vendor Select vendor of the external device which is communicated with TOP.

Select ““LS INDUSTRIAL SYSTEMS CO., LTD””.

PLC Select a model name of the external device which is communicated with TOP.

Select “GLOFA-GM Series FENET”.

Check whether the external device you want to use is connectable or not

in “1. System configuration”.

2. Selection of TOP, External device
Select a external device which is communicated to the TOP.
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Item TOP GLOFA-GM Series Note

IP Address*1)2) 192.168.0.50 192.168.0.51 User set

     Protocol UDP Private server*3) User set

     Port 1024 2005 User set

Protocol TCP/IP UDP/IP MODBUS TCP

Port number 2004 2005 502

■ [ Project > Project property > project > TOP Setting > TOP’s Name ]

Set communication interface of TOP.

- From right window [ HMI Setup > check Use HMI Setup > Device Manager ] 

- From right window [ HMI Setup > check Use HMI Setup > PLC Setting ]

■ External Device Settings

Set up the “XGT(XGI/XGR), XGB(XEC) Series FENET” communication option

- IP Address (PLC): Type the IP address that the external device was given.

- Reading port / writing port: Choose the port number that will be used for ethernet 

communication. Please input the port number that [GPPW] issued.

- Block processing method : Select the protocol method

3. System setting
Set Communication interface of TOP and external device as below. 

3.1 Example 1

Set your system as below.

*1) Network address TOP and external device must be same. (IP's three place : 192.168.000 )

*2) Don't use same address in same network.

*3) Private driver port of FEnet I/F module admits communication to specified port number/protocol to appropriate IP.

(1) XDesignerPlus setting

Set [Project >Project property] of XDesignerPlus as below and download it to TOP machine.



XDesignerPlus Ver2.0 Communication Manual 5 / 13

■ GMR ■ GM 1/2/3

(2) External device setup

Run "FEnet Frame Editor" of GLOFA-GM series communication system setting tool for communication setting. 

If you want to change communication interface, modify refer to PLC manual.

1.  Connect to CPU unit RS-232 port of external device and PC 

    with [GLOFA GM loader cable]. 

2.  Run “FEnet Frame Editor”.

Select [FENET] at Dialog Box of [TYPE setting of Frame editor].

3.  Select [Edit] > [Default setting] and set FEnet information and click [OK].

PC ( 9pin) GM(9pin)

signal pin pin signal

RD 2 2 RD

SD 3 3 SD

SG 5 5 SG

[GLOFA GM loader cable]
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■ GM 4/6

4. Run [Online] > [Connect] and connect external device and PC.

5.  Run [Online] > [Write] and select slot number with ethernet communication card and "default parameter" and click [write] 

button.

 

6.  After transmission complete, reset power of PLC.
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Item TOP GLOFA GM Series Note

IP Address*1)2) 192.168.0.50 192.168.0.51 User set

     Protocol TCP Private server *주3) User set

     Port 1024 2004 User set

Protocol TCP/IP UDP/IP MODBUS TCP

Port number 2004 2005 502

■ [ Project > Project property > project > TOP Setting > TOP’s Name ]

Set communication interface of TOP.

- From right window [ HMI Setup > check Use HMI Setup > Device Manager ] 

- From right window [ HMI Setup > check Use HMI Setup > PLC Setting ]

■ External Device Settings

Set up the “XGT(XGI/XGR), XGB(XEC) Series FENET” communication option

- IP Address (PLC): Type the IP address that the external device was given.

- Reading port / writing port: Choose the port number that will be used for ethernet 

communication. Please input the port number that [GPPW] issued.

- Block processing method : Select the protocol method 

3.2 Example 2

Set your system as below.

*1) Network address TOP and external device must be same. (IP's three place : 192.168.000 )

*2) Don't use same address in same network.

*3) Private driver port of FEnet I/F module admits communication to specified port number/protocol to appropriate IP.

(1) XDesignerPlus setting

Set [Project >Project property] of XDesignerPlus as below and download it to TOP machine.
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■ GMR ■ GM 1/2/3

■ GM 4/6

(2) External device setup

Run "FEnet Frame Editor" of GLOFA-GM series communication system setting tool for communication setting. 

If you want to change communication interface, modify refer to PLC manual.

1.  Connect to CPU unit RS-232 port of external device and PC 

    with [GLOFA GM loader cable]. 

2.  Run “FEnet Frame Editor”.

Select [FENET] at Dialog Box of [TYPE setting of Frame editor].

3.  Select [Edit] > [Default setting] and set FEnet information and click [OK].

4. Run [Online] > [Connect] and connect external device and PC.

PC ( 9pin) GM(9pin)

signal pin pin signal

RD 2 2 RD

SD 3 3 SD

SG 5 5 SG

[GLOFA GM loader cable]
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5.  Run [Online] > [Write] and select slot number with ethernet communication card and "default parameter" and click [write] 

button.

 

6.  After transmission complete, reset power of PLC.
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■ [ Project > Project property > project > TOP Setting > TOP’s Name ]

Set communication interface of TOP.

- From right window [ HMI Setup > check Use HMI Setup > Device Manager ] 

- From right window [ HMI Setup > check Use HMI Setup > PLC Setting ]

■ External Device Settings

Set up the “XGT(XGI/XGR), XGB(XEC) Series FENET” communication option

- IP Address (PLC): Type the IP address that the external device was given.

- Reading port / writing port: Choose the port number that will be used for ethernet 

communication. Please input the port number that [GPPW] issued.

- Block processing method : Select the protocol method 

■ Setting communication Interface

item Description

Serial Signal Level Setup signal level(RS-232C/422/485) of PLC connected with COM2/1 port. (COM1 only RS-232C)

Serial Baud Rate Setup [communications Baud rate] of PLC connected with COM2/1 port. 

Serial Data Bit Setup [Data Bit] of PLC connected with COM2/1 port.                                    

Serial Stop Bit Setup [Stop Bit] of PLC connected with COM2/1 port.

Serial Parity Bit Setup [Parity Bit] of PLC connected with COM2/1 port.

Time Out [ x100 mSec ] Setup [Time Out] of PLC connected with COM2/1 port.  (Timeout:: waiting time for answer of PLC)

Send Wait [ x10 mSec ] Setup [Send Wait] of PLC connected with COM2/1 port.

(Send Wait: communicate after waiting setting time when touch screen requires communications.)

Station Num. in Diag.[0~31] Setup [Station Num.(0~31)] using "4.3 Communication Diagnosis”

4. Communication setting
Communication setup can be set on XDesignerPlus or TOP Main Menu. The setting should be the same with the external device. 

(1) XDesignerPlus setup – register information of external device
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PLC setup

PLC IP : 192 . 168 . 0 . 51 Communication Interface

Protocol : UDP Settings

PLC Read Port : 2005

PLC Write Port : 2005

TOP Port : 1024

PLC Address : 00

Timeout : 1000 [mSec]

Delay time of transmission : 0 [mSec]

TOP IP : 192 . 168 . 0 . 50

 TOP Ethernet setting communication diagnosis

Details Contents

PLC IP It is an IP address that external device was given.

Protocol Select the protocol method either UDP or TCP.

PLC Read Port It is the port address that will be used for ethernet of external device.

PLC Write Port It is the port address that will be used for ethernet of external device.

TOP port Setting the TOP port number to connect with external device.

PLC address [0~65535] Address of other device. Select between [0 - 65535].

Timeout [ x1 mSec ] Set up TOP’s waiting time from external device at [0 - 5000] x 1mSec.

Delay Time before

transmitting [ x1 mSec]

Set up TOP’s waiting time between response receiving – next command request transmission 

from external device at [ 0 – 5000 ] x 1 mSec.

TOP IP Setup the IP address that TOP receives in the network.

Port Settings

* Ethernet Communication Ethernet Port

 + Network setting Communication Interface

  - MAC : 00 - 15 - ID - 00 - 30 - 52  (each device has different address) Settings

  - IP Address : 192. 168 . 0 . 50

  - Subnet mask : 255 255 . 255 . 0

  - Gateway : 192 168 . 0 . 1

Details Contents

MAC Physical official address in the network.

IP Address Setup the IP address that TOP receives in the network.

Subnet mask An address that divides the network ID and host ID regarding of IP address.

Gateway An address that connects a network to another network.

4.2 TOP main menu setup item

 - When a buzzer is on during the power reset, touch 1 spot at the upper LCD to move to "TOP Management Main" display.

- Set up driver interface at TOP according to below Step1 → Step2.

(Press “TOP ethernet setup” in Step 1 to change setup at Step 2.)

Step 1. [ PLC setup ] .Setup driver interface.

Step 1–Reference.

Step 2. [PLC Setup] > [TOP Ethernet Setup] - Setup the serial parameter of correspond port.

Step 1–Reference.
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OK! Communication setting succeeded

Time Out Error! Communication setting error

- Error in the setting situation of Cable and TOP / External device

(reference : Communication Diagnosis sheet)

Details Contents Confirm

TOP Version Information xDesignerPlus : O.S : 

Name of Driver OK NG

External device

information

IP Address
OK NG

(xDesignerPlus Subnet mask OK NG

Project setting) Gateway OK NG

TOP Information Protocol UDP/IP TCP/IP OK NG

(Main Device 

Menu Setting)

IP Address
OK NG

Subnet mask OK NG

Gateway OK NG

Other specified setting info OK NG

System 

configuration

System Connection Method
1:1 1:N N:1 OK NG

Name of cable (Hub usage) Direct (Use Hub) Cross (No Hub) OK NG

External 

device

Name of CPU
OK NG

Name of communication device OK NG

Protocol(mode) OK NG

Other specified setting info OK NG

IP Address (Local) (Destination) OK NG

Port number (Local) (Destination) OK NG

Subnet mask OK NG

Gateway OK NG

Address range confirm (other docs) OK NG

4.3 Communication diagnosis

■ TOP - Confirming interface setting condition between external devices 

- Move to Menu by clicking the top side of LCD screen as resetting the power of TOP.

- [Main Menu >Communication setting] Confirm if detail in number 20~24 is identical to the setup information of “■Setup exercise 

1”.

- PLC Setup > Click the button in "Communication diagnosis" of TOP Ethernet.

- Diagnosis dialog box will pop up on the screen, you can judge by following informations that are shown on box no. 3 section.

■ Communication Diagnosis Sheet 

- Please refer to the information below if you have a problem between external devices and communication connection.
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model WORD Address range

GM1 %I(input) %IW00.0.0 ~ %IW63.7.3

%Q(output) %QW00.0.0 ~ %QW63.7.3

%M(inner memory) %MW00000 ~ %MW65535

GM2 %I(input) %IW00.0.0 ~ %IW31.7.3

%Q(output) %QW00.0.0 ~ %QW31.7.3

%M(inner memory) %MW00000 ~ %MW65535

GM3, GM4 %I(input) %IW00.0.0 ~ %IW07.7.3

%Q(output) %QW00.0.0 ~ %QW07.7.3

%M(inner memory) %MW00000 ~ %MW32767

GM6, GM7 %I(input) %IW00.0.0 ~ %IW07.7.3

%Q(output) %QW00.0.0 ~ %QW07.7.3

%M(inner memory) %MW00000 ~ %MW16383

5. Available address
The available address of device are as below.

Device(address) range might be different according to series/type of CPU. TOP Series are capable of supporting maximum address 

range which is available in external Device.

Be careful get out of address range.

* Setting method of Input and Output(IW / QW) address

0000        card number

        slot number(slot number next CPU is 0)

Base number(start number is 0)

※ card number explanation - Card number of 16 point card is 0. If it is 32 point card, card number of 0~15 bit is 0, card number of 

16~31 bit is 1. If it is 64 point card, card number of 0~15 bit is 0, card number of 16~31 bit is 1, card number of 32~47 bit is 2, 

card number of 48~63 bit is 3.


