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1. System configuration

The system configuration of TOP and “Seorim Automation Technology : PMC3000 Series Computer Link” is as follows:

‘ Link I/F ‘ Communication method System setting

Seorim 3. TOP communication

: "
Automation | o\ 13000 | cns RS-422 ( 4 wire ) nd 5.1. Cable table 1

Technology 4.1. External device
setting 1

W Connection configuration

+ 1:1 connection (one MASTER and one TOP) connection

+ 1:N (one TOP and multiple external devices) connection — configuration which is possible in RS422/485 communication.
AP

[J ' «j' ;‘3«] .........

External device connection manual for TOP Design Studio 2/ 1



TOP ooz e
Touch Qperation Panel

2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device H
PLC select [COM2]

Filter : |[A\I] v| Search : l:l

@ Model (O Vendor

Vendor Model
~ A
FANUC Co., Ltd. & SPEEDITECH : PUL-2000 Series
MINEBEA Co., Ltd.
° & TISANG : Rectifier
Azbil Corporation
ASN : TBH Sensor
KORO TECHNOLOGY
& SNC : Flow Meter
ROBOSTAR 5
" SEORIM : PMC3000
Ebmpapst
& MEMORY MAP SLAVE
CaDeSys Automation Alliance
i .
Ophir Optronics Solutions Ltd. & WILLINGS : Master-
SERVOMEX & SAMAHM TECH : Digital Air Speed Meter
Tiger Optics, LLC & Si TEC : MUX
B &R Automation & DONGDO TECH : ML Series
Peripheral Device & Human Automation : TSD
5
B & On OFf System : NEOS-HSD
v v

M8 Back | W Next *® Cancel

Select Device n

PLC Setting[ SEORIM : PMC3000 ]

Alizs Mame : |PLC1

Interface : | Computer Link ~

Protocol : | MC Protocol 1C ACPU ~ Comm Manual
String Save Mode @ |First LH HL Change

[J use Redundancy

AND ~
Condition - Edi
Primary Option
Timeout msec
Send Wait msec
Station Mum
4@ Back + OK * Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select "OTHERS".
PLC Select an external device to connect to TOP.

Interface Protocol

PMC3000 Computer Link MC Protocol 1C ACPU

Supported Protocol
MC Protocol 1C Format 1

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting

M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Serial]

— Set the TOP communication interface in TOP Design Studio.

Project Opticn

[ croroe i Add PLC[A) | TN Change PICKD) | [ Delete PLCID)
I; Ll gmp Sem”ﬂmmnm. Date / Time Sync. | Screen Option | Unit Convert
‘.'“-2”2”|z1;d”|(enjsem”9 Project Option = Screen Change HmiSetup | Global Lock & Touch | Project Style  Splash | PLC Buffer Sync.
= o BFID (0_) Use HMI Setup
h \;_':_'E::VEZ;T‘ES)Q i Seio Aotios Initialization I Edit |
v fg® com2 (1) Project Setting |
.. PLC1 ; SEORIM : PMC300| HMIDisable=0
- Fg¥ COM3 (0) Project Ndama’;Naw project
Ethernet (1) Start Mode =Menu
: UsBDevice (0) f:xr;icsr:inn Me.=1
Latch Set=0n0
Communication Error Message=0
USBErrorMessage=0
StorageErrorMessage=1
DatabaseMessage=1
Control Panel
System m Devices = Serjal
— {4 - Serial Port: | COMZ -
Il l 7 " Signal Level
PLLC Security Dat e/ Time O Rs-232C @ Rs-422(4) O RS-485(2)
Baud Rate: 19200 =
. Data Bit: |8 S
0 - 0 —
L it:
Stop Bit: 1 M
Et hernet Serial HOK | . .
Parity Bit: HNone 2
Flow: [ff
i — Auto Search  Loopback Test
. Ping
Diagnost ic File Ping
Marager Apply Cancel
Items TOP External device Remarks
Signal Level (port) RS-422 RS-422
Baud Rate 19200
Data Bit 8
Stop Bit 1
Parity Bit None.

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [Project > Project Property > Device Setting > COM > “PLC1 : SEORIM PMC3000"]

— Set the options of the Seorim Automation Technology : PMC3000 Series Computer Link communication driver in TOP
Design Studio.

Project Option

- Change HMI[H] ' AddPLC[A] | THITal Change PLCIC | [ Delete PLCID]

v D TOP Setting
- 5Y5 : TOPRX1500%

PLC Setting[ SEORIM : PMC3000 ]

Option Module Setting Alias Name : |PLC1
& FieldBus (0) Interface : | Computer Link ~
. RFID (0)

v gy Device Setting Protocol @ |MC Protocol 1C ACPU ~

- Tg¥ COML(0) String Save Mode : [First LH HL Change
PLC1 : SEORIM : PMC300
= [ use Redundancy

= Ethernet (0} AND =
.. USBDevice (0)

Comm Manual

L —]

Conditior Edi
Primary Option
Timeout 200 &1 | msec
Send Wait msec
Retry g -

£ >
Apply Clase
Items Settings Remarks
Interface Select “Computer Link". Refer to “2. External
Protocol Select "PC Link". device selection”.
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.
SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device
and sending the next command request.
Station Num Enter the prefix of an external device.
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* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

Conikroll Panel

oE Serial
Bun . —
Serial Port: lCDME ‘v]
!l'l G Signal Level
' () B5-232C @ RS-422(4) O RS-485(2) ]
Security : .
Baud Rate: | 18200  ~|
YHC
i . Data Bit: g -
Yiewer [|J-|'l|] = = l ‘ ]
. ] | -~ Stop Bit: | 1 -
] Ethernet Serial
" E Parity Bit: | None -
Amma —
Sc;een m _[:' Flow: l 0f f “']
shot
g [Auto Search] [Loopback Test]
Diagnost ic File
Manager
{| l Apply H Cancel ]
[System] Close r
|
Items TOP External device Remarks
Signal Level (port) RS-422 RS-422
Baud Rate 19200
Data Bit 8
Stop Bit 1
Parity Bit None.

* The above settings are setting

examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.

External device connection manual for TOP Design Studio

6/ 11



TO,

(2) Communication option setting
M [Main Screen > Control Panel > PLC]

§ @

YHC
Yiewer

Screen
shot

ERI2 e B X
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o I} PLG
@ Syste Driver(COMZ)  PLCI(SEORIM : PMC3000) v]
Interface | Computer Link [~]
] Protocol | MC Protocol 1C ACPL|~
FLC Timeout 300 |5 msec
send Wait msec
) R
i =]
Et hernet Station b _ﬂ
Diagnost ic
[System] l Diagnostic l o |y H Cancel ]

G

Items Settings Remarks
Interface Select “Computer Link". Refer to "2. External
Protocol Select "pc link". device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP’s receiving a response from an external device

and sending the next command request.

Station Num

Enter the prefix of an external device.
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3.3 Communication diagnostics

B Check the interface setting status between the TOP and an external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information oK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG . .
diagnostics 3. Communication setting
Serial Parameter Transmission
oK NG
Speed
Data Bit oK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name oK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings OK NG . .
4. External device setting
Serial Parameter Transmission
oK NG
Speed
Data Bit oK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
oK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

For more detailed setting method than that described, refer to the PLC user manual.
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5. Cable table

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.
(The cable diagram described in this section may differ from the recommendations of “Seorim Automation Technology : PMC3000

Series Computer Link")

5.1. Cable table (PMC3000)

W RS-422 (1:1 connection)

TOP External device
Pin Signal Pin Cable connection ) :
Signal name Pin arrangement
arrangement*Note 1) name number
RDA 1 TX+(6)
1 5 2 TX-(7)
Q o]
o 3 RX+(4)
@}
6 9 RDB 4 RX-(5) SDA |®
Q=
Based on SG > SG SDB |®
communication 6 Terminating ®| FG
SDA ) RDA |®
cable connector resistance (2) ®| NC
front, 7 Terminating RDB |®
D-SUB 9 Pin male resistance (1)
(male, convex) 8
SDB 9
*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
B RS-422 (1:N connection) - Refer to 1:1 connection to connect in the following way.
TOP ) ) o External device Cable connection and signal External device
————— Cable connection and signal direction - o -
Signal name Signal name direction Signal name
RDA SDA SDA
RDB SDB SDB
SDA RDA RDA
SDB RDB RDB
SG SG SG
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6. Supported addresses

The devices available in TOP are as follows:
The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address
range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Type Remarks Bit-designated address Word-designated address
Input Bit X0000 — X1FFF X0000 — X1FFO
Output Bit Y0000 — YTFFF Y0000 - YTFFO
Special relay Bit FO000 — F2047 FO000 - F2032
LATCH relay Bit L0000 — L8191 L0000 - L8176
Internal relay Bit M0000 — M8191 MO0000 — M8176
Special relay Bit M9000 - M9255 M9000 — M9240
Timer-Current value Word TNO000.00 — TN2047.15 TNOOO — TN2047
Counter-Current value Word CNO000.00 — CN2047.15 CNOO0O — CN2047
LINK relay Bit BOOOO — B1FFF BOOOO — B1FFF
LINK register Word WO0000.0 - W1FFF.F WO0000 — W1FFF
Data register Word D0000.0 — D8191.15 DO000 - D8191
Special register Word D9000.0 - D9255.15 D9000 - D9255
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