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A&D CO., LTD 

A&D Weighing Indicator AD Series 

(Command Mode)  

Computer Link Driver 
 Supported version TOP Design Studio V1.3.3.2 or higher  

 

CONTENTS 

We would like to thank our customers for using M2I's "Touch Operation 

Panel (M2I TOP) Series". Read this manual and familiarize yourself with 

the connection method and procedures of the “TOP and external device”. 

 

1. System configuration Page 2 

 

 

 

Describes the devices required for connection, the setting of each 

device, cables, and configurable systems. 

2. External device selection  Page 3 

 Select a TOP model and an external device. 

3. TOP communication setting Page 4 

 Describes how to set the TOP communication. 

4. External device setting Page 9 

 Describes how to set up communication for external devices. 

5. Cable table Page 10 

 Describes the cable specifications required for connection. 

6. Supported addresses Page 11 

 Check for addresses that can communicate with an external device. 
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1. System configuration 

The system configuration of TOP and “A&D Co., Ltd – A&D Weighing Indicator AD Series (Command Mode) Computer Link” is as 

follows. 

 

Series CPU Link I/F 
Communication 

method 
System setting Cable 

AD 
AD-4401 

CB/EK-i 
RS-232C I/O Port RS–232C 

3. TOP communication 

setting 

4. External device 

setting 

5. Cable table 

 

 

 

■ Connection configuration 
 

ㆍ1:1 (one TOP and one external device) connection – This configuration is available in RS232c communication. 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 

 

Settings Contents 

TOP Model Check the display and process of TOP to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Select “Indicator Series”. 

PLC Select an external device to connect to TOP. 
 

Model Interface Protocol 

A&D AD Series (Command Mode) Computer Link AND Format 
 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [ Project > Project properties > TOP settings] → [Project option > Check “Use HMI settings” > Edit > Serial ] 

– Set the TOP communication interface in TOP Design Studio. 
 

 

 

 

 

Items TOP External device Remarks 

Signal Level (port) RS-232C RS-232C  

Baud Rate 9600  

Data Bit 7  

Stop Bit 1  

Parity Bit Even  

* The above settings are examples recommended by the company. 

 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device. 

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [ Project > Project properties > PLC settings > COM > “PLC1: A&D AD Series (Command Mode)” ] 

– A&D Co,.Ltd – A&D Weighing Indicator AD Series (Command Mode) Computer Link  

Set the options of the communication driver in TOP Design Studio. 

 

 

Items Settings Remarks 

Interface Select “Computer Link”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

   

(1) Communication interface setting 

■ [ Main screen > Control panel > Serial ] 
 

 

Items TOP External device Remarks 

Signal Level (port) RS-232C RS-232C  

Baud Rate 9600  

Data Bit 7  

Stop Bit 1  

Parity Bit Even  

* The above settings are setting examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device. 

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [ Main screen > Control panel > PLC ] 

 
 

 

Items Settings Remarks 

Interface Select “Computer Link”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC ]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  

OK NG 

6. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 

For more detailed setting methods than described in this example, please refer to the user manual of A&D Co., Ltd. 

 

Step 1. While holding down the ‘ENTER’ key, press the ‘SETPOINT’ key, and then press the ‘ENTER’ key again. 

 

Step 2. Press the ‘△’ or ‘▽’ button to change to “ rS “, and press the ‘ENTER’ key. 

 

Step 3. RSF(OP-04 RS-232C) Set the detailed item settings as follows. 
 

Items Functions Settings Settings Remarks 

RSF-01 Output data 1 Command RW contents: Display weight Only 1 to 4 are available 

RSF-02 Data transfer mode 4 Communication method: command mode Fixed 

RSF-03 Transmission Speed 5 Communication speed: 9600 bps  

RSF-04 Parity Bit 2 Parity bit: even  

RSF-05 Character bit 7 Character bit: 7  

RSF-06 Stop Bit 1 Stop Bit: 1  

RSF-07 End code 2 End code: CR + LF Fixed 

RSF-08 Change RS-422/485 1 Invalid when using RS-232C  

RSF-09 Prefix 0 Exchange number: 0 Fixed 

 

Step 4.Press the ‘POWER’ key (ESC key) to return to the weight display status. 
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5. Cable table 

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. (The cable diagram 

described in this chapter may differ from the recommendations of “A&D Co., Ltd.”) 

 

■ RS-232C (1:1 connection) 

COM 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

CD 1  1  

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RD 2 2 SD 

SD 3 3 RD 

DTR 4 4  

SG 5 5  

DSR 6 6  

RTS 7 7 SG 

CTS 8 8  

 9 9  

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 
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6. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

 

⚫ AD-4401 

 

Device Bit Address Word Address Read/Write Remarks 

RW.WEIGHT – RW.WEIGHT Read *Note 1) 

RW.STS RW.STS0 ~ RW.STS2 RW.STS Read *Note 2) 

RW.GSNT RW.GSNT0 ~ RW.GSNT2 RW.GSNT Read *Note 3) 

RW.UNIT – RW.UNIT Read *Note 4) 

RB.WEIGHT – RB.WEIGHT Read  

RF.WEIGHT – RF.WEIGHT Read *Note 1) 

RF.STS RF.STS0 ~ RF.STS2 RF.STS Read *Note 2) 

RF.GSNT RF.GSNT0 ~ RF.GSNT2 RF.GSNT Read *Note 3) 

RF.UNIT – RF.UNIT Read *Note 4) 

RT.WEIGHT – RT.WEIGHT Read *Note 1) 

RT.UNIT – RT.UNIT Read *Note 4) 

RT.COUNT – RT.COUNT Read *Note 5) 

DT DT DT Write *Note 6) 

MG MG MG Write *Note 7) 

MN MN MN Write *Note 8) 

MZ MZ MZ Write *Note 9) 

MT MT MT Write *Note 10) 

CT CT CT Write *Note 11) 

BB BB BB Write *Note 12) 

BD BD BD Write *Note 13) 

HB HB HB Write *Note 14) 

SS SS SS Write *Note 15) 

SS.DATA – SS.DATA1 ~ SS.DATA7 Read/Write *Note 16) 

RS.DATA – RS.DATA1 ~ RS.DATA7 Read *Note 17) 
 

*Note1) Float-type data. It is a device that must be registered to read data such as STS, GSNT and UNIT of the same command. 
 

*Note 2) 

Response data when the next bit is ON 

STS0 Stable 

STS1 Unstable 

STS2 Overload 
 

*Note 3) 

Response data when the next bit is ON 

GSNT0 Gross 

GSNT1 Net 

GSNT2 Tare 
 

*Note 4) It indicates the unit being displayed by the indicator. Use only as a string (length: 2). 

*Note 5) Data representing the total number of times. 
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※ For details on the commands below, refer to the user manual of A&D Co., Ltd. 

 

*Note 6) DT (Delete Total): Total number of times clear. 

*Note 7) MG (Make Gross): Mark as gross weight. 

*Note 8) MN (Make Net): Mark as net weight. 

*Note 9) MZ (Make Zero): Zero. 

*Note 10) MT (Make Tare): Remove the container. 

*Note 11) CT (Clear Tare): Clear container. 

*Note 12) BB (Begin Batch): Start input. 

*Note 13) BD (Begin Discharged): Start discharging. 

*Note 14) HB (Halt Batch): Emergency stop. 

*Note 15) SS (Set Setpoints): Set SETPOINT. 

*Note 16) Data to set SETPOINT using SS command. 

*Note 17) Request Setpoint: SETPOINT data currently in use. 

 

※  Write-only Device   Use Method 

① Pop-up window for object’s property → ② Effect and action→ ③Setting Conditions → ④Action setting 

Set to input data to the device when a condition occurs in the action settings. 
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⚫ CB/EK – I Series 

 

Device Bit Address Word Address Read/Write Remarks 

Q.WEIGHT – Q.WEIGHT Read *Note 1) 

Z Z00~Z15 – Write *Note 3) 

U U00~U15 – Write *Note 3) 

Q.STS Q.STS0 ~ Q.STS3 Q.STS Read *Note 2) 

Q.UNIT – Q.UNIT Read *Note 4) 

 

*Note 1) Float-type data. It is a device that must be registered to read data such as STS, GSNT and UNIT of the same command. 

*Note 2) 

Response data when the next bit is ON 

Q.STS0 Stable 

Q.STS1   Stable in a counting mode  

Q.STS2 Unstable 

Q.STS3 Overload 

*Note 4) It indicates the unit being displayed by the indicator. Use only as a string (length: 2). 

*Note 3) Z :  Set Zero 

        U :  Unit change 

 


