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YOKOGAWA Electric Corporation  

FA-M3 Series  

Ethernet Driver 
 Supported version TOP Design Studio V1.0 or higher  

 

CONTENTS 

We would like to thank our customers for using M2I's "Touch 

Operation Panel (M2I TOP) Series". Read this manual and familiarize 

yourself with the connection method and procedures of the “TOP and 

external device”. 

 

1. System configuration Page 2 

 

 

Describes the devices required for connection, the setting of 

each device, cables, and configurable systems. 

2. External device selection  Page 3 

 Select a TOP model and an external device. 

3. TOP communication setting Page 4 

 Describes how to set the TOP communication. 

4. External device setting Page 9 

 Describes how to set up communication for external devices. 

5. Supported addresses Page 11 

 Refer to this section to check the addresses which can 

communicate with an external device. 
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1. System configuration 

The system configuration of TOP and “YOKOGAWA Electric Corporation – FA-M3 Series Ethernet” is as follows: 

 

Series CPU Link I/F 
Communication 

method 
System setting Cable 

FA-M3 

F3SP21-0N 

F3SP25-2N 

F3SP28-3N 

F3SP35-5N 

F3SP38-6N 

F3SP53-4H 

F3SP58-6H 

F3SP28-3S 

F3SP38-6S 

F3SP53-4S 

F3SP58-6S 

F3SP59-7S 

F3LE01-5T 

Ethernet 

(UDP) 

3. TOP communication 

setting 

4.1. External device setting 1 
Twisted pair 

cable*Note 1) 

Ethernet 

(TCP) 

F3LE11-0T 

Ethernet 

(UDP) 

Ethernet 

(TCP) 

F3SP66-4S 

F3SP67-6S 
CPU Direct 

Ethernet 

(UDP) 
3. TOP communication 

setting 

4.2. External device setting 2 
Ethernet 

(TCP) 

*Note 1) Twisted pair cable 

- Refers to STP (Shielded Twisted Pair Cable) or UTP (Unshielded Twisted Pair Cable) Category 3, 4, 5. 

- Depending on the network configuration, you can connect to components such as the hub and transceiver, and in this case, use a 

direct cable. 

 

■ Connectable configuration 

 

ㆍ1:1 connection (one TOP and one external device) connection 

 

 

 

ㆍ1:N connection (one TOP and multiple external devices) connection 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 
 

 
 

Settings Contents 

TOP Model Check the TOP display and process to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Select “YOKOGAWA Electric Corporation”. 

PLC Select the external device to be connected to the TOP. 
 

Model Interface Protocol 

FA-M3 Series Ethernet PC Link 
 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 

Supported Protocol 

PC Link (ASCII) PC Link (Binary) 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [Project > Project Property > TOP Setting] → [Project Option > “Use HMI Setup” Check > Edit > Ethernet] 

– Set the TOP communication interface in TOP Design Studio. 

 

 

 

 
 

Items TOP External device Remarks 

IP Address*Note 1) Note 2) 192.168.0.50 192.168.0.51  

Subnet Mask 255.255.255.0 255.255.255.0  

Gateway 192.168.0.1 192.168.0.1  

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 168 . 0 . 0) should match. 

*Note 2) Do not use duplicate IP addresses over the same network. 

* The above settings are examples recommended by the company. 

 

 

Items Description 

IP Address Set an IP address to be used by the TOP over the network. 

Subnet Mask Enter the subnet mask of the network. 

Gateway Enter the gateway of the network. 
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(2) Communication option setting 

■ [ Project > Project Property > PLC Setting > ETHERNET(1) > “PLC1 : FA-M3 Series”] 

– Set the options of the FA-M3 Series Ethernet communication driver in TOP Design Studio. 

 
* The above settings are examples recommended by the company. 

 

Items Settings Remarks 

Interface Select “Ethernet”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

IP Enter the IP address of the external device.  

Ethernet Protocol Select the Ethernet protocol between the TOP and an external device.  

Port Enter the Ethernet communication port number of an external device.  

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external 

device and sending the next command request. 
 

Cpu No Enter the CPU no. of the external device.  
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3.2. Communication setting in TOP  

* This is a setting method when "Use HMI Setup" in the setting items in "3.1 TOP Design Studio" is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen.  

   

(1) Communication interface setting 

■ [Main Screen > Control Panel > Ethernet] 
 

 

 

Items TOP External device Remarks 

IP Address*Note 1) Note 2) 192.168.0.50 192.168.0.51  

Subnet Mask 255.255.255.0 255.255.255.0  

Gateway 192.168.0.1 192.168.0.1  

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 168 . 0 . 0) should match. 

*Note 2) Do not use duplicate IP addresses over the same network. 

* The above settings are examples recommended by the company. 

 

 

Items Description 

IP Address Set an IP address to be used by the TOP to use over the network. 

Subnet Mask Enter the subnet mask of the network. 

Gateway Enter the gateway of the network. 
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 (2) Communication option setting 

■ [Main Screen > Control Panel > PLC] 
 

 
* The above settings are examples recommended by the company. 

 

Items Settings Remarks 

Interface Select “Ethernet”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

IP Enter the IP address of the external device.  

Ethernet Protocol Select the Ethernet protocol between the TOP and an external device.  

Port Enter the Ethernet communication port number of an external device.  

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external 

device and sending the next command request. 
 

Cpu No Enter the CPU no. of the external device.  
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check if the port (ETH1/ETH2) settings you want to use in [Control Panel > Ethernet] are the same as those of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Ethernet port setting IP Address OK NG 

Subnet Mask OK NG 

Gateway OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Ethernet port setting IP Address OK NG 

Subnet Mask OK NG 

Gateway OK NG 

Check address range  

OK NG 

5. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 

4.1. External device setting 1 (Ethernet Interface Module) 

Set up the Dip Switch located inside the side cover of the communication card to set up the communication.  

For more detailed setting method than that described in this example, refer to the PLC user manual. 
 

 

Do not use duplicate IP addresses over the same network. 

For detailed instructions on how to set up the "Dip Switch", check the attached documentation inside 

the side cover. 
 

 

 

Step 1. Operation Condition Setup Switch Settings 

Switch Number Contents OFF ON 
Recommended 

settings 
Remarks 

SW1 Data format ASCII Binary ON *Note 1)  

SW2 Write protection Disabled Enabled OFF Fixed 

SW3 

Always off    OFF  
SW4 

SW5 

SW6 

SW7 Line processing on TCP timeout Close Do not close OFF  

SW8 Loopback test Normal mode Test mode OFF  

*Note 1) Set the same as the TOP communication options. Switch off SW1 when communicating with ASCII. 

 

Step 2. IP Address Setup Switch Settings 

Set the IP address of the external device by changing the Rotary Switch to hexadecimal units. Please refer to the information below. 

 

Step 3. Restart the power after configuring.  
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4.2. External device setting 2 (CPU Direct) 

Set as below using “FA–M3 Series” Ladder Software “WideField3”.  

For more detailed setting method than that described in this example, refer to the PLC user manual. 
 

Step 1. Set as below from [Project] – [Project Settings] – [CPU Properties] – [LOAD] and [SETUP]. 

 
 

ㆍ[LOAD] 

Items Settings Settings Remarks 

NETWORK 1 NETWORK setup load flag On Fixed 

ETHERNET 1 ETHERNET setup load flag On Fixed 

HIGHER-LEVEL_LINK_SERVICE 1 HIGHER-LEVEL_LINK_SERVICE setup flag On Fixed 

Set up items 0   
 

ㆍ[SETUP - NETWORK] 

Items Settings Remarks 

NETWORK_SELECT 1 Fixed 
 

ㆍ[SETUP - ETHERNET] 

Items Settings Remarks 

ETHER_MY_IPADDRESS 192.168.0.51  

ETHER_SUBNET_MASK 255.255.255.0  
 

ㆍ[SETUP – HIGHER-LEVEL-LINK-SERVICE] 

Items Settings Settings Remarks 

HLLINK_PROTOCOL_A 0 TCP/IP 1 = UDP/IP 

HLLINK_DATA_FORMAT_A 1 Binary 0 = ASCII 

 

Step 2. Send setting information via CPU. 
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5. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use.  
 

 

"TOP Design Studio" represents the CPU's "Device" in accordance with the "FA–M3 Series" Multi–CPU 

configuration (on Single Unit) as "CPU Number" + "Device Name" (one unit device).  

 (Example) for Data Register 

Multi–CPU TOP Design Studio Device Name Shown 

CPU 1 Data Register 1D 

CPU 2 Data Register 2D 

CPU 3 Data Register 3D 

CPU 4 Data Register 4D 

(Note) Multi–CPU configurations can extend to up to four CPUs. 
 

 

Device Bit Address Word Address 32 Bit Remarks 

Input Relay 
1X00201 – 4X71664 1X00201 – 4X71649 

L/H 

*Note 1) 

Note 2) 

Output Relay 1Y00201 – 4Y71664 1Y00201 – 4Y71649 *Note 1) 

Internal Relay 1I00001 – 4I65535 1I00001 – 4I65535  

Joint Relay 
1E0001 – 4E4096 1E0001 – 4E4081  

Special Relay 
1M0001 – 4M9984 1M0001 – 4M9969  

Link Relay 
1L00001 – 4L78192 1L00001 – 4L78177 *Note 3) 

Timer Contact 1T0001 – 4T3072 ––––––  

 Current –––––– 1TP0001 – 4TP3072  

 Setup –––––– 1TS0001 – 4TS3072  

Counter Contact 1C0001 – 4C3072 ––––––  

 Current –––––– 1CP0001 – 4CP3072  

 Setup –––––– 1CS0001 – 4CS3072  

Data Register 
1D0001.00 – 4D65535.15 1D0001 – 4D65535  

File Register 
1B00001.00 – 4B262144.15 1B00001 – 4B262144  

Joint Register 
1R0001.00 – 4R4096.15 1R0001 – 4R4096  

Special Register 
1Z001.00 – 4Z1024.15 1Z001 – 4Z1024  

Link Register 
1W00001.00 – 4W78192.15 1W00001 – 4W78192 *Note 3) 

*Note 1)Instructions for showing Input/Output Relay are as follows.. 

(Example)      X 0[Module Unit No.] 02[Module Slot No.] 01[Terminal No.] 

Items Setting range 

Module Unit No. 0 – 7 

Module Slot No. Module unit No is “0” 02 – 16 

 Module unit No is “1–7” 01 – 16 

Terminal No. 01 – 64 

*Note 2)Read-only Device 

*Note 3) Instructions for showing link relay (L), link register (W) are as follows. 

(Example)      L 7[link Number] 1024[address] 

Items Setting range 

Link Number 0 – 7 

address 0001 – 71009 

 


