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Rockwell Automation, Inc. 

Control/Compact Logix Series 

Ethernet Driver 
 Supported version TOP Design Studio V1.0 or higher  

 

CONTENTS 

We would like to thank our customers for using M2I's "Touch 

Operation Panel (M2I TOP) Series". Read this manual and familiarize 

yourself with the connection method and procedures of the “TOP and 

external device”. 

 

1. System configuration Page 2 

 

 

Describes the devices required for connection, the setting of 

each device, cables, and configurable systems. 

2. External device selection  Page 3 

 Select a TOP model and an external device. 

3. TOP communication setting Page 4 

 Describes how to set the TOP communication. 

4. External device setting Page 9 

 Describes how to set up communication for external devices. 

5. Supported addresses Page 10 

 Refer to this section to check the addresses which can 

communicate with an external device. 
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1. System configuration 

The system configuration of TOP and “Rockwell Automation, Inc. – Control/Compact Logix Series Ethernet” is as follows. 

 

Series CPU Link I/F 
Communication 

method 
System setting Cable 

ControlLogix All CPUs 

1756-ENET/B  

1756-ENET  

1756-ENBT 

Ethernet (TCP) 

3. TOP communication 

setting 

4.1. External device setting 1 

Twisted pair 

cable*Note 1) 

1761-NET-ENI Ethernet (TCP) 

3. TOP communication 

setting 

4.2. External device setting 2 

CompactLogix 

All CPUs 1761-NET-ENI Ethernet (TCP) 

3. TOP communication 

setting 

4.2. External device setting 2 

1769-L32E  

1769-L35E 
CPU Direct Ethernet (TCP) 

3. TOP communication 

setting 

4.3 External device setting 3 

*Note 1) Twisted pair cable 

- Refer to STP (Shielded Twisted Pair Cable) or UTP (Unshielded Twisted Pair Cable) Category 3, 4, 5. 

- Depending on the network configuration, you can connect to components such as the hub and transceiver, and in this case, use a 

direct cable. 

 

 

■ Connectable configuration 

 

ㆍ1:1 connection (one TOP and one external device) connection 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 

 
 

 
 

Settings Contents 

TOP Model Check the TOP display and process to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Select “Rockwell Automation (AB)”. 

PLC Select the external device to be connected to the TOP. 
 

Model Interface Protocol 

Control/Compact Logix Series Ethernet EtherNet/IP 
 

 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [ Project > Project properties > TOP settings] → [Project option > Check “Use HMI settings” > Edit > Ethernet] 

– Set the TOP communication interface in TOP Design Studio. 
 

 

 

 

 
 

Items TOP External device Remarks 

IP address*Note 1) 192.168.0.50 192.168.0.51  

Subnet Mask 255.255.255.0 255.255.255.0  

Gateway 192.168.0.1 192.168.0.1  

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 168 . 0 . 0) should match. 

* The above settings are examples recommended by the company. 

 

 

Items Description 

IP Address Set an IP address to be used by the TOP to use over the network. 

Subnet Mask Enter the subnet mask of the network. 

Gateway Enter the gateway of the network. 
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(2) Communication option setting 

■ [ Project > Project property > PLC settings > ETHERNET(1) > “PLC1 : Control/Compact Logix Series”] 

– Set the options of the communication driver of the Control/Compact Logix Series Ethernet in TOP Design Studio 
 

 
* The above settings are examples recommended by the company. 

 

Items Settings Remarks 

Interface Select “Ethernet”. Refer to “2. External 

device selection”. Protocol Select “EtherNet/IP”. 

IP Enter the IP address of the external device.  

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

Port Enter the Ethernet communication port number “44818” of the external device. Fixed 

CPU Slot No Enter the CPU slot number of the external device.  
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen.  

   

(1) Communication interface setting 

■ [ Main screen > Control panel > Ethernet ] 
 

 

 

Items TOP External device Remarks 

IP address*Note 1) 192.168.0.50 192.168.0.51  

Subnet Mask 255.255.255.0 255.255.255.0  

Gateway 192.168.0.1 192.168.0.1  

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 168 . 0 . 0) should match. 

* The above settings are examples recommended by the company. 

 

 

Items Description 

IP Address Set an IP address to be used by the TOP to use over the network. 

Subnet Mask Enter the subnet mask of the network. 

Gateway Enter the gateway of the network. 
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 (2) Communication option setting 

■ [ Main screen > Control panel > PLC ] 
 

 
* The above settings are examples recommended by the company. 

 

Items Settings Remarks 

Interface Select “Ethernet”. Refer to “2. External 

device selection”. Protocol Select “EtherNet/IP”. 

IP Enter the IP address of the external device.  

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

Port Enter the Ethernet communication port number “44818” of the external device. Fixed 

CPU Slot No Enter the CPU slot number of the external device.  
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check whether the port (ETH1/ETH2) settings you want to use are the same as those of the external device in [Control panel > 

Ethernet]. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC ]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Ethernet port setting IP Address OK NG 

Subnet Mask OK NG 

Gateway OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Ethernet port setting IP Address OK NG 

Subnet Mask OK NG 

Gateway OK NG 

Check address range  

OK NG 

5. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 
 

4.1 External device setting 1 (1756-ENBT, 1756-ENET(/B)) 

Set as below using “Control/CompactLogix Series” Ladder Software “RSLogix5000”. 

For more detailed setting methods than described in this example, refer to the PLC user manual.  

Step 1. Right-click [I/O Configuration] of the Project tree in “RSLogix5000” to select [New Module].  

Step 2. Select a module to be used in [Select Module] dialog box. 

Step 3. Right-click the added module name in the Project tree to select [Properties]. 

Step 4. Set “IP Address: 192.168.0.51” and other matters in [General] tab of the [Module Properties] dialog box. 

Step 5. Download the settings. 

 

 

 

 

 

 

 

 

 

 

4.2 External device setting 2 (1761-NET-ENI) 

Use [ENI/ENIW Utility] for communication settings to configure as shown below. 

For more detailed setting method than that described in this example, refer to the PLC user manual. 
 

Step 1. From the [ENI IP Addr] tab of [ENI/ENIW Utility], configure the “IP Address : 192.168.0.51” and other settings. 

Step 2. Download the configurations for 1761-NET-ENI. 

 

 

 

 

 

 

 

 

 

 

 

4.3 External device setting 3 (CPU Direct) 

Set as below using “Control/CompactLogix Series” Ladder Software “RSLogix5000”. 

For more detailed setting method than that described in this example, refer to the PLC user manual.   

Step 1. Right-click the CPU Direct Ethernet Port of [I/O Configuration] in the Project tree, “RSLogix5000” to select [Properties]. 

Step 2. Set “IP Address: 192.168.0.51” and other matters in [General] tab of the [Module Properties] dialog box. 

Step 3. Download the settings. 
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5. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

 
 

 
Device notation TOP Design Studio ➔ Data Type File Number : Element 

Ladder Software “RSLogix5000” ➔ Tag Name[Element] 
 

 

 

 

 

Device Bit Address Word Address 32 bits Remarks 

BOOL BOOL000:00000 – BOOL999:31999 BOOL000:00000 – BOOL999:31999 

L/H 

 

INT INT000:000/00 – INT999:999/15 INT000:000 – INT999:999  

REAL  REAL000:000 – REAL999:999  

DINT DINT000:000/00 –DINT999:999/31 DINT000:000 – DINT999:999  
 

 

 

 

☞ Continued on next page. 
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※ For communication between TOP and “Control/Compact Logix Series”, [File Number]: [Element] must be set 

in the corresponding tag. The setting method is as follows. 
 

Execute the below in “Control/Compact Logix Series” Ladder Software “RSLogix5000”. 
 

■ Execute [Logic] > [Edit Tags] to create a tag to be used for communication between TOP and Control/Compact Logix. 

 
 

Items Contents 

Name This is the name of the tag used in “RSLogix5000”. (user definition).g 

For communication connection with TOP, File Number must be mapped to the corresponding tag. 

☞ Refer to “■ Map PLC/SLC Messages“. 

Data Type BOOL 32Bit Data 

 DINT Double Word Data 

 INT Word Data 

 REAL Float data  
 

■ Execute [Logic] > [Map PLC/SLC Messages] to map the tags created in [Edit Tags]. 
 

 

 

Tag address in TOP Design Studio when set as in this example. 

Tag TOP Design Studio 

BOOL_TOPR BOOL001:00000 ~ BOOL001:01023 

INT_TOPR INT002:000 ~ INT002:999 

REAL_TOPR REAL003:000 ~ REAL003:999 

DINT_TOPR DINT004:000 ~ DINT004:999 

 

 

  

 

 

 

 

 

 

 

 

 

 

Don’t care 


