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1. System configuration

The system configuration of TOP and “CAS Corporation — CAS Indicator CI/NT Series” is as follows:
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device H
PLC select [COM1]
Filter : |[A\I] v| Search : l:l
@ Model (O Vendor
Vendor

TEMCOLINE Co., Ltd. L

HMoT & Indicator XE Series

CHINO Corporation

KOLVER Srl
SENGEMUITY
PELCO

FASTECH Co., Ltd.
HYOSUNG

MMEA

AJINEXTEK Co., Ltd.
IEC Standard

CAS

ARD
SEHIWA CHM Y
M8 Back | W Next *® Cancel
Select Device n

PLC Setting[ Indicator CI/NT Series ]

Alizs Mame @ |PLCL

Interface : | Serial ~
Protocol : | Syl M=y ~

String Save Mode : |First LH HL Change

[ use Redundancy
AND v

Comm Manual

Primary Option

Timeout msec

Send Wait

Retry 5 =

Station Num

@ Back + OK * Cancel

Settings

Contents

TOP

Model

Check the display and process of TOP to select the touch model.

External device

Vendor

Select the vendor of the external device to be connected to TOP.
Select "CAS".

PLC

Select an external device to connect to TOP.

Protocol

Interface

Indicator CI/NT Series Serial Command Type 2

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting
M [ Project > Project Property > TOP Settings ] — [ HMI Settings > “Use HMI Setup” Check > Edit > Serial ]

— Set the TOP communication interface in TOP Design Studio.

Project Option

- Change HMI[H]

— Add PLC [4] 1‘“ Change PLC[C]

E3 Delete PLCD)

.IEEP;:_UEMZUX Date / Time Sync.  Screen Option | Unit Convert
h !2ﬁ;.n|:|;du\(eu)5etﬁng Project Option  Screen Change HmiSetup = Global Lock & Touch  Project Style  Splash  PLC Buffer Sync.
-8 RFID (0.) Use HMI Setup
M "_:Eivieo’iit?:f e Initialization | Edit |
-4 PLC1 : Indicator CI/NT Se Project Setting P
g COM2 (0) HMIDisable=0
g COM3 (0) Project NdamaMzNaw project
thernet (0) Start Mode=Menu
; Eiiralesst(ou) E;B&SUCS’EEZE Ne.=1
-l USBDevice (0) Latch Set=0n~0
Communication Errar Message=0
USBErrorMessage=0
StorageErrorMessage=1
DatabaseMessage=1
Control Panel
System mDevices ._?Service =5 0ption
s Serjal A
e =
10! </ serial Port: | COMI -
PLC SECUT ity Dat e/ Time Signal Level
(®) A5-232C (O RS-42204) O R5-4E85(2)
Baud Rate: (9600 v
o - 0 [—
Y it:
Data Bit: & <
Et hernet Serial HOK | .
Stop Bit: |1 -
g \ Parity Bit: HNone M
= S\ Flow: 07f
L_A @ Ping
Diagnost ic File Fing Auto Search Loopback Test
Manager
Apply | Cancel
Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C
Baud Rate 9600
Data Bit 8
Stop Bit 1
Parity Bit None.

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting
M [ Project > Project Property > Device Settings > COM > “Indicator CI/NT Series"]

ERI2 e B X
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— Set the options of the Indicator CI/NT Series Command Type 2 communication driver in TOP Design Studio.

Project Option

- Change HMI[H] ' AddPLC[A] | THTM) Change PLCIC | [] Delete PLCID]

~ ] TOFP Setting
| L[ 5Y5:RD1520%

Option Module Setting
B FieldBus (0)

PLC Setting[ Indicator CI/NT Series ]

Alizs Name : [PLC1 |

Interface : | Serial ~

Protocol : | Command Type 2 ~

J String Save Mode : (First LH HL Change

[] use Redundancy

AND v
e g o
e0 -
Conditior Edi
Primary Option

Timeout m msec
Send Wait msec
Retry 5 z

Comm Manual

£ >

Apply Close
Items Settings Remarks
Interface Configure the communication interface between the TOP and an external device. Refer to "2. External

Protocol Configure the communication protocol between the TOP and an external device.

device selection”.

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

sending the next command request.

Set the waiting time between TOP’s receiving a response from an external device and

Retry Configure the amount of redelivery attempts from TOP to external device.

Station Num Set the prefix of an external device.

Device ID
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3.2. Communication setting in TOP

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting
M [ Main Screen > Control Panel > Serial ]

Conitrol Panel

Serial

Serial Port: [COM1 ']

Signal Level
@ RS-232C () RS-422(4) () RS-485(2)

Baud Rate: [ 9600

Run
L
PLC

|
2

¥HC |
tlbrac ] [ 2R | = Data Bit: |8 M
Ethernet Serial Stop Bit: [1 lv]
Parity Bit: | None |

N ’

.§ Flow: | 0ff -] y

Diagnost ic File P,|: [Auto Search] [Loopback Testl V
Manager

[ Apply HCancel ] —

[System] Crosc

TOPRX - TOPRX0800S A  2021-08-31 04:27:57 PH
Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C
Baud Rate 9600
Data Bit 8
Stop Bit 1
Parity Bit None.

* The above settings are setting examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [ Main Screen > Control Panel > PLC ]

@ » : 'a]' PLC
@ System

Dr iver(COM1) [ PliB1( Indiestor BlANT: Series) v]
Q Interface (
(

erial |~

| |9

)

PLC ss Timeout 300 |3 msec

YHC Send Wait msec

Protocol ommand Type 2 [~]

Ethernet

e

Station b

Retry 5 B
0 1

[y

Diagnost ic

[System] [ Diagnostic [ Apply ”Cancel J

TOPRX - TOPRX0800S A 2021-08-31 04:28:10 PH

Items Settings Remarks

Interface Configure the communication interface between the TOP and an external device. Refer to "2. External
Protocol Configure the communication protocol between the TOP and an external device. device selection”.
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and

sending the next command request.

Retry Configure the amount of redelivery attempts from TOP to external device.

Station Num Set the prefix of an external device. Device ID
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3.3 Communication diagnostics

B Check the interface setting status between the TOP and an external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC ].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information OK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG L .
diagnostics 3. TOP communication setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name OK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings OK NG . .
4. External device setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

Refer to the user manual of CAS Corporation’s CI/NT Series to identically configure the communication settings of the TOP.
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5. Cable table
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This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.
(The cable diagram described in this section may differ from the recommendations of “CAS Corporation”)

m RS-232C
TOP External device
Pin Signal Pin Pin Signal Pin
arrangement+Note 1) name number number name arrangement*Note 1)
1 5
Q
g 3 SD 3 3 RXD Based on
communication
Based on
cable connector
communication SG 5
front,
cable connector D-SUB 25 Pin male
front, 7 SG
(male, convex)
D-SUB 9 Pin male
(male, convex)

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.

W RS-422 (1:1 connection)

TOP External device
Pin Signal Pin Signal
arrangement*Note 1) name number name
1 5 RDA(+) 1 SDA(+)
Q Q
6 9 RDA(+)
Based on RDB() 4 RDB(-)
communication SG SG
cable connector SDA(+) 6
front,
D-SUB 9 Pin male
(male, convex) SDB(-) 9

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.

W RS-485 (1:1 connection)

TOP External device
Pin Signal Pin Signal
arrangement*Note 1) name number name
1 5 RDA(+) 1 SDA(+)
Q Q
6 9 RDA(+)
Based on RDB() 4 RDB(-)
communication SG SG
cable connector SDA(+) 6 R
front,
D-SUB 9 Pin male
(male, convex) SDB(-) 9

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
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External device

TOP
. Signal
Pin arrangement
name
O +
| 10 ,llIsG SG
16,1} -
+

W RS-422 (1:N connection)

External device

Signal name

TOP External device
Signal name Signal name
RDA(+) SDA(+)
RDB(-) SDB(-)
SDA(+) RDA(+)
SDB(-) RDB(-)

W RS-485 (1:N connection)

External device

Signal name

TOP External device
Signal name Signal name
RDA(+) SDA(+)
RDB(-) SDB(-)
SDA(+) RDA(+)
SDB(-) RDB(-)

External device connection manual for TOP Design Studio
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6. Supported addresses
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The devices available in TOP are as follows:

The device range (address) may differ depending on the CPU module series/type. The TOP supports the maximum address range

used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Double word

Device Bit address Word address R/W Remarks
address

WEIGHT - WEIGHT WEIGHT R Weight
WEIGHT_FLOAT - - WEIGHT_FLOAT R Weight (Float value)
STS STSO ~ STS2 sTS STS R ﬂg::i?w stable/Overload®
GSNT GSNTO~GSNT1 GSNT GSNT R j,zzatLV;TIght/Net weight
ZERO_KEY ZERO_KEY ZERO_KEY ZERO_KEY W Zero Key
TARE_KEY TARE_KEY TARE_KEY TARE_KEY W Tare Key
GROSS_KEY GROSS_KEY GROSS_KEY GROSS_KEY W Gross Key
NET_KEY NET_KEY NET_KEY NET_KEY W Net Key
START_KEY START_KEY START_KEY START_KEY W Start Key
STOP_KEY STOP_KEY STOP_KEY STOP_KEY W Stop Key
PRINT_KEY PRINT_KEY PRINT_KEY PRINT_KEY W Print Key
TOTALPRINT_KEY TOTALPRINT_KEY TOTALPRINT_KEY TOTALPRINT_KEY W Total Print Key
ITEM_NO - ITEM_NO ITEM_NO R/W [tem No.*Note 3)
ONESTEP_WEIGHT ONESTEP_WEIGHT ONESTEP_WEIGHT
_VALUE i _VALUE _VALUE RIW One Step Weight
SUPPLY_VALUE - SUPPLY_VALUE SUPPLY_VALUE R/W Supply Value
SET_VALUE - SET_VALUE SET_VALUE R/W Set Value
FALL_VALUE - FALL_VALUE FALL_VALUE R/W Fall Value
HIGHLIMIT_VALUE - HIGHLIMIT_VALUE HIGHLIMIT_VALUE R/W High Limit Value
LOWLIMIT_VALUE - LOWLIMIT_VALUE LOWLIMIT_VALUE R/W Low Limit Value

*Note 1)

Balance status when the following bit is enabled

STSO Unstable
STS1 Stable
STS2 Overload
*Note 2)
Balance status when the following bit is enabled
GSNTO Gross
GSNT1 Net

*Note 3) If you enter a value

value.
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