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Temperature Controller- T50/N50 Series
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1. System configuration

The system configuration of TOP and “TemcolLine Co., Ltd. — Temperature Controller Series” is as follows:

‘ Link I/F Communication method System setting ‘
T52
T53
750 T54 Terminal Port RS485 3.1 Settings example 1 5.1. Cable table 1
T57 on CPU unit (2 wire) (Page 4) (Page 8)
T59
N50

H Connection configuration

+ 1:1 (one TOP and one external device) connection — configuration which is possible in RS232C/422/485 communication.

+ 1:N (one TOP and multiple external devices) connection — configuration which is possible in RS422/485 communication.
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2. External device selection
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M Select a TOP-R model and a port, and then select an external device.

Select Device

PLC select [COM2]

Filter + [ (] ~| Search
@ Model () Vendor

Wendor Model

1AI Corporation ~ :“ TemcoLine T50 Seri

MKP

TEMCOLINE Co., Ltd.

LINMOT

CHING Corporation
KOLVER Srl
SENGENUITY
PELCO

FASTECH Co., Ltd.
HYQSUNG

MMEA

AJINEXTEK Co., Ltd.

IEC Standard

cas s

4 Eack | W Mext *® Cancel

Select Device H

PLC Setting[ TemcoLine T50 Series ]

Alias Name : |PLC1

Interface : | Computer Link ~

Protocol : PC Link ~
String Save Mode : |First LH HL Change

[ use Redundancy

Comm Manual

Primary Option

Timeout msec
Send Wait msec
Station Mum El
Checksum

@ Back v oK ® Cancel
Settings Contents
TOP-R Model Check the TOP-R display and process to select the touch model.

External device | Vendor

Select the vendor of the external device to be connected to TOP-R.

Select “Temcoline”.

PLC

Select an external device to connect to TOP-R.

Interface Protocol

TemcolLine T50 Series Computer Link PC LINK

Please check the system configuration in Chapter 1 to see if the external device you want to
connect is a model whose system can be configured.
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3. TOP-R Communication setting

The communication can be set in TOP Design Studio or TOP-R main menu. The communication should be set in the same way as
that of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting
M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Serial]

— Set the TOP-R communication interface in TOP Design Studio.

Project Opticn X
[ cranoe HMi] W Adapci T Changs PLC [ Delete PLCID)

3 TOP et
1—‘35#!\555! Date / Time Sync.  Screen Option | Unit Convert

] OP"FD”E;d“'E)S““”g Project Option  Screen Change  HmiSetup  Global Lock & Touch  Project Style  Splash  PLC Buffer Sync.
el us

. RFID (0) Use HMI Setup
v i i | |
g Device Setting Initialization Edit

Hmi Setup Option

-1g¥ COM1 (0)
~ fgW COM2 (1 Project Setting .
H -4 PLC1 : Temcoline T50 Ser| HMIDisable =0

Project Name=New project
Start Mode=Menu
Start Screen No. =1

i-{gm Wireless (0)
i USBDevice (0) Latch Set=0~0

Communication Error Message =0
USBErrorMessage =0
StorageErrorMessage=1
DatabaseMessage=1

Latch Use=0

Control Panel

System Devices @Service _'—""'_'Dption

ill “gm pLC (XN

PLC Security | Driver [PLCI1(Temcol ine TS0 £ - |[COMZ -

[Communication Optionl -
TimeOut (ms) 300

""I" m SendWait (ms. O
Retrw 5
station Mum 1

Et hernet Serial

= | Checksum ‘fes A ﬂ
=
Diagnozt ic File I Cance ” bopl ]

Managew — = == - y
Items TOP-R External device Remarks
Signal Level (port) RS-485 RS-485
Baud Rate 19200
Data Bit 8
Stop Bit 1
Parity Bit NONE

* The above settings are examples recommended by the company.

Items Description
Signal Level Select the serial communication method between the TOP-R and an external device.
Baud Rate Select the serial communication speed between the TOP-R and an external device.
Data Bit Select the serial communication data bit between the TOP-R and an external device.
Stop Bit Select the serial communication stop bit between the TOP-R and an external device.
Parity Bit Select the serial communication parity bit check method between the TOP-R and an external device.

External device connection manual for TOP Design Studio 4/ 10



TOP ooz e
Touch Qperation Panel

(2) Communication option setting

M [Project > Project Property > Device Setting > COM > “PLC1 : FP Series”]

— Set the options of the MICREX-SX Series communication driver in TOP Design Studio.

Project Option

- Change HMI[H] ' Add PLC[A] | THiTal Change PICIO | 1] Delete PLCID]

~ [} TOP Setting
| L[ sYS:RD1520%
v -l Option Module Setting

Device Setting
i--#g® COM1(0)
[

L J
W Ethernet (0)
Wireless (0)
L. USBDevice (0)

PLC1: Temcoline T50 Se

PLC Setting[ TemcoLine T50 Series ]

Alizs Name : [PLC1 |

Interface : | Computer Link ~
Protocol : | PC Link ~

String Save Mode : (First LH HL Change

| [ use Redundancy

Comm Manual

Primary Option

Timeout msec
Send Wait msec
Station Num IZI
Checksum

>
Apply Close
Items Settings Remarks
Interface Select "Computer Link".
Protocol

Select the serial communication protocol between the TOP-R and an external device.

TimeOut (ms)

Set the time for the TOP-R to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP-R's receiving a response from an external device and
sending the next command request.

Retry

Number of redelivery attempts upon communication error

Station num

Plc id num

Checksum

Enable or disable checksum during communication

External device connection manual for TOP Design Studio

5/10



3.2. Communication

setting in TOP-R
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* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP-R screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

Conitkroll Panel
ar Serial
Serial Port: lCUME ]
Signal Level
() BS-232C (O RS-422(4) @ RS-485(2) ]
Baud Rate: | 19200 -
¥YHC
Viever [.J"-.] Data Bit: |8 B
. I Stop Bit: | 1 ~|
] Et hernet
g4©° Parity Bit: | None -
T
Screen m Flow: l Of f ‘v]
shot
Diagnost ic
[System] Close r
|
Items TOP-R External device Remarks
Signal Level (port) RS-485 RS-485
Baud Rate 19200
Data Bit 8
Stop Bit 1
Parity Bit none

* The above settings are setting

examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP-R and an external device.

Baud Rate Select the serial communication speed between the TOP-R and an external device.

Data Bit Select the serial communication data bit between the TOP-R and an external device.

Stop Bit Select the serial communication stop bit between the TOP-R and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP-R and an external device.

3.3 Communication diagnostics

B Check the interface setting status between the TOP-R and an external device.

- Touch the top of the TOP-R screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.
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W Diagnosis of whether the port communication is normal or not

- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.
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OK

Communication setting normal

Time Out Error

Communication setting abnormal

- Check the cable, TOP-R, and external device setting status. (Reference: Communication diagnostics

sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system oK NG ) )
. . - 1. System configuration
configuration Connection cable name OK NG
TOP-R Version information oK NG
Port in use oK NG
Driver name oK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG . .
Cormmunication 2. External dvevufe select.lon
. . oK NG 3. Communication setting
diagnostics
Serial Parameter Transmission Speed oK NG
Data Bit oK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name oK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings oK NG 4. External device setting
Serial Parameter Transmission Speed oK NG
Data Bit oK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

Configure the communication setting of the external device by referring to its user manual.
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5. Cable table
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This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. (The cable

diagram described in this section may differ from the recommendations of “Temcoline Co., Ltd.")

4.1. Cable table 1

M 1:1 connection

TOP COM Port (9 pin)

TOP COM Temperature Controller
Pin Signal Pin Cable connection Signal )
Pin arrangement
arrangement Note 1) name number name
1 5 RDA 1 RTX(+)
e)
Q 3 SG Alt) ®
6 9
Based on RDB 4 RS485 |
communication SG 5 B ®
cable connector SDA 6 T |
front, 7 5G ®
D-SUB 9 Pin male 8
(male, convex) SDB 9

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.

B 1:N connection — Refer to 1:1 connection to connect in the following way.

Cable connection and signal

direction

External device

Signal name

RTX(+)

RTX(-)

TOP ) ) o External device
X Cable connection and signal direction -

Signal name Signal name
RDA RTX(+)
RDB RTX(-)
SDA I SG
SDB
SG
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6. Supported addresses
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The devices available in TOP are as follows:

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Device Bit Address Word Address Remarks
D Register D0000.00 — D9999.15 D0000 — D9999
| Register 10000 - 19999 e
W Reference: D Register Overview (For more details, refer to the user manual distributed by Temcoline Co., Ltd.)
Register Contents
Configured as read-only range, user range
0001(NPV) Current PV value
0002(NSV) Current operating SV value
0003(NRSV) Current operating Remote SV value
0005(MVOUT) Current output volume
0006 - 0007(CH1,20UT) Output volume if HC-type
0008(PIDNO) Current operating PID number
0001 — 0099 0009(ALMSTS) Current alarm status (BIT info)
0010(STEPNO) Current step number during program operation
0011(BRSEGTM) Current remaining time of the step during program operation
0014-0015(HC1,2_CUR) Heater Cut value
0016(ADESTS) Input processing error info (bit info)
0017(ERRSTS) Input & AT error info (bit info)
0018(MODSTS) Current operating status (bit info)
0050-0099 User range (Read/Write feature)
Operating status check and transition
0100 (OPMODE) 0 : Local, 1: Program, 2 : Remote
0101(PROG) 0 : Reset, 1: Program Run
0100 - 0199 0102(ZOM) 0 : Zone Off, 1 : Zone On
0103(FUZY) 0 : Fuzzy Off, 1 : Fuzzy On
0104(ARW) 0 : ARW Off, 1 : ARW On
0106(DIS) Select DI
0200 - 0299 Program draft
0300 - 0399 SV & PID settings
0400 - 0499 Alarm parameter settings
Transfer & Remote parameter settings; Communication parameter check
0500 - 0599
(0510 - 0516 : Read-only section)
0600 - 0699 Input/output parameter settings
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