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PANASONIC Electric Works 

FP Series  

Computer Link (MEWTOCOL-COM) Driver 
 Supported version TOP Design Studio V1.0 or higher  
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We want to thank our customers who use the Touch Operation Panel. 
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Refer to this section to check the data addresses which can 

communicate with an external device. 
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1. System configuration 

The system configuration of TOP and “PANASONIC Electric Works – FP Series Computer Link” is as follows: 

 

Series CPU Link I/F Communication 

method 

System setting Cable 

FP 

FP2 

FP2SH 

CPU built-in TOOL Port  RS-232C 

3. TOP communication 

setting 

4. External device 

setting 

5. Cable table 

CPU built-in RS-232C Port RS-232C 

AFPS 

RS-232C 

RS-422 ( 4-wire ) 

RS-485 ( 2-wire ) 

FP-X 

CPU built-in TOOL Port RS-232C 

AFPX 
RS-232C 

RS-485 (2-wire) 

FP∑ 

CPU built-in TOOL Port RS-232C 

AFPG 
RS-232C 

RS-485 (2-wire) 

FP0 
CPU built-in TOOL Port RS-232C 

CPU built-in RS-232C Port RS-232C 

FP-e 

CPU built-in TOOL Port RS-232C 

AFPE 
RS-232C 

RS-485 (2-wire) 

FP-M 
CPU built-in TOOL Port RS-232C 

CPU built-in RS-232C Port RS-232C 

FP10SH 

CPU built-in TOOL Port RS-232C 

CPU built-in RS-232C Port RS-232C 

AFP3462 RS-232C 

FP10S 
CPU built-in TOOL Port RS-232C 

AFP3462 RS-232C 

FP3 
CPU built-in TOOL Port RS-232C 

AFP3462 RS-232C 

FP1 
CPU built-in TOOL Port RS-232C 

CPU built-in RS-232C Port RS-232C 

FP7 

CPU built-in RS-232C Port RS-232C 

AFP7NSC 

RS-232C 

RS-422 (4-wire) 

RS-485 (2-wire) 

 

■ Connectable configuration 

ㆍ1:1 connection 
 

                      

 

 

ㆍ1:N connection 
 

                          ∙∙∙    
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 
 

 

Settings Contents 

TOP Model Check the display and process of TOP to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Select “PANASONIC Electric Works”. 

PLC Select an external device to connect to TOP. 
 

Model Interface Protocol 

FP Series Computer Link MewtocolCom 
 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [Project] → [Property] → [TOP Setting] → [HMI Setup] → [Use HMI Setup Check] → [Edit] → [Serial] 

– Set the TOP communication interface in TOP Design Studio. 
 

 

 

 

 

Items TOP External device Remarks 

Signal Level RS-232C / RS-422 / RS-485 RS-232C / RS-422 / RS-485  

Baud Rate 19200  

Data Bit 8  

Stop Bit 1  

Parity Bit Odd  

* The above settings are examples recommended by the company. 

 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device. (COM3 supports only RS-485.) 

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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(2) Communication option setting 

■ [Project] → [Project Property] → [PLC Setting> COM1 > PLC1 : FP Series] 

– Set the options of the FP Series Computer Link communication driver in TOP Design Studio. 
 

 

 

Items Settings Remarks 

Interface Select “Computer Link”. Refer to “2. External 

device selection”. Protocol Select the serial communication protocol between the TOP and an external device. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

Station Num Enter the prefix of an external device.  

Command Header Configure the header for the MEWTOCOL-COM protocol. Initial Value: % 
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

   

(1) Communication interface setting 

■ [Control Panel] → [Serial]  
 

 

  

Items TOP External device Remarks 

Signal Level RS-232C / RS-422 / RS-485 RS-232C / RS-422 / RS-485  

Baud Rate 19200  

Data Bit 8  

Stop Bit 1  

Parity Bit Odd  

* The above settings are setting examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device. (COM3 supports only RS-485.) 

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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(2) Communication option setting 

■ [Control Panel] → [PLC] 
 

 

Items Settings Remarks 

Interface Select “Computer Link”. Refer to “2. External 

device selection”. Protocol Select the serial communication protocol between the TOP and an external device. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

Station Num Enter the prefix of an external device.  

Command Header Configure the header for the MEWTOCOL-COM protocol. Initial Value: % 
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check that the settings of the connected ports in [Control Panel] → [Serial] are the same as the settings of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel] → [PLC]. 

- Check whether communication is connected or not. 
 

Communication 

diagnostics 

succeeded 

Communication setting normal 

Error message Communication setting abnormal 

- Check the cable, TOP, and external device settings. (Refer to Communication diagnostics sheet.) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 
 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Cable OK NG 

TOP Version OK NG 

2. External device selection 

3. Communication setting 

Communication port OK NG 

Communication driver and protocol OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External device CPU OK NG 

 

Communication port OK NG 

Protocol OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  

OK NG 

6. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 
 

Configure the COM port of the external device as shown below by referring to the vendor’s user manual. 
 

Items Settings Remarks 

Communication Mode MEWTOCOL-COM Master/slave (Computer Link) Fixed 

Prefix 1  

Communication speed 19200  

Data Length 8  

Parity Odd  

Stop Bit 1  

RS/CS Control Restriction ※Note 1) 

Transmit time delay 0  

Modem connection Restriction  

※Note 1) When allowed, short-circuit the RS and CS pins of the external device. 

 

※ Control FPWIN 7 FP7 model COM 0 Setup Screen 
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5. Cable table 

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. 

(The cable diagram described in this section may differ from the recommendations of “PANASONIC Electric Works”) 

 

■  RS-232C  [CPU built-in Tool Port] 

TOP 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

   1 SG 

 

Based on 

communication 

cable connector 

front, 

Tool Port 5 pin 

(Male, convex) 

RD 2 2 SD 

SD 3 3 RD 

    

SG 5 5 +5V 

   

  

  

 
 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-232C [CPU built-in RS232C Port] 

 

TOP 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

     

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RD 2 2 SD 

SD 3 3 RD 

  4 RS 

SG 5 5 CS 

    

  7 SG 

    

    

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-232C [CPU built-in RS232C Terminal] 

    TOP 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 
Pin arrangement 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

     

RD 2 SD 

SD 3 RD 

   

SG 5 SG 

   

  

  

  

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 
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■ RS-232C [Terminal) 
 

TOP 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 
Pin arrangement 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

     

RD 2 SD 

SD 3 RD 

   

SG 5 SG 

   

   

   

   

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.  

■ RS-232C [Terminal] - in the setting RS/CS Controlled 
 

TOP 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 
Pin arrangement 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

     

RD 2 SD 

SD 3 RD 

   

SG 5 SG 

   

  RS 

  CS 

   

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.  

■ RS-422 [Terminal] 
 

TOP 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 
Pin arrangement 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  + / S 

 

  - / S 

  + / R 

RDB 4 - / R 

SG 5  

SDA 6  

   

   

SDB 9  

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.  

■ RS-422 [Terminal] 1:N connection – Refer to 1:1 connection to connect in the following way.. 
 

TOP 
Cable connection and signal direction 

External device Cable connection and signal 

direction 

External device 

Signal name Signal name Signal name 

RDA  + / S  + / S 

RDB - / S - / S 

SDA + / R + / R 

SDB - / R - / R 

SG   
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■ RS-485 [Terminal] 
 

TOP 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 
Pin arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  + 

 

  - 

   

RDB 4  

SG 5  

SDA 6  

   

   

SDB 9  

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-485 [Terminal] 

TOP 

Cable connection 

External device 

Pin arrangement 
Signal 

name 

Signal 

name 
 

 

 

 

+  +  

- - 

SG SG 

  

 

■ RS-485 [Terminal] 1:N connection – Refer to 1:1 connection to connect in the following way. 

TOP 
Cable connection and signal direction 

External device Cable connection and signal 

direction 

External device 

Signal name Signal name Signal name 

RDA  +  + 

RDB – – 

SDA   

SDB   

SG   
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■ RS-485 [AFP2465 + AFP2805] (1 : 1 connection) 

TOP 

Cable connection 

PLC 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  1 E 

 

Based on 

communication 

cable connector 

front,  

Terminal Block 5 

Pin 

  2 – 

  3 + 

RDB 4 4 – 

SG 5 5 + 

SDA 6  

  

  

SDB 
9 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ 1:N connection – Refer to 1:1 connection to connect in the following way. (For split prefix devices, connect “E” Terminal with “-”. 

TOP 
Cable connection and signal direction 

External device Cable connection and signal 

direction 

PLC External 

device 

Signal name Signal name Signal name 

RDA  E  E 

RDB – – 

SDA + + 

SDB – – 

SG + + 
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6. Supported addresses 

The devices available in TOP are as follows: 

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

 

Operand Name Bit address Word address Remarks 

X Input relay X00 ~ X511F WX0 ~ WX511 *Note 1) 

Y Output relay Y00 ~ Y511F WY0 ~ WY511 *Note 1) 

R Internal relay R00 ~ R886F WR0 ~ WR886 *Note 1) 

Special relay R9000 ~ R910F WR900 ~ WR910 

L Link relay L00 ~ L639F WL0 ~ WL639 *Note 1) 

T Timer(contact) T0 ~ T3071 –––––  

C counter(contact) C0 ~ C3071 –––––  

SV Timer/Counter(Setting value) ––––– SV0 ~ SV3071  

EV Timer/Counter(Elapsed value) ––––– EV0 ~ EV3071  

DT Data register DT0.0 ~ DT10239.F DT0 ~ DT10239 *Note 2) 

 Special data register DT90000.0 ~ DT90511.F DT90000 ~ DT90511  

LD Link register LD0.0 ~ LD8447.F LD0 ~ LD8447  

FL File register FL0.0 ~ FL32764.F FL0 ~ FL32764  

*Note1) For X, Y, R, and L, bit/word processing is possible. In bit processing, 1 unit is hexadecimal and 10 units is decimal. 

     (E.g.)  X12C 

Word processing is preceded by a W (e.g.) WX12 = X120-X12F 16-bit data) 

 

*Note 2) Special registers (DT) are only available for FP2/2SH/10SH. 

 


