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TO BRI HE B X
Touch Qperation Panel

1. System configuration

The system configuration of TOP and “KORO — ROBOT" is as follows:

Communication method Communication setting

Series

3. TOP communication

setting

KORO - ROBOT RS-232C 4.1. Cable table

W Connection configuration

+ 1:1 (one TOP and one external device) connection
k (=1}

_
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2. External device selection

TOP ooz e
Touch Qperation Panel

H Select a TOP model and a port, and then select an external device.

Select Device

PLC select [COM1]

Filter : | [all

Vendor

@ Model (O Vendor
Model

AJINEXTEK Co., Ltd. ~
IEC Standard

CAS

ARD

SEHWA CNM
SHINHAN Electronics
BONGSHIM LOADCELL
FAMUC Co., Ltd.
MINEBEA Co., Lid.
Azbil Corporation
ROBOSTAR

Ebmpapst

CoNefve Autnmatinn Aliance Y

>
EE———

M8 Back | W Next *® Cancel

Select Device

PLC Setting[ KORO ROBOT ]

Alizs Mame : |PLC1

Interface : | Serial

~

Protocol : | KORO Motion Control ~ Comm Manual

String Save Mode @ |First LH HL Change

[J use Redundancy
AND ~

Primary Option

Timeout msec
Send Wait msec

Retry 5 -

4@ Back + OK * Cancel

Settings

Contents

TOP

Model

Check the TOP display and process to select the touch model.

External device | Vendor

Select the vendor of the external device to be connected to TOP.
Select "KORO TECHNOLOGY".

PLC

Select an external device to connect to TOP.

KORO ROBOT

Interface Protocol

Serial KORO Motion Control
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3. TOP communication setting

TO,

ERI2 e B X
Touch Qperation Panel

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting

M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Serial]

— Set the TOP communication interface in TOP Design Studio.

Project Option x
-ChangeHMI[ﬂ] 'Aﬂd PLC[A] | THITW Change PLCIC) | [ Delete PLCID)
v D o Sen:ing 20X Date [ Time Sync. = Screen Option Unit Convert
v !_2”2"";";5'“';)59””9 Project Option = Screen Change HmiSetup  Global Lock & Touch  Project Style  Splash  PLC Buffer Sync.
v "%_f::‘"é;;it?;')g e Initialization Edit
i..q@ PLC1: KORO ROBOT Project Seting -
-fg® COM2 (0) HMIDisable =0
- Fg¥ COM3 (0) Project Ndama;New project
thernet (0) Start Mode =Menu
; \E“firalesst(DD) f?ﬁiz:ig No. =1
-8 USBDevice (0) Latch Set=0~0
Communication Error Message=0
USBErrorMessage=0
StorageErrorMessage=1
DatabaseMessage=1
Control Fanel
System mDevices :nﬂService =" Option
o Serjal s
S—— s
T (S Serial Port: | COMI -
PLC Secur ity Date/Time Signal Level
(®) R5-232C () RS-42204) (O RS-485(2)
Baud Rate: |3600 M
[ - a [—
(1111 Data Bit: 8 -
Et hernet Serial HOM | Stop Bit: 1 -
- — \ Parity Bit: MNone i
= S\ Flow: [0ff
L | . Ping
Dlagnost Ic File Ping Auto Search  Loopback Test
Manager
Apply | Cancel
Items TOP External device Remarks
Signal Level (port) RS232C RS232C
Baud Rate 9600 Fixed
Data Bit 8 Fixed
Stop Bit 1 Fixed
Parity Bit None Fixed

*Programmer port of RS232C is configured identically as the above example settings.

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [Project > Project Property > Device Setting > COM > "PLC1 : KORO ROBOT"]
— Set the options of the KORO ROBOT communication driver in TOP Design Studio.

TOP ooz e
Touch Qperation Panel

Project Option

TOP Setting
-3 5Y5 ¢ RD1520%
Option Module Setting
-4 FieldBus (0)
W RFID (0)
W - Device Setting

v Rala TENALY
i | --w PLC1: KORO ROBOT |
¥ COMZ (0)

8 Ethernet (0)
® Wireless (0)
9 USBDevice (0)

- Change HMI[H] ' Add PLC[A] | THiTal Change PICIO | 1] Delete PLCID]

PLC Setting[ KORO ROBOT ]
Alizs Name : [PLC1

Interface : |Serial ~

Protocol @ | KORO Motion Control ~
String Save Mode : (First LH HL Change

[ use Redundancy

Primary Option

h

Comm Manual

Send Wait msec
Retry 5 z
Apply Close
Items Settings Remarks
Interface Select “Serial”. Refer to “2. External
Protocol

Select the communication protocol between the TOP and an external device.

device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP’s receiving a response from an external device and
sending the next command request.
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TO hEQIRE E AT
Touch Qperation Panel

3.2. Communication setting in TOP

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

Conikroll Panel

Serial

Bun

Serial Port: lCDhﬂ "

Signal Level
; @ RS-Z32C () RS-422(4) () RS-485(2)

Baud Rate: l 9600
YHC

Yiewer i Data Bit: l ]
.-.‘
Hin

Ethernet Serial Stop Bit: l 1

Parity Bit: [ Mone

m | Flow: | 0f

Diagnost ic File

[ Apply H Cancel ] —

""""""""""""""""""" \ir

[System]

el

Items TOP External device Remarks
Signal Level (port) RS232C RS232C
Baud Rate 9600 Fixed
Data Bit 8 Fixed
Stop Bit 1 Fixed
Parity Bit None Fixed

*Programmer port of RS232C is configured identically as the above example settings.
* The above settings are setting examples recommended by the company.
Items Description
Signal Level Select the serial communication method between the TOP and an external device.
Baud Rate Select the serial communication speed between the TOP and an external device.
Data Bit Select the serial communication data bit between the TOP and an external device.
Stop Bit Select the serial communication stop bit between the TOP and an external device.
Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting
M [Main Screen > Control Panel > PLC]

M

Ethernet

bl

Diagnost ic

[System]

Dr iver (COMT)

Interface

Protocol
Timeout
Send Wait

Retry

PLCT{KORD ROBOT)

’

[ Serial

-]

| KORO Motion Control|«|

Diagnostic

TO,

ERI2 e B X
Touch Qperation Panel

o’
| Aeply || Cancel |

S

Items Settings Remarks
Interface Configure the communication interface between the TOP and an external device. Refer to "2. External
Protocol Configure the communication protocol between the TOP and an external device. device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP’s receiving a response from an external device and

sending the next command request.
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TO BRI HE B X
Touch Qperation Panel

3.3 Communication diagnostics

B Check the interface setting status between the TOP and an external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information oK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG . .
diagnostics 3. Communication setting
Serial Parameter Transmission
oK NG
Speed
Data Bit oK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name oK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings OK NG . .
4. External device setting
Serial Parameter Transmission
oK NG
Speed
Data Bit oK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
oK NG (For details, please refer to the PLC
vendor's manual.)
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Touch Qperation Panel

4. External device setting

Refer to the vendor’s user manual to identically configure the communication settings of the external device to that of the TOP.
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TOP 225 -
5. Cable table

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.
(The cable diagram described in this section may differ from the recommendations of “KORO TECHNOLOGY")

4.1. Cable table

m RS-232C
COM PLC
Pin Signal Pin Cable connection )
Signal name
arrangementNote 1) name number
1 5 CcD 1 RD
Q Q
SD SD
6 9
Based on DTR
communication G SG
DSR

cable connector
front, RTS
D-SUB 9 Pin male CTs

(male, convex)

O || N[ | dMjlw( N
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6. Supported addresses

TO BRI HE B X
Touch Qperation Panel

The devices available in TOP are as follows:

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

[] 00 0000

|—>Address Number : 0000(Dec)
ID Number : 00 (Dec)

Device Name

Device Bit Address Word Address SIZE R/W Description
A 0000.00 — 9999.15 0000 — 9999 16Bit R/W Acceleration/Deceleration
C 0000.00 — 9999.15 0000 — 9999 16Bit R Display “error status occurred”
Address: 0-7
0: TXT
1: EMG
2: ESC
3: HOM
4: CW
5: CCW
6: ALM
7:RUN
D 0000.00 - 9999.31 0000 - 9999 32Bit W Pulse motion count
F 0000.00 — 9999.15 0000 — 9999 16Bit R/W Initial speed
G 0000.00 — 9999.15 0000 — 9999 16Bit W Run
H 0000.00 - 9999.15 0000 - 9999 16Bit W Execute original position
HZ 0000.00 — 9999.15 0000 - 9999 16Bit W Execute original position using Z figure.
HA 0000.00 — 9999.15 0000 - 9999 16Bit R/W Configure the acceleration/deceleration value to use when
executing the origin.
HAA 0000.00 — 9999.15 0000 — 9999 16Bit R/W Configure the acceleration/deceleration value (Final) to use
when executing the origin.
HD 0000.00 — 9999.15 0000 - 9999 16Bit R/W Configure the distance value to use when executing the origin.
H1V 0000.00 — 9999.15 0000 - 9999 16Bit R/W Configure the speed value 1 to use when executing the origin.
H2V 0000.00 — 9999.15 0000 — 9999 16Bit R/W Configure the speed value 2 to use when executing the origin.
H3V 0000.00 — 9999.15 0000 — 9999 16Bit R/W Configure the speed value 3 to use when executing the origin.
| 0000.00 — 9999.31 0000 — 9999 32Bit R Display the input status of the sensor and general input.
Address: 0-7
0: INPUT X
1: INPUT Y
2:JOG CW
3:JOG CCW
4: HOME
5: CW LIMIT
6: CCW LIMIT
7: EMERGENCY
8: S-READY
9: S-ALARM
10: S-INPOS
M 0000.00 — 9999.15 0000 — 9999 16Bit R/W Motor settings
N 0000.00 - 9999.31 0000 - 9999 32Bit R/W Assign variables
P 0000.00 — 9999.31 0000 — 9999 32Bit R Display current positional value
S 0000.00 — 9999.15 0000 — 9999 16Bit W Stop motor
N 0000.00 — 9999.15 0000 — 9999 16Bit R/W Save execution data
\ 0000.00 — 9999.31 0000 — 9999 32Bit R/W Speed
77 0000.00 — 9999.15 0000 — 9999 16Bit W Set current position to 0
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