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MITSUBISHI Electric Corporation 

MELSEC Q Series  

Ethernet Driver 
 Supported version TOP Design Studio V1.0 or higher  

CONTENTS 

We want to thank our customers who use the Touch Operation 

Panel. 

 

1. System configuration Page 2 

 Describes connectable devices and network configurations. 

2. External device selection  Page 3 

 Select a TOP model and an external device. 

3. TOP communication setting Page 4 

 Describes how to set the TOP communication. 

4. External device setting Page 14 

 
Describes how to set up communication for external 

devices. 

5. Supported addresses Page 20 

 
Refer to this section to check the data addresses which can 

communicate with an external device. 
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1. System configuration 

The system configuration of TOP and “MITSUBISHI Electric Corporation - MELSEC Q Ethernet” is as follows. 

 

Series CPU Link I/F 
Communication 

method 

Communication 

setting 
Cable 

MELSEC-Q 

Q00CPU 

Q00JCPU 

Q01CPU 

Q02CPU 

Q02HCPU 

Q06HCPU 

Q12HCPU 

Q25HCPU 

Q03UDECPU 

Q04UDEHCPU 

Q06UDEHCPU 

Q13UDEHCPU 

Q26UDEHCPU 

QJ71E71 

Ethernet 

(TCP/UDP) 

3. TOP 

communication 

setting 

4. External device 

setting 

Twisted pair cable*Note 1) 

QJ71E71-B2 

QJ71E71-B5 

QJ71E71-100 

Q02UCPU 

Q03UDCPU 

Q04UDHCPU 

Q06UDHCPU 

Q13UDHCPU 

Q26UDHCPU 

QJ71E71-B2 

QJ71E71-B5 

QJ71E71-100 

*Note 1) Twisted pair cable 

- Refer to STP (Shielded Twisted Pair Cable) or UTP (Unshielded Twisted Pair Cable) Category 3, 4, 5. 

- Depending on the network configuration, you can connect to components such as the hub and transceiver, and in this case, use a direct cable. 

 

 

■ Connectable configuration 

ㆍ1:1 connection 
 

                      

 

 

ㆍ1:N connection 
 

                          ∙∙∙    
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 
 

 
 

Settings Contents 

TOP Model Check the display and process of TOP to select the touch model. 

External device 

Vendor 
Select the vendor of the external device to be connected to TOP. 

Please select “MITSUBISHI Electric Corporation”. 

PLC 

Select the external device to be connected to the TOP. 
 

Model Interface Protocol 

MELSEC Q Series Ethernet Set Users 
 

 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured.  

 

Supported Protocol 

MC Protocol 3E (Binary) MC Protocol 3E (ASCII) MELSOFT Connection 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [Project] → [Property] → [TOP Setting] → [HMI Setup] → [Use HMI Setup Check] → [Edit] → [Ethernet] 

– Set the TOP communication interface in TOP Design Studio. 
 

 
 

 

 

Items TOP External device Remarks 

IP Address 192.168.0.100 192.168.0.51  

Subnet Mask 255.255.255.0 255.255.255.0  

Gateway 192.168.0.1 192.168.0.1  

* The above settings are examples recommended by the company. 

 

Items Description 

IP Address Set the IP address of the TOP. 

Subnet Mask Enter the subnet mask of the network. 

Gateway Enter the gateway of the network. 
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(2) Communication option setting 

 The “Ethernet” interface of the MELSEC Q Series communication driver supports 3 protocols. 

 Refer to the following to proceed with the settings for the protocol to be used. 
 

① MC Protocol 3E Binary 

■ [Project] → [Project properties] → [PLC settings > Ethernet > PLC1 : MELSEC Q Series] 

– Set the options for MC Protocol 3E Binary in TOP Design Studio. 
 

 
 

Items Settings Remarks 

Interface Select “Ethernet”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

IP Enter the IP address of the external device.  

Ethernet Protocol Select the Ethernet protocol between the TOP and an external device.  

Port Enter the Ethernet communication port number of the external device.  

Timeout Set the time for the TOP to wait for a response from an external device.  

Send Wait Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
 

HMI Port Enter the Ethernet communication port number of the TOP.  

Open System Select Open System when using TCP.  
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② MC Protocol 3E ASCII 

■ [Project] → [Project properties] → [PLC settings > Ethernet > PLC1 : MELSEC Q Series] 

– Set the options for MC Protocol 3E ASCII in TOP Design Studio. 
 

 
 

Items Settings Remarks 

Interface Select “Ethernet”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

IP Enter the IP address of the external device.  

Ethernet Protocol Select the Ethernet protocol between the TOP and an external device.  

Port Enter the Ethernet communication port number of the external device.  

Timeout Set the time for the TOP to wait for a response from an external device.  

Send Wait Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
 

HMI Port Enter the Ethernet communication port number of the TOP.  

Open System Select Open System when using TCP.  
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③ MELSOFT Connection 

■ [Project] → [Project properties] → [PLC settings > Ethernet > PLC1 : MELSEC Q Series] 

– Set the options for MELSOFT Connection in TOP Design Studio. 
 

 
 

Items Settings Remarks 

Interface Select “Ethernet”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

IP Enter the IP address of the external device.  

Ethernet Protocol Select the Ethernet protocol between the TOP and an external device.  

Port Enter the Ethernet communication port number of an external device. *Note 1) 

Timeout Set the time for the TOP to wait for a response from an external device.  

Send Wait Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
 

Dst Network No Enter the PLC network number.  

Dst Station No Enter the prefix of PLC.  

Src Network No Set the TOP network number.  

Src Station No Set the prefix of TOP.  

*Note 1) UDP : 5001, TCP : 5002 
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3.2. Communication setting in TOP  

※ This is the setting method when “Use HMI settings” in “3.1 Communication setting in TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 
 

   

(1) Communication interface setting 

■ [Control Panel] → [Ethernet] 
 

 

 

Items TOP External device Remarks 

IP Address 192.168.0.100 192.168.0.50  

Subnet Mask 255.255.255.0 255.255.255.0  

Gateway 192.168.0.1 192.168.0.1  

* The above settings are examples recommended by the company. 

 

Items Description 

IP Address Set the IP address of the TOP. 

Subnet Mask Enter the subnet mask of the network. 

Gateway Enter the gateway of the network. 
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(2) Communication option setting 

The “Ethernet” interface of the MELSEC Q Series communication driver supports 3 protocols. 

Refer to the following to proceed with the settings for the protocol to be used. 
 

① MC Protocol 3E Binary 

◼ [Control panel] → [PLC] 
 

 
* The above settings are examples recommended by the company. 

 

Items Settings Remarks 

Interface Select “Ethernet”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

IP Enter the IP address of the external device.  

Ethernet Protocol Select the Ethernet protocol between the TOP and an external device.  

Port Enter the Ethernet communication port number of the external device.  

Timeout Set the time for the TOP to wait for a response from an external device.  

Send Wait Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
 

HMI Port Enter the Ethernet communication port number of the TOP.  

Open System Select Open System when using TCP.  
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② MC Protocol 3E ASCII 

◼ [Control panel] → [PLC] 
 

 
* The above settings are examples recommended by the company. 

 

Items Settings Remarks 

Interface Select “Ethernet”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

IP Enter the IP address of the external device.  

Ethernet Protocol Select the Ethernet protocol between the TOP and an external device.  

Port Enter the Ethernet communication port number of the external device.  

Timeout Set the time for the TOP to wait for a response from an external device.  

Send Wait Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
 

HMI Port Enter the Ethernet communication port number of the TOP.  

Open System Select Open System when using TCP.  
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③ MELSOFT Connection 

◼ [Control panel] → [PLC] 
 

 
* The above settings are examples recommended by the company. 

 

Items Settings Remarks 

Interface Select “Ethernet”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

IP Enter the IP address of the external device.  

Ethernet Protocol Select the Ethernet protocol between the TOP and an external device.  

Port Enter the Ethernet communication port number of an external device. *Note 1) 

Timeout Set the time for the TOP to wait for a response from an external device.  

Send Wait Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
 

Dst Network No Enter the PLC network number.  

Dst Station No Enter the prefix of PLC.  

Src Network No Set the TOP network number.  

Src Station No Set the prefix of TOP.  

*Note 1) UDP : 5001, TCP : 5002 
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check that the settings of the connected ports in [Control Panel] → [Ethernet] are the same as the settings of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel] → [PLC]. 

- Check whether communication is connected or not. 
 

Communication 

diagnostics succeeded 

Communication setting normal 

Error message Communication setting abnormal 

- Check the cable, TOP, and external device settings. (Refer to Communication diagnostics sheet.) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external device, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. TOP communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Ethernet port setting IP Address OK NG 

Subnet Mask OK NG 

Gateway OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Ethernet port setting IP Address OK NG 

Subnet Mask OK NG 

Gateway OK NG 

Check address range  OK NG 5. Supported addresses 
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4. External device setting 

 

Use MELSOFT Engineering Software to set as follows. 

This example is a setting method using GX Works2. For more details, refer to the manufacturer’s user manual. 

 

※ Set it to the same protocol as TOP. 

 

4.1 MC Protocol 3E Binary 

Step1. Register the Ethernet communication module in the [Parameter] → [I/O Assignment] window. 
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Step2. Set the Ethernet network in the [Network Parameter] → [Ethernet / CC IE / MELSECNET] window. 
 

 
 

Items Contents Setting value Remarks 

Network Type Network Ethernet  

Start I/O No. I/O number of the Ethernet communication module 0000  

Network No. PLC network number 1  

Station No. PLC station number 1  
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Step3. Set the Ethernet network in the [Network Parameter] → [Ethernet / CC IE / MELSECNET] → [Operation Setting] window. 
 

 
 

Items Contents Setting value Remarks 

Communication Data Code Data code Binary  

Initial Timing Communication module initialization time Always wait for OPEN  

IP Address Setting IP setting 192.168.0.51  

Send Frame Setting Send frame setting Ethernet  

Enable Online Change Enable online change Enable  

TCP Existence Confirmation Setting TCP Existence Confirmation Setting Use the KeepAlive  
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Step4. Set the Ethernet network in the [Network Parameter] → [Ethernet / CC IE / MELSECNET] → [Open Setting] window. 

Case1. When set to UDP (recommended) 
 

 
 

Items Contents Setting value Remarks 

Protocol Ethernet protocol UDP  

Host Station Port No. PLC Ethernet port No. 6000  

Destination IP Address TOP Ethernet IP 192.168.0.100  

Destination Port No. TOP Ethernet port No. 1024  

  

※ UDP setting is recommended for wireless TOP or in a noisy environment. 

※ When connecting N TOP(s) to one PLC, set it up using the following method. 
 

       

  

  PLC Port         TOP IP         TOP Port 
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Case2. When setting to TCP 1 
 

 
 

Items Contents Setting value Remarks 

Protocol Ethernet protocol TCP  

Host Station Port No. PLC Ethernet port No. 6000  
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Case3. When setting to TCP 2 
 

 
 

Items Contents Setting value Remarks 

Protocol Ethernet protocol TCP  

Host Station Port No. PLC Ethernet port No. 6000  

Destination IP Address TOP Ethernet IP 192.168.0.100  

Destination Port No. TOP Ethernet port No. 1024  

 

4.2 MC Protocol 3E ASCII 

Set the Communication Data Code in the [Network Parameter] → [Ethernet / CC IE / MELSECNET] → [Operation Setting] window 

to ASCII. The rest of the setting method is the same as MC Protocol 3E Binary. 

 

  



 

 External device connection manual for TOP Design Studio 19 / 20 

4.3 MELSOFT Connection 

Refer to MC Protocol 3E Binary setting method to proceed Step 1~3, and then set as follows in the [Network Parameter] → 

[Ethernet / CC IE / MELSECNET] → [Open Setting] window. 
 

 
 

Items Contents Setting value Remarks 

Protocol Ethernet protocol TCP  

Open System Open way MELSOFT Connection  
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5. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 
 

Address Bit Word Remarks 32 BIT 

Input Relay X0000 ~ X1FFF (HEX) X0000 ~ X1FF0 (HEX) X***0 *Note 1) 

L/H *Note 3) 

Output Relay Y0000 ~ Y1FFF (HEX) Y0000 ~ Y1FF0 (HEX) Y***0 *Note 1) 

Internal Relay M0000 ~ M61439 M0000 ~ M61424 M0000 + 16*n *Note 2) 

Special Relay SM0000 ~ SM2047 SM0000 ~ SM2032 SM0000 + 16*n *Note 2) 

Latch Relay L0000 ~ L32767 L0000 ~ L32752 L0000 + 16*n *Note 2) 

Annunciator F0000 ~ F32767 F0000 ~ F32752 F0000 + 16*n *Note 2) 

Edge Relay V0000 ~ V32767 V0000 ~ V32752 V0000 + 16*n *Note 2) 

Step Relay S0000 ~ S8191 S0000 ~ S8176 S0000 + 16*n *Note 2) 

Link Relay B0000 ~ BEFFF (HEX) B0000 ~BEFF0 (HEX) B***0 *Note 1) 

Special Link Relay SB0000 ~ SB7FF0 (HEX) SB0000 ~ SB7FF0 (HEX) SB***0 *Note 1) 

Timer (contact) TS00000 ~ TS25471 TS00000 ~ TS25456  

Timer (coil) TC00000 ~ TC25471 TC00000 ~ TC25456  

Aggregate Timer (contact) SS00000 ~ SS25471 SS00000 ~ SS25456  

Aggregate Timer (coil) SC00000 ~ SC25471 SC00000 ~ SC25456  

Counter (contact) CS00000 ~ CS25471 CS00000 ~ CS25456  

Counter (coil) CC00000 ~ CC25471 CC00000 ~ CC25456  

Timer (current value) TN00000.0 ~ TN25471.15 TN00000 ~ TN25471  

Aggregate Timer 

(current value) 
SN00000.0 ~ SN25471.15 SN00000 ~ SN25471  

Counter (current value) CN00000.0 ~CN25471.15 CN00000 ~ CN25471  

Data Register 
D0000000.0 ~ D4212223.15 D0000000 ~ D4212223 Binary Protocol 

D000000.0 ~ D999999.15 D000000 ~ D999999 ASCII Protocol 

Special Data Register SD0000.0 ~ SD2255.15 SD0000 ~ SD2255  

Link Register W000000.0 ~ W4045FF.F W000000 ~ W4045FF  

Link Special SW0000.0 ~ SW7FFF.F SW0000 ~ SW7FFF  

Index Z00.0 ~ Z19.15 Z00 ~ Z19  

File Register  Custom range  

*Note 1) For bit addresses with hexadecimal “0~F” notations, use the initial 0 bit as the word address 

*Note 2) When using a bit address that uses decimals, use a word address in units of “16” 

*Note 3) The lower 16 BIT data of 32 BIT data is saved in the address whose screen has been registered, and the upper 16 BIT data is saved in the 

address next to the address whose screen has been registered. 

   Ex. When saving 32BIT data hexadecimal data 12345678 in address D00100, it is saved to 16BIT device address as follows: 

Items 32BIT 16BIT 

Address D00100 D00100 D00101 

Input data 

(hexadecimal) 
12345678 5678 1234 

 


