FUJI Electric Co., Ltd
MICREX-SX Series

Computer Link Driver

Supported version  TOP Design Studio V1.4.4 or higher {Rl

TOP

"

CONTENTS

We would like to thank our customers for using M2I's "Touch

Operation Panel (M2] TOP) Series". Read this manual and familiarize
yourself with the connection method and procedures of the "TOP and

external device”.

1. System configuration Page 2

Describes the devices required for connection, the setting of

each device, cables, and configurable systems.

2. External device selection Page 3

‘ Select a TOP model and an external device.

3. TOP communication setting Page 4

Describes how to set the TOP communication.

4. External device setting Page 9

Describes how to set up communication for external devices.

5. Cable table Page 10

Describes the cable specifications required for connection.

6. Supported addresses Page 11

Refer to this section to check the addresses which can

communicate with an external device.
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1. System configuration

The system configuration of TOP and “FUJI Electric Co., Ltd — MICREX-SX Series” is as follows:

CPU port RS-232C
SPH3000
3. TOP communication
MICREX-SX SPH300 tti 5. Cable tabl
- setting . Cable table
SPH2000 - )
NP1L-RS[] 4. External device setting
SPH200 ( General Purpose RS-232C
Communication RS-485
Module)

W Connection configuration

+ 1:1 (one TOP and one external device) connection

BT

* 1:N (one TOP and multiple external devices) connection

B ) .
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device H
PLC select [COM1]
Filter : |[AII] v‘ Search : I:I

@ Model (O Vendor

Vendor
FUII Electri L
SANGII Precision Co., Ltd. & FRENIC S000G11S/P115
DEVA

& MICREXF Series
OPTICON

TOHMICHL

Giddings & Lewis Motion Contral
DELTA TAU Data Systems
KEYENCE Corporation

Digital Electronics Corporation
HONEYWELL

MISUMI

PARKER HANMIFIN Corporation

TOSHIBA

ATI A% COPCO %

4_Back | B Next *® Cancel

Select Device n

PLC Setting[ MICREX-SX Series ]

Alizs Mame @ |PLCL

Interface : | Computer Link ~

Protocol : | Loader Command ~
String Save Mode : |First LH HL Change

[ use Redundancy

Primary Option
Timeout 300 -
Send Wait

Comm. Address

@ Back + OK * Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select “FUJI Electric Co., Ltd".
PLC Select an external device to connect to TOP.

Interface Protocol

MICREX-SX Series Computer Link Loader Command

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting
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TO,

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting
M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Serial]

— Set the TOP communication interface in TOP Design Studio.

Project Option

-Change HMI[H]

- TOP Setting
Lm'l vl o0y

- Option Module Setting

-4 Device Setting
v -1g® COM1 (1)
i L. PLC1: MICREX-SX Series
g8 COM2Z (0)
S COM3 (0)
Ethernet (0)
Wireless {0)
i USBDevice (0)

' Add PLC [A] "n ChangePLCIT] | []  Delete PLCD]

Date [ Time Sync. | Screen Option

Project Option = Screen Change = HmiSetup

Use HMI Setup

Unit Convert
Global Lock & Touch

Project Style

Splash  PLC Buffer Sync.

Edit |

Initialization

Project Setting

HMIDisable =0

Project Name =Mew project
Start Mode =Menu

Start Screen No.=1

Latch Use=0

Latch Set=0~0
Communication Error Message=0
USBErrorMessage =0
StorageErrorMessage=1
DatabaseMessage=1
SystemMessage=1
DisplayLockIcon=0
DisplayPermissionlcon=0
DarkDraw=0
DrawTouchPos=0
TOPID=1

AutoRun=0
Language=English

Project Advanced Setting
HMIDisable =0
RunSleep=50
EffectSleep=50
CommunicationSleep=1
ProjectLoadType=1
InitDataPrevScreen=1
ErrorLogWrite=0
BlinkTime=0
WatchDog=0
SDCoverOption=0
TaskMonitor=1
CommSleepChgUse=0
CommSleepChg=1000
MomentaryBitActionTime=20
CommunicationRatio=0

Ethernet

HMIDisable =0

ETH1=1
IP1=192.168.0.100
Subnet1=255.255,255.0

-

Close

Apply

Contrel Panel

System Devices @Service %""Uption

FLC Secur ity

'

(I

Ethernet

[ .

Disgnost ic File
Manager

Serial

)

[

[

|

Date/Time

HOK | Initiali

Ping kevpad

.
e
~ (@) =~
o~
.

A

Sensor Wi-Fi

—zat ion

. S ER

Top Menu MPAM
Analysis

Opt ion

[System]

Cancel

Get Hrl Setup 0K

s Serial

Serial Port:

Signal Level

(O RS-232C @ R5-422(4) O R5-485(2)

Baud Rate:
Data Bit:
Stop Bit:

Parity Bit:
Flow:

Auto Search

COM1 v

9600 o
a -
1 -
Even v
Off

Loopback Test

Apply Cancel
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Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C
(CPU port)
Baud Rate 9600
Data Bit 8
Stop Bit 1
Parity Bit Even

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.

(2) Communication option setting

M [ Project > Project Property >Device Setting > COM > "PLC1 : MICREX-SX Series"]
— Set the options of the MICREX-SX Series communication driver in TOP Design Studio.

Project Option

-(hange HIMIH]

~ -] TOP Setting

W acapic Tl Change PLCIC]

E3 Delete PLCID)

PLC Setting[ MICREX-SX Series ]

Alias Name : |PLC1

Interface : | Computer Link e

8 Option Module Setting
i~ FieldBus (0)

Protocol : | Loader Command ~
String Save Mode : |First LHHL Change

[ use Redundancy

AS
g PLC1: MICREX-SX Series J
3% COM2 (0
¥ COM3 (0)

USBDevice (0)

Primary Option
Timeout 00
Send Wait
Retry

Comm, Address

Apply Close
Items Settings Remarks
Interface Select the TOP communication interface. Refer to “"2. External
Protocol Select the TOP communication protocol. device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP's receiving a response from an external device and
sending the next command request.

Comm. Address

Enters the SX Bus Station number of the external device.
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3.2. Communication setting in TOP
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* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

Security

(i

Ethernet

Serial

Conitkroll Panel

- Serial

Serial Port: [ COM1

‘ -

Signal Level

) R5-232C @ R5-422(4) O R5-485(2)

Baud Rate: [ 9600

-

Data Bit: | 8

Stop Bit: | 1

Parity Bit: [ Even

-

|
|
M
-
-
o
-

I!HII Flow: | (ff -
[Auto Search] lLoopbaCk Test]
Diagnost ic File
Manager
| Apply H Cancel ] —
[System] Close (
__-‘
Items TOP External device Remarks
Signal Level t RS-422
g (port) RS-422
(CPU port)
Baud Rate 9600
Data Bit 8
Stop Bit 1
Parity Bit Even

* The above settings are setting examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.

External device connection manual for TOP Design Studio

6/ 11



(2) Communication option setting
M [Main Screen > Control Panel > PLC]

el - - - = -
O — PLC

Dr iver (COM1)

Bun

YHC
Yiewer

Screen
shot

@ System
)

PLC Se
)
T
Ethernet 25
=
3 |
Diagnost ic _F
Ma

[System]

TO,

l PLCT(MICREX-SK Series) vl

Interface | Computer Link R
Protocol [ Loader Command i~
Timeout 300 |3 msec
send Wait msec
Retry
Comm.  Ade L=

Diagnostic

ERI2 e B X
Touch Qperation Panel

| 4eply || Cancel |

—lll

Items Settings Remarks
Interface Select the TOP communication interface. Refer to "2. External
Protocol Select the TOP communication protocol. device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP's receiving a response from an external device and

sending the next command request.

Comm. Address

Enters the SX Bus Station number of the external device.
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3.3 Communication diagnostics

W Check the interface setting status between the TOP and external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the port (COM1/COM?2) settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information OK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
. . oK NG . ;
diagnostics 3. Communication setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name OK NG
Communication port name (module
OK NG
name)
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings oK NG 4. External device setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

Refer to the communication settings manual of the external device for configuration.
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5. Cable table

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.

(The cable diagram described in this section may differ from the recommendations of “FUJI Electric Co., Ltd.")

W RS-422 (1:1 connection)

Based on

coM MELSEC FX Positioning Controller
Pin Signal Pin Cable connection Pin )
Pin arrangement*Note 1)
arrangement*Note 1) | name number number
RDA 1 1 )
1 5 4
2 o . /@ 8
2 o
O Q, [ ® @
RDB w e 7
6 9 1 \ o .\7
SG VNG / 6
3

communication cable SDA

connector front, Based on communication
D-SUB 9 Pin male

(male, convex)

O IN|ojlu|dMlw|N

cable connector front,
MINI-DIN 8 Pin male (male,

convex)

O || N[ | MW N

SDB

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
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6. Supported addresses
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The devices available in TOP are as follows:

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Device Bit Word Double word Remarks
Input Memory 1X000.00 — I1X511.15 IW000 — IW511 ID000 - ID510
Output Memory QX000.00 — QX511.15 QWO000 - QW511 QD000 — QD510
Standard Memory MX1.0.0 — MX1.4999999.15 MW1.0 - MW1.4999999 MD1.0 — MD1.4999998
Retain Memory MX3.0.0 — MX3.3388607.15 MW3.0 - MW3.3388607 MD3.0 - MD3.3388606
System Memory MX10.0.0 - MX10.65535.15 MW10.0 - MW10.65535 MD10.0 - MD10.65534
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