LS Industrial Systems Co., Ltd.
XGT(XGK-CPU), XGB(XBC-CPU/XBM-CPU) Series
FENET Driver

Support version  OS V4.0 and over H

XDesignerPlus  4.0.0.0 and over

CONTENTS

Thank you for using TOP series of M2I corporation.

Please read this manual carefully to know connection methods and

procedures of “TOP to External device”

1. System configuration Page 2

A section for showing connectable external devices, serial signal
types, connection configurations. Refer this section to select the

right system configuration.

2.Selection of TOP, External device Page3

4] A section for selecting a Top model and the external device.

3. Example of system setting Page 4

TOP to External Device.
Select the correct example in your case according to “1. System

A section for explaining examples to connect communications of
configuration”.

4. Communication setting Page 8
A section for Communication setting.
The setting should be the same with the external device.

5. Usable address Page 10

A section for usable address to communicate with external

device.
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1. System configuration

System configuration of TOP and “LS Industrial Systems Co., Ltd — XGT(XGK), XGB(XBC/XBM) Series" is as below.

Series CPU Link I/F Communication type | System setting cable
Xotechun Ethernet (UDP) sefting ex 1
XGK-CPUA (4 page )

XGK XGK-CPUS XGL-EFMT
XGK-CPUE setting ex 2

Ethernet (TCP)

XGK-CPUU (6 page) *1
Twist pair cable

- i 1

XBM-D[J16S Ethernet (UDP) setting ex

XBM-D[J32S (4 page)

XGB XGL-EMTA =
XBC-DLI32H setting ex 2
XBC-D[]64H Ethernet (TCP) —

(6 page )

*1) Twist pair cable
- It means STP(shield twist pair cable) or UTP(shieldless twist pair cable) category 3, 4, 5.

- It can connect to hub, transceiver etc. according to network composition and use direct cable in this case.
W Connection configuration

+1:1 connection (TOP 1 unit to External device 1 unit)
h[e]]

]
— | HuB

+ 1 : N connection (TOP 1 unit to External device several units)

] IR AR T - 1

| quB b—td | '|
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2. Selection of TOP, External device

Select a external device which is communicated to the TOP.

| TargetPLC
PLC
Vendor PLEC
| M2l Corporation * || GLOFA-GM Series FENET
MITSUBISHI Electric Corporation . MASTER-K(2005/3005/M10005) Series FENET
OMRON Industrial Automation |E | xaT Seres(XGIXGR), XGE Series(XEC) FENET
LS Industrial Systems | . XGT Series(XGK), XGB Series(XBCXEM) FENET
MODBEUS Organization
SIEMENS AG.
Rockwell Automation (AB)
GE Fanuc Automation
PAMASONIC Electric Works
YASKAWA Electric Corporaticn
YOKOGAWA Electric Corporation
Schneider Electric Industries
KDOT Systems
RS Automation(SAMSUNG)
oK || cancal
Setting Items Description
TOP Series Select a TOP series which is communicated with external device.
Install an OS file v3.1 as diagram below before download a project file you have made.
Series OS Version
XTOP / HTOP V4.0
Name Select a TOP model which is communicated with external device.
External Device | Vendor Select vendor of the external device which is communicated with TOP.
Select "LS Industrial Systems Co., Ltd".
PLC Select a model name of the external device which is communicated with TOP.
Select "XGT(XGK), XGB(XBC/XBM) Series FENET".
Check whether the external device you want to use is connectable or not
in “1. System configuration”.
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3. System setting
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Set Communication interface of TOP and external device as below.

3.1 Example 1

Set your system as below.

Item TOP XGT(XGI/XGR), XGB(XEC) Series Note
IP Address*1)2) 192.168.0.50 192.168.0.51 User Set
Protocol ubP XGT server*3) User Set
Port 1024 2005 User Set

*1) Network address TOP and external device must be same. (IP's three place : 192.168.000 )

*2) Don't use same address in same network.

*3) XGT driver private port of FEnet I/F module admits communication to specified port number/protocol to appropriate IP.

TCP/IP

Protocol

UDP/IP

MODBUS TCP

Port number

2004

2005

502

(1) XDesignerPlus Setting

[Project >Project property] of XDesignerPlus as below and download it to TOP machine.

= Project
£l TOP Setting
i L. XTOPDSMO-ED{-E}
Bl PLC Setting
i becomz (o)
L cOMt (D)
- Ethernet (1)

Set communication interface of TOP.

4| M [ Project >Project Property > Project >TOP Setting > TOP Name ]

-Right window : [HMI Setting > check HMI Setting using > Device manager].

HMI Setup | Sepcial Buffer Sync |

+ FigldBus (0)

i L.USB Device (0)

- CF/SD Card Setting
.. CFISD Card

| HMi Setup | Sepcial Buffer Sync |

- PLCA : XGT(XGK,XGB) Ethernst System Setup | PLC Setup | Device Manager | Interface |
* Network
-1P address : 192 % 168 2 0 =l =0 =
- Subnet mask - 255 ‘L2855 1255 30 =
- Gateway : 192 % 168 20 i =

-Right window : [HMI Setting > check HMI Setting using > PLC setting]

[¥] Use HMI Setup

PLCIP 192 L 168 10 -

Read Port - 2005

Write Port - 2005

Ak Ak AF

Port HMI- 1024

(PLC2) XGT Series(XGK}, XGB Series(XBC/MXEM) FENET

51 b=
Time Out - 1000 3
Wait before send - o z
Protocol : ubp

msec.

msec.

W External device setup

Set the communication driver option "XGT(XGK), XGB(XBC,XBM) Series FENET"..

IP Address (PLC) : 192 3
Read Port (0~65535) - 2005
Write Port (0~65535) - 2006

PLC Comm Info
B8 3. 0 3 81 3

-
-

- IP Address (PLC): Type the IP address that the external device was given.

- Reading port / writing port: Choose the port number that will be used for ethernet

communication. Please input the port number that [GPPW] issued.
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(2) External device setup

TO,

Run "XG-PD Editor" program for communication setting and set as below.

If you want to change communication interface, modify refer to PLC manual.

hgtgl= e EfXmg

Touch Operation Panel

A Don't use overlapping IP address in unit network.

1. Run File > New File". Select CPU Type and push OK button refer to 1. system configuration".

2. Connect CPU LOADER port of XGT Series and serial port of PC by serial cross cable.

(If there is USB port in CPU, connect USB.)

3. Run [Online] > [Connection settings] menu. Select [Connection settings->Type] and click [Connect] button.

4. Run [Online] > [I/O Information] and read slot number. Run [Online] > [Read Parameter] and read parameter information of slot

of communication card.

5. Double click slot of FEnet card in [Project Window], show dialog box of [Default settings].

Set [Connection] and [Run Mode] as below and click [OK].

oz am (3
TCRAP 22 FAE HOE €8
D@3 =E; 0 Comos =2 HolE
OICIH AUTO(EID v | P =a |
P54 (e . T8, 0, 8 | U |
MeER OpAS 285, % % 0|
Aoissio; [ 192 T8 0 T |
DNS AH: o.0 .0 1|
[CIDHCP
28 I AZE 16 | =tz -255)
HE s WL [3 -1
ECHIIHH M) &3
SR [XGT A >
C== ] 52 ]
Item Contents Note
TCP/IP setting High speed 0 Set station number when it communicated to high
link station number speed between XGT PLC FEnet I/F module and
module.
Media AUTO Select media.
IP address 192.168.0.51 Set IP address of FEnet I/F module. Required
setting
Subnet mask 255.255.255.0 | Subnet mask
Gateway 192.168.0.1 Gateway address(Router address)
DNS server 0.0.01 Domain name server
DHCP OFF (default) If you use automatically assigned IP, check "ON". Required
setting
Receive Wait time 15 (default)
Personal connection | 3 (default) Maximum number of private service that can
unit connect simultaneously.
Driver(server) setting | Driver XGT server Required
setting
Host table setting Unable OFF Module of registered IP address is only admitted | Required
Host table connection to FEnet I/F.(If it is unable, unregistered | setting
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client can't connect.)

6. Transfer setting contents to CPU at [Online] > [Parameter Write].

7. Reset PLC at [Online] > [Reset] > [Reset PLC].
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3.2 Example 2

Set your system as below.

Item TOP XGT(XGI/XGR), XGB(XEC) Series Note
IP Address*1)2) 192.168.0.50 192.168.0.51 User set
Protocol TCP XGT server*3) User set
Port 1024 2004 User set

*1) Network address TOP and external device must be same. (IP's three place : 192.168.000 )
*2) Don't use same address in same network.
*3) XGT driver private port of FEnet I/F module admits communication to specified port number/protocol to appropriate IP.

Protocol TCP/IP UDP/IP MODBUS TCP

Port number 2004 2005 502

(1) XDesignerPlus setting

[Project >Project property] of XDesignerPlus as below and download it to TOP machine.

Eifyed 4' B [ Project >Project Property > Project >TOP Setting > TOP Name ]
= TOP Setting
© L. XTOPOSMO-ED(-E) Set communication interface of TOP.
= P!_Ccsoe;f:i;gm -Right window : [HMI Setting > check HMI Setting using > Device manager].
. COM1 () HMI Setup | Sepcial Buffer Sync |

= Ethernet (1)
i L.PLCY:XGT(XGKXGH)Ethernet |

i FieldBus (0) System Setup | FLC Setup | Device Manager | Interface |
(It Network
e - 1P address : 192 2168 20 S | o
- Subnet mask : Py iougbR:  Shops 2l =
- Gateway : 192 ;168 = 0 =il =

-Right window : [HMI Setting > check HMI Setting using > PLC setting]
| HMi Setup | Sepcial Buffer Sync |

[7] Use HMI Setup

(FLC2) XGT Seres(XGK), XGB Senes(XBCIXEM) FENET
PLCIP - 192 7 168 0 8 3
Read Port - 2005 H Time Out 1000 * msec.
Write Port - 2006 % Wait before send - o 2 msec.
Port HMI: 1024 H Protocol © UDP -

—P» B External device setup

Set the communication driver option "XGT(XGK), XGB(XBC,XBM) Series FENET"..

PLC Comm Info
IP Address (PLC) o 5 Mes 3 & 23 B 2
Read Port (0~65535) - 2005 =
Write Port (0~65535) - 2005 -

- IP Address (PLC): Type the IP address that the external device was given.
- Reading port / writing port: Choose the port number that will be used for ethernet

communication. Please input the port number that [GPPW] issued.
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TO,

Run "XG-PD Editor" program for communication setting and set as below.

If you want to change communication interface, modify refer to PLC manual.

A Don't use overlapping IP address in unit network.

1. Run File > New File". Select CPU Type and push OK button refer to 1. system configuration".

2. Connect CPU LOADER port of XGT Series and serial port of PC by serial cross cable.
(If there is USB port in CPU, connect USB.)

3. Run [Online] > [Connection settings] menu. Select [Connection settings->Type] and click [Connect] button.

4. Run [Online] > [I/O Information] and read slot number. Run [Online] > [Read Parameter] and read parameter information of slot

of communication card.

5. Double click slot of FEnet card in [Project Window], show dialog box of [Default settings].

Set [Connection] and [Run Mode] as below and click [OK].

X

2z A
TCR/P & TAEHOS 28
o3 2 [0 CI2AH0IE =AE HOIS
Oicio: AITOET) | | P =t |
P 5 (% . @ . 0 . 8 | L |
MumOprs: [ 2%, &5 % 0|
AoEsor [ 1% @ 0 1|
DNS MH: 0 0 o1
CIDHCP
2H 7 A2 [18 | E(2- 2
HE Hs W2 3 ] =18
ECt0IEME 23
= [XGT AH ]
C= =2
Item Contents Note
TCP/IP setting High speed 0 Set station number when it communicated to high
link station number speed between XGT PLC FEnet I/F module and
module.
Media AUTO Select media.
IP address 192.168.0.51 Set IP address of FEnet I/F module. Required
setting
Subnet mask 255.255.255.0 | Subnet mask
Gateway 192.168.0.1 Gateway address(Router address)
DNS server 0.0.01 Domain name server
DHCP OFF (default) If you use automatically assigned IP, check "ON". Required
setting
Receive Wait time 15 (default)
Personal connection | 3 (default) Maximum number of private service that can
unit connect simultaneously.
Driver(server) setting | Driver XGT server Required
setting
Host table setting Unable OFF Module of registered IP address is only admitted | Required
Host table connection to FEnet I/F.(If it is unable, unregistered | setting
client can't connect.)
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6. Transfer setting contents to CPU at [Online] > [Write].

7. Reset PLC at [Online] > [Reset PLC].
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TO,

item Description

Serial Signal Level

Setup signal level(RS-232C/422/485) of PLC connected with COM2/1 port. (COM1 only RS-232C)

Serial Baud Rate

Setup [communications Baud rate] of PLC connected with COM2/1 port.

Serial Data Bit

Setup [Data Bit] of PLC connected with COM2/1 port.

Serial Stop Bit

Setup [Stop Bit] of PLC connected with COM2/1 port.

Serial Parity Bit

Setup [Parity Bit] of PLC connected with COM2/1 port.

Time Out [ x100 mSec ]

Setup [Time Out] of PLC connected with COM2/1 port.

(Timeout:: waiting time for answer of PLC)

Send Wait [ x10 mSec ]

Setup [Send Wait] of PLC connected with COM2/1 port.
(Send Wait: communicate after waiting setting time when touch screen requires communications.)

Station Num. in Diag.[0~31]

Setup [Station Num.(0~31)] using "4.3 Communication Diagnosis”

4. Communication setting

Communication setup can be set on XDesignerPlus or TOP Main Menu. The setting should be the same with the external device.

(1) XDesignerPlus setup — register information of external device

Eifroee M [ Project >Project Property > Project >TOP Setting > TOP Name ]
=~ TOP Setting
{ L. XTOPOSMO-ED{E) Set communication interface of TOP.
&l PLC Setting -Right window : [HMI Setting > check HMI Setting using > Device manager].
L COMZ ()
COM1 (D) HMI Setup | Sepcial Buffer Sync |

= Ethernet (1)
- PLCY : XGT(XGK, XGH) Ethernet

o FieldBus (0) System Setup | PLC Setup | Device Manager | Interface |
e pora o *Network
R - 1P address 192 $ 168 2 0 - | =
- Subnet mask ; 266 S 256 L 286 1 O =
- Gateway 192 * 188 * 0 # %

‘ HMI Seiup | Sepcial Buffer Sync ‘

-Right window : [HMI Setting > check HMI Setting using > PLC setting]

[¥] Use HMI Setup

(PLC2) XGT Serles(XGK), XGB Series(XBC/XEM) FENET

PLCIP - 192 5 188 30 2151 =

Read Port - 2005 = Time Out - 1000 T msec
Write Port 2008 = Wait before send - o T msec.
Port HMI: 1024 H Protocol - UDP -

—' B External device setup
Set the communication driver option "XGT(XGK), XGB(XBC,XBM) Series FENET"..

PLC Comm Info
IP Address (PLC) 2 T dee 3 0z &1 3
Read Port (0-65635): 2005 £
Write Port (0~65535) - 2005 =

W Setting communication Interface
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4.2 TOP main menu setup item

- When a buzzer is on during the power reset, touch 1 spot at the upper LCD to move to "TOP Management Main" display.

- Set up driver interface at TOP according to below Stepl — Step2.
(Press "TOP ethernet setup” in Step 1 to change setup at Step 2.)

Step 1. [ PLC setup ] .Setup driver interface.

PLC setup

PLCIP:192.168.0.51

Protocol : UDP

PLC Read Port : 2005

PLC Write Port : 2005

TOP Port : 1024

PLC Address : 00

Timeout : 1000 [mSec]

Delay time of transmission : 0 [mSec]
TOPIP:192.168.0.50

Communication Interface

Settings

T(bP Ethernet setting cdmmunication diagnosis

Step 1-Reference.

Details Contents
PLC IP It is an IP address that external device was given.
Protocol Select the protocol method either UDP or TCP.

PLC Read Port

It is the port address that will be used for ethernet of external device.

PLC Write Port

It is the port address that will be used for ethernet of external device.

TOP port

Setting the TOP port number to connect with external device.

PLC address [0~65535]

Address of other device. Select between [0 - 65535].

Timeout [ x1 mSec ]

Set up TOP’s waiting time from external device at [0 - 5000] x 1mSec.

Delay Time before

transmitting [ x1 mSec]

Set up TOP's waiting time between response receiving — next command request transmission

from external device at [ 0 — 5000 ] x 1 mSec.

TOP IP

Setup the IP address that TOP receives in the network.

Step 2. [PLC Setup] > [TOP Ethernet Setup] - Setup the serial parameter of correspond port.

Port Settings

* Ethernet Communication
+ Network setting
-MAC:00-15-1ID-00 - 30 - 52
- IP Address : 192. 168 . 0. 50
- Subnet mask : 255 255 . 255 .0
- Gateway : 192168 .0 .1

Ethernet Port
Communication Interface

(each device has different address) Settings

Step 1-Reference.

Details

Contents

MAC

Physical official address in the network.

IP Address

Setup the IP address that TOP receives in the network.

Subnet mask

An address that divides the network ID and host ID regarding of IP address.

Gateway

An address that connects a network to another network.
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B TOP - Confirming interface setting condition between external devices

- Move to Menu by clicking the top side of LCD screen as resetting the power of TOP.

- [Main Menu >Communication setting] Confirm if detail in number 20~24 is identical to the setup information of “BSetup exercise

1"

- PLC Setup > Click the button in "Communication diagnosis" of TOP Ethernet.

- Diagnosis dialog box will pop up on the screen, you can judge by following informations that are shown on box no. 3 section.

OK!

Communication setting succeeded

Time Out Error!

Communication setting error

- Error in the setting situation of Cable and TOP / External device

(reference : Communication Diagnosis sheet)

B Communication Diagnosis Sheet

- Please refer to the information below if you have a problem between external devices and communication connection.

Details Contents Confirm
TOP Version Information xDesignerPlus : 0sS:
Name of Driver OK NG
External device IP Address
. . oK NG
information
(xDesignerPlus Subnet mask OK NG
Project setting) Gateway oK NG
TOP Information Protocol UDP/IP TCP/IP OK NG
(Main Device IP Address
) oK NG
Menu Setting)
Subnet mask OK NG
Gateway OK NG
Other specified setting info OK | NG
System System Connection Method
, , 11 N N:1 OK | NG
configuration
Name of cable (Hub usage) Direct (Use Hub) Cross (No Hub) OK NG
External Name of CPU
. oK NG
device
Name of communication device OK NG
Protocol(mode) OK NG
Other specified setting info OK | NG
IP Address (Local) (Destination) OK NG
Port number (Local) (Destination) OK NG
Subnet mask OK NG
Gateway oK NG
Address range confirm (other docs) OK NG
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The available address of device are as below.

Device(address) range might be different according to series/type of CPU. TOP Series are capable of supporting maximum address

range which is available in external Device.

Be careful get out of address range.

Device Bit Address Word Address 32 Bit Property

Input / Output Relay PO0000 — P2047F PO000 — P2047 R/W
Auxiliary Relay MO00000 — M2047F MO0000 — M2047 R/W
Keep Relay KOO000 — K2047F KO000 — K2047 R/W
Link Relay LO00000 — L11263F LO0000 — L11263 R/W
Special Relay FO0000 — F2047F FO000 — F2047 R

Timer (Contact) TOO00 — T2047 R/W
Counter (Contact) C0000 — C2047 L/HY R/W
Timer (Current Value) TO000 — T2047 R/W
Counter (Current Value) C0000 — C2047 R/W
Data Register D00000.00 - D65535.15 D00000 - 65535 R/W
Communication Data Register N00000.00 — D65535.15 N00000 — N21503 R/W
File Register R00000.00 — R32767.15 RO0000 — R32767 R/W
File Register ZR00000.00 — ZR65535.15 ZR00000 — ZR65535 R/W

R:read / W:write

*1) Low 16BIT of 32BIT data is saved address input by touch program, high 16Bit of 32BIT data is saved next address input by touch

program.

(Ex) If you input [12345678] of hex 32bit data at address [D00100], it will save in 16bit device as below.

Item 32BIT 16BIT
address D00100 D00100 D00101
Input data(Hex) 12345678 5678 1234
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