LS Industrial Systems
MASTER-K (50H,200H) Series
LOADER Driver

Supported version  TOP Design Studio V1.0 or higher {Rl

TOP

"

CONTENTS

We would like to thank our customers for using M2I's "Touch

Operation Panel (M2] TOP) Series". Read this manual and familiarize
yourself with the connection method and procedures of the "TOP and

external device”.

1. System configuration Page 2

Describes the devices required for connection, the setting of

each device, cables, and configurable systems.

2. External device selection Page 3

‘ Select a TOP model and an external device.

3. TOP communication setting Page 4

Describes how to set the TOP communication.

4. Cable table Page 9

Describes the cable specifications required for connection.

5. Supported addresses Page 10

Refer to this section to check the addresses which can

communicate with an external device.
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1. System configuration

TO BRI HE B X
Touch Qperation Panel

The system configuration of TOP and “LS Industrial Systems — MASTER-K Series 500H, 1000H" is as follows:

500H K5P-15H
. 3.1 Settings example 1 5.1. Cable table 1
CPU Direct RS-232C ® 4) ® 8)
age age

1000H K7P-30H
W Connection configuration
+ 1:1 (one TOP and one external device) connection

k=11 -

|
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2. External device selection

W Select a TOP model and a port, and then select an external device.
(1) TOP setting

Select Device n

PLC select [COM1]

Filter : |[.q||] V‘ Search : l:l

@ Model () Vendor

Vendor Model
-
M2I Corporation X(E1/XGR/XEC Series
MITSUBISHI Electric C Ll
sekic barparation XGK/XEM/XBC Series
OMRON Industrial Automation
GLOFA-GM Series

MASTER (80512052005 /3005/10005) Series

MODBUS Organization

STARVERT Series
SIEMEMS AG.

XCODE RFID HF Reader Series [H-1306/1307
Rockwell Automation

TR A A

MASTER-K(500H, 1000H

GE Fanuc Automation

PANASONIC Electric Works MASTER-K 105, 1051 Series

@

‘YASKAWA Electric Corporation
YOKOGAWA Electric Corporation
Schneider Electric Industries

KDT Systems

RS Automatinn

& Back | B Next *® Cancel

Select Device n

PLC Setting[ MASTER-K({500H/ 1000H) Series ]

Alias Name : PLC1

Interface : | CPU Direct ~

Protocol : | MASTER-K(500H,/1000H) 5 v Comm Manual
String Save Mode : |First LH HL Change

[J use Redundancy

AND 4
TimeQOut 5 :
Condition [ Edit
Primary Option
Timeout 300 & | msec
Send Wait msec
4 Back + OK *® Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select “LS Industrial Systems".
PLC Select an external device to connect to TOP.
MASTER-K(500H/1000H) Series LOADER
Please check the system configuration in Chapter 1 to see if the external device you want to
connect is a model whose system can be configured.
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3. TOP communication setting
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting
M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Serial]

— Set the TOP communication interface in TOP Design Studio.

Project Opticn X
B crenoe Hie W acorici TlE Change PLCiC) | 3 Delete PLCID)
I?—Dg:?;t—uuznx Date / Time Sync. | Screen Option  Unit Convert
__2“2_”|;";d“|;)59m”9 Project Option | Screen Change  HmiSetup | Global Lock & Touch | Project Style  Splash | PLC Buffer Sync.
B
v E'Eivg;;elt?;g TS Initialization Edit
i . PLC1: MASTER-K(S00H/100C T G =
5% COMZ (0) Communication Error Message =0
USBErrorMessage =0
Ethernet (1) gm‘;angErh;orMezsagle=1
Wireless (0) alabase Emf=
.4 USEDevice (0) E,};;,";T{j,gd“;?: o
Control Pangl
. | . = El .
System m Devices :uﬂ Service = Option
I —
e Serial
S— oy
1 l 7 « Serial Port: | COMZ ot
PLE Security Date/Tine g Signal Level
(O R3-232C O RS-422(4) ® R5-485(2)
) Baud Rate: 9600 &
%,
o o — Data Bit: § -
e | —/
i Stop Bit: | -
Et hernet Serial HOM | Imi . .
-z Parity Bit: |None M
B Flow: [ff
| | Tl % Auto Search  Loopback Test
L nal & Ping o
Diagnost ic File Ping ks Apply  Cancel
Manager 0
Items TOP External device Remarks
Signal Level (port) RS-232C .
RS-232C Fixed
(CPU port)
Baud Rate 9600 Fixed
Data Bit 8 Fixed
Stop Bit 1 Fixed
Parity Bit None. Fixed

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [ Project > Project Property > Device Setting > COM > "PLC1 : MASTER- LINK"]
— Set the options of the MASTER- LINK Series communication driver in TOP Design Studio.

ERI2 e B X
Touch Qperation Panel

Project Option

~ -] TOP Setting
'3 SYS : TOPRX 1500X

- Change HMIL) | |l Add PLC [4) THT ChangePLCIC] ] Delete PLCID]

PLC Setting] MASTER-K(500H/ 1000H) Series ]

~ -l Option Module Setting Alias Name : |PLC1 ]
i & FeldBus (0) Interface : | CPU Direct v
& RFID (0)
& Device Setting Protocol : MASTER-K(S00H/1000H) § v Comm Manual
: :" COoM1(0) String Save Mode : |FirstLH HL Change
AR
i lemPLCL: MAS‘I‘E!-IC(SOOH,I‘J.]
i Crmrerre
i g Ethernet (0) AND v
\.qg® USBDevice (0) =
Primary Option
Timeout 300 4 | msec
Send Wait 0 & | msec
Retry 5 B
< >
Apply Close
Items Settings Remarks
Interface Select "CPU Direct”. Refer to "2. External
Protocol Select "MASTER-K (500H/1000H)".

device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP’s receiving a response from an external device and

sending the next command request.

Retry

Select amount of redelivery attempts upon communication failure.
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3.2. Communication setting in TOP
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* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

Conikroll Panel
Run
(p¢|  Serial Port: ‘CUME |'|
!||l| 7 Signal Level
‘ | |® ms-2azc O Rs-422(4) O Rs-485(2) l
FLC Security Date/
Baud Rate: 19200 |
¥HC .
S [ | | e e 8 M
puny Stop Bit: | | ~|
1 ﬁ Ethernet Serial
' Parity Bit: | None -
Ammam o - [ | l
g | Flow: | 0ff v
R IS
oi . ; [Auto Search] lLoopback Testl
iagnost ic File Pin
Mariager
/ l Apply “ Cancel l -
[System] Close r
Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C Fived
- ixe
(CPU port)
Baud Rate 1922 Fixed
Data Bit 8 Fixed
Stop Bit 1 Fixed
Parity Bit None. Fixed

* The above settings are setting examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.

External device connection manual for TOP Design Studio

6/ 10



TO tHRIRUE &3y -
Touch Qperation Panel

(2) Communication option setting

B [Main Screen > Control Panel > PLC]

) PLC
. © svsten | 5iercoonn | PLCT(HASTERK(S00H/1000H) Series) |+|
un |
! Interface [ CPU Direct Rd
‘ i Protocol | MASTER-K(500H/ 1000k +|
Lt 3 Timeout 300 |3 msec

YHC send Wait msec

Yi r

e | 8 ety 5B
e (11
[] Ethernet
[
Smmm i
5 p

o™ ||| A |

S, 8
Diagnost ic
v
[System] [ Diagnostic l dop |y “Cancel l

Items Settings Remarks
Interface Select “"CPU Direct". Refer to "2. External
Protocol Select "MASTER-K Link Series". device selection”.
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.
SendWait (ms) Set the waiting time between TOP's receiving a response from an external device and

sending the next command request.
Retry Select amount of redelivery attempts upon communication failure.
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3.3 Communication diagnostics

W Check the interface setting status between the TOP and external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information oK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG . .
diagnostics 3. Communication setting
Serial Parameter Transmission
oK NG
Speed
Data Bit oK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name oK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings OK NG . .
4. External device setting
Serial Parameter Transmission
oK NG
Speed
Data Bit oK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
oK NG (For details, please refer to the PLC
vendor's manual.)
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TOP 225 -
4. Cable table

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.

(The cable diagram described in this section may differ from the recommendations of “LS Industrial Systems Co., Ltd.")

COM PLC
Pin Signal Pin Cable connection Pin Signal Pin
arrangement*Note 1) | name number number | name | arrangement*Note 1)
D 1 1 D
1 5 ¢ ¢ 1 5
(o) (@) SD 3 3 SD O [e)

6 9 DTR 4 4 DTR 6 9
Based on G 5 5 G Based on
communication cable DSR 6 6 DSR communication cable
connector front, RTS 7 - RTS connector front,
D-SUB 9 Pin male D-SUB 9 Pin male
CTS 8 8 CTS
(male, convex) 9 9 (male, convex)
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5. Supported addresses
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The devices available in TOP are as follows:

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Bit Address Word Address 32 bits Remarks
Input / Output Relay PO00 — P63F P00 — P63
Auxiliary Relay M000 - M191F MO0 — M191
Keep Relay K000 — K31F KOO - K31
Special Relay FOOO — F63F FOO — F63 *Note 1) Cannot be written
Timer T0000.00 — T1255.15 T0000 — T1255 L/H
Counter €0000.00 — C1255.15 C0000 — C1255
Step Relay S0000 - S0099

Data Register

D0000.00 - D9999.15

DO000 - D9999

*Note 1) The lower 16BIT data of 32BIT data is saved in the address whose screen has been registered, and the upper 16BIT data is

saved in the address next to the address whose screen has been registered.

Ex. When saving 32BIT data hexadecimal data 12345678 in address D00100, it is saved to 16BIT device address as follows:

Items 32BIT 16BIT
Address D00100 D00100 D00101
Input data
. 12345678 5678 1234
(hexadecimal)
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