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1. System configuration 

The system configuration of TOP and “GREENPOWER – OHS CPS Master” is as follows. 

 

Series CPU 
Communication 

method 
System setting Cable 

GREENPOWER – OHS CPS Converter RS–485 

3.1 Settings 

example 1 

(Page 4) 

4. Cable table 

Page 10 

 

■ Connection configuration 

 

ㆍ1:1 connection 
 

 
 

ㆍ1:N connection 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 
 

 

Settings Contents 

TOP Model Check the display and process of TOP to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Select “GREENPOWER”. 
PLC Select an external device to connect to TOP. 

 

Model Interface Protocol 

OHS CPS MASTER Serial WPS Link 
 

 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [ Project > Project properties > TOP settings] → [Project option > Check “Use HMI settings” > Edit > Serial ] 

– Set the TOP communication interface in TOP Design Studio. 

 

 

 

 

 

 

Items TOP External device Remarks 

Signal Level (port) RS-485 RS-485  

Baud Rate 9600  

Data Bit 8  

Stop Bit 1  

Parity Bit none  

* The above settings are examples recommended by the company. 

 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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(2) Communication option setting 

■ [ Project > Project properties > Device setting > COM > “PLC1 : OHS CPS MASTER” ] 

– Set the options of the communication driver of OHS CPS MASTER in TOP Design Studio. 

 

 

Items Settings Remarks 

Interface Select “Serial”. Refer to “2. External 

device selection”. Protocol Select “WPS Link”. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) 
Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

Retry Configure the amount of request attempts from TOP to external device.   

Station No Prefix  
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

   

(1) Communication interface setting 

■ [ Main screen > Control panel > Serial ] 
 

 

Items TOP External device Remarks 

Signal Level (port) RS-485 RS-485  

Baud Rate 9600  

Data Bit 8  

Stop Bit 1  

Parity Bit none  

* The above settings are setting examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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(2) Communication option setting 

■ [ Main screen > Control panel > PLC ] 
 

 

Items Settings Remarks 

Interface Select “Serial”. Refer to “2. External 

device selection”. Protocol Select “WPS Link”. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) 
Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

Retry Configure the amount of request attempts from TOP to external device.   

Station No Prefix  
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC ]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External device CPU name OK NG 

 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  

OK NG 

6. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 

 

Refer to the vendor’s user manual to identically configure the communication settings of the external device to that of the TOP.
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5. Cable table 

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. 

(The cable diagram described in this chapter may differ from the recommendations of “GREENPOWER – OHS CPS MASTER”.) 
 

■ RS-485 (1:1 connection) 
 

TOP 

Cable connection 

PLC 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 
 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA(+) 1  ╋  

  — 

  SG 

RDB(-) 4  

SG 5  

SDA(+) 6  

  

  

SDB(-) 9 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-485 (1:1 connection) 
 

TOP 

Cable connection 

PLC 

Pin arrangement 
Signal 

name 

Signal 

name 
 

 

╋  ╋ 

 

— — 

SG SG 

 

 

 

 

 

■ RS-485  (1:N connection) 
 

TOP  PLC  PLC 

Signal name  Signal name  Signal name 

╋  ╋  ╋ 

—  —  — 

SG  SG  SG 
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6. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

 

Device Type / size Data range Description 

ID DEC 16bit 0~99 Unit classification 

STATUS DEC 16bit 0~4 

Unit status information 

0 : STOP 

1 : RUN 

2 : Fault 

3 : Warning 

4 : FailOver 

 

VOLTAGE1 DEC 16bit 0~9999 Rectification voltage 

VOLTAGE2 DEC 16bit 0~9999 Boost voltage 

CURRENT1 DEC 16bit 0~9999 Boost current 1 

CURRENT2 DEC 16bit 0~9999 IGBT current 

CURRENT3 DEC 16bit 0~9999 Track current 

FREQUENCY1 DEC 16bit 0~9999 Output frequency 

TEMP1 DEC 16bit 0~9999 Converter heat sink temperature 

TEMP2 DEC 16bit 0~9999 Converter internal temperature 

ERROR_CODE DEC 16bit 0~9999 Converter Error Code 

VOLTAGE_RS DEC 16bit 0~9999 Input voltage RS 

VOLTAGE_ST DEC 16bit 0~9999 Input voltage ST 

VOLTAGE_TR DEC 16bit 0~9999 Input voltage TR 

CURRENT_R DEC 16bit 0~9999 Input current R 

CURRENT_S DEC 16bit 0~9999 Input current S 

CURRENT_T DEC 16bit 0~9999 Input current T 

FREQUENCY2 DEC 16bit 0~9999 Input frequency 

POWER_FACTOR FLOAT 32bit -9.99~+9.99  3-phase power factor 

TOTAL_KW DEC 16bit 0~9999 Instantaneous Power 

KVAR DEC 16bit -999~+999 Instantaneous Reactive Power 

KWH DEC 32bit 0~999,999,999 Accumulated power energy 
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Converter Error list 

Error_Code Error Name Description Converter LCD 

1  HeatSink_OverHeat_60  Heat sink overheats to 60 °C (Bimetal)  HeatSink Warning 

2  Panel_OverTemp Converter panel internal overheating Panel O.T warning 

3  IGBT_OverHeat_Warning  IGBT overheats to 60 °C  IGBT O.T Warning 

4  Main_Fan_Warning  Main fan malfunction   Reserved 

5 Reserved Reserved Reserved 

6 Reserved Reserved Reserved 

7 Reserved Reserved Reserved 

8 Reserved Reserved Reserved 

9 Fail-Over Fail-over operationg switching Fail-Over 

10 Reserved Reserved Reserved 

11 Reserved Reserved Reserved 

12 Reserved Reserved Reserved 

13 Reserved Reserved Reserved 

14 Reserved Reserved Reserved 

15 Smoke_Detect_Warning Smoke detector operation SMOKE_Warning 

16 Reserved Reserved Reserved 

17 RS232_Comm_Fail Failed communication with watt-hour meter  RS232 Comm Fail 

18 RS485_Comm_Fail Master Panel Communication Fail RS485 Comm Fail 

19 Reserved Reserved Reserved 

20 Reserved Reserved Reserved 

21 Reserved Reserved Reserved 

22 Reserved Reserved Reserved 

23 Reserved Reserved Reserved 

24 Reserved Reserved Reserved 

25 Reserved Reserved Reserved 

26 Reserved Reserved Reserved 

27 Reserved Reserved Reserved 

28 Reserved Reserved Reserved 

29 Reserved Reserved Reserved 

30 Reserved Reserved Reserved 

31 Reserved Reserved Reserved 

32 Reserved Reserved Reserved 

33  Erec_peakVoltage   Input voltage greater than 420 V results in overvoltage  Erec P.V 

34  Erec_OverVoltage   Input voltage greater than 400 V results in overvoltage  Erec O.V 

35  Erec_UnderVoltage   Input voltage lesser than 230 V results in undervoltage  Erec U.V 

36  Eboost_PeakVoltage   Overvoltage occurs when DC voltage is 500V or higher.  Eboost P.V 

37  Eboost_OverVoltage   Overvoltage occurs when DC voltage is 480V or higher.  Eboost O.V 

38 Reserved Reserved Reserved 
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Error_Code Error Name Description Converter LCD 

39 Reserved Reserved Reserved 

40 Reserved Reserved Reserved 

41 Reserved Reserved Reserved 

42  Iboost_PeakCurrent   Boost IGBT greater than 150 A results in overcurrent   Iboost P.C 

43  Iboost_OverCurrent   Boost IGBT greater than 140 A results in overcurrent   Iboost O.C 

44  Iboost2_PeakCurrent  Boost IGBT greater than 140 A results in overcurrent   Iboost2 P.C 

45  Iboost2_OverCurrent  Boost IGBT greater than 150 A results in overcurrent   Iboost2 O.C 

46 Reserved Reserved Reserved 

47 Reserved Reserved Reserved 

48  Isrc_PeakCurrent   Track current 100 A or higher  Isrc P.C 

49  Isrc_OverCurrent   Track current 90 A or higher  Isrc O.C 

50  Isrc_UnderCurrent   Track current 25 A or lower  Isrc U.C 

51 Isrc_FO_PeakCurrent  FO_Track current 100 A or higher  F/O Isrc P.C 

52 Isrc_FO_OverCurrent  FO_Track current 90 A or higher  F/O Isrc O.C 

53 Isrc_FO_UnderCurrent  FO_Track current 25 A or lower  F/O Isrc U.C 

54  Iout_PeakCurrent   Inv IGBT current 120 A or higher  Iout P.C 

55  Iout_OverCurrent   Inv IGBT current 110 A or higher  Iout O.C 

56  Boost1_Gate_Fault  Boost1 IGBT malfunction   BoostA GateFault  

57  Boost2_Gate_Fault  Boost2 IGBT malfunction   BoostB GateFault  

58 Reserved Reserved Reserved 

59  Inv1_Gate_Fault  Inverter1 IGBT malfunction  InvA GateFault  

60  Inv2_Gate_Fault  Inverter2 IGBT malfunction  InvB GateFault  

61  Initial_Charge_Fail   Failed initial charging during RUN operation   InitCharge Fail 

62  EMO_Stop_Int   Internal emergency operation for converter  EMO Stop Int  

63  EMO_Stop_Ext   Internal emergency operation for converter   EMO Stop Ext 

64 Reserved Reserved Reserved 

65  Fuse_Open   Input Fuse Open  Fuse Open 

66  Sag_Gen_Fault   Power outage lasts longer than 1 s  Sag Gen Fault 

67  Main_Fan_Fault   Faulty operation of main fan  Main Fan Fault 

68  HeatSink_OverHeat_80  Heat sink overheats to 80 °C (Bimetal)  HeatSink OverHeat  

69  IGBT_OverHeat   IGBT overheats to 80 °C (NTC)  IGBT OverHeat  

70  Track_Cable_OverHeat   Track Power Cable 90 °C thermal wire operation  OutCable OverHeat  

71  Inside_Cable_OverHeat  
 Converter’s Internal Power Cable 90 °C thermal wire 

operation 
 InCable OverHeat 

72  Busbar_OverHeat  Output busbar overheats to 80 °C (Bimetal)   Busbar OverTemp  

73  FO_Track_Cable_OverHeat 
 Heat-detecting wire operates when the temperature 

of FO_Track Power Cable reaches 90 degree. 
 F/O OutCable O.T.  

74 Reserved Reserved Reserved 

75  FO_Busbar_OverHeat  
Overheat when the temperature of FO_output terminal 

block busbar reaches 75 degree or higher. 
 F/O Busbar O.T. 
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Error_Code Error Name Description Converter LCD 

76  Panel_Over Temp  Overheat when the internal temperature reaches 40 degree.  Panel O.T Fault 

77 Reserved Reserved Reserved 

78  Regulator Fault(Interlock)  Regulator Fault (Bypass break)   Regulator Fault 

79  eeprom_ad_check_sum_fail  Controller EEPROM Data Load error   Ad Data R/W Fail 

80  eeprom_sys_check_sum_fail  Faulty controller EEPROM data load   Sys Data R/W Fail 

81 eeprom_gain_check_sum_fail   Faulty controller EEPROM data load   GainData R/W Fail 

82  Watchdog_fault   Faulty controller operation   WatchDog Fault 

83 Reserved Reserved Reserved 

84 Reserved Reserved Reserved 

85 Reserved Reserved Reserved 

86 Reserved Reserved Reserved 

87 Reserved Reserved Reserved 

88 Reserved Reserved Reserved 

89 est Eboost PV  Boost predictive overvoltage occurs est Eboost P.V 

90 est Eboost OV  Boost predictive overvoltage occurs  est Eboost O.V  

91 est inv Eboost PV  (Inverter duty calculation) Boost predictive overvoltage occurs  est inv Eboost P.V 

92 est inv Eboost OV  (Inverter duty calculation) Boost predictive overvoltage occurs  est inv Eboost O.V 

93 Erec Eboost Gap  Voltage error due to voltage detection error  Erec-Eboost Gap 

94 Reserved Reserved Reserved 

95 Reserved Reserved Reserved 

96 Reserved Reserved Reserved 

97 FailOver_MC_Short  Fail-Over MC Short Error when the Fail-Over operates FailOvere MC Short 

98 CPS2_Main_MC_Short  CPS2 Main-MC Open Error when the Fail-Over operates FailOvere MC Short 

99 CPS2_Sub_MC_Short  CPS2 Sub-MC Open Error when the Fail-Over operates  FailOvere MC Short 

100 Reserved Reserved Reserved 

101 Reserved Reserved Reserved 

102 Reserved Reserved Reserved 

103 Reserved Reserved Reserved 

104 Reserved Reserved Reserved 

105 Cap OverHeat 
 Overheat when the temperature of the resonant 

capacitor is over 75 (Bimetal) 
Cap OverTemp 

106 Reserved Reserved Reserved 

107 Reserved Reserved Reserved 

108 EXT_Earthquake External earthquake detection signal input Earthquake 

109 Reserved Reserved Reserved 

110 Reserved Reserved Reserved 

111 Reserved Reserved Reserved 

112 Reserved Reserved Reserved 

 

 


