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1. System configuration
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The system configuration of TOP and "ASIC Controls - ASIC Controls Series” is as follows:

NEIES

Communication

Link I/F

method

Communication

setting

ASIC

Series

ASIC/2-7040

RS-232C

3. TOP

communication

setting

4. External Device

setting

5.1. Cable table 1

Controller built-in Port

ASIC/2-7540

RS-485

w

.10

communication

setting

)

4. External Device

setting

5.2. Cable table 2

B Connectable configuration

+ 1:1 (one TOP and one external device) connection — configuration which is possible in RS232C/422/485 communication.

=

+ 1:N (one TOP and multiple external devices) connection — configuration which is possible in RS422/485 communication.

) (+] S—

__
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device H
PLC select [COM2]

Filter : |[AII] v‘ Search : I:I

@ Model (O Vendor

Vendor
FANUC Co., Ltd. L Lo
MINEBEA Co., Ltd. (@ ESCO : 1GET Rectifier
Azbil Corporation

OKY : DVC
KORO TECHNOLOGY

& ILSHINBIO : FD FRONT

ROBOSTAR

SHINSUNG E&G : MCUL32 Series
Ebmpapst

SPEEDTECH : PUI-2000 Series
CoDeSys Automation Alliance

Ophir Optronics Solutions Ltd. JISANG : Rectifier
SERVOMEX ASN : T8H Sensor
Tiger Optics, LLC SNC : Flow Meter
E &R Automation SECRIM : PMC3000
Peripheral Device

OTHERS Manufacture

v

MEMORY MAP SLAVE

WILLINGS : Master K

22 AR AR AR

4_Back | B Next *® Cancel

Select Device n

PLC Setting[ ASI Systems : ASIC/2 Series ]

Alizs Mame @ |PLCL

Interface : | Computer Link ~

Protocol : | Asic Link ~ Comm Manual
String Save Mode : |First LH HL Change

[ use Redundancy

Primary Option
Timeout

Send Wait

Bus Address

@ Back + OK * Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select "OTHERS Manufacture”.
PLC Select an external device to connect to TOP.

Interface Protocol

DDC Monitoring Computer Link PC Link
(ASIC/2 Series)

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting

M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Serial]

— Set the TOP communication interface in TOP Design Studio.

Project Option

- Change HMI[H]

— AddPLC[A] | THTAl Change PLCICI

TOP Settin
1 575 : RD1520%
~ - Option Module Setting
-4 FieldBus (0)
48 RFID (0)
v - Device Setting
1% COM1 (0)
v 18 COM2 (1)
-4 PLC1 : ASI Systems : ASI(
1% COM3 (0)
4 Ethernet (0)
@ Wireless (0)
-4 UsBDevice (0)

E3 Delete PLCID)

Date / Time Sync. | Screen Option

Project Option  Screen Change

Hmi Setup Option

Use HMI Setup

HmiSetup

Unit Convert

Global Lock & Touch

Project Style | Splash

Initialization | Edit |

PLC Buffer Sync.

Project Setting
HMIDisable=0

Project Name=New praject
Start Mode=Menu

Start Screen Mo, =1

Latch Use=0

Latch Set=0~0
Communication Error Message =0
USBErrorMessage=0
StorageErrorMessage=1
DatabaseMessage=1

~

Control Panel

System mDevices ?Service %'"'.'Uption

i Serial
o
101 ~ Serial Port: | COM? -
FLC Security Date/Time Shemal Lersl
(® RS-232C O Rs-422(4) O R5-485(2)
Baud Rate: 4500 e
ol ol &)
L Data Bit: 8 -
Et hernet Serial HOM | Stop Bit: 5 -
p—— \ Parity Bit: MNone e
| - S\ Flow: [0ff
L_ A . Fing
Diagnost ic File Fing Auto Search | Loopback Test
Manager
Apply | Cancel
Items TOP External device Remarks

Signal Level (port)

RS-232C/RS-485

RS-232C/RS-485

Baud Rate 9600
Data Bit 8
Stop Bit 2
Parity Bit None

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting
W [ Project > Project Property > PLC Setting > COM > “DDC Monitoring (ASIC/2 Series)"]

— Set the options of the Computer Link communication driver in TOP Design Studio.
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Project Option

- Change HMI[H] ' AddPLC[A] | THTM) Change PLCIC | [] Delete PLCID]

~ ] TOFP Setting
L[ sYs:RD1520X
Option Module Setting
B FieldBus (0)

- RFID (0)

o Device Setting Protocol : | Asic Link ~

- 15¥ COM1(0) String Save Mode : [First LH HL Change

v g
= PLC1: ASI Systems : ASIL]
5 [] use Redundancy

8 Ethernet (0) AND w
™ Wireless (0) T +
.4 USBDevice (0) T

PLC Setting[ ASI Systems : ASIC/ 2 Series ]
Alizs Name : [PLC1 |

Interface : | Computer Link ~

Ak

Conditior Edi
Primary Option
Timeout m msec
Send Wait msec
Retry 5 z

Bus Address

Comm Manual

£ >

Apply Close
Items Settings Remarks
Interface Configure the communication interface between the TOP and an external device. Refer to "2. External
Protocol Configure the communication protocol between the TOP and an external device. device selection”.

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.

( X Caution: Please set the timeout time to 1000 [mSec] in ASIC Series. )

SendWait (ms)

sending the next command request.

Set the waiting time between TOP’s receiving a response from an external device and
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3.2. Communication setting in TOP

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

B ~ i 1~ '
o o serial
@ System Dey
Run Serial Port: [COM1 " =
; e Signal Level
‘ L) (- RS-232C O RS-422(4) O Rs-485(2) ]
MR sy D Baud Rate: | 9600 -
YNC ip.
; Data Bit: | 8 v
Yiewer [r'-H] r.l [ ‘
e i Stop Bit: | 2 g
'] Ethernet Serial
. Parity Bit: | None -
LE R -
acreod | Sl | Flow: | Off v
B oriee! -~ | | 5
, - Fils [Auto Search] [Loopback TestJ

Manager

‘ Apply H Cancel l —

Ulose

[System]

TOPRX - TOPRX0D800S A 2021-09-01 10:49:44 AW
Items TOP External device Remarks
Signal Level (port) RS-232C/RS-485 RS-232C/RS-485
Baud Rate 9600 Fixed
Data Bit 8 Fixed
Stop Bit 2 Fixed
Parity Bit None Fixed

* The above settings are setting examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting
M [Main Screen > Control Panel > PLC]

ks o) RILC

@ System| Driver(COM1) [PLC1(ASI Systems : ASIC/2 Ser

ies) 'l

Interface | Computer Link 4
!lllu Protocol | Asic Link R4
PLC Timeout 1000 |3 msec

Send Wait msec

{11 ety :
[«
S Bus Addre 7040 |5

Diagnost ic

[System] [ Diagnostic

A

[ App |y “Cancel’

TOPRX - TOPRX0800S A 2021-09-01 10:-50:-08 AM

Items Settings Remarks
Interface Configure the communication interface between the TOP and an external device. Refer to “2. External
Protocol Configure the communication protocol between the TOP and an external device.

device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

( X Caution: Please set the timeout time to 1000 [mSec] in ASIC Series. )

SendWait (ms)

Set the waiting time between TOP's receiving a response from an external device

and sending the next command request.

BUS Address
(Prefix)

Set BUS Address (Prefix) for communication device.
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3.3 Communication diagnostics

B Check the interface setting status between the TOP and an external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information OK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG L .
diagnostics 3. Communication setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name OK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings OK NG . .
4. External device setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External Device Settings

Use "ASI Visual Expert” and set together as follows. Reboot the external device after downloading the configuration.

For a more detailed setting method than described in this example, refer to the user manual of the external device.

Step 1. The information window is activated on the screen when you connect to the controller after running "ASI Visual Expert".

Step 2. "ASI Visual Expert" — Click “System Bus" at the top of the information window to activate information about it.
(XInformation about “System Bus" is the communication details of ASIC Controls to RS485.)

| Local Bus | IP Config | Diagnastics |

System [

InstanceM ame: 5Y5-00

Syztem Bus Address: (7540
Syztem Baud Rate: 9600

Token Enable:[ Mo

System Global Enable:| Mo

Output Disable:] Mo
MotifyDisable:| Mo

DialManagerDisable:[ Mo Polling Disable:[ Mo

Broadcast Disable:[ Mo
Group Address 1:/0 D A Remote Point Disable:[~ Mo
Time BroadcastDisable:[ Mo

Group Address 2:0
ASIC/2-7540 Configuration -- Copyright ?A5] Controls, 1997-2006

Step 3. "ASI Visual Expert” — Click “Local Bus” at the top of the information window to activate information about it.

(XInformation about “Local Bus” is the communication details of ASIC Controls to RS232C.)

System | System Bus { i IP Config | Diagnostics |

InstanceName: SYS-00

Group Pass-Thru Disable:[” Mo
Local Bus Address: 7040 Global Pass-Thru Disable:] Mo
Local Baud Rate: 9600 High Pass-thru Addr: 0
Low Pass-thru Addr: 0
Polling Disable:| Mo
Polling Pause Time: 0
Broadcast Disable:/~ Mo

Modbus Enable:]” Mo

o (b [

Display Mangager Enable:] No Display and Keypad cannot be used with Polling or Broadcast
Display List Enable:/ Mo

ASIC/2-7540 Configuration - Copyright 7451 Controls, 1997-2006

Step Reference. The communication settings are set in 'System/Local Baud Rate’, and other data bits, stop bits, and parity bits

are fixed values.
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5. Cable table
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This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.

(The cable diagram described in this section may differ from the recommendations of “SAI - DDC Monitoring (ASIC/2 Series)")

5.1. Cable table 1

W RS232 connection

TOP COM Port (9 pin)

TOP COM External device
Pin Signal Pin Cable connection Pin Signal Pin
arrangementNote 1) name number number name arrangement*Note 1)
1 5 1 5
(© Q) RD 2 2 SD (© ©)
Q e SD 3 3 RD Q S
6 9 6 9
Based on Based on
SG 5 5 SG

communication

cable connector

front,

D-SUB 9 Pin male

(male, convex)

communication
cable connector
front,
D-SUB 9 Pin male

(male, convex)

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
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5.2. Cable table 2
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B RS485 connection

TOP COM Port (9 pin)

TOP COM External device
Pin Signal Pin Cable connection Signal ;
Pin arrangement*note 1)
arrangement-Note 1) name number name
1 5 RDA 1 D+
(@ o) 2 D-
Q Q, 3 SG D+ D- SG
6 9
Based on
communication 56 > Based on communication cable
cable connector SDA 6 connector front,
front, 7 Terminal Block 3 Pin
D-SUB 9 Pin male 8
(male, convex) SDB 9

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.

TOP COM External device
. Signal Cable connection i
Pin arrangement Signal name
name
+ DA(Pin 1)
_ — DB(Pin 2)
©)
| SG
| =
+
®)
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6. Support Address

The devices available in TOP are as follows:
The device range (address) may differ depending on the CPU module series/type. The TOP series supports the
maximum address range used by the external device series. Please refer to each CPU module user manual and be

take caution to not deviate from the address range supported by the device you want to use.

Contents Bit Address Word Address 32 Bit Remarks
W 00:000:000.0 ~ 99:255:255.15 00:000:000 ~ 99:255:255
B 00:000:000.0 ~ 99:255:255.15 00:000:000 ~ 99:255:255
— Reference
Device Object (2) Index (3) Attribute (3)
Formation 99 (Maximum) 255 (Maximum) 255 (Maximum)
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