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KDT Systems Co., Ltd.  

CIMON PLC Series  

HMI Protocol Serial Driver 
 Supported version TOP Design Studio V1.4.9.85 or higher  
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1. System configuration 

The system configuration of TOP and KDT Systems Co., Ltd. – CIMON HMI Protocol is as follows: 

 

Series CPU Link I/F 
Communication 

method 
System setting Cable 

XP 

CM1-XP1S 

CM1-XP1F 

CM1-XP2F 

CM1-XP3F 

CM1-XP1E 

CM1-XP2E 

CM1-XP3E 

Built-in Serial RS-232C 

3. TOP communication 

setting 

4. External device setting 

5. Cable table 

CM1–SC02A 

CM1-SC02CDMA 

RS–232C 

RS-422/485 

CM1–SC01A RS–232C 

CM1–SC01B RS–422/485 

CM1–XP1R 

CM1–XP1A 

CM1–XP2A 

CM1–XP3A 

CM1–SC02A 

CM1-SC02CDMA 

RS–232C 

RS-422/485 

CM1–SC01A RS–232C 

CM1–SC01B RS–422/485 

CP 

CM1-CP3E 

CM1-CP4E 

CM1-CP4F 

CM1-CP4C 

Built-in Serial RS-232C 

CM1–SC02A 

CM1-SC02CDMA 

RS-232C 

RS-422/485 

CM1–SC01A RS–232C 

CM1–SC01B RS–422/485 

CM1-CP4D 

CM1-CP4U 

Built-in Serial RS-485 

CM1–SC02A 

CM1-SC02CDMA 

RS-232C 

RS-422/485 

CM1–SC01A RS–232C 

CM1–SC01B RS–422/485 

CM1–CP3A 

CM1–CP3B 

CM1–CP3P 

CM1–CP3U 

CM1–CP4A 

CM1–CP4B 

CM1–SC02A 

CM1-SC02CDMA 

RS-232C 

RS-422/485 

CM1–SC01A RS–232C 

CM1–SC01B RS–422/485 

PLC-S 

CM3-SP32MDT 

CM3-SP32MDTE 

CM3-SP32MDC 

CM3-SP32MDCE 

CM3-SP16MDR 

CM3-SP16MDRE 

Built-in Serial RS-232C 

CM3-SP02ERS 

CM3-SP02ERSC 

RS–232C 

RS–422/485 

CM3-SP02ERR 

CM3-SP02ERC 
RS-232C 

CM3-SP32MDTV 

CM3-SP32MDTF 

CM3-SP32MDCV 

CM3-SP32MDCF 

CM3-SP16MDRV 

CM3-SP16MDRF 

Built-in Serial 
RS–232C 

RS–485 

CM3-SP02ERS 

CM3-SP02ERSC 

RS–232C 

RS–422/485 

CM3-SP02ERR 

CM3-SP02ERC 
RS-232C 
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■ Connectable configuration 

ㆍ1:1 connection 
 

                      

 

 

ㆍ1:N connection 
 

                          ∙∙∙    
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 
 

 

Settings Contents 

TOP Model Check the display and process of TOP to select the touch model. 

External device 

Vendor 
Select the vendor of the external device to be connected to TOP. 

Select “KDT Systems”. 

PLC 

Select an external device to connect to TOP. 
 

Model Interface Protocol 

CIMON PLC Series Serial HMI Protocol 
 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [Project] → [Property] → [TOP Setting] → [HMI Setup] → [Use HMI Setup Check] → [Edit] → [Serial] 

– Set the TOP communication interface in TOP Design Studio. 

 
 

 
 

 

Items TOP External device Remarks 

Signal Level (port) RS-232C 

RS-422/485 

RS-232C 

RS-422/485 
 

Baud Rate 38400  

Data Bit 8  

Stop Bit 1  

Parity Bit None.  

* The above settings are examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device. 

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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(2) Communication option setting 

■ [Project] → [Project Property] → [Device Setting > COM > CIMON PLC Series] 

– Set the options of the CIMON PLC Series HMI Protocol communication driver in TOP Design Studio. 
 

 

 

Items Settings Remarks 

Interface Select “Serial”. Refer to “2. External 

device selection”. Protocol Select “HMI Protocol”. 

TimeOut (ms) Set the time to wait for a response from an external device.  

SendWait (ms) Set the waiting time before sending a data request to an external device.  

Station No Enter the prefix of an external device.  
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3.2. Communication setting in TOP  

* This is a setting method when "Use HMI Setup" in the setting items in "3.1 TOP Design Studio" is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

   

(1) Communication interface setting 

■ [Control Panel] → [Serial] 
 

 

Items TOP External device Remarks 

Signal Level (port) RS-232C 

RS-422/485 

RS-232C 

RS-422/485 
 

Baud Rate 38400  

Data Bit 8  

Stop Bit 1  

Parity Bit None.  

* The above settings are setting examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device. 

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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(2) Communication option setting 

■ [Control Panel] → [PLC] 
 

 

Items Settings Remarks 

Interface Select “Serial”. Refer to “2. External 

device selection”. Protocol Select “HMI Protocol”. 

TimeOut (ms) Set the time to wait for a response from an external device.  

SendWait (ms) Set the waiting time before sending a data request to an external device.  

Station No Enter the prefix of an external device.  
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check that the settings of the connected ports in [Control Panel] → [Serial] are the same as the settings of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication Diagnostics” in [Control Panel] → [PLC]. 

- Check whether communication is connected or not. 
 

Communication 

diagnostics 

succeeded 

Communication setting normal 

Error message Communication setting abnormal 

- Check the cable, TOP, and external device settings. (Refer to Communication diagnostics sheet.) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  OK NG 6. Supported addresses 
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4. External device setting 
 

Refer to the user manual of the vendor and configure the communication channel options. 
 

Items Settings Remarks 

Operation mode Protocol HMI protocol Fixed 

Prefix 0  

Communication 

parameter 

Communication speed (BPS) 38400   

 None  

Data bit 8  

Stop bit 1  

 0  
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5. Cable table 

This chapter introduces a cable diagram for normal communication between the TOP and the external device. 

(The cable diagram described in this section may differ from the recommendations of “KDT Systems Co., Ltd.”) 
 

■ RS-232C 

TOP 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

 1  1  

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RD 2 2 RD 

SD 3 3 SD 

 4 4  

SG 5 5 SG 

 6 6  

 7 7  

 8 8  

 9 9  

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-422 

TOP 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 
Pin arrangement 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  SDA 

 

 2 SDB 

 3 RDA 

RDB 4 RDB 

SG 5 SG 

SDA 6  

 7 

 8 

SDB 9 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-485 

TOP 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Signal 

name 
Pin arrangement 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  SDA 

 

 2 SDB 

 3 RDA 

RDB 4 RDB 

SG 5 SG 

SDA 6  

 7 

 8 

SDB 9 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 
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■ RS-485 

TOP 

Cable connection 

External device 

Pin arrangement 
Signal 

name 

Signal 

name 
Pin arrangement 

 

+  SDA 

 

- SDB 

SG RDA 

 

RDB 

SG 

 

 

 

■ RS-232C 

TOP 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

CD 1  1  

 

Based on 

communication 

cable connector 

front, 

8-pin male RJ45  

(Male, convex) 

RD 2 2  

SD 3 3  

DTR 4 4 SG 

SG 5 5 RD 

DSR 6 6 SD 

RTS 7 7  

CTS 8 8  

 9  

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 
 

■ RS-422 

TOP 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  1 SDA 

 

Based on 

communication 

cable connector 

front, 

8-pin male RJ45  

(Male, convex) 

 2 2 SDB 

 3 3 RDA 

RDB 4 4  

SG 5 5 RDB 

SDA 6 6  

 7 7  

 8 8 SG 

SDB 9  

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 
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■ RS-485 

TOP 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  1 SDA 

 

Based on 

communication 

cable connector 

front, 

8-pin male RJ45  

(Male, convex) 

 2 2 SDB 

 3 3 RDA 

RDB 4 4  

SG 5 5 RDB 

SDA 6 6  

 7 7  

 8 8 SG 

SDB 9  

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-485 

TOP 

Cable connection 

External device 

Pin arrangement 
Signal 

name 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 

1) 

 

+  1 SDA 

 

Based on 

communication 

cable connector 

front, 

8-pin male RJ45  

(Male, convex) 

- 2 SDB 

SG 3 RDA 

 

4  

5 RDB 

6  

7  

8 SG 

 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-422 1:N connection – Refer to 1:1 connection to connect in the following way. 

TOP 
Cable connection and signal direction 

External device Cable connection and signal 

direction 

External device 

Signal name Signal name Signal name 

RDA 

 

SDA 

 

SDA 

RDB SDB SDB 

SDA RDA RDA 

SDB RDB RDB 

SG SG SG 

 

■ RS-485 1:N connection – Refer to 1:1 connection to connect in the following way. 

TOP 
Cable connection and signal direction 

External device Cable connection and signal 

direction 

External device 

Signal name Signal name Signal name 

RDA  SDA  SDA 

RDB SDB SDB 

SDA RDA RDA 

SDB RDB RDB 

SG SG SG 
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6. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

 

Address Bit Word Remarks 

  Input relay X00000– X1023F X00000 – X10230  

  Output relay Y00000 – Y1023F Y00000 – Y10230  

  Sub relay M00000 – M4095F M00000 – M40950  

  Keep relay K00000 – K4095F K00000 – K40950  

  Link relay L00000 – L4095F L00000 – L40950  

Timer contact T0000 – T4095 –––  

 current ––– TC0000 – TC4095  

 setting ––– TS0000 – TS4095  

Counter contact C0000 – C4095 –––  

 current ––– CC0000 – CC4095  

 setting ––– CS0000 – CS4095  

Data register D00000.00 – D32766.15 D00000 – D32766  

 


