FUJI Electric Co., Ltd
MICREX-F Series

Computer Link Driver

Supported version  TOP Design Studio V1.4.4.0 or higher {Rl

TOP

"

CONTENTS

We would like to thank our customers for using M2I's "Touch

Operation Panel (M2] TOP) Series". Read this manual and familiarize
yourself with the connection method and procedures of the "TOP and

external device”.

1. System configuration Page 2

Describes the devices required for connection, the setting of

each device, cables, and configurable systems.

2. External device selection Page 3

‘ Select a TOP model and an external device.

3. TOP communication setting Page 4

Describes how to set the TOP communication.

4. External device setting Page 9

Describes how to set up communication for external devices.

5. Cable table Page 10

Describes the cable specifications required for connection.

6. Supported addresses Page 11

Refer to this section to check the addresses which can

communicate with an external device.
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1. System configuration

The system configuration of TOP and “FUJI Electric Co., Ltd — MICREX-F Series" is as follows:

F80H RS-232C

F120H FFU120B RS-422

F230 RS-485

F30

F50 RS-232C

F60

£70 FFK120A-C10

F70S RS-422

F80 RS-485 3. TOP communication
MICREX-F FSOH setting 5. Cable table

F81 4. External device setting

F120

F120H FFK100A-C10 RS-232C

F120S

F200

F250

70 NC1L-RS2 RS-232C

F70S NC1L-Rs4 RS-485

W Connection configuration

- 1:1 (one TOP and one external device) connection

i 1

* 1:N (one TOP and multiple external devices) connection

) N
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device H
PLC select [COM1]
Filter : |[AII] v‘ Search : I:I
@ Model (O Vendor
vendor Wodel
EMOTIONTEK ~ & MICREX-5X Series

RKC Instrument Inc.

& FRENIC 50006115/P115

HANYOUNG NUX ;ﬂ MICREX-F Series

SAMWONTECH

SICK AG.

SANGII Predision Co., Ltd.
DEVA

OPTICON

TOHNICHL

Giddings & Lewis Motion Control
DELTA TAU Data Systems
KEYENCE Corporation

Ninital Flertronics Cornoratinn

4_Back | B Next *® Cancel

Select Device n

PLC Setting[ MICREX-F Series ]

Alizs Mame @ |PLCL

Interface : | Computer Link ~

Protocol : |PC Link {Ascii) ~
String Save Mode : |First LH HL Change

[ use Redundancy
AND v

Primary Option
Timeout 300 &|| msec

Send Wait

Station No.

File Register

@ Back + OK * Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select “FUJI Electric Co., Ltd".
PLC Select an external device to connect to TOP.

Protocol

Interface

MICREX-F Series Computer Link Set Users

Supported Protocol
PC Link (Ascii)

PC Link (Binary)

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that
of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting

M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Serial]
— Set the TOP communication interface in TOP Design Studio.

Project Option X
-ChangeHMllﬂ] [ PR T ChangePLCIC) | [ Delete PLCID)
me Date / Time Sync.  Screen Option  Unit Convert
" -Einﬁ_”lzgd“‘(enfemng Project Option | Screen Change  HmiSetup = Global Lock & Touch | Project Style  Splash = PLC Buffer Sync.
L % RFID (0) Use HMI Setup
"'%_E;VE;;EITT)Q e Initialization | Edit |
{ l.m PLC1: MICREX-F Series Project Sating -
T5® Com2 (0) HMIDisable =0
Ta¥ COM3 (0) Project Mame =New project
Ethernet (0) Start Mode =Menu
- Wireless (0) E?&iz:igmm:l
i USBDevice (0) Latch Set=0n~0
Communication Error Message=0
USBErrorMessage =0
StorageErrorMessage=1
DatabaseMessage =1
Control Panel
. | . = El .
System m Devices [~ | service =" Option
i Serial d
(S
11 | Serial Port: COM1 v
PLE Security Date/Ti Signal Level
() R5-232C (@ RS-422(4) (O RS-485(2)
Baud Rate: 3500 M
""l" _-_ '\__ Data Bit: & M
Ethernet Serial HOH | Stop Bit: 1 -
Parity Bit: Even ©
I = % Flow: [0f
e )
A Pin Auto Search  Loopback Test
Diagnost ic File Fing
Manager
Apply | Cancel
Items TOP External device Remarks
Signal Level (port) RS-232C
d P RS-232C
(CPU port)
Baud Rate 9600
Data Bit 8
Stop Bit 1
Parity Bit Even

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting
M [Project > Project Property > Device Setting > COM > "PLC1 : MICREX-SX Series"]
— Set the options of the MICREX-SX Series communication driver in TOP Design Studio.

TOP ooz e
Touch Qperation Panel

Project Option

- Change HMI[H]

W Acd PLC Al Tl Change PLCIC)

[ Delete PLCID)

v {3 TOF Setting
i [ 5YS: RD1520%

B FieldBus (0)

- RFID (0)

W -igy Device Setting
v fg¥ COM1(1)

Option Module Setting

PLC Setting[ MICREX-F Series ]

Alizs Name : [PLC1

8 Ethernet (0)
™ Wireless (0)
4§ USBDevice (0)

- PLC1 : MICREXF Series

Interface : | Computer Link ~
Protocol @ |PC Link {Asdii) ~
String Save Mode : |First LH HL Change
[] use Redundancy
AND w
TimeO c, -
e0 5 -
Conditio Edi
Primary Option
Timeout m msec
Send Wait msec
Retry 5 z
File Register

Apply Close
Items Settings Remarks
Interface Select the TOP communication interface. Refer to "2. External
Protocol

Select the TOP communication protocol.

device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP’s receiving a response from an external device and
sending the next command request.

Comm. Address

Enters the SX Bus Station number of the external device.
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3.2. Communication setting in TOP

TO BRI HE B X
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* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

Run

-

Conikroll Panel

Serial

Serial Port: lCUhﬂ “'

Signal Level
‘ () RS-232C @ RS-422(4) (O R5-485(2) l
Baud Rate: l 9600 “l
¥NC e
Yiewver ""l" L-_' Data Bit: l g ‘vl
e Stop Bit: |1 ~|
[ ] Et hernet Serial
4©° Parity Bit: | Even ~|
T P
= Flow: | 07 B
3
il S
, , . lAuto Searchl [Loopback Test]
Diagnost ic File
Manager
_Apply | Cancel | ||
[ System ] Close r
Items TOP External device Remarks
Signal Level (port) RE125 RS-422
(CPU port)
Baud Rate 9600
Data Bit 8
Stop Bit 1
Parity Bit Even

* The above settings are setting examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting
M [Main Screen > Control Panel > PLC]

e

o

@ System| Driver(COMI)

PLE

[ PLGT(MICREX-F Series) v]

| Computer Link -]
FBE Uink hseiiy ™+

300 [3)meec

msec

Ii
CRT0

Unu

Interface
!| | | Frotocol
PLC Timeout
send Wait
[,J-L] | Retry
"""l station b
Et hernet
File Reai
Diagnost ic
[System] l Diagnostic

TO,

ERI2 e B X
Touch Qperation Panel

"

| Aeply | Cancel |

G

Items Settings Remarks

Interface Select the TOP communication interface. Refer to "2. External
Protocol Select the TOP communication protocol. device selection”.
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.

SendWait (ms) Set the waiting time between TOP's receiving a response from an external device

and sending the next command request.

Comm. Address

Enters the SX Bus Station number of the external device.
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3.3 Communication diagnostics

B Check the interface setting status between the TOP and an external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the port (COM1/COM?2) settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information OK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
. . oK NG . ;
diagnostics 3. Communication setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name OK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings OK NG . .
4. External device setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

Refer to the communication settings manual of the external device for configuration.
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TOP 225 -
5. Cable table

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.

(The cable diagram described in this section may differ from the recommendations of “FUJI Electric Co., Ltd.")

W RS-422 (1:1 connection)

coM MELSEC FX Positioning Controller
Pin Signal Pin Cable connection Pin )
Pin arrangement*note 1)
arrangementNote 1) name number number
RDA 1 1 5
1 5 4
o o 2 2 ‘® .8
o o) 3 3 20 @®)
6 9 RDB 4 4 e O 7
Based on SG 5 s 1 '\v-”-\_‘. ./6
communication DA 6 6 1?3-/
cable connector 7 7
Based on communication
front, 8 8 b ;
D-SUB 9 Pin male 5 cable connector front,
MINI-DIN 8 Pi | |
(male, convex) SDB 8 Pin male (male,

convex)

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
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6. Supported addresses
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The devices available in TOP are as follows:

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Device Description Bit Word Size Remarks
B I/O relay B000.00 - B511.15 B0OO - B511 16 bit
M Auxiliary relay M000.00 - M511.15 M000 - M511 16 bit
K Keep relay K00.00 - K63.15 K00 - K63 16 bit
F Special relay F0000.00 - F4095.15 FO000 - F4095 16 bit
A Announce relay A0000.00 - A4095.15 A0000 - A4095 16 bit
D Different relay D00.00 - D63.15 D00 - D63 16 bit
W9 Current value of 0.1 sec timer - W9.000 - W9.511 32 bit
TS Set value of timer - TS000 - TS511 32 bit
TR Current value of timer - TROOO - TR511 32 bit
(& Set value of counter - CS000 - CS255 32 bit
CR Current value of counter - CRO00 - CR255 32 bit
DB Data memory - BD000O - BD4095 32 bit
WL No. 1 block WL000.00 - WL511.15 WL000 - WL511 16 bit
W21 P-link station No. 2 block W21.0000.00 - W21.4095.15 W21.0000 - W21.4095 16 bit
W22 0 memory No. 3 block W22.0000.00 - W22.4095.15 W22.0000 - W22.4095 16 bit
W23 No. 4 block W23.0000.00 - W23.4095.15 W23.0000 - W23.4095 16 bit
W24 Direct I/O W24.000.00 - W24.255.15 W24.000 - W24.255 16 bit
W30
- File memory W30.0000.00 - W109.4095.15 W30.0000 - W109.4095 16 bit
W109
W120 No. 1 block W120.0000.00 - W120.4095.15 [ W120.0000 - W120.4095 16 bit
W121 P-link station No. 2 block W121.0000.00 - W121.4095.15 [ W121.0000 - W121.4095 16 bit
W122 1 memory No. 3 block W122.0000.00 - W122.4095.15 [ W122.0000 - W122.4095 16 bit
W123 No. 4 block W123.0000.00 - W123.4095.15 [ W123.0000 - W123.4095 16 bit
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