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RS Automation 

X8 Series  

X8_Xnet Ethernet 
 Supported version TOP Design Studio V1.0 or higher  

 

 

 

CONTENTS 

We would like to thank our customers for using M2I's "Touch 

Operation Panel (M2I TOP) Series". Read this manual and familiarize 

yourself with the connection method and procedures of the “TOP and 

external device”. 

 

 

 

1. System configuration Page 2 

 

 

Describes the devices required for connection, the setting of 

each device, cables, and configurable systems. 

2. External device selection  Page 3 

 Select a TOP model and an external device. 

3. TOP communication setting Page 4 

 Describes how to set the TOP communication. 

4. External device setting Page 9 

 Describes how to set up communication for external devices. 

5. Supported addresses Page 11 

 Refer to this section to check the addresses which can 

communicate with an external device. 
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1. System configuration 

The system configuration of TOP and “RS Automation – X8 Series” is as follows: 
 

Series CPU Link I/F 
Communication 

method 
System setting Cable 

X8 

X8-M32DDT 

X8-M14DDT 

X8-M16DDR 

CPU Port Ethernet (TCP) 
3.1 Settings example 1 

(Page 4) 

Twisted pair 

Cable*Note 1) 

 

■ Connectable configuration 

 

ㆍ1:1 connection (one TOP and one external device) connection 

 

 

ㆍ1:N connection (one TOP and multiple external devices) connection 

 

 

ㆍN:1 connection (multiple TOPs and one external device) connection 

 



 

 External device connection manual for TOP Design Studio 3 / 10 

2. External device selection 

■ Select a TOP model and a port, and then select an external device. 

 

 
 

 
 

Settings Contents 

TOP Model Check the TOP display and process to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Select “RS Autoamtion”. 

PLC Select the external device to be connected to the TOP. 
 

Select “X8 Xnet”.  

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [ Project > Project properties > TOP settings] → [Project option > Check “Use HMI settings” > Edit > Ethernet ] 

– Set the TOP communication interface in TOP Design Studio. 

 

 

 
 

Items TOP External device Remarks 

IP Address*Note 1) Note 2) 192.168.0.50 192.168.0.51  

Subnet Mask 255.255.255.0 255.255.255.0  

Gateway 192.168.0.1 192.168.0.1  

*Note 1) The network address of TOP and the external device (the first three digits of the IP 192 . 168 . 0 . 0 ) must be the same. 

*Note 2) Do not use duplicate IP addresses over the same network. 

* The above settings are examples recommended by the company. 

 

 

Items Description 

IP Address Set an IP address to be used by the TOP to use over the network. 

Subnet Mask Enter the subnet mask of the network. 

Gateway Enter the gateway of the network. 
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(2) Communication option setting 

■ [ Project > Project properties > PLC settings > ETHERNET > “PLC1 : RS Automation X8 Series 

– Set the options of the communication driver of Control/Compact Logix Series Ethernet in TOP Design Studio. 

 
* The above settings are examples recommended by the company. 

 

Items Settings Remarks 

Interface Select “Ethernet”. Refer to “2. External 

device selection”. Protocol Select “EtherNet/IP”. 

IP Enter the IP address of the external device.  

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

Port Enter “1024”, the Ethernet communication port number of the external device. Fixed 
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen.  

   

(1) Communication interface setting 

■ [ Main screen > Control panel > Ethernet ] 
 

 

 

Items TOP External device Remarks 

IP Address*Note 1) Note 2) 192.168.0.50 192.168.0.51  

Subnet Mask 255.255.255.0 255.255.255.0  

Gateway 192.168.0.1 192.168.0.1  

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 168 . 0 . 0) should match. 

*Note 2) Do not use duplicate IP addresses over the same network. 

* The above settings are examples recommended by the company. 

 

 

Items Description 

IP Address Set an IP address to be used by the TOP to use over the network. 

Subnet Mask Enter the subnet mask of the network. 

Gateway Enter the gateway of the network. 
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 (2) Communication option setting 

■ [ Main screen > Control panel > PLC ] 
 

 
* The above settings are examples recommended by the company. 

 

Items Settings Remarks 

Interface Select “Ethernet”. Refer to “2. External 

device selection”. Protocol Select “EtherNet/IP”. 

IP Enter the IP address of the external device.  

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

Port Enter “1024”, the Ethernet communication port number of the external device. Fixed 
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check whether the Eth port settings you want to use are the same as those of the external device in [Control panel > Ethernet]. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC ]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Ethernet port setting IP Address OK NG 

Subnet Mask OK NG 

Gateway OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Ethernet port setting IP Address OK NG 

Subnet Mask OK NG 

Gateway OK NG 

Check address range  

OK NG 

5. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 
 

 Set as below using “X8 Series Ladder Software XGPC”. 

Reboot the external device after downloading the configuration 

For a more detailed setting method than described in this example, refer to the user manual of the external device. 
 

 
Check the node address and line control method. 

 

Step 1. Upload the PC and XGPC S/W. 

Step 2.  From the tool bar left of the XGPC S/W, double click Channel Configuration. 

       ( X8-M Toolbar → ‘Comms Config’ → ‘Channel Configuration’ → ‘Ethernet’ ) 

 

 

 

 

 

 

 

 

 

 

 

 

 

Step 3.  From the Channel Configuration window, configure the Parameter.  

▣ IP Config  

 ▷ IP Config Method : Static IP 

- BOOTH Client: If BOOTP is selected, X8 PLC tries to acquire 

network-related parameters through BOOTP request when the power 

is turned on.  

- DHCP Client: If DHCP is selected, the DHCP server automatically 

assigns network-related parameters to the X8 PLC when logging into 

the TCP/IP network.  

- Static IP: If Static IP is selected, you can input and set IP address, 

Subnet mask, Default gateway, Domain name and DNS at the 

bottom.  

▣ Port Config  

 ▷ Negotiation : AutoNegotiate 

▷ Port Speed : Half Duplex 

▣ Protocol Enable Config *Remark1) 

 ▷ Xnet over IP : 1(Enable) 

(Check ‘1(Enable)’ when using the X8 official communication protocol.) 

*Remark 1) Protocol Enable Conifg additional description 

- Xnet Over IP: When using X8 official communication protocol 

- Modbus TCP: When using Modbus protocol of MODICON 

- EtherNet/IP: When using a protocol officially supported by ODVA 

- Web Server: When using X8 PLC communication for HTTP 

communication 

- Duplicate IP Detection: Used for detecting duplicated IP 

 

▣ Xnet over IP Config 

▷ Local TCP Port Number : ex)1024 ( TCP connect ‘Port’ Number ) 

 

Check the above information and press confirm. 

Step 4.  From the top tool bar go to ‘Online’ → Click ‘Download’. 
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5. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

 

Contents Bit Address Word Address 32 Bit Remarks 

Input X 1.0.0.0 ~ 1.1535.0.15 1.0.0 ~ 1.1535.0   

Output Y 0.0.0.0 ~ 0.1535.0.15 0.0.0 ~ 0.1535.0   

Input(by slot) X(by slot) 1.0.0.0 ~ 1:96.511.15 1.0.0 ~ 1.96.511  *Note 1) 

Output(by slot) Y(by slot) 0.0.0.0 ~ 0.96.0.15 0.0.0 ~ 0.96.511  *Note 1) 

System Register SR 2.0.0.0 ~ 2.127.0.15 2.0.0 ~ 2.127.0   

Binary B 3.0.0.0 ~ 1535.1535.0.15 3.0.0 ~ 1535.1535.0   

Integer N 3.0.0.0 ~ 1535.1535.0.15 3.0.0 ~ 1535.1535.0   

Floating Point F – 3.0.0 ~ 1535.1535.0   

Long L 3.0.0.0 ~ 1535.1535.0.15 3.0.0 ~ 1535.1535.0   

ASCII A 3.0.0.0 ~ 1535.1535.0.15 3.0.0 ~ 1535.1535.0   

String ST – 3.0.0 ~ 1535.799.41   

Timer TM 3.0.0.0 ~ 1535.1535.4.15 3.0.0 ~ 1535.1535.4  *Note 2) 

Timer Preset TM Preset 3.0.1.0 ~ 1535.1535.1.31 3.0.1 ~ 1535.1535.1 ∨  

Timer Accumulator TM Accumulator 3.0.3.0 ~ 1535.1535.3.31 3.0.3 ~ 1535.1535.3 ∨  

Counter CT 3.0.0.0 ~ 1535.1535.4.15 3.0.0 ~ 1535.1535.4  *Note 3) 

Counter Preset CT Preset 3.0.1.0 ~ 1535.1535.1.31 3.0.1 ~ 1535.1535.1 ∨  

Counter Accumulator CT Accumulator 3.0.3.0 ~ 1535.1535.3.31 3.0.3 ~ 1535.1535.3 ∨  

Control CR 3.0.0.0 ~ 1535.1535.4.15 3.0.0 ~ 1535.1535.4  *Note 4) 

Control Length CR Length 3.0.1.0 ~ 1535.1535.1.31 3.0.1 ~ 1535.1535.1   

Control Position CR Position 3.0.3.0 ~ 1535.1535.3.31 3.0.3 ~ 1535.1535.3   

 

*Note 1) X (by slot), Y (by slot) Device Format 

Ex) Configurations for 1, 2, 3, and 4 of X (by slot) are as follows: (Same for Y (by slot).) 

Notation X 1 .2 .3 .4 

Description Device Name Table Address Slot Number Word Offset Bit Position 

 

*Note 2) TM Address Details 

Details for each bit of the 16 bit data of the TM address are as follows. 

8th Bit 9th Bit 13th Bit 14th Bit 15th Bit 

Time Base 0 Time Base 1 Done Timer Timing Enable 

 

*Note 3) CT Address Details 

Details for each bit of the 16 bit data of the CT address are as follows. 

11th Bit 12th Bit 13th Bit 14th Bit 15th Bit 

Underflow Overflow Done Count Down Count Up 

 

*Note 4) CR Address Details 

Details for each bit of the 16 bit data of the CR address are as follows. 

8th Bit 9th Bit 10th Bit 11th Bit 

Found Inhibit Unload Error 

12th Bit 13th Bit 14th Bit 15th Bit 

Empty Done Enable. Unload Enable 

 


