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AJINEXTEK CO,.LTD 

SDC-N404 Series  

Computer link 
 Supported version TOP Design Studio V1.0 or higher  

 

CONTENTS 

We would like to thank our customers for using M2I's "Touch 

Operation Panel (M2I TOP) Series". Read this manual and familiarize 

yourself with the connection method and procedures of the “TOP and 

external device”. 

 

1. System configuration Page 2 

 

 

 

Describes the devices required for connection, the setting of 

each device, cables, and configurable systems. 

2. External device selection  Page 3 

 Select a TOP model and an external device. 

3. TOP communication setting Page 4 

 Describes how to set the TOP communication. 

4. External device setting Page 9 

 Describes how to set up communication for external devices. 

5. Cable table Page 10 

 Describes the cable specifications required for connection. 

6. Supported addresses Page 11 

 Check for addresses that can communicate with an external 

device. 
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1. System configuration 

The system configuration of TOP and “AJINEXTEK CO,.LTD – SDC-N404 Series” is as follows. 

 

Series CPU Link I/F 
Communication 

method 
System setting Cable 

SDC-N404 All CPU Loader Port(DSUB 9 pin)  RS–232C 
3. TOP communication 

setting 
5. Cable table 

 

 

■ Connection configuration 
 

ㆍ1:1 (one TOP and one external device) connection – configuration which is possible in RS232C communication. 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 
 

 

Settings Contents 

TOP Model Check the display and process of TOP to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Select “AJINEXTEK CO,.LTD.” 

PLC Select an external device to connect to TOP. 

Select “SDC-N404.” 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 



 

 External device connection manual for TOP Design Studio 4 / 12 

3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [ Project > Project properties > TOP settings] → [Project option > Check “Use HMI settings” > Edit > Serial ] 

– Set the TOP communication interface in TOP Design Studio. 
 

 

 

 
 

Items TOP External device Remarks 

Signal Level (port) RS-232C RS-422 RS-485 RS-232C 

RS-422/485 
 

Baud Rate 38400  

Data Bit 8  

Stop Bit 1  

Parity Bit None.  

* The above settings are examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device. 

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [ Project > Project properties > PLC settings > COM > “PLC1 : AJINEXTEK PLC Series”] 

– AJINEXTEK CO,.LTD – SDC-N404 Series. Set the options of the communication driver in TOP Design Studio. 

 

 

Items Settings Remarks 

Interface Select “Computer Link”. Refer to “2. External 

device selection”. Protocol Select “Computer link”. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

Retry Select the number of communication retries.  
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

   

(1) Communication interface setting 

■ [ Main screen > Control panel > Serial ] 
 

  

Items TOP External device Remarks 

Signal Level (port) RS-232C RS-422 RS-485 RS-232C 

RS-422/485 
 

Baud Rate 38400  

Data Bit 8  

Stop Bit 1  

Parity Bit None.  

* The above settings are setting examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device. 

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [ Main screen > Control panel > PLC ] 
 

  

Items Settings Remarks 

Interface Select “Computer Link”. Refer to “2. External 

device selection”. Protocol Select “Computer link”. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
 

Retry Select the number of communication retries.  
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC ]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Serial Parameter Transmission Speed OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial Parameter Transmission Speed OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  

OK NG 

6. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device settings 
 

- Refer to the manual of the external device and configure the communication options. 
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5. Cable table 

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. (The cable 

diagram described in this chapter may differ from the recommendations of “AJINEXTEK CO,.LTD.”) 

 

■ RS-232C (1:1 connection) 

COM 

Cable connection 

PLC 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

CD 1  1 CD 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RD 2 2 RD 

SD 3 3 SD 

DTR 4 4 DTR 

SG 5 5 SG 

DSR 6 6 DSR 

RTS 7 7 RTS 

CTS 8 8 CTS 

 9 9  

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 
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6. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

■ Status/Settings 

Area Bit address Word Address Remarks 

Axis status AXI0.0 ~ AXI3.7 –––––– *F1 *1 *3 

Full status ROB0.0 ~ ROB3.7 –––––– *F1 *1 *3 

System status SYS0.0 ~ SYS3.7 –––––– *F1 *1 *4 

Mechanical signal MES0.0 ~ MES3.7 –––––– *F1 *1 *5 

Mechanical Active Level MEL0.0 ~ MEL3.7 –––––– *F1 *1 *6 

Motion error status –––––– ERR *1 

Task Status –––––– TS0 ~ TS1 *F3 *1 *7 

 Run TR0 ~ TR1 –––––– *F3 *2 

 Pause TP0 ~ TP1 –––––– *F3 *2 

[Address format] 

*F1 Axis *F3 Task 

*1 Read only  *2 Write only 

*3 Each axis has the following information. *4 Each axis has the following information. *5 Each axis has the following information. 

Bit pos Comment Bit pos Comment Bit pos Comment 

0 Servo-on status 0 Emergency stop status 0 + Limit signal status 

1 Zero return status 1 Alarm status 1 – Limit signal status 

2 Busy status 2 + Limit status 2 Alarm signal status 

3 – Limit status 3 – Limit status 3 In-position signal status 

4 + Limit status 4 In-position status 4 Emergency stop signal status 

5 Alarm status 5 In-motion status 5 Home signal status 

6 Emergency stop status 6 Servo-on status 6 Z-phase signal status 

7 In-position status 7 Alarm clear status 7 (Unused) 

*6 Each axis has the following information. *7 Word data has the following information. 

Bit pos Comment Data Comment 

0 + Limit signal active level 0 Stop 

1 – Limit signal active level 1 Run 

2 Alarm signal active level 2 Pause 

3 In-position signal active level  

4 Emergency stop signal active level  

5 Home signal active level  

6 Z-phase signal active level  

7 (Unused)  

■ Variable 

Area Bit address Word Address Remarks 

Input I0.0 ~ I0.27 –––––– *1 27BIT 

Output O0.0 ~ O0.27 –––––– 27BIT 

M variable –––––– M0/0 ~ M7/3 *F2 32BIT 

Point file ––––– P0/0 ~ P3/9999 *F4 

[Address format] 

*F2 Address *F4 Axis / Address 

*1 Read only 

■ Parameter 

Area Bit address Word Address Remarks 

Encoder input –––––– PE0 ~ PE3 *F1 

Pulse output –––––– PP0 ~ PP3 *F1 

ABS/REL mode –––––– PA0 ~ PA3 *F1 

Profile mode –––––– PF0 ~ PF3 *F1 

Unit/Pulse –––––– PU0 ~ PU3 *F1 

[Address format] 

*F1 Axis 
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■ Axis control 

Area Bit address Word Address Remarks 

Axis command position –––––– ASP0 ~ ASP3 *F1 *1 32BIT 

Axis actual position –––––– ACP0 ~ ACP3 *F1 *1 32BIT 

Axis drive speed –––––– AVE0 ~ AVE3 *F1 *1 32BIT 

Single 

axis 

Position drive Run AM0 ~ AM3 –––––– *F1 *2 *3 

  Drive position –––––– _AM_P 32BIT 

  Drive speed –––––– _AM_V 32BIT 

  Drive acceleration –––––– _AM_A 32BIT 

  Drive deceleration –––––– _AM_D 32BIT 

 Speed drive Run AV0 ~ AV3 –––––– *F1 *2 *4 

  Drive speed –––––– _AV_V 32BIT 

  Drive acceleration –––––– _AV_A 32BIT 

  Drive deceleration –––––– _AV_D 32BIT 

 Drive stop AS0 ~ AS3 –––––– *F1 *2 

 Emergency stop AE0 ~ AE3 –––––– *F1 *2 

Multiple 

axis 

Position drive Run XJ –––––– *2 *5 

  Drive position –––––– _XJ0 ~ _XJ3 *F1 32BIT 

 Interpolation 

drive 

Run XL –––––– *2 *6  

  Drive position –––––– _XL0 ~ _XL3 *F1 32BIT 

 Speed 

setting 

 XV –––––– *2 *7 

  Drive speed –––––– _XV0 ~ _XV3 *F1 32BIT 

 Acceleration 

setting 

 XA –––––– *2 *8 

  Drive acceleration –––––– _XA0 ~ _XA3 *F1 32BIT 

 Deceleration 

setting 

 XD –––––– *2 *9 

  Drive deceleration –––––– _XD0 ~ _XD3 *F1 32BIT 

 Axis setting  XX –––––– *2 *10 

  Drive axis –––––– _XX0 ~ _XX3 *F1 32BIT 

Servo ON/OFF SERVO0 ~ SERVO3 –––––– *F1 *2 

Alarm ON/OFF ALM0 ~ ALM3 –––––– *F1 *2 

Home search H0 ~ H3 –––––– *F1 *2 

Zero position setting ZP0 ~ ZP3 –––––– *F1 *2 

Position compensation setting PC0 ~ PC3 –––––– *F1 *2 

Multi-axis zero return XZ –––––– *2 

[Address format] 

*F1 Axis 

*1 Read only  *2 Write only 

*3 _AM_P, _AM_V, _AM_A, AM_D reference run  *4 _AV_V, _AV_A, AV_D reference run 

*5 _XJ0 ~ _XJ3 reference run *6 _XL0 ~ _XL3 reference run *7 XV0 ~ XV3 reference run *8 XA0 ~ XA3 reference run 

*9 XD0 ~ XD3 reference run *10 XX0 ~ XX3 reference run 

 


