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ABSODEX 
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 Supported version TOP Design Studio V1.4.2 or higher  
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We want to thank our customers who use the Touch Operation Panel. 

 

1. System configuration Page 2 

 

 

Describes the devices required for connection, the setting of 

each device, cables, and configurable systems. 

2. External device selection  Page 3 

 Select a TOP model and an external device. 
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1. System configuration 

The system configuration of TOP and “CKD – ABSODEX Actuator” is as follows: 

 

Series CPU Link I/F 
Communication 

method 

Communication 

setting 
Cable 

CKD ABSODEX Actuator - RS–232C 

3. TOP 

communication 

setting 

4.1. Cable table 1 

 

■ Connection configuration 

 

ㆍ1:1 (one TOP and one external device) connection 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 

 

Settings Contents 

TOP Model Check the TOP display and process to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Select “CKD Corporation”. 

PLC Select an external device to connect to TOP. 
 

Model Interface Protocol 

CKD ABSODEX Computer Link ABSODEX Link 
 

 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [Project > Project Property > TOP Setting] → [Project Option > “Use HMI Setup” Check > Edit > Serial] 

– Set the TOP communication interface in TOP Design Studio. 
 

 

 

 
 

Items TOP External device Remarks 

Signal Level (port) RS-232C RS-232C  

Baud Rate 9600 (fixed) Fixed 

Data Bit 7  

Stop Bit 1  

Parity Bit Odd  

* The above settings are examples recommended by the company. 

 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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(2) Communication option setting 

■ [Project > Project Property > Device Setting > COM > “CKD ABSODEX”] 

– Set the options of the Computer Link communication driver in TOP Design Studio. 
 

 

 

Items Settings Remarks 

Interface Configure the communication interface between the TOP and an external device. Refer to “2. External 

device selection”. Protocol Configure the communication protocol between the TOP and an external device. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
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3.2. Communication setting in TOP  

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

   

(1) Communication interface setting 

■ [Main Screen > Control Panel > Serial] 
 

  

Items TOP External device Remarks 

Signal Level (port) RS-232C RS-232C  

Baud Rate 9600 Fixed 

Data Bit 7  

Stop Bit 1  

Parity Bit Odd  

* The above settings are setting examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device. 

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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(2) Communication option setting 

■ [Main Screen > Control Panel > PLC] 
 

  

 

Items Settings Remarks 

Interface Configure the communication interface between the TOP and an external device. Refer to “2. External 

device selection”. Protocol Configure the communication protocol between the TOP and an external device. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device 

and sending the next command request. 
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  

OK NG 

6. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. Cable table 

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. 

(The cable diagram described in this section may differ from the recommendations of “CKD ABSODEX”) 

 

4.1. Cable table 1 
 

■ RS-232C (1:1 connection) 

 

TOP COM 

Cable connection 

External device 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

CD 1  1 TXD 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RD 2 2 RXD 

SD 3 3 NC 

DTR 4 4 NC 

SG 5 5 FGND 

DSR 6 6 NC 

RTS 7 7 EMG 

CTS 8 8 DGND 

 9 9 +5V 

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
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5. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

(1) Operation Mode 

Device Bit Address Word Address Description Remarks 

M - 0001 ~ 0006 Operation Mode Switching Code Write Only 

 

■ Device Details  

Device Address Description Remarks 

M 0001 Automatic mode Power-on mode 

Mode in which programs are run continuously 

0002 Single block mode Mode in which programs are executed block by block 

0003 MDI(manual data input) 

mode 

Mode in which NC code input through RS232C port is instantaneously 

executed 

0004 Jog mode Communication codes S5 and S6 enable job motion 

0005 Servo off mode Selecting M1 to M4 and M6 will turn the servo ON 

0006 Pulse string input 

mode 

In this mode, operation proceeds according to pulse string input signals.  

Disable motions by using the NC program, and changing parameters. To 

change, switch to M1 to M5 

 

(2) Motion Instructions 

Device Bit Address Word Address Description Remarks 

S - 0001 ~ 0020 Motion Instruction Codes Write Only 

 

■ Device Details  

Device Address Description Remarks 

S 0001 Start Same function as CN3 program start input (Auto run, single block) 

0002 Program stop Same function as CN3 program stop input 

0003 MDI & execution One block of NC code is input and executed. (Note1)  

0004 Home return Same function as home return instruction input 

0005 Jog(CW) Rotation continues in accordance with PRM 14 and 15 until CN3 

program stop input or continuous rotation stop or S2 and S20 

communication code in input 
0006 Jog(CCW) 

0007 Alarm Reset Effective only for alarm 

Same function as that of CN3 answer input 

0010 Answer response Valid only when an answer is waited for. 

Same function as that of CN3 answer input 

0020 Continuous rotation 

stop 

Continuous rotation G7 jog operation stop. 

Same function as CN3 continuous rotation stop input 

(Note1) 

(Note 1) 

For S0003 devices, the NC code for one block can be entered by the user.  

Enter the NC Code by specifying the TOPR internal address and word count (code character count = word count x 2) to store NC 

code in the "Project Information" -> "PLC Comm Info" option as shown in the figure below.  
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The above figure is an example of specifying 50 words (100 characters) from 100 TOP internal addresses to allow the user to enter 

up to 100 characters beginning from NC code 100. 

 

(3) Data Input and Output 

Device Bit Address Word Address Description Remarks 

L01 - 0000 Alarm Number Output Read Only 

L03 - 0000 Current Position Output 

Unit : Pulse 

Coordinate : Actuator coordinate 

Read Only 

L04 - 0000 Current Position Output 

Unit : Degree 

Coordinate : Actuator coordinate 

Read Only 

L05 - 0000 Current Position Output 

Unit : Pulse 

Coordinate : G92 coordinate 

Read Only 

L06 - 0000 Current Position Output 

Unit : Degree 

Coordinate : G92 coordinate 

Read Only 

L07 - 0000 ~ 9999 

(Program Number) 

Parameter Data Input 

(To read PRM) 

Read : L09 

Write : L07 

L07A - 0000 ~ 9999 

(Program Number) 

Parameter Data Input 

(To read PRM in angel unit) 

Read : L09A 

Write : L07A  

L07R - 0000 ~ 9999 

(Program Number) 

Parameter Data Input 

(To read the data on RAM of PRM 8 in angle unit) 

Read : L09R  

Write : L07R 

L10 - 0000 Program Number Output Read Only 

L11 - 0000 ~ 4095 NC Program Input / Output Read : L12 

Write : L11 (note1) 

L12 Not Supported Not Supported Not Supported - 

L13 - 0000 NC program Number/Directory Output Read Only 

L16 - 0000 Designation of Program Number Write Only 

L17 - 0000 Delete of Program Number Write Only 

L18 - 0000 ~ 0002 Change of Program Number Write Only (note2) 

L19 - 0000 Output of the Next Block of Program to be executed Read Only 

L21 - 0000 Mode Output Read Only 

L89 - 0000 Serial actuator number output Read Only 

PRG_RD - 0000 Read NC Program in L11 Buffer Write only (note3) 

PRG_WR - 0000 Write NC Program in L11 Buffer Write only (note3) 

(Note 1) 

(1) Address for program saving and program reading commands run for NC program writing. 

(2) The L11 device is a 32-bit device that saves 4 program characters in one address. 

(3) The program capacity is 16k bites. 
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(Note 2) 

Device Word Address Description Remarks 

L18 0000 Trigger Command for change of Program Number Write Only 

 0001 Current Program number Write Only 

 0002 New Program number Write Only 

 

(Note 3) 

(1) For Write-only PRG_RD device, if you enter the PRG-RD device program number read as data, it reads the program 

number corresponding to the entered data and displays it on the L11 device. 

(2) For Write-only PRG_WR device, if you enter any data (regardless of the data value) on the PRG_WR device, the program 

entered in L11 is sent. 


