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1. System configuration

The system configuration of TOP and “On Off System — NEOS-HSD" is as follows:

Series

Communication method System setting

Heat-Smoke
NEOS-HSD

3. TOP communication setting
RS-485
Detector

; ; 5. Cable table
4. External device setting -

H Connection configuration

+ 1:1 connection

+ 1:N connection

. > - < -
E E E
© ® 3 5 o 3 ®

000000
000000
000000
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device H
PLC select [COM1]
Filter : |[A\I] v| Search : l:l

@ Model (O Vendor

Vendor

Model

FAMUC Co., Ltd.
MINEBEA Co., Ltd.
Azbil Corporation
KORO TECHNOLOGY
ROBOSTAR

Ebmpapst

CaDeSys Automation Alliance

Ophir Optronics Solutions Ltd.

SERVOMEX

Tiger Optics, LLC

B &R Automation

SPEEDTECH : PUL-2000 Series

JISANG : Rectifier

ASN : TBH Sensor

SNC : Flow Meter

SEORIM : PMC3000

MEMORY MAP SLAVE

WILLINGS : Master

SAMAHM TECH : Digital Air Speed Meter
5i TEC @ MUX

DOMNGDO TECH : ML Series

Peripheral Device

OTHERS Manufacture

LA A A AR AR AR A

Human Automation : TSD

73
"" On OFff System : NEOS-HSD
v

M8 Back | W Next
Select Device H

PLC Setting[ On Off System : NEOS-HSD ]

Alias Name ; |PLC1

Interface : | Serial ~

v

® Cancel

Protocol : | Private Protocol ~
String Save Mode @ |First LH HL Change

[J use Redundancy

Comm Manual

Primary Option

Timeout 300 < msec
Send Wait msec
Address No

4 Back v oK ® Cancel
Settings Contents
TOP Model Check the display and process of TOP to select the touch model.
Select the vendor of the external device to be connected to TOP.
Vendor

Select "OTHERS Manufacture”.

Select the external device to be connected to the TOP.

Protocol

Interface

External device

Model On Off System : NEOS-HSD Serial Private Protocol

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that
of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting

M [Project > Project Property > TOP Setting] — [HMI Setup > "Use HMI Setup” Check > Edit > Serial]
— Set the TOP communication interface in TOP Design Studio.

Project Option

Bl crenoe vt W darcia ST Change PLCIC]
——

1 D TOP Setting
Lm?w!gi - ’ 20X

8 Option Module Setting

Date / Time Sync.

Screen Option

E3 Delete PLCDI

Unit Convert

s () Project Option = Screen Change HmiSetup = Global Lock & Touch  Project Style  Splash = PLC Buffer Sync.

i RFID (0)

M ‘-:_f:i‘"é;;alt?';)g Initialization I Edit I
{m PLC1:ON OFf System : NI Profect Setig —
i-fg¥ COM2 (0) HMIDisable=0
158 COM3 (0) Project Name=New project
: Ethernet (0) Start Mode=Menu
g Wireless (0) f?&iz:i’a =l
L. USBDevice (0) Latch Set=0~0

Communication Error Message=0
USBErrorMessage =0
StorageErrorMessage=1
DatabaseMessage=1
Centrel Panel
. [l | !
System m Devices .
i Serial ¥
o — Serial Port: | COM1 M
T y (o
Signal Level
PLLC Security Dat e/ Time () B5-232C () P5-422(4) (@ BS-485(2)
Baud Rate: 115200 '
.-. — Data Bit: |3 M
NI &
Stop Bit: |1 v
Et hernet Serial HOK |
Parity Bit: None o
— Flow: ([ff
e 0. Auto Search  Loopback Test
Diagnost ic File Fing
Manager Apply  Cancel

Items TOP External device Remarks
Signal Level RS-485

Baud Rate 115200

Data Bit 8

Stop Bit 1

Parity Bit None.

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [Project > Project Property > Device Setting > COM1 > "PLC1 : On Off System : NEOS-HSD"]

— Set the options of the On Off System : NEOS-HSD communication driver in TOP Design Studio.

Project Option

“ AddPLC[A] | THITal Change PLCIC)

m Delete PLC[D]

- Change HMIH]
W

TOP Setting
-3 5Y5 ¢ RD1520%
Option Module Setting
-4 FieldBus (0)
- RFID (0)
W - Device Setting
e COML(Y)

PLC Setting[ On Off System : NEOS-HSD ]
Alizs Name : [PLC1 |

Interface : |Serial ~

Protocol @ | Private Protocol ~

8 Ethernet (0)
® Wireless (0)
9 USBDevice (0)

I— PLC1: On Off System : NI
L

String Save Mode : (First LH HL Change

[ use Redundancy

Primary Option

Timeout 200 &1 | msec
Send Wait msec
Retry 5 z
Address No

Comm Manual

£ >

Apply Close
Items Settings Remarks
Interface Select “Serial". Refer to “2. External
Protocol Select "Private Protocol”.

device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP’s receiving a response from an external device
and sending the next command request.

Retry

Configure the amount of redelivery attempts from TOP to external device.

Address No

Set the prefix of an external device.
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3.2. Communication setting in TOP

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting
M [Main Screen > Control Panel > Serial]

Conitkroll Panel

o serial

5| Serial Port: | COMI -

Signal Level
() BS-232C O RS-422(4) @ RS-485(2)

-

Da l
Baud Rate: 115200  |~|

¥HC
Yiewer ] |2E | § Data Bit: |8 -
:--. Et hernet Serial Stop Bit: [ 1 |vl
:g Parity Bit: | None N
M

Screen m . : ] Flow: [Uff
shot .

[Auto Search] lLoopbaCk Testl

Diagnost ic File

| Apply | Cancel | |

Close r

[System]

|

Items External device Remarks
Signal Level RS-485
Baud Rate 115200
Data Bit 8
Stop Bit 1
Parity Bit None.

* The above settings are examples recommended by the company.
Items Description
Signal Level Select the serial communication method between the TOP and an external device.
Baud Rate Select the serial communication speed between the TOP and an external device.
Data Bit Select the serial communication data bit between the TOP and an external device.
Stop Bit Select the serial communication stop bit between the TOP and an external device.
Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

B [Main Screen > Control Panel > PLC]

Jiil] PLC

@ Systel priver(COMD)

PLCT(On OFf System : NEOS-HSD) |

Run

Interface | Serial -~
‘ !hll Protocol | Private Protocol =)
PLC Timeout 300 12 msec
=

YNC Send Wait msec
S [ | e 55
0 5

mmy
E Ethernet Address MNo
- . A
Screen

shot

Diagnost ic

e

[System]

Diagnostic

[ADDIyI[Camcell

.—‘—

Items Settings Remarks

Interface Select “Serial”. Refer to "2. External
Protocol Select “Private Protocol”. device selection”.
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.

SendWait (ms) Set the waiting time between TOP's receiving a response from an external device

and sending the next command request.

Retry Configure the amount of redelivery attempts from TOP to external device.

Address No Set the prefix of an external device.
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3.3 Communication diagnostics

B Check the interface setting status between the TOP and an external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
configuration Connection cable name OK NG 1. System configuration
TOP Version information oK NG
Port in use oK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG ) )
Cormmunication 2. External d.eV|c‘e selectilon
diagnostics OK NG 3. Communication setting
Serial port setting Baud Rate oK NG
Data Bit oK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name oK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings oK NG 4. External device setting
Serial port setting Baud Rate oK NG
Data Bit oK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range oK NG 6. Supported addresses
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4. External device setting
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For more detailed setting method than that described in this example, refer to the On Off System user manual.

¥ Must have the same communication settings as the external device of the TOP. (Reference)

Step 1. Use the DIP switch to configure the prefix (detector address).
® 4 bit address

Switch Bit Value when
number ON

1 Bit 0 1

2 Bit 1 2

3 Bit 2 4

4 Bit 3 8

Ex)

Switch Status

number
1 OFF
2 ON
3 ON
4 OFF

Address 6
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5. Cable table
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This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.
(The cable diagram described in this section may differ from the recommendations of “NEOS-HSD")

m RS-485
TOP External device
Pin Signal Pin Pin Signal
arrangement*Note 1) name number number name
1 5 RDA 1 3 RS485-A
Q Q
6 9
Based on RDB 4 1 RS485-B
communication SG 2 GND
cable connector SDA 6
front,
D-SUB 9 Pin male
(male, convex) SDB 9

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.

M RS-485 (1:N connection

TOP

Signal name

External device

Signal name

SG

GND

External device

Signal name

RDA

RS485-A

GND

RDB

SDA ¢

SDB

RS485-B

RS485-A
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6. Supported addresses
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The devices available in TOP are as follows:
The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum
address range used by the external device series. Please refer to each CPU module user manual

and be take caution to not deviate from the address range supported by the device you want to use.

Double word

Device Bit address Word address R/W Remarks
address
RUN_STATE RUN_STATE RUN_STATE - R Operation status
SMOKE_ALARM SMOKE_ALARM SMOKE_ALARM - R Smoke alarm
Temperature
TEMP_WARNING TEMP_WARNING TEMP_WARNING - R .
warning
Temperature
TEMP_ALARM TEMP_ALARM TEMP_ALARM - R
alarm
CURRENT_TEMP Current
CURRENT_TEMP - - R
(FLOAT) temperature
CURRENT_HUMI o
CURRENT_HUMI - - R Current humidity
(FLOAT)
Temperature
TEMP_WARNING_VALUE )
TEMP_WARNING_VALUE - - R/W warning
(FLOAT)
Reference value
Temperature
TEMP_WARNING_
TEMP_WARNING_DVA_VALUE - - R/W warning
DVA_VALUE (FLOAT) L
Deviation value
Temperature
TEMP_ALARM_VALUE
TEMP_ALARM_VALUE - - R/W alarm
(FLOAT)
Reference value
Temperature
TEMP_WARNING TEMP_WARNING
TEMP_WARNING_CMODE - R/W warning
_CMODE _CMODE o
Maintain usage
Temperature
TEMP_ALARM TEMP_ALARM
TEMP_ALARM_CMODE - R/W alarm
_CMODE _CMODE o
Maintain usage
Reset all
ALARM_RESET ALARM_RESET ALARM_RESET - W )
alarm/warning
Enable
TEMP_AMODE TEMP_AMODE TEMP_AMODE - R/W temperature

alarm/warning
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