RS Automation
ROBOCON SRC-PLUS Series

Supported version TOP Design Studio V1.0 or higher {Rl
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1. System configuration

The system configuration of TOP and “RS Automation, Inc. SRC-PLUS Series” is as follows:

Communication .
System setting Cable

Series
method

3.1 Settings example 1 5.1. Cable table 1
RS-232C -

(Page 4) (Page 5)

SRC-PLUS Series

RS—-485 3.2 Settings example 2 5.1. Cable table 2

(2 wire) (Page 4) (Page 5)

H Connectable configuration

+ 1:1 (one TOP and one external device) connection — configuration which is possible in RS232C/485 communication.

+ 1:N (one TOP and multiple external devices) connection — configuration which is possible in RS422 communication.

. Eil i e

ne 3 |
]

* N:1 connection (multiple TOPs and one external device) connection — configuration which is possible in RS422 MultiLink

communication.
i [=1.] = k[+1.] ki [+1-]

- [ [l
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device H

PLC select [COM2]

Filter : |[AII] v‘ Search : I:I

@ Model (O Vendor

Vendor Model
YASKAWA Electric Corporation &

NX Series

YOKOGAWA Electric C i
=cimic Lorporation NX Plus Series

Schneider Electric Industries
XB Series

AR

KDT Systems
& Modbus Modicon F50
HITACHI IES

FATEK Automation Corporation
DELTA Electronics

KOYO Electronic Industries
VIGOR Electric Corporation

COMFILE TECHNOLOGY Inc.

DST ROBOT
BACnet
| & MECAPTON %
4_Back | B Next *® Cancel
Select Device n

PLC Setting[ SPC Series ]

Alizs Mame @ |PLCL

Interface : | Serial ~

Protocol : | SPC Protocol ~ Comm Manual
String Save Mode : |First LH HL Change

[ use Redundancy

AND ~
Co :)::-' : Edi
Primary Option
Timeout msec
Send Wait msec
Station No (0~191, 255)
@ Back + OK * Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select “"RS AUTO".
PLC Select an external device to connect to TOP.
Interface Protocol
SRC Serial SRC PLUS PROTOCOL
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3. TOP communication setting
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting

M [ Project > Project Property > TOP Setting ] — [ Project Options > “Use HMI Setup” Check > Edit > Serial ]

— Set the TOP communication interface in TOP Design Studio.

Project Option s
-ChangeHMllﬂ] .Md PLC[A) | TR Change Picicl | [ Delete PLCID)
%ﬂsnnx Date / Time Sync.  Screen Option Unit Convert
he -225;_”|:;d“‘(fnfﬁtﬁ”g Project Option | Screen Change  HmiSetup | Global Lock & Touch | Project Style  Splash || PLC Buffer Sync.
Y ‘—_Eivﬁapieln(]gf En oo Initialization Edit
v fam COM2 (1) Project Setting -~
W8 PLC1: SPC Series [0] HMIDisable=0
2% COM3 (0) Project Ndama;Naw project
thernet (0) Start Mode =Menu
: Essoavitcau(o) e
Latch Set=0~0
Communication Errar Message=0
USBErrorMessage=0
StorageErrorMessage=1
DatabaseMessage=1
Caontrol Panel
System [ pevices —He e
i Serial d
——— 7 Serial Port: @ COM1 <
1| )
i : Signal Level
FLC Security Dat e/Tims ) RE-2320 @ RS-422(4) () RS-485(2)
Baud Rate: 13200 M
o 8 Data Bit: -
] e = C |
Ethernet Ser ial HOM Stop Bit: | |
Parity Bit: HMNaone ©
= h Flow: [(ff
L_A Ping| Auto Search Loopback Test
Diagnost ic File Fing
Manager
Apply | Cancel
Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C
RS-422/485 RS-422/485
Baud Rate 19200
Data Bit 8
Stop Bit 1
Parity Bit None.

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [ Project > Project Property > PLC Settings > COM > "PLC1 :SRC Series"]

— Set the options of the SR Series communication driver in TOP Design Studio.

Project Option

- Change HMI[H] ' AddPLC[A] | THTM) Change PLCIC | [] Delete PLCID]

~ ] TOFP Setting
-} S¥5 1 TOPRX1500%
Option Module Setting
B FieldBus (0)
.. RFID (0)
v Device Setting

-rg® COM1 (D)

PLC Setting[ SPC Series ]

Alizs Name : [PLC1

Interface : | Serial ~

Protocol : | SPC Protocol ~

String Save Mode : (First LH HL Change

ol COoM2 (1)

% PLC1: 5PC Series [0]

Cpww sy
i Ethernet (0)

..... W% USBDevice (0)

[] use Redundancy

AND v
e g o
e0 5 -
Conditio Edi
Primary Option

Timeout m msec
Send Wait msec
Retry 5 z
Station Mo

(0~121, 255)

Comm Manual

Apply Close
Items Settings Remarks
Interface Select “SRC PLUS". Refer to “2. External
Protocol

Select the communication protocol between the TOP and an external device.

device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP’s receiving a response from an external device and
sending the next command request.

Station No

Enter the prefix of an external device.
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3.2. Communication setting in TOP
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* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [ Main Screen > Control Panel > Serial ]

Yiews

Scree
shot

Conitrol

Panel

Project

= o

Project
Setting
oystem
=5
-
[
Dat
cwme| ©
Serial
'_E\_rJ E
— /|
g L
File Manager H

Communication Dg

Serial Port: COM2

Signal Level
® AS-42204)

( O RS-292C

-

|
O R3-485(2)

Baud Rate: |19200

-

|
|
l
]
l
l
l

Data Bit: |8 I &
Stop Bit: |1 | darostic
Parity Bit: |None o) Lo
Flow: [Off ER
[Loopback Test | | Cancel | | Apply |

!lll —
' =
PLLC Printer

Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C
RS-422/485 RS-422/485
Baud Rate 19200
Data Bit 8
Stop Bit 1
Parity Bit None.

* The above settings are setting

examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [ Main Screen > Control Panel > PLC ]

Drvier(COM2) PLCI1(SPC Series)  |+]

Interface  [Serial R

Protocol |SPC Protocol R

_ TimeOut (ms)
‘ SendWait (ms. [0 |
elle| Retry
Viewe Serial station No [

Run|

—
L]
A
(]

File Manag

shot] Commun i c

!lll I
PLC

{
Opt ional
|

l Cance | I [ dipp |y ] I
Items Settings Remarks
Interface Configure the communication interface between the TOP and an external device. Refer to "2. External
Protocol Configure the communication protocol between the TOP and an external device. device selection”.
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.
SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and

sending the next command request.

Station No Enter the prefix of an external device.
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3.3 Communication diagnostics

B Check the interface setting status between the TOP and an external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC ].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information oK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG . .
diagnostics 3. Communication setting
Serial Parameter Transmission
oK NG
Speed
Data Bit oK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name oK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings OK NG . .
4. External device setting
Serial Parameter Transmission
oK NG
Speed
Data Bit oK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
oK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

Refer to the vendor’s user manual to identically configure the communication settings of the external device to that of the TOP.
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5. Cable table

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.

(The cable diagram described in this section may differ from the recommendations of “RKC SR Series”)

5.1. Cable table 1

W RS-232C (1:1 connection)
(A) TOP COM Port (9 pin)

TOP COM External device
Pin Signal Pin Cable connection Pin Signal Pin
arrangement*Note 1) name number number name arrangement*Note 1)
1 5 CD 1 1 CD 1 5
g g SD 3 3 SD g g
Based on DTR 4 4 485P+ Based on
communication SG 5 &) G communication
cable connector DSR 6 6 485N- cable connector
front, RTS 7 I: 7 RTS front,
D-SUB 9 Pin male CTS 8 8 CTS D-SUB 9 Pin female
(male, convex) NC 9 9 NC (male, convex)
*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
B RS-485 (connection)
(B) TOP COM Port (9 pin)
TOP COM External device
Pin Signal Pin Cable connection Pin Signal Pin
arrangement*Note 1) name number number name arrangement*Note 1)
1 5 RDA 1 1 CD 1 5
e 3 : o | T3
Based on RDB 4 4 485P+ Based on
communication > 5 G communication
cable connector SDA 6 6 485N- cable connector
front, 7 I: 7 RTS front,
D-SUB 9 Pin male 8 8 CTS D-SUB 9 Pin female
(male, convex) SDB 9 9 NC (male, convex)
*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
B RS-485 (1:1 connection)
TOP External device
. Signal Cable connection Pin Signal Pin
Pin arrangement
name number name arrangement*Note 1)
+ 1 CD 1 5
e e
O SG 3 SD Q =
6 9
| L SG 4 485P+ Based on
|| = E) SG communication
+ 6 485N- cable connector
O I: 7 RTS front,
8 CTS D-SUB 9 Pin female
9 NC (male, convex)

External device connection manual for TOP Design Studio 10 / 12



6. Supported addresses
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The devices available in TOP are as follows:

TOP Designer
Device | TOKEN Explanation R/W | Address Input Value
Range
RUN_ 0x2C Run program W 000~999 Don't care
STOP 0x2D Stop program w 000 Don't care
PAUS 0x73 Pause W 000 Don't care
FREE 0x73 Unpause w 000 Don't care
OVER 0x61 Override Speed Read and Write R/W | 001~100 Don't care
PWON Ox4A Servo power w 000 Don't care
PWOF 0x4B Servo power OFF W 000 Don't care
STS_ 0x79 Robot status R 000 Don't care
INIT 0x40 Error initialization W 000 Don't care
IJNTX 0x42 X-axis Joint current location (no save) R 000 Don't care
IJNTY 0x42 Y-axis Joint current location (no save) R 000 Don't care
INTZ 0x42 Z-axis Joint current location (no save) R 000 Don't care
JNTA 0x42 A-axis Joint current location (no save) R 000 Don't care
JNTB 0x42 B-axis Joint current location (no save) R 000 Don't care
IJNTC 0x42 C-axis Joint current location (no save) R 000 Don't care
WRDX 0x42 X-axis World current location (no save) R 000 Don't care
WRDY 0x42 Y-axis World current location (no save) R 000 Don't care
WRDZ 0x42 Z-axis World current location (no save) R 000 Don't care
WRDA 0x42 A-axis World current location (no save) R 000 Don't care
WRDB 0x42 B-axis World current location (no save) R 000 Don't care
WRDC 0x42 C-axis World current location (no save) R 000 Don't care
*RUN_: Run program

Name the program with the same format as "PROG000-PROG999".

The name must begin with "PROG". When entering an address in the designer, only enter three

digits, excluding "PROG". If the program name is "PROG123", just enter the numbers (and not

the letters) as shown in the following image.

* OVER : Override Speed Settings

Set the decimal places to 1. Enter a value between 001 and 100 (%).
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* STS_: Robot status  Bit Value

TO,

ERI2 e B X
Touch Qperation Panel

Set the address to 000 and view the following table only for bit digits to configure.

Bit number Meaning Bit number Meaning
BIT15 E-stop button Bit7 Joint Jog
BIT14 Servo power BIT6 World Jog
BIT13 H/W Limit BITS Tool Jog
BIT12 S/W Limit BIT4 Jog mode
BIT11 Error status BIT3 External Control Mode
BIT10 Run status BIT2 Origin run completed
BIT9 Step Run BIT1 Completing origin run
BIT8 Pause status BITO Unused
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