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MITSUBISHI Electric Corporation 

MELSEC iQ-R Series  

Ethernet Driver 
 Supported version TOP Design Studio V1.0 or higher  

 

 

 

CONTENTS 

We would like to thank our customers for using M2I's "Touch 

Operation Panel (M2I TOP) Series". Read this manual and familiarize 

yourself with the connection method and procedures of the “TOP and 

external device”. 

 

 

 

1. System configuration Page 2 

 

 

Describes the devices required for connection, the setting of 

each device, cables, and configurable systems. 

2. External device selection  Page 3 

 Select a TOP model and an external device. 

3. TOP communication setting Page 4 

 Describes how to set the TOP communication. 

4. External device setting Page 9 

 Describes how to set up communication for external devices. 

5. Supported addresses Page 11 

 Refer to this section to check the addresses which can 

communicate with an external device. 
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1. System configuration 

The system configuration of TOP and “MITSUBISHI Electric Corporation - MELSEC IQR Ethernet” is as follows: 

 

Series CPU Link I/F 
Communication 

method 

Communication 

setting 
Cable 

MELSEC iQ-R 

R04 

R04EN 

R08 

R08EN 

R120 

R120EN 

R16 

R16EN 

R32 

R32EN 

CPU Built-in 

Ethernet 

Ethernet 

(TCP/UDP) 

3. TOP 

communication 

setting 

4. External device 

setting 

Twisted pair cable*Note 1) 

*Note 1) Twisted pair cable 

- Refer to STP (Shielded Twisted Pair Cable) or UTP (Unshielded Twisted Pair Cable) Category 3, 4, 5. 

- Depending on the network configuration, you can connect to components such as the hub and transceiver, and in this case, use a 

direct cable. 

 

 

■ Connectable configuration 

 

ㆍ1:1 (one TOP and one external device) connection 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 
 

 

Settings Contents 

TOP Model Check the TOP display and process to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Please select “MITSUBISHI Electric Corporation”. 

PLC Select the external device to be connected to the TOP. 
 

Model Interface Protocol 

MELSEC IQR Series CPU Ethernet iQ-R Ethernet (Binary) 
 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 

Supported Protocol 

iQ-R Ethernet (BINARY) 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [ Project > Project Property > TOP Setting ] → [ Project Options > “Use HMI Setup” Check > Edit > Ethernet ] 

– Set the TOP communication interface in TOP Design Studio. 
 

 

 

 

 

 

 

Items TOP External device Remarks 

IP Address*Note 1) Note 2) 192.168.0.100 192.168.0.51  

Subnet Mask 255.255.255.0 255.255.255.0  

Gateway 192.168.0.1 192.168.0.1  

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 168 . 0 . 0) should match. 

*Note 2) Do not use duplicate IP addresses over the same network. 

* The above settings are examples recommended by the company. 

 

Items Description 

IP Address Set an IP address to be used by the TOP to use over the network. 

Subnet Mask Enter the subnet mask of the network. 

Gateway Enter the gateway of the network. 
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(2) Communication option setting 

■ [ Project > Project Property > PLC Settings > ETHERNET > “PLC1 : MELSEC-IQR Series”] 

– Set the options of the MELSEC IQR Series Ethernet communication driver in TOP Design Studio. 

 

 

Items Settings Remarks 

Interface Select “CPU Ethernet”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

IP Enter the IP address of the external device.  

Ethernet Protocol Select the Ethernet protocol between the TOP and an external device.  

Port Enter the Ethernet communication port number of an external device. Reference the table 

below 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
 

HMI TCP PORT For TCP N:1, set the HMI TCP PORT differently for each HMI.  
 

MELFSEC iQ-R Series CPU Communication port no. 

Protocol Port number Remarks 

TCP 5007 DEC Fixed 

UDP 5006 DEC Fixed 
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3.2. Communication setting in TOP  

* This is a setting method when "Use HMI Setup" in the setting items in "3.1 TOP Design Studio" is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen.  

   

(1) Communication interface setting 

■ [ Main Screen > Control Panel > Ethernet ] 
 

 

 

Items TOP External device Remarks 

IP Address*Note 1) Note 2) 192.168.0.100 192.168.0.51  

Subnet Mask 255.255.255.0 255.255.255.0  

Gateway 192.168.0.1 192.168.0.1  

*Note 1) The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 168 . 0 . 0) should match. 

*Note 2) Do not use duplicate IP addresses over the same network. 

* The above settings are examples recommended by the company. 

 

 

Items Description 

IP Address Set an IP address to be used by the TOP to use over the network. 

Subnet Mask Enter the subnet mask of the network. 

Gateway Enter the gateway of the network. 
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 (2) Communication option setting 

■ [ Main Screen > Control Panel > PLC ]  
 

 

 

Items Settings Remarks 

Interface Select “CPU Ethernet”. Refer to “2. External 

device selection”. Protocol Select the communication protocol between the TOP and an external device. 

IP Enter the IP address of the external device.  

Ethernet Protocol Select the Ethernet protocol between the TOP and an external device.  

Port Enter the Ethernet communication port number of an external device. Reference the table 

below 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
 

HMI TCP PORT For TCP N:1, set the HMI TCP PORT differently for each HMI.  

 

MELFSEC iQ-R Series CPU Communication port no. 

Protocol Port number Remarks 

TCP 5007 DEC Fixed 

UDP 5006 DEC Fixed 
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check if the port (ETH1/ETH2) settings you want to use in [Control Panel > Ethernet] are the same as those of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC ]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Ethernet port setting IP Address OK NG 

Subnet Mask OK NG 

Gateway OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Ethernet port setting IP Address OK NG 

Subnet Mask OK NG 

Gateway OK NG 

Check address range  

OK NG 

5. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 

4.1 GX Works3 Connection Settings 

Set as below using MELSEC Series Ladder Software "GX Works3”. For more detailed setting method than that described in this 

example, refer to the PLC user manual. 
 

 

⚫ The network addresses of the TOP and the external device (the first three digits of the IP, 192 . 

168 . 0 . 0) should match. 

⚫ Do not use duplicate IP addresses over the same network. 
 

Step 1. In [GX Works3] software project window [Parameter] – [relevant CPU model name] double-click and bring up [Module 

parameter] pop-up window 
 

Step 2. In [Module parameter], select [Basic Settings] tab and set as follows: 
 

 
 

Items Settings 

IP address IP MELSEC-iQ-R CPU Ethernet Port Assignment IP 

 Subnet mask pattern Set when using subnet mask 

 Default router IP Set when using router 

Communication data code Binary code (fixed) 

Enable online change  Not used 
 

Step 3. [Online] > Transmit the parameter set to [Write to PLC] and reset the PLC. 
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4.2 GX Works3 N:1 setting (*Relevant only for TCP) 

Step 1. In [GX Works3] software project window [Parameter] – [relevant CPU model name] double-click and bring up [Module 

parameter] pop-up window 

Step 2. In [Module parameter], select [Detailed Setting on right side of External Device Configuration] tab and set as follows: 

 

 

 

Step 3. [Ethernet Configuration] > Drag [MELSOFT Connection Module] from the [Module List] to the left, set it up, and select 

Close With Reflecting the Setting, as shown in the picture below.  

 

 

Step 4.In [Module Parameter] window, press Apply. 

Step 5. [Online] > Transmit the parameter set to [Write to PLC] and reset the PLC. 
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5. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use.  

 

Device Bit Address Word Address Word Address NOTE 32 BIT 

Input Relay X0000 ~ X3FFF(HEX) X0000 ~ X3FF0(HEX) X***0 *Note 1) 

L/H *Note 3) 

Output Relay Y0000 ~ Y3FFF(HEX) Y0000 ~ Y3FF0(HEX) Y***0 *Note 1) 

Internal Relay M0 ~ M161882111 M0 ~ M161882096 M0000 + 16*n *Note 2) 

Special Relay SM0 ~ SM4095 SM0 ~ SM4080 SM0000 + 16*n *Note 2) 

Latch Relay L0000 ~ L32767 L0000 ~ L32752 L0000 + 16*n *Note 2) 

Annunciator F0 ~ F131071 F0 ~ F131056 F0000 + 16*n *Note 2) 

Link Relay B0 ~ B9A61FFF(HEX) B0 ~ B9A61FF0(HEX) B***0 *Note 1) 

Special Link Relay SB0 ~ SB9A61FFF(HEX) SB0 ~ SB9A61FF0(HEX) SB***0 *Note 1) 

Timer (contact) TS0 ~ TS8993439 -  

Timer (coil) TC0 ~ TC8993439 -  

Aggregate Timer (contact) SS0 ~ SS8993439 -  

Aggregate Timer (coil) SC0 ~ SC8993439 -  

Counter (contact) CS0 ~ CS8993439 -  

Counter (coil) CC0 ~ CC8993439 -  

Timer (current value) TN0.00 ~ TN8993439.15 TN0 ~ TN8993439  

Aggregate Timer (current value) SN0.00 ~ SN8993439.15 SN0 ~ SN8993439  

Counter (current value) CN0.00 ~ CN8993439.15 CN0 ~ CN8993439  

Data Register D0.00 ~ D10117631.15 D0 ~ D10117631  

Special Data Register SD0.00 ~ SD4095.15 SD0 ~ SD4095  

File Register R0.00 ~ R32767.15 R0 ~ R32767  

Link special register SW0.00 ~ SW9A61FF.15(HEX) SW0 ~ SW9A61FF(HEX)  

Extension file register ZR0.00 ~ ZR10027007.15 ZR0 ~ ZR10027007  

Index register Z0.00 ~ Z23.15 Z0 ~ Z23  

Buffer memory G0.00 ~ G268435455.15 G0 ~ G268435455  

Index register (32bits) LZ0.00 ~ LZ11.31 LZ0 ~ LZ11  

Link register W0.00 ~ W9A61FF.15(HEX) W0 ~ W9A61FF(HEX)  

Long timer  contact LTS0 ~ LTS2529407 -  

Long timer coil LTC0 ~ LTC2529407 -  

Long timer current value(32bits) LTN0.00 ~ LTN2529407.31 LTN0 ~ LTN2529407  

Long retentive timer contact LSS0 ~ LSS2529407 -  

Long retentive timer coil LSC0 ~ LSC2529407 -  

Long retentive timer current 

value(32bits) 
LSN0.00 ~ LSN2529407.31 LSN0 ~ LSN2529407  

*Note 1) For bit addresses with hexadecimal “0~F” notations, use the initial 0 bit as the word address 

*Note 2) When using a bit address that uses decimals, use a word address in units of “16” 

*Note 3) The lower 16 BIT data of 32 BIT data is saved in the address whose screen has been registered, and the upper 16 BIT data 

is saved in the address next to the address whose screen has been registered. 

   Ex. When saving 32BIT data hexadecimal data 12345678 in address D00100, it is saved to 16BIT device address as follows: 

Items 32BIT 16BIT 

Address D00100 D00100 D00101 

Input data 

(hexadecimal) 
12345678 5678 1234 

 


