LS Industrial Systems
MASTER-K(80S/120S/200S/300S/1000S) Series
CPU Direct Driver

Supported version  TOP Design Studio V1.0 or higher {Rl

TOP

"

CONTENTS

We would like to thank our customers for using M2l's "Touch

Operation Panel (M2] TOP) Series". Read this manual and familiarize
yourself with the connection method and procedures of the "TOP and

external device”.

1. System configuration Page 2

Describes the devices required for connection, the setting of

each device, cables, and configurable systems.

2. External device selection Page 3

Select a TOP model and an external device.

3. TOP communication setting Page 4

Describes how to set the TOP communication.

4. Cable table Page 9

Describes the cable specifications required for connection.

5. Supported addresses Page 10

Refer to this section to check the addresses which can

communicate with an external device.
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1. System configuration

The system configuration of TOP and “LS Industrial Systems — MASTER-K (80S/120S/200S/300S/1000S) Series CPU Direct” is as

follows:

K1000S K7P-30AS

K300S K4P-15AS

K3P-07AS
K200S K3P-07BS

K3P-07CS
K7M-D[J20U 3. TOP communication

. settin
cioos | KMPO30U 1 port on cpU unit Mot D RS-232C cefting 5 Cable table
K7M-D[J40U 4. External device -

K7M-D[160U setting

K7M-D[110S
K7M-D[120S
K80S K7M-D[130S
K7M-D[140S
K7M-D[160S

*Note 1) PC connection loader port

W Connection configuration

- 1:1 (one TOP and one external device) connection
k[=1.]

I TE -]
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2. External device selection

W Select a TOP model and a port, and then select an external device.

Select Device H

PLC select [COM1]

Filter : |[AII] v‘ Search : I:I

@ Model (O Vendor

Vendor Model
~
M2I Corporation & NGL/XGR/XEC Series
MITSUBISHI Electric C i
eimic Lorporation 83 KGK/XBM/YEC Series
OMRON Industrial Automation
GLOFA-GM Series
;
'4' MASTER-K(805/1205/2005/3005/10005) Series
MODBUS Organization
& STARVERT Series
SIEMENS AG.
& XCODE RFID HF Reader Series IH-1306/1307
Rockwell Automation
G Fanuc Automation & MASTER(500H/1000H) Series
PANASCNIC Electric Works & MASTERK 105, 1051 Series

‘YASKAWA Electric Corporation
YOKOGAWA Electric Corporation
Schneider Electric Industries

KDT Systems

RS Autnmation

4_Back | B Next *® Cancel

Select Device n

PLC Setting[ MASTER-K(805/1205/ 2005/ 3005/ 1000S) Series ]

Alizs Mame @ |PLCL

Interface : | CPU Direct ~
Protocol : | CPU ~ Comm Manual

String Save Mode : |First LH HL Change

[ use Redundancy

AND ~
Primary Option
Timeout 300 &|| msec
Send Wait msec
@ Back + OK * Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select “LS Industrial Systems".
PLC Select an external device to connect to TOP.
Interface Protocol
MASTER-K CPU Direct CPU
(80S/120S/200S/300S/1000S)
Series

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting

M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Serial]

— Set the TOP communication interface in TOP Design Studio.

Praject Option
. Changs HMIH]
D_ TOP Setting
= Rl 520

Option Module Setting
A FieldBus (0)
4 RFID (0)
W g Device Setting
v g8 COM1(1)

Date / Time Sync.

Project Option  Screen Change

Use HMI Setup
Hmi Setup Option

Screen Option

. Add PLC [A] "n Change PLC[C] E:i Delete PLC[D]

Unit Convert

HmiSetup | Global Lock & Touch

Project Style  Splash

PLC Buffer Sync.

Initialization

Edit

W PLC1: MASTER-K(805/1205/
% COM2 (D)

5% COM3 (0)

W Ethernet (0)

&9 Wireless (0}

i USBDevice (0)

Start Mode =Menu

Start Screen Mo.=1
Latch Use=0

Latch Set=0~0
Communication Error Message =0
USBErrorMessage =0
StorageErrorMessage=1
DatabaseMessage=1
SystemMessage=1
DisplayLoddcon=0
DisplayPermissionIcon=0
DarkDraw =0
DrawTouchPos=0
TOPID=1

AutoRun=0

Language =English

Project Advanced Setting
HMIDisable =0
RunSleep=50
EffectSleep=50
CommunicationSleep=1
ProjectLoadType=1
InitDataPrevScreen=1
ErrorLogWrite=0
BlinkTime =0
WatchDog=0
SDCoverOption=0
TaskMonitor=1
CommSleepChgUse=0
CommSleepChg=1000
MomentaryBitActionTime=20
CommunicationRatio =0

Ethernet

HMIDisable =0

ETH1=1
P1=192.168.0.100
Subnet1=255,255, 255.0
Gateway1=192.168.0.1
Speed1=0
DefaultGatewavl=1

Apply

Close

Control Panel

System Devices

@Service p"

"'_' Option

—
i

FLC SEcurity Dates/Time

= [

Et hernet Serial HOK |
= N
II ‘Il Ping
——
Diagnost ic File Ping
Manager

o Serial

K Serial Port:

Signal Level

Baud Rate:
Data Bit:
Stop Bit:

Parity Bit:
Flow:

Auto Search

COM1

(® R5-232C O RS-422(4) (O RS-485(2)

38400 @
8 =
1 =
Odid v

Of f

Loopback Test

Apply Cancel
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Items TOP External device Remarks

Signal Level (port) RS-232C )
RS-232C Fixed

(CPU port)

Baud Rate 38400 Fixed

Data Bit 8 Fixed

Stop Bit 1 Fixed

Parity Bit None. Fixed

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.

(2) Communication option setting
M [ Project > Project Property > Device Setting > COM > "PLC1 : MASTER-K(80S/120S/200S/300S/1000S) Series”]
— Set the options of MASTER-K Series CPU Direct communication driver in TOP Design Studio.

Project Option

-Change HMI[H

W aaric ST Change PLCIC]

[ Delete PLCID]

v -] TOP Setting
i [ SYS :RD1520X

W FieldBus (0)

- RFID (1)

v - Device Setting
e il

Option Medule Setting

PLC Setting[ MASTER-K(S0S/1205/ 2005/ 2005/ 1000S) Series ]

Alias Name : [PLC1

Interface : | CPU Direct

w

Protocol : | CPU

w

W PLC1 : MASTER-K(805/1205/]

String Save Mode : |First LH HL Change

fa® UM
1o COM3 (0)

USBDevice {0)

[ use Redundancy

4

Primary Option

Timeout

Comm Manual

Send Wait meec
< >
Apply Close
Items Settings Remarks
Interface Select “CPU Direct". Refer to “2. External
Protocol Select "CPU". device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP’s receiving a response from an external device and

sending the nextcommand request.
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3.2. Communication setting in TOP
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* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

Conitroll Panel

(= o]

|
m Signal Level
PLC i Da

Serial

—] Serial Port: lCDhﬂ "

® R3-232C O RS-422(4) O RS-485(2)

Ethernet Serial

]

l

Baud Rate: | 38400 -

, Data Bit: |8 -

(0 I Rl s W B
-

]

Parity Bit: [ Mone

m ——; Flow: [Uff
bl o

[Auto Searchl [Loopback Test]

Diagnost ic File

 Apply | Cancel |

[System]

Clos;:___r'-'

_-‘

Items TOP External device Remarks
Signal Level (port) RS-232C )

RS-232C Fixed

(CPU port)

Baud Rate 38400 Fixed
Data Bit 8 Fixed
Stop Bit 1 Fixed
Parity Bit None. Fixed

* The above settings are setting examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting
M [Main Screen > Control Panel > PLC]

Run

PLG

TO,

ERI2 e B X
Touch Qperation Panel

PLCT{MASTER-K(B0S/1205/2005/3005/ 1000S) Se v]

il
Driver(COMI) |
Interface | CPU Direct Rd
!lill Protocol _ CRU B2
PLE Timeout 300 15 msec
Send Wait msec
[-"'-] Retry =
{0
Et hernet
Diagnost ic
[System] l Diagnostic

| Aeply || Cancel |

Items Settings Remarks
Interface Select "CPU Direct”. Refer to "2. External
Protocol Select “CPU". device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP's receiving a response from an external device and

sending the next command request.
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3.3 Communication diagnostics

M Check the interface setting status between the TOP and external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information OK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG L .
diagnostics 3. Communication setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name OK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings oK NG
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 5. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. Cable table
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This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.

(The cable diagram described in this section may differ from the recommendations of “LS Industrial Systems Co., Ltd.")

W RS-232C (1:1 connection)

COM External device
Pin Signal Pin Cable connection Pin Signal Pin
arrangement*Note 1) | name | number number name arrangement*Note 1)
@) 1 1 cDh
1 5 1 5
© © RD 2 >< : - 0 N
o) [e) SD 3 3 SD O Q
6 9 DTR 4 4 DTR 6 9
Based on G 5 5 G Based on
communication cable DSR 6 6 DSR communication cable
connector front, RTS - - RTS connector front,
D-SUB 9 Pin male D-SUB 9 Pin male
CTS 8 8 CTS
(male, convex) 9 9 (male, convex)

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.

External device connection manual for TOP Design Studio

9/10



5. Supported addresses
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The devices available in TOP are as follows:

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Device Bit Address Word Address Remarks
Input / Output Relay PO00 — P63F POO — P63

Auxiliary Relay MO000 - M191F MO0 - M191

Keep Relay K000 - K31F KOO - K31

Link Relay LO00 - L63F LOO - L63

Special Relay FOOO0 — F63F FOO — F63 Cannot be written
Timer(Contact) TO0O — T255 -

Timer(Elapsed Value) TO0O — T255

Counter(Contact) C000 — C255

Counter(Elapsed Value) C000 - C255

Step Relay S00 - S99

Data Register

D0000.00 - D9999.99

DO000 — D9999

*The lower 16 BIT data of 32 BIT data is saved in the address whose screen has been registered, and the upper 16 BIT data is saved

in the address next to the address whose screen has been registered.

Ex. When saving 32BIT data hexadecimal data 12345678 in address DO0100, it is saved to 16BIT device address as follows:

Items 32BIT 16BIT
Address D00100 D00100 D00101
Input data
12345678 5678 1234
(hexadecimal)
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