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1. System configuration 

The system configuration of TOP and “Schneider Electric Industries – UNI-TELWAY” is as follows: 

 

Series CPU Link I/F 
Communication 

method 

Communication 

setting 
Cable 

Premium 

TSX/TPMX P57 1□ 

TSX/TPMX P57 2□ 

TSX/TPMX P57 3□ 

TSX/TPMX P57 4□ 

TER Port on CPU unit 

RS-232C 

3. TOP 

communication 

setting 

4. External device 

setting 

5. Cable table 

RS–485 (2 wire) 

AUX Port on CPU unit RS–485 (2 wire) 

“TSX P ACC 01” unit 

AUX/TER Port 
RS–485 (2 wire) 

“TSX SCA 62” 

Connection unit 
RS–485 (2 wire) 

“TSX SCY 21601” 

Communication module 
RS–485 (2 wire) 

Micro 

TSX 37 05 028 DR1 

TSX 37 08 056 DR1 

TSX 37 10 028 AR1 

TSX 37 10 028 DR1 

TSX 37 10 128 DR1 

TSX 37 10 128 DT1 

TSX 37 10 128 DTK1 

TSX 37 10 164 DTK1 

TSX 37 21 101 

TSX 37 22 101 

TSX 37 21 001 

TSX 37 22 001 

TER Port on CPU unit 

RS-232C 

RS–485 (2 wire) 

AUX Port on CPU unit RS–485 (2 wire) 

“TSX P ACC 01” unit 

AUX/TER Port 
RS–485 (2 wire) 

TSX SCA 62 RS–485 (2 wire) 

Nano 

TSX 07 3L □□28 

TSX 07 30 10□□ 

TSX 07 31 16□□ 

TSX 07 31 24□□ 

TSX 07 32 □□28 

TSX 07 33 □□28 

Programming port 

on CPU unit 

RS-232C 

RS-485 (2 wire) 

“TSX P ACC 01” unit 

AUX/TER Port 
RS–485 (2 wire) 

TSX SCA 62 RS–485 (2 wire) 

 

■ Connection configuration 
 

ㆍ1:1 (one TOP and one external device) connection 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 
 

 
 

 

Settings Contents 

TOP Model Check the TOP display and process to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Please select “Schneider Electric Industries”. 

PLC Select an external device to connect to TOP. 
 

Model Interface Protocol 

UNI-TELWAL Serial UNI-TELWAY 
 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [Project > Project Property > TOP Setting] → [Project Option > “Use HMI Setup” Check > Edit > Serial] 

– Set the TOP communication interface in TOP Design Studio. 

 
 

 
 

Items TOP External device Remarks 

Signal Level (port) RS-232C 

RS-485 
 

Baud Rate 19200  

Data Bit 8  

Stop Bit 1  

Parity Bit Odd  

* The above settings are examples recommended by the company. 

 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device. 

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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(2) Communication option setting 

■ [Project > Project Property > Device Setting > COM > “PLC1 : UNI-TELWAY”] 

– Set the options of the UNI-TELWAY communication driver in TOP Design Studio. 

 

 

Items Settings Remarks 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
 

Retry Configures the number of attempts for data request.  

Client Address Sets the prefix for which the TOP operates.  

Network Enters the network number of the external device  

Station Enters the station number of the external device.  

Gate Enters the gate number of the external device.  



 

 External device connection manual for TOP Design Studio 6 / 13 

3.2. Communication setting in TOP  

* This is a setting method when "Use HMI Setup" in the setting items in "3.1 TOP Design Studio" is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the 

main screen.  

   

(1) Communication interface setting 

■ [Main Screen > Control Panel > Serial] 
 

 

Items TOP External device Remarks 

Signal Level (port) RS-232C 

RS-485 
 

Baud Rate 19200  

Data Bit 8  

Stop Bit 1  

Parity Bit Odd  

* The above settings are setting examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [Main Screen > Control Panel > PLC] 
 

 

 

Items Settings Remarks 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
 

Retry Configures the number of attempts for data request.  

Client Address Sets the prefix for which the TOP operates.  

Network Enters the network number of the external device  

Station Enters the station number of the external device.  

Gate Enters the gate number of the external device.  
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch "Communication diagnostics" in [Control Panel > PLC]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  

OK NG 

6. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 
 

Using the PLC software “PL7” of Schneider Electric Industries, configure as shown in the example below. 

Refer to the user manual of the manufacturer for more details than those provided in this example. 
 

Step 1. Open “Hardware Configuration” to load the configuration of the connecting port (module). 
 

 

 

Step 2. Refer to the image below to configure the settings required for communication. 
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* Caution 

 Communication will not occur if the client address is greater than the number of slaves in the TOP communication options. 

  

Set up items Value 

Protocol UNI-TELWAY LINK 

Type Master 

Transmission speed 19200 bps/s 

Data 8 bits 

Stop 1 bit 

Parity Odd 

Number of slaves 8 
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5. Cable table  

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. 

(The cable diagram described in this section may differ from the recommendations of “Schneider Electric Industries”) 
 

■ RS-232C (1:1 connection, COM1/COM2) 

TSX PCX 1031 (2.5m) 

(Rotary switch : TER Direct) 

 
 

■ RS-485 (1:1 connection) 

TOP 

Cable connection 

External device 

Pin arrangement 
Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 
Pin arrangement 

 

 

Connector front 

Male 9 pin D-SUB 

(Male, convex) 

RDA 1  1 D (B) 

 

Connector front 

Male 8 pin mini DI 

(Male, convex) 

 2 2 D (A) 

 3 3 - 

RDB 4 4 /DE 

SG 5 5 DPT 

SDA 6 6 - 

 7 7 SG 

 8 8 VCC (5V) 

SDB 9  

 

■ RS-485 (1:1 connection) 

TOP 

Cable connection 

External device 

Pin arrangement 
Signal 

name 

Pin 

number 

Signal 

name 
Pin arrangement 

 

+  1 D (B) 

 

Based on connector 

front 

Male 8 pin mini DI 

(Male, convex) 

- 2 D (A) 

SG 3 - 

 

4 /DE 

5 DPT 

6 - 

7 SG 

8 VCC (5V) 

 

 

  



 

 External device connection manual for TOP Design Studio 12 / 13 

■ RS-485 (1:1 connection) 

TOP 

Cable connection 

External device 

Pin arrangement 
Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 
Pin arrangement 

 

 

Connector front 

Male 9 pin D-SUB 

(Male, convex) 

RDA 1  14 D(B) 

 

Connector front 

Male 15 pin D-SUB 

(Male, convex) 

 2 7 D(A) 

 3 15 SG 

RDB 4  

SG 5 

SDA 6 

 7 

 8 

SDB 9 
 

■ RS-485 (1:1 connection) 

TOP 

Cable connection 

External device 

Pin arrangement 
Signal 

name 

Pin 

number 

Signal 

name 
Pin arrangement 

 

+  14 D(B) 

 

Connector front 

Male 15 pin D-SUB 

(Male, convex) 

- 7 D(A) 

SG 15 SG 

 

 

 

■ RS-485 (1:1 connection) 

TOP 

Cable connection 

External device 

Pin arrangement 
Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 
Pin arrangement 

 

 

Connector front 

Male 9 pin D-SUB 

(Male, convex) 

RDA 1  19 D(B) 

 

Connector front 

Male 25 pin D-SUB 

(Male, convex) 

 2 12 D(A) 

 3 25 SG 

RDB 4  

SG 5 

SDA 6 

 7 

 8 

SDB 9 
 

■ RS-485 (1:1 connection) 

TOP 

Cable connection 

External device 

Pin arrangement 
Signal 

name 

Pin 

number 

Signal 

name 
Pin arrangement 

 

+  19 D(B) 

 

Connector front 

Male 25 pin D-SUB 

(Male, convex) 

- 12 D(A) 

SG 25 SG 
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6. Supported addresses 

The devices available in TOP are as follows: 

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

Device Bit Word Size Remarks 

Internal Data Bit M00000 ~ M32767 - 1 bit  

Internal Data Word MW00000.00 ~ MW32767.15 MW00000 ~ MW32767 16 bit  

Internal Data Dword MD00000.00 ~ MW32767.31 MD00000 ~ MD32767 32 bit  

Constant Data Word KW00000.00 ~ KW32767.15 KW00000 ~ KW32767 16 bit Read-only 

Constant Data Dword KD00000.00 ~ KD32767.15 KD00000 ~ KD32767 32 bit Read-only 

System Data Bit S00000 ~ S32767 - 1 bit  

System Data Word SW00000.00 ~ SW32767.15 SW00000 ~ SW32767 16 bit  

System Data Dword SD00000.00 ~ SD32767.31 SD00000 ~ SD32767 32 bit  

 

PL7 Timer 

Timer type (PL7) - T1:000 ~ T1:255 8 bit Read-only 

Preset type - T2:000 ~ T2:255 8 bit Read-only 

Preset value - T3:000 ~ T3:255 16 bit  

Value - T4:000 ~ T4:255 16 bit  

Time base - T5:000 ~ T5:255 8 bit Read-only 

(Type PL7) - T6:000 ~ T6:255 8 bit Read-only 

R output - T7:000 ~ T7:255 8 bit Read-only 

 

IEC Timer 

Timer type (TP, TON, TOF)  TM1:000 ~ TM1:255 8 bit Read-only 

Preset type  TM2:000 ~ TM2:255 8 bit Read-only 

Preset value  TM3:000 ~ TM3:255 16 bit  

Value  TM4:000 ~ TM4:255 16 bit  

Time base  TM5:000 ~ TM5:255 8 bit Read-only 

(Type = TP, TON, TOF)  TM6:000 ~ TM6:255 8 bit Read-only 

 

Counter 

Preset type  C1:000 ~ C1:255 8 bit Read-only 

Preset value  C2:000 ~ C2:255 16 bit  

Value  C3:000 ~ C3:255 16 bit  

Sortie E  C4:000 ~ C4:255 8 bit Read-only 

D output  C5:000 ~ C5:255 8 bit Read-only 

F output  C6:000 ~ C6:255 8 bit Read-only 

 

Drum 

controller 

Time base  DR1:000 ~ DR1:255 8 bit Read-only 

Activity time  DR2:000 ~ DR2:255 16 bit Read-only 

Number of steps  DR3:000 ~ DR3:255 16 bit Read-only 

Number of current step  DR4:000 ~ DR4:255 16 bit Read-only 

Status of current step  DR5:000 ~ DR5:255 16 bit Read-only 

F output  DR6:000 ~ DR6:255 8 bit Read-only 

F status table  DR7:000 ~ DR7:255 16 bit Read-only 

 

Monostable 

Preset type  MN1:000 ~ MN1:255 8 bit Read-only 

Preset value  MN2:000 ~ MN2:255 16 bit  

Value  MN3:000 ~ MN3:255 16 bit  

Time base  MN4:000 ~ MN4:255 8 bit Read-only 

R output  MN5:000 ~ MN5:255 8 bit Read-only 

 

Register 

Register type  R1:000 ~ R1:255 8 bit Read-only 

Register length  R2:000 ~ R2:255 16 bit Read-only 

Input value  R3:000 ~ R3:255 16 bit  

Output value  R4:000 ~ R4:255 16 bit Read-only 

E output  R5:000 ~ R5:255 8 bit Read-only 

F output  R6:000 ~ R6:255 8 bit Read-only 

 


