MITSUBISHI Electric Corporation
MELSEC FX2N Positioning Controller Series
CPU Direct Driver

Supported version  TOP Design Studio V1.4.3 or higher {Rl

TOP

"
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We would like to thank our customers for using M2l's "Touch

Operation Panel (M2] TOP) Series". Read this manual and familiarize
yourself with the connection method and procedures of the "TOP and

external device”.

1. System configuration Page 2

Describes the devices required for connection, the setting of

each device, cables, and configurable systems.

2. External device selection Page 3

Select a TOP model and an external device.

3. TOP communication setting Page 4

Describes how to set the TOP communication.

4. External device setting Page 9

Describes how to set up communication for external devices.

5. cable table Page 10

Describes the cable specifications required for connection.

6. Supported addresses Page 11

Refer to this section to check the addresses which can

communicate with an external device.
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1. System configuration

The system configuration of TOP and “MITSUBISHI Electric Corporation - MELSEC FX2N Positioning Controller Series” is as follows:

m Link I/F Communication method Communication setting

3. TOP communication

MELSEC-FX FXeN-10GM CPU Direct RS-422 ( 4 wire) tti 5. Cable tabl
- irec - wire setting . Cable table
FX2N-20GM . .
4. External device setting

W Connection configuration

+ 1:1 (one TOP and one external device) connection

L[]
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2. External device selection

TOP

ERI2 e B X
Touch Qperation Panel

W Select a TOP model and a port, and then select an

external device.

Select Device

PLC select [COM1]

o [ g S —
@ Model (O Vendor

Vendor Model

MZ2I Corporation @D

MITSUBISHI Electric Corporation

OMRON Industrial Automation
LS Industrial Systems
MODBUS Organization
SIEMENS AG.

Rockwell Automation

GE Fanuc Automation
PAMASONIC Electric Works

‘YASKAWA Electric Corporation

MELSEC Q Series

MELSEC FX Series

MELSEC AnMN/AnS Series

MELSEC AnA/fAnU Series

MELSERVO J2 Series

MELSERVO 13 Series

MELSERVO 14 Series

LA A AR AR

"&

MELSEC iQ-F Series

MELSEC FX2N-10/20GM Series

»

YOKOGAWA Electric Corporation

Schneider Electric Industries

KDT Systems
RS Autnmation &
4_Back | B Next *® Cancel
Select Device n
PLC Setting[ MELSEC FX2N-10/20GM Series ]
Interface : | CPU Direct ~
Protocol : | CPU Direct ~ Comm Manual
String Save Mode : |First LH HL Change
[ use Redundancy
AND ~
Condition Edi

Primary Option

Timeout 300 &|| msec

Send Wait msec

= F_ 9

@ Back + OK * Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select “MITSUBISHI Electric Corporation”.
PLC Select an external device to connect to TOP.

Protocol
CPU Direct

Interface

MELSEC FX2N-10/20GM Series CPU Direct

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting

TO,
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting
W [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Serial]
— Set the TOP communication interface in TOP Design Studio.

Project Option

- Change HMIH] | | Add PLC 1) T Change PLCICT | [T Delete PLCID
g—

%X Date [ Time Sync.  Screen Option Unit Convert
‘f"‘ﬁ“;;?;j;';ﬂ;am”g Project Option  Screen Change  HmiSetup | Global Lock & Touch | Project Style  Splash | PLC Buffer Sync.
i w8 RFID (0) Use HMI Setup
v -4, Device Settin
‘:’_' COMl[l)g et Initialization I Eait I
.. PLC1 : MELSEC FX2M-10/4 Project Setting -
g% COM2 (0) HMIDisable=0
- 1g¥ COM3 (0) Project Name =New project
S et
- |JSBDevice (0) Latch Set=0n~0
Communication Error Message =0
USBErrorMessage=0
StorageErrorMessage=1
DatabascMessage=1
Control Panel
System m Devices Mo (=Bl Ot inn
o Serial *
—— 7 Serial Port: | COM1 <
1 :
LE - - R Signal Level
sourity SEATInE () RS-232C @ RS-422(4) O RS-485(2)
Baud Rate: Q600 w2
L » | — Data Bit: -
] e | == i
Ethernet Serial HOM I Stop Bit: |1
Parity Bit: |Even <
- Flow:
=R
e O Auto Search  Loopback Test
Diagnost ic File Fing
Manager
¢ Apply | Cancel
Items TOP External device Remarks
Signal Level (port) RS-422 )
RS-422 Fixed
(CPU port)
Baud Rate 9600 Fixed
Data Bit 8 Fixed
Stop Bit 1 Fixed
Parity Bit Even Fixed

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [Project > Project Property > Device Setting > COM > “PLC1 : MELSEC FX2N-10/20GM Series"]
— Set the options of the MELSEC FX2N Positioning Controller Series communication driver in TOP Design Studio.

TOP ooz e
Touch Qperation Panel

Project Option

~ ] TOFP Setting
| L[ 5Y5:RD1520%
Option Module Setting
B FieldBus (0)
- RFID (0)
W -igy Device Setting
v fg# COM1(1)

Alias Name
Interface

Protocol

|- PLC1 : MELSEC FX2N-10{

String Save Mode

Cipweyrauy)
s¥ COM3 (0)
8 Ethernet (0)
™ Wireless (0)
i USBDevice (0)

Primary Option
Timeout
Send Wait

Retry

- Change HMI[H] ' AddPLCIA] | THITal Change PLCIC | [T Delete PLCID)

PLC Setting[ MELSEC FX2N-10/20GM Series ]

t[pLca |
: | CPU Direct e
: | CPU Direct e

+ |First LH HL Change

[] use Redundancy

Ak

Comm Manual

Apply Close
Items Settings Remarks
Interface Select "CPU Direct". Fixed
Protocol Select “CPU Direct". Fixed

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP’s receiving a response from an external device and

sending the next command request.
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3.2. Communication setting in TOP
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* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

Run

YHC
Yiewer

Security

;

(i

Ethernet Serial

J—
4 -
Diagnost ic File

Mariager

Diat

[System]

Conikrel Panel

- Serial

Serial Port

Signal Leve

() R5-232C @ R5-422(4) O R5-485(2)

;| coMt

M

Baud Rate:
Data Bit:
Stop Bit:

Parity Bit

Flow:

-

3 [ Even

-

| Of f

-

|
M
M
-
M
-

[Auto Search] lLoopbaCk Testl

r

— ]

Items TOP External device Remarks
Signal Level (port RS-422

g (port) RS-422 Fixed

(CPU port)

Baud Rate 9600 Fixed
Data Bit 8 Fixed
Stop Bit 1 Fixed
Parity Bit Even Fixed

* The above settings are setting examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting
M [Main Screen > Control Panel > PLC]

A Interface | CPU Direct [~]
i ' Protocol | CPU Direct -
‘ PLE s Timeout 300 E msec
Send Wait msec
YHC
Yiewer [.J-I'H] - Retry =
]
. [
] Et hernet
4C°)
|
Sc;een m ‘i
shot
\ Diagnost ic |
[Systen] [ Diagnostic [ App |y HCanceI]

TO,

ERI2 e B X
Touch Qperation Panel

@ System | Driver(COMI)  PLCT(MELSEC FXZN-10/20GM Ser jes)

o

] -

Items Settings Remarks
Interface Select “"CPU Direct". Fixed
Protocol Select “"CPU Direct". Fixed
TimeOut (ms) Set the time for the TOP to wait for a response from an external device.
SendWait (ms) Set the waiting time between TOP's receiving a response from an external device and

sending the next command request.
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3.3 Communication diagnostics

W Check the interface setting status between the TOP and an external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the port (COM1/COM?2) settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information OK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG L .
diagnostics 3. Communication setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name OK NG
Communication port name (module
OK NG
name)
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings oK NG 4. External device setting
Serial Parameter Transmission
OK NG
Speed
Data Bit OK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

+ The communication interface for the MELSEC FX2N-10/20GM Series CPU Port does not require a separate configuration.
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TOP 225 -
5. Cable table

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.

(The cable diagram described in this section may differ from the recommendations of “Mitsubishi Electric Corporation”)

W RS-422 (1:1 connection)

coM MELSEC FX Positioning Controller
Pin Signal Pin Cable connection Pin )
Pin arrangement*note 1)
arrangement*Note 1) name number number
RDA 1 1 )
1 5 4
(S) [} 2 2 r;“\ g
o s} 3 3 2 ‘/\".’/. e
6 9 RDB 4 4 e O 7
Based on SG 5 5 1" e ./76
communication SDA 6 6 ?3
cable connector 7 7 o
Based on communication
front,
. 8 8 cable connector front,
D-SUB 9 Pin male
9 MINI-DIN 8 Pin male (male,
(male, convex) SDB

convex)

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
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TOR =32 I
6. Supported addresses

The devices available in TOP are as follows:
The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address
range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Type Remarks Bit Address Word Address 32 bit Property
Input Bit X000 - X067 X000 - X067 *Note 1)
X372 - X377 X372 - X377
Output Bit Y000 - Y067 Y000 — Y067 *Note 1)
Internal relay Bit MO0000 — M0511 MO0000 — M0511 *Note 2)
Special relay Bit M9000 — M9175 M9000 — M9175 L/HNote 4 *Note 2)
Data register Word D0000.00 — D3999.15 D0000 — D3999
File register Word D4000.00 — D6999.15 D4000 — D6999 *Note 3)
Special register Word D9000.00 — D9599.15 D9000 — D9599

*Note 1) Octal notation
*Note 2) Registers as a multiple of 16 when using word as the M device.
*Note 3) Requires separate configuration of “PARA.101" in order to use the file register.

*Note 4) When using 32 bit, saves 16 bit data of registered addresses and any subsequent addresses to the bottom and top,

respectively.
Ex) If D0O0100;s data is “1234", then given that D0O0101's data is “5678", 32 bit will be used for D00100
Items 16BIT 32BIT
Address D00100 D00101 D00101
Data (hexadecimal) 1234 5678 56781234
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