LS Industrial Systems
XGIl / XGR / XEC Series
CPU Direct Driver

Supported version TOP Design Studio V1.0 or higher {Rl

TOP

"
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We would like to thank our customers for using M2I's "Touch

Operation Panel (M2] TOP) Series". Read this manual and familiarize
yourself with the connection method and procedures of the "TOP and

external device”.
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Describes the devices required for connection, the setting of

each device, cables, and configurable systems.

2. External device selection Page 3

‘ Select a TOP model and an external device.

3. TOP communication setting Page 4

Describes how to set the TOP communication.

4. External device setting Page 9

Describes how to set up communication for external devices.
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Describes the cable specifications required for connection.

6. Supported addresses Page 11

Refer to this section to check the addresses which can

communicate with an external device.
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1. System configuration

The system configuration of TOP and “LS Industrial Systems — XGIl / XGR / XEC Series CPU Direct” is as follows:

Communication

Series CPU*Note 1) Link I/F System setting
method
XGI-CPUE
XGI-CPUH
XGl XGI-CPUS 3. TOP
XGI-CPUU PADT connector (9 pin) *Note 2) RS232 communication
XGI-CPUU/D setting 5. Cable table
XGR XGR-CPUH 4. External device
setting
XEC-D[32H .
XGB PADT connector (6 pin) *Note 2) RS232
XEC-D[J64H

*Note 1) Check that the CPU unit is labeled as version V 1.1 or higher.
*Note 2) PADT Access connector: the PLC CPU connector used to connect to the PC Ladder S/W XG5000

B Connection configuration (TOP connection—-External device connection)

+ 1:1 (one TOP and one external device) connection — configuration which is possible in RS232C communication.
k(=]

_
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2. External device selection

W Select a TOP model and a port, and then select an external device.

Select Device H

PLC select [COM1]

Filter : | [all ~ |

@ Model (O Vendor

Vendor Model
M2I Corporation

Se

< ;" KGL/GR/X

& XGK/NEMXBC Series

& GLOFA-GM Series
& MASTER (805/1205/2005/3005/10005) Series

MODBUS Organization
& STARVERT Series

& XCODE RFID HF Reader Series IH-1306/1307

MITSUBISHI Electric Corporation

OMRON Industrial Automation

SIEMENS AG.
Rockwell Automation

E Fanuc Automation & MASTERK(500H/1000H) Series

& MASTERA 105, 1051 Series

PAMASONIC Electric Works

Y ASKAWA Electric Corporation
YOKOGAWA Electric Corperation
Schneider Electric Industries

KDT Systems

RS Automation Y

M8 Back | W Next *® Cancel

Select Device n

PLC Setting[ X6I/XGR/XEC Series ]

Alizs Mame : |PLC1

Interface : | CPU Direct ~
Protocol : | CPU ~ Comm Manual
String Save Mode @ |First LH HL Change
[J use Redundancy
AND ~
Condition Edi
Primary Option
Timeout 300 & | msec
Send Wait msec
4@ Back + OK * Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Please select “LS Industrial Systems”.
PLC Select an external device to connect to TOP.

Interface

Protocol
CPU Direct CPU

XGI / XGR / XEC Series

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.

External device connection manual for TOP Design Studio

3/ 1



3. TOP communication setting
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The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting

M [Project > Project Property > TOP Setting] — [Project Option > “Use HMI Setup” Check > Edit > Serial]

— Set the TOP communication interface in TOP Design Studio.

Project Option he
-ChangeHMllﬂ] W Ao PLC ST Change Pl | [ Delete PLCID)
%wx Date [ Time Sync. =~ Screen Option Unit Convert
M '!2";”|:;d”‘(eu)sem”9 Project Option  Screen Change  HmiSetup | Global Lock & Touch | Project Style  Splash | PLC Buffer Sync.
-4 RFID {0} Use HMI Setup I_l
v -4 Device Settin
\:"_' comL [l)g p— Initialization Edit
-4 PLC1 : XGIXGR/XEC Serie Project Seting ~
~1g¥ COM2 (0) HMIDisable=0
1% COM3 (0) Project NdamEM=NEw project
thernet (0) Start Mode=Menu
; S‘JirEIEsst(DD) e
8 USBDevice (0) L:bch S:E:UMU
Communication Error Message =0
USBErrorMessage=0
StorageErrorMessage=1
D
Centrol Panel
Swystem m Devices | 4 Service =% 0Dption
s Serial L E—
— =
1! £~ Serial Port: | COM -
PLC Security Date/Time Signal Level
(@ RS-232C () RS-42204) (O RS-485(2)
Baud Rate: 115200 w2
0 o —
III"" L [\__/ Data Bit: g -
Et hernet Serial HOK | Stop Bit: i -
Parity Bit: [None -
| Sy % Flow: (f
L al . Ping
: : e - Auto Search  Loopback Test
Diagnost ic File Ping
WManager
Apply Cancel
Items TOP External device Remarks
) RS-232C )
Signal Level (port) RS-232C Fixed
(CPU port)
Baud Rate 115200 Fixed
Data Bit 8 Fixed
Stop Bit 1 Fixed
Parity Bit None. Fixed

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device. (COM3 supports
only RS-485.)

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting
M [Project > Project Property > Device Setting > COM > “PLC1 : XGI/XGR/XEC Series"]
— Set the options of the XGI / XGR / XEC Series CPU Direct communication driver in TOP Design Studio.

ERI2 e B X
Touch Qperation Panel

Project Option

- Change HMI[H]

W Acd PLC Al Tl Change PLCIC)

[ Delete PLCID)

v D TOP Setting
! L. s5YS:RD1520%
Option Module Setting

Date / Time Sync. Screen Option Unit Convert

Project Option = Screen Change  HmiSetup | Global Lock & Touch Project Style

Use HMI Setup
Hmi Setup Option

Wireless (0)
- |USBDevice (0)

Splash

PLC Buffer Sync.

Initialization Edit

Project Setting
HMIDisable=0

Project Name=Mew project
Start Mode=Menu

Start Screen No.=1

Latch Use=0

Latch Set=0~0
Communication Error Message =0
USEErrorMessage=0
StorageErrorMessage=1
DatabaseMessage=1
SystemMessage=1
DisplayLockIcon=0
DisplayPermissionlcon=0
DarkDraw =0
DrawTouchPos=0

TOPID =1

AutoRun=0

Language =English

Project Advanced Setting
HMIDisable=0
RunSleep=50
EffectSleep=50
CommunicationSleep=1
ProjectLoadType=1
InitDataPrevSoreen=1
ErrorLog\Write=0
BlinkTime=0
WatchDog=0
SDCoverOption=0
TaskMonitor=1
CommsSleepChgUse=0
CommsSleepChg=1000
MomentaryBitActionTime =20
CommunicationRatio=0

Ethernet

HMIDisable=0

ETH1=1
IP1=192.168.0.100
Subnet1=255,255.255.0

Close

Apply

Items

Settings

Remarks

Interface

Select “CPU Direct".

Protocol

Select "CPU".

Refer to “2. External

device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP’s receiving a response from an external device and

sending the next command request.
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3.2. Communication setting in TOP
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* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

B Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the

main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

Conikrol Panel

Serial
Run ——
Serial Port: lCUhﬂ “']
!Iill Signal Level
‘ i ® FS-232C (O RS-422(4) O RS-485(2) ]
PLC Security
Baud Rate: | 115200  -|
_'||'H[: .
Viever i T Data Bit: |8 B
Pmmy Stop Bit: l 1 "]
" ﬁ Et hernet Serial
. Parity Bit: | None -
L —
g | = Flow: | Off M
s | |l B | M
Diagnost ic File [Auto Searchl [Loopback Test]
Manager
’ _Apply | Cancel |
[Svstem] Close r
|
Items TOP External device Remarks
. RS-232C _
Signal Level (port) RS-232C Fixed
(CPU port)
Baud Rate 115200 Fixed
Data Bit 8 Fixed
Stop Bit 1 Fixed
Parity Bit None. Fixed

* The above settings are setting examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting
M [Main Screen > Control Panel > PLC]

@ Syste

PLC

(i

Ethernet

Diagnost ic

[System]

Dr iver (COM1)

Interface
Protocol
Timeout
send Wait

Retry

PLG

TO,

PLC1(KG/HGR/MEC Series)

| CPU Direct

Diagnostic

ERI2 e B X
Touch Qperation Panel

o
| feply || cancel |

— |

Items Settings Remarks
Interface Select “CPU Direct". Refer to “2. External
Protocol Select "CPU". device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP’s receiving a response from an external device and

sending the next command request.
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3.3 Communication diagnostics

M Check the interface setting status between the TOP and external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information oK NG
Port in use OK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG
Communication 2. External device selection
) ) oK NG . .
diagnostics 3. Communication setting
Serial Parameter Transmission
oK NG
Speed
Data Bit oK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name oK NG
Communication port name (module name) OK NG
Protocol (mode) OK NG
Setup Prefix oK NG
Other detailed settings OK NG . .
4. External device setting
Serial Parameter Transmission
oK NG
Speed
Data Bit oK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
oK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

+ Loader port communication interface of the “XGI / XGR / XEC Series” is fixed as the target configuration value of the following

example.
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5. Cable table

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.

(The cable diagram described in this section may differ from the recommendations of “LS Industrial Systems Co., Ltd.")

m XGI / XGR RS-232C Port on CPU Unit (1:1 connection)

front, front,

cT1s D-SUB 9 Pin male

(male, convex)

D-SUB 9 Pin male cTs

(male, convex)

TOP COM XGI / XGR RS-232C Port on CPU Unit
Pin Signal Pin Cable connection Pin Signal Pin
arrangementNote 1) name number number name arrangement-Note 1)
1 5 CD 1 1 CcD 1 5
g g SD 3 3 D g S’
Based on DTR 4 4 DTR Based on
communication 56 > > 56 communication
cable connector DSR 6 6 DSR cable connector
RTS 7 7 RTS
8 8
9 9

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.

m XEC RS-232C Port on CPU Unit (1:1 connection)

TOP COM XEC RS-232C Port on CPU Unit
Pin Signal Pin Cable connection Pin Signal Pin
arrangement*Note 1) name number number name arrangementNote 1)
CD 1 1
1 5 RD 2 — 2 RD
Q o
o o SD 3 3 SG
6 9 DTR 4 4
Based on SG 5 - 5
communication DSR 6 6 D Based on
cable connector RTS 7 communication
front CTS 8 cable connector
D-SUB 9 Pin male 9 front,
(male, convex) D-SUB 6 Pin male
(male, convex)

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
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6. Supported addresses
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The devices available in TOP are as follows:

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Device Bit Address Word Address Double Word Address | Remark
Input 1X0.0.0 ~ 1X127.15.63 IW0.0.0 ~ QW127.15.3
Output QX0.0.0 ~ QX127.15.63 QWO0.0.0 ~ QW127.15.3
M memory MX0 ~ MX2097151 MWO ~ MW131071 MDO ~ MD65535
W memory WX0 ~ WX8388607 WWO0 ~ WW524287
F memory FX0 ~ FX32767 FWO ~ FW2047 *Note 1)
K memory KX0 ~ KX132959 KWO ~ KW8309
L memory LX0 ~ LX180223 LWO ~ LW11263
R memory RX0 ~ R524287 RWO ~ RW32767
A memory AXO ~ AX4194303 AWO0 ~ AW262143
U memory UX0.0.0 ~ UX7.15.511 UWO0 ~ UW7.15.31

*Note 1) Cannot be written

*The lower 16 BIT data of 32 BIT data is saved in the address whose screen has been registered, and the upper 16 BIT data is saved

in the address next to the address whose screen has been registered.
Ex. When saving 32 BIT data hexadecimal data 12345678 in address D00100, it is saved to 16 BIT device address as follows:

Items 32BIT 16BIT
Address D00100 D00100 D00101
Input data
12345678 5678 1234
(hexadecimal)
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