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1. System configuration

The system configuration of TOP and “CAS Corporation — CAS Indicator CI/NT Series” is as follows:

Link I/F Communication method Communication setting
) 3. TOP communication
CAS Cl Series Built " RS-232C i 5 Cable tabl
uilt-in por setting . Cable table
Indicator NT Series P RS-422/485

4. External device setting

W Connectable configuration

+ 1:1 connection — RS232C/422/485 communication

+ 1:N connection — RS422/ 485 communication
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2. External device selection

H Select a TOP model and a port, and then select an external device.

Select Device H
PLC select [COM1]
Filter : |[AII] v‘ Search : I:I

@ Model (O Vendor

Vendor Model
CAS

-
" Indicator

AED & Indicator XB Series

SEHWA CNM

SHINHAN Electronics
BONGSHIN LOADCELL
FAMUC Co., Ltd.

MINEBEA Co., Ltd.

Azbil Corporation

KORO TECHNOLOGY
ROBOSTAR

Ebmpapst

CoDeSys Automation Alliance
Ophir Optronics Solutions Lid,

SFRUOMFX %

4_Back | B Next *® Cancel

Select Device n

PLC Setting[ Indicator CI/NT Series ]

Alizs Mame @ |PLCL

Interface : | Serial ~

Protocol : | Command Type 3 ~ Comm Manual
String Save Mode : |First LH HL Change

[ use Redundancy
AND v

Primary Option
Timeout 300 &|| msec
Send Wait msec

Retry

Station Num

@ Back + OK * Cancel
Settings Contents
TOP Model Check the TOP display and process to select the touch model.
External device | Vendor Select the vendor of the external device to be connected to TOP.
Select "CAS".
PLC Select an external device to connect to TOP.

Interface Protocol

Indicator CI/NT Series Serial Command Type 3

Please check the system configuration in Chapter 1 to see if the external device you want to

connect is a model whose system can be configured.
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3. TOP communication setting

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that

of the external device.

3.1 Communication setting in TOP Design Studio

(1) Communication interface setting
M [ Project > Project Property > TOP Setting ] — [ HMI Setup > “Use HMI Setup” Check > Edit > Serial ]

— Set the TOP communication interface in TOP Design Studio.

Project Option X

-Change HMI[H] 'Add PLC[A] | THIMl Change PLCIC)

[ Delete PLCID]

Date / Time Sync.  Screen Option Unit Convert

Project Option  Screen Change Global Lock & Touch

se HMI Setup

HmiSetup Project Style  Splash = PLC Buffer Sync.

v - Device Setting

~ 158 COM1(1)

ro® COM2 (0)
o8 COM3 (1)
W Ethernet (0)

..... W9 USEDevice (0)

-4 PLC1: Indicator CI/NT Se

Hmi Setup Option

Initialization

Edit

Project Setting
HMIDisable=0

Project Name=Mew project
Start Mode=Menu

Start Screen MNo.=1

Latch Use=0

Latch Set=0~0
Communication Error Message=0
USBErrorMessage =0
StorageErrorMessage =1
DatabaseMessage=1
SystemMessage=1
DisplayLockIcon=0
DisplayPermissionlcon =0
DarkDraw=0
DrawTouchPos=0
TOPID=1

AutoRun=0

Language =English

Project Advanced Setting
HMIDisable=0
RunSleep=50
EffectSleep=50
CommunicationSleep=1
ProjectLoadType=1
InitDataPrevScreen=1
ErrorLogWrite=0
BlinkTime=0
WatchDog=0
SDCoverOption=0
TaskMonitor=1
CommSleepChgUse=0
CommsSleepChg=1000
MomentaryBitActionTime =20
CommunicationRatio=0

Ethernet

HMIDisable=0

ETH1=1

IP1=192.168.0.100

Subnet1=255,255.255.0 w

Close

Apply

Centrol Panel

System Devices ]:_uaService =% 0ption

Secur ity Date/Time Display Touch Sound

s Serial X

Serial Port:

COM1 ©

Signal Level

(S—
1]
FLE @ RS-232C (O RE-42204) O RS-485(2)

Baud Rate: 9600 v

Data Bit: § -

Serial HOMI

L] [}
TR B

Ethernet Initiali Senzor

-zat ion

Stop Bit: 1 ~

Top Menu Rdsbd
Analysis

Parity Bit: MNone <

Off

Diagrost ic File Fing
Wanager

Feypad

Opt ion F|0|":

Auto Search Loopback Test

[System]

App |y Cancel

Cancel

Get HM Setup OK
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Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C

Baud Rate 9600

Data Bit 8

Stop Bit 1

Parity Bit None.

* The above settings are examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting

M [Project > Project Property > Device Setting > COM > “Indicator CI/NT Series"]

— Set the options of the Indicator CI/NT Series Command Type 3 communication driver in TOP Design Studio.

ERI2 e B X
Touch Qperation Panel

Project Option

- Change HMI[H] ' AddPLCIA] | THITal Change PLCIC | [T Delete PLCID)

v -3 TOF Setting

- S¥5 : RD12105
Option Module Setting Alias Name : |PLC1 |
8 FieldBus (0)

PLC Setting[ Indicator CI/NT Series ]

Interface : | Serial ~

Protocol : |Command Type 3 ~

J String Save Mode : (First LH HL Change

[] use Redundancy

AND v
e g o
e0 -
Conditior Edi
Primary Option

Timeout m msec
Send Wait msec
Retry 5 z

Comm Manual

Apply Close
Items Settings Remarks
Interface Configure the communication interface between the TOP and an external device. Refer to "2. External
Protocol Configure the communication protocol between the TOP and an external device.

device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP's receiving a response from an external device and
sending the next
command request.

Retry

Configure the amount of redelivery attempts from TOP to external device.

Station Num

Set the prefix of an external device.

Device ID
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3.2. Communication setting in TOP

* This is a setting method when “Use HMI Setup” in the setting items in “3.1 TOP Design Studio” is not checked.

W Touch the top of the TOP screen and drag it down. Touch “EXIT" in the pop-up window to go to the main screen.

(1) Communication interface setting

M [Main Screen > Control Panel > Serial]

e

o Conit:roll Panel

@ System Dev
Run — )
n [ Serial Port: ’COM1 l']
m Signal Level
PLC Security

ps| | @ RS-232C (O RS-422(4) O RS-485(2) ]

_— Baud Rate: [ 9600 \'
Lipror mEE_AR Data Bit: |8 -~
:. — Ethernet Serial Stop Bit: [ 1 \vJ
|
S ,__ Parity Bit: | None -
S oo m = Flow [Off -]
" shot ! I q
' Diagnost ic M;Ialg% . [Auto Search] lLoopback Test]

[ Apply H Cancel ] —
orese

[System]

TOPRX - TOPRX0800S A  2021-08-31 04:28:24 PH
Items TOP External device Remarks
Signal Level (port) RS-232C RS-232C
Baud Rate 9600
Data Bit 8
Stop Bit 1
Parity Bit None.

* The above settings are setting examples recommended by the company.

Items Description

Signal Level Select the serial communication method between the TOP and an external device.

Baud Rate Select the serial communication speed between the TOP and an external device.

Data Bit Select the serial communication data bit between the TOP and an external device.

Stop Bit Select the serial communication stop bit between the TOP and an external device.

Parity Bit Select the serial communication parity bit check method between the TOP and an external device.
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(2) Communication option setting
M [Main Screen > Control Panel > PLC]

¥YNC
Yiewer

TOPRX — TOPRX0800S

TO,
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r Conitrol Panel

Serial Port: [CUM1

-

Signal Level

l

PLC Security Da @ RS-232C () RS-422(4) ) RS-485(2) ]

Baud Rate: | 9600 -]

o] SMEE §  DataBit: (B [

Ethernet Serial Stop Bit: [ i lv]
Parity Bit: | None | P

m Er] < Flow: [Off B

Diagnost ic MFile [ﬁuto Search] ‘Loopback Test]

anager
[ Apply ” Cancel J =
[System] e »

A 2021-08-31 04:28:-24 PH

Items Settings Remarks
Interface Configure the communication interface between the TOP and an external device. Refer to "2. External
Protocol Configure the communication protocol between the TOP and an external device.

device selection”.

TimeOut (ms)

Set the time for the TOP to wait for a response from an external device.

SendWait (ms)

Set the waiting time between TOP's receiving a response from an external device and
sending the next command request.

Retry

Configure the amount of redelivery attempts from TOP to external device.

Station Num

Set the prefix of an external device.

Device ID
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3.3 Communication diagnostics

W Check the interface setting status between the TOP and external device.
- Touch the top of the TOP screen and drag it down. Touch "EXIT" in the pop-up window to go to the main screen.
- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device.

W Diagnosis of whether the port communication is normal or not
- Touch “Communication diagnostics” in [Control Panel > PLC].

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status.

oK Communication setting normal

Time Out Error Communication setting abnormal

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet)

B Communication diagnostics sheet

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below.

Items Contents Check Remarks
System How to connect the system OK NG ) )
' . ) 1. System configuration
configuration Connection cable name oK NG
TOP Version information oK NG
Port in use oK NG
Driver name OK NG
Other detailed settings oK NG
Relative prefix Project setting oK NG ) )
— 2. External device selection
Communication . .
. . OK NG 3. TOP communication setting
diagnostics
Serial Parameter Transmission Speed oK NG
Data Bit oK NG
Stop Bit oK NG
Parity Bit oK NG
External device CPU name oK NG
Communication port name (module
oK NG
name)
Protocol (mode) OK NG
Setup Prefix OK NG ) )
- - 4. External device setting
Other detailed settings oK NG
Serial Parameter Transmission Speed oK NG
Data Bit oK NG
Stop Bit oK NG
Parity Bit oK NG
Check address range 6. Supported addresses
OK NG (For details, please refer to the PLC
vendor's manual.)
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4. External device setting

Refer to the user manual of CAS Corporation’s CI/NT Series to identically configure the communication settings of the TOP.
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5. Cable table

TO,

ERI2 e B X
Touch Qperation Panel

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device.

(The cable diagram described in this section may differ from the recommendations of “CAS Corporation”)

m RS-232C
TOP External device
Pin Signal Pin Pin Signal Pin
arrangement*Note 1) | name number number | name | arrangement*Note 1)
1 5
o e} RD 2 2 TXD
SD 3 3 RXD Based on
6 9 communication cable
Based on SG 5 connector front,
communication cable D-SUB 25 Pin male
connector front, - G (male, convex)
D-SUB 9 Pin male
(male, convex)

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.

W RS-422 (1:1 connection)

External device

TOP
Pin Signal Pin
arrangement*Note 1) | name | number
3 5 RDA(+) 1
Q o]
6 9 RDB(-) 4
Based on G 5
communication cable SDA(+) 6
connector front,
D-SUB 9 Pin male
(male, convex)
SDB(-) 9

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.

B RS-485 (1:1 connection)

External device

TOP
Pin Signal Pin
arrangement*Note 1) [ name | number
3 5 RDA(+) 1
Q o
6 9 RDB(-) 4
Based on G
communication cable SDA(+) 6
connector front,
D-SUB 9 Pin male
(male, convex)
SDB(-) 9

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector.
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M RS-485 (1:1 connection)
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External device

TOP
. Signal
Pin arrangement
name
O +
| 10 ,llIsG SG
16,1} -
+

W RS-422 (1:N connection)

External device

Signal name

TOP External device
Signal name Signal name
RDA(+) SDA(+)
RDB(-) SDB(-)
SDA(+) RDA(+)
SDB(-) RDB(-)

W RS-485 (1:N connection)

External device

Signal name

TOP External device
Signal name Signal name
RDA(+) SDA(+)
RDB(-) SDB(-)
SDA(+) RDA(+)
SDB(-) RDB(-)

External device connection manual for TOP Design Studio
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6. Supported addresses
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The devices available in TOP are as follows:

The device range (address) may differ depending on the CPU module series/type. The TOP supports the maximum address range

used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the

address range supported by the device you want to use.

Double word
Device Bit address Word address R/W Remarks
address
WEIGHT - WEIGHT WEIGHT R Weight
STS STSO — STS2 STS STS R Unstable/Stable/Overload*Note 1)
GSNT GSNTO-GSNT1 GSNT GSNT R Total weight/Net weight*Note 2)
*Note 1)
Balance status when the following bit is enabled
STSO Unstable
STS1 Stable
STS2 Overload
*Note 2)
Balance status when the following bit is enabled
GSNTO Gross
GSNT1 Net
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