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MITSUBISHI Electric Corporation 

MELSERVO MR-J3 Series 

MELSERVO J3 Series Driver 
 Supported version TOP Design Studio V1.0 or higher  

 

CONTENTS 

We would like to thank our customers for using M2I's "Touch 

Operation Panel (M2I TOP) Series". Read this manual and familiarize 

yourself with the connection method and procedures of the “TOP and 

external device”. 

 

 

 

1. System configuration Page 2 

 

 

Describes the devices required for connection, the setting of 

each device, cables, and configurable systems. 

2. External device selection  Page 3 

 Select a TOP model and an external device. 

3. TOP communication setting Page 4 

 Describes how to set the TOP communication. 

4. External device setting Page 10 

 Describes how to set up communication for external devices. 

5. Cable table Page 11 

 Describes the cable specifications required for connection. 

6. Supported addresses Page 12 

 Refer to this section to check the addresses which can 

communicate with an external device. 
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1. System configuration 

The system configuration of TOP and “MITSUBISHI Electric Corporation - MELSERVO MR–J3 Series” is as follows: 

 

Series CPU Link I/F 
Communication 

method 

Communication 

setting 
Cable 

MELSERVO 

MR–J3 
MR–J3–□A 

CN3 Port 

on CPU unit 
RS–422 

3. TOP 

communication 

setting 

4. External device 

setting 

5. Cable table 

 

 

■ Connection configuration 
 

ㆍ1:1 (one TOP and one external device) connection – configuration which is possible in RS232C/422/485 communication. 

 
 

ㆍ1:N (one TOP and multiple external devices) connection – configuration which is possible in RS422/485 communication. 
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2. External device selection 

■ Select a TOP model and a port, and then select an external device. 
 

 

 

 

 
 

Settings Contents 

TOP Model Check the TOP display and process to select the touch model. 

External device Vendor Select the vendor of the external device to be connected to TOP. 

Please select “MITSUBISHI Electric Corporation”. 

PLC Select an external device to connect to TOP. 
 

Model Interface Protocol 

MELSERVO J3 Series Computer Link Computer Link 

Please check the system configuration in Chapter 1 to see if the external device you want to 

connect is a model whose system can be configured. 
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3. TOP communication setting 

The communication can be set in TOP Design Studio or TOP main menu. The communication should be set in the same way as that 

of the external device. 
 

3.1 Communication setting in TOP Design Studio 

(1) Communication interface setting 

■ [ Project > Project Property > TOP Setting ] → [ Project Options > “Use HMI Setup” Check > Edit > Serial] 

– Set the TOP communication interface in TOP Design Studio. 

 

 

 

 

 

Items TOP External device Remarks 

Signal Level (port) RS-422 RS-422  

Baud Rate 38400  

Data Bit 8  

Stop Bit 1  

Parity Bit Even  

* The above settings are examples recommended by the company. 

 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device.  

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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(2) Communication option setting 

■ [ Project > Project Property > PLC Settings > COM > “PLC1 : MELSERVO J3 Series”] 

– Set the options of the MELSERVO J3 Series communication driver in TOP Design Studio. 

 

 

 

Items Settings Remarks 

Interface Select “Computer Link”. Refer to “2. External 

device selection”. Protocol Select “Computer Link”. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next 

command request. 

 

Retry Set the number of request retries when the data request result is no 

response/negative response. 
 

Station Num Set the prefix of an external device.  

Decimal Point of 

POS 

Configures the transfer length arrangement of the external device. Must be 

configured identically to the settings of the external device in order for normal 

writing procedure to occur on the POS address.  

*Note) 

*Note) Refer to the user manual of the external device for more details on transfer length arrangement. 

Decimal Point of POS 
Input Scale for Position data 

[mm] [inch] 

0 - 999.999 ~ + 999.999 - 99.9999 ~ + 99.9999 

1 - 9999.99 ~ + 9999.99 - 999.999 ~ + 999.999 

2 - 99999.9 ~ + 99999.9 - 9999.99 ~ + 9999.99 

3 - 999999 ~ + 999999 - 99999.9 ~ + 99999.9 
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3.2. Communication setting in TOP  

* This is a setting method when "Use HMI Setup" in the setting items in "3.1 TOP Design Studio" is not checked. 
 

■ Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen.  

   

(1) Communication interface setting 

■ [ Main Screen > Control Panel > Serial ] 
 

 

Items TOP External device Remarks 

Signal Level (port) RS-422 RS-422  

Baud Rate 38400  

Data Bit 8  

Stop Bit 1  

Parity Bit Even  

* The above settings are setting examples recommended by the company. 
 

Items Description 

Signal Level Select the serial communication method between the TOP and an external device. 

Baud Rate Select the serial communication speed between the TOP and an external device. 

Data Bit Select the serial communication data bit between the TOP and an external device. 

Stop Bit Select the serial communication stop bit between the TOP and an external device. 

Parity Bit Select the serial communication parity bit check method between the TOP and an external device. 
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 (2) Communication option setting 

■ [ Main Screen > Control Panel > PLC ] 
 

 

 

Items Settings Remarks 

Interface Select “Computer Link”. Refer to “2. External 

device selection”. Protocol Select “Computer Link”. 

TimeOut (ms) Set the time for the TOP to wait for a response from an external device.  

SendWait (ms) Set the waiting time between TOP’s receiving a response from an external device and 

sending the next command request. 
 

Retry Set the number of request retries when the data request result is no 

response/negative response. 
 

Station Num Set the prefix of an external device.  

Decimal Point of 

POS 

Configures the transfer length arrangement of the external device. Must be 

configured identically to the settings of the external device in order for normal 

writing procedure to occur on the POS address.  

*Note) 

*Note) Refer to the user manual of the external device for more details on transfer length arrangement. 

Decimal Point of POS 
Input Scale for Position data 

[mm] [inch] 

0 - 999.999 ~ + 999.999 - 99.9999 ~ + 99.9999 

1 - 9999.99 ~ + 9999.99 - 999.999 ~ + 999.999 

2 - 99999.9 ~ + 99999.9 - 9999.99 ~ + 9999.99 

3 - 999999 ~ + 999999 - 99999.9 ~ + 99999.9 
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3.3 Communication diagnostics 

■ Check the interface setting status between the TOP and an external device. 

- Touch the top of the TOP screen and drag it down. Touch “EXIT” in the pop-up window to go to the main screen. 

- Check if the COM port settings you want to use in [Control Panel > Serial] are the same as those of the external device. 

 

■ Diagnosis of whether the port communication is normal or not 

- Touch “Communication diagnostics” in [Control Panel > PLC ]. 

- The Diagnostics dialog box pops up on the screen and determines the diagnostic status. 

OK Communication setting normal 

Time Out Error Communication setting abnormal 

- Check the cable, TOP, and external device setting status. (Reference: Communication diagnostics sheet) 

 

■ Communication diagnostics sheet 

- If there is a problem with the communication connection with an external terminal, please check the settings in the sheet below. 

Items Contents Check Remarks 

System 

configuration 

How to connect the system OK NG 
1. System configuration 

Connection cable name OK NG 

TOP Version information OK NG 

2. External device selection 

3. Communication setting 

Port in use OK NG 

Driver name OK NG 

Other detailed settings OK NG 

Relative prefix Project setting OK NG 

Communication 

diagnostics 
OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

External device CPU name OK NG 

4. External device setting 

Communication port name (module name) OK NG 

Protocol (mode) OK NG 

Setup Prefix OK NG 

Other detailed settings OK NG 

Serial Parameter Transmission 

Speed 
OK NG 

Data Bit OK NG 

Stop Bit OK NG 

Parity Bit OK NG 

Check address range  

OK NG 

6. Supported addresses 

(For details, please refer to the PLC 

vendor's manual.) 
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4. External device setting 

ㆍThe serial communication parameter of the “MELSERVO MR–J3 Series” is configured by the servo amplifier main body’s  

“Push button switch”.  

ㆍReboot the external device after configuration.  

 

For a more detailed setting method than described in this example,  

refer to the user manual of the external device. 

 

 

 

■ Communication Parameter Settings for MELSERVO–J3 Series 

Items Parameter Descriptions 

Prefix number setting Base Parameter No. 20 0 (Default value: 0) 

Select the serial 

communication speed. 

Base Parameter No. 21 

: 0020 

Configure the 4-digit value of the default parameter for No. 16 as shown below: 

 
 

① Select Serial 

Transmission Speed 

② Select Response 

Latency 

0 9600 BPS 0 Null 

1 19200 BPS 1 Valid 

2 38400 BPS   

3 57600 BPS   

4 115200 BPS   
 

 

 

  

 

Push button 

switch 
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5. Cable table  

This chapter introduces a cable diagram for normal communication between the TOP and the corresponding device. 

(The cable diagram described in this section may differ from the recommendations of “MITSUBISHI Electric Corporation”) 
 

■ RS-422 (1:1 connection) 

COM 

Cable connection 

PLC 

Pin 

arrangement*Note 1) 

Signal 

name 

Pin 

number 

Pin 

number 

Signal 

name 

Pin 

arrangement*Note 1) 

 

Based on 

communication 

cable connector 

front, 

D-SUB 9 Pin male 

(male, convex) 

RDA 1  1 LG 

 

Based on 

communication 

cable connector 

front, 

8-pin male RJ45  

(Male, convex) 

 2 2 P5 

 3 3 RDP 

RDB 4 4 SDN 

SG 5 5 SDP 

SDA 6 6 RDN 

 7 7 LG 

 8 8 TRE 

SDB 9  

*Note 1) The pin arrangement is as seen from the connecting side of the cable connection connector. 

 

■ RS-422 (1:N connection) – Refer to 1:1 connection to connect in the following way. 

TOP Cable connection and signal 

direction 

MELSERVO Cable connection and signal 

direction 

MELSERVO 

Signal name Signal name Signal name 

RDA  1 LG  1 LG 

RDB 2 P5 2 P5 

SDA 3 RDA 3 RDA 

SDB 4 SDB 4 SDB 

SG 5 SDA 5 SDA 

  6 RDB  6 RDB 

  7 LG  7 LG 

  8 TRE  8 TRE 
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6. Supported addresses 

The devices available in TOP are as follows:  

The device range (address) may differ depending on the CPU module series/type. The TOP series supports the maximum address 

range used by the external device series. Please refer to each CPU module user manual and be take caution to not deviate from the 

address range supported by the device you want to use. 

 

Device Bit Word Remarks 

Bit Device 

SP SP0 - SP6 - Servo amplifier request    

SP0: Clear status display data 

SP1 : Reset current alarm 

SP2: Clear alarm history 

 

- Restrict or disable input devices (DI), external 

analog input signal, and pulse train input excluding 

the EM2 (force stop 2), LSP (forward rotation stroke 

end), and LSN (reverse rotation stroke end) 

SP3: (a) Restriction 

SP5: (b) Disable restriction 

- Restrict or disable output device (DO) 

SP4: (a) Restriction 

SP6: (b) Disable restriction 

 

Note 1) 

OM OM0 to OM2 

OM4 - OM5 

- Operation mode selection 

READ: Test operation mode 

Read test operation mode 

0000: Normal mode (Not a test operation mode) 

0001: JOG operation 

0002: Positioning operation 

0003: No motor operation 

0004: Output signal (DO) forced export 

WRITE: Select operation mode 

Switch operation mode 

0000: Disable test operation mode 

0001: JOG operation 

0002: Positioning operation 

0004: Output signal (DO) forced export 

TMB TMB1 - TMB6 - 
 Instruction demand 

- Used when paused during a test operation 

(positioning operation) 

TMB1: Pause 

TMB5: Resume remaining length 

TMB6: Clear remaining length 

 

TMB2: Start command for test operation 

(positioning operation) 

- Select positioning direction for test operation 

(positioning operation) 

TMB3: Forward rotation direction 

TMB4: Reverse rotation direction 

Note 1) 
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Device Bit Word Remarks 

OTI OTI0 - OTI5 - OTI0 - One-touch tuning command  

OTI1 - One-touch tuning start command(Basic mode) 

OTI2 - One-touch tuning start command(High mode) 

OTI3 - One-touch tuning start command(Low mode) 

OTI4 - One-touch tuning start command 

OTI5 - Return to initial value 

OTI6 - Return to value before adjustment 

Note 1) 

Word device 

PA PA1.00 - PA32.31 

PA1001.00 - PA1032.31 

PA1 - PA32(RAM) 

PA1001 - PA1032(EEPROM) 

Basic setting parameter 

PB PB1.00 - PB64.31 

PB1001.00- PB1064.31 

PB1 - PB64(RAM) 

PB1001- PB1064(EEPROM) 

Gain filter parameter 

PC PC1.00 - PC80.31 

PC1001.00- PC1080.31 

PC1 - PC80(RAM) 

PC1001- PC1080(EEPROM) 

Extension setting parameter 

PD PD1.00 - PD48.31 

PD1001.00 - PD1048.31 

PD1 - PD48(RAM) 

PD1001 - PD1048(EEPROM) 

I/O setting parameter 

PE PE1.00 - PE64.31 

PE1001.00 - PE1064.31 

PE1 - PE64(RAM) 

PE1001 - PE1064(EEPROM) 

Extension setting No.2 parameter 

PF PF1.00 - PF48.31 

PF1001.00 - PF1048.31 

PF1 - PF48(RAM) 

PF1001 - PF1048(EEPROM) 

Extension setting No.3 parameter 

PO PO1.00 - PO32.31 

PO1001.00 - PO1032.31 

PO1 - PO32(RAM) 

PO1001 - PO1032 

Option unit parameter 

PL PL1.00 - PL48.31 

PL1001.00 - PL1048.31 

PL1 - PL48(RAM) 

PL1001 - PL1048(EEPROM) 

Linear servo motor/DD motor setting parameter 

PT PT1.00 - PT48.31 

PT1001.00 - PT1048.31 

PT1 - PT48(RAM) 

PT1001 - PT1048(EEPROM) 

Positioning control parameter 

ST ST0.00 - ST48.31 ST0 - ST48 Status display 

Note 2) 

AL AL0.00 - AL1.15 

AL11.00 - AL25.15 

AL0 - AL1 

AL11 - AL25 

Alarm (current alarm compatible with J3) 

Note 2) 

AL AL200.00 - AL205.15 

AL210.00 - AL215.15 

AL230.00 - AL235.15 

AL200 - AL205 

AL210 - AL215 

AL230 - AL235 

Alarm (alarm history compatible with J3) 

Note 2) 

ALM ALM0.00 - ALM1.15 

ALM11.00 - ALM59.15 

ALM0 - ALM1 

ALM11 - ALM59 

Alarm (current alarm, extended for J4) 

Note 2) 

ALM ALM200.00 - ALM215.15 

ALM220.00 - ALM235.15 

ALM240.00 - ALM255.15 

ALM200 - ALM215 

ALM220 - ALM235 

ALM240 - ALM255 

Alarm (alarm history, extended for J4) 

Note 2) 

POS POS1.00 - POS255.31 

POS1001.00 - POS1255.31 

POS1 - POS255(RAM) 

POS1001 - 

POS1255(EEPROM) 

Point table (position)  

SPD SPD1.00 - SPD255.31 

SPD1001.00 - SPD1255.31 

SPD1 - SPD255(RAM) 

SPD1001 - SPD1255(EEPROM) 

Point table (speed) 

ACT ACT1.00 - ACT255.31 

ACT1001.00 - ACT1255.31 

ACT1 - ACT255(RAM) 

ACT1001 - ACT1255(EEPROM) 

Point table (acceleration time constant) 

DCT DCT1.00 - DCT255.31 

DCT1001.00 - DCT1255.31 

DCT1 - DCT255(RAM) 

DCT1001 - 

DCT1255(EEPROM) 

Point table (deceleration time constant) 

DWL DWL1.00 - DWL255.31 

DWL1001.00 - DWL1255.31 

DWL1 - DWL255(RAM) 

DWL1001 - 

DWL1255(EEPROM) 

Point table 
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Device Bit Word Remarks 

AUX AUX1.00 - AUX255.31 

AUX1001.00 - AUX1255.31 

AUX1 - AUX255(RAM) 

AUX1001 - 

AUX1255(EEPROM) 

Point table (auxiliary function) 

MCD MCD1.00 - MCD255.31 

MCD1001.00 - MCD1255.31 

MCD1 - MCD255(RAM) 

MCD1001 - 

MCD1255(EEPROM) 

Point table (M code) 

MD MD0.00 - MD11.15 MD0 - MD11 Machine diagnosis data 

OTS OTS0.00 - OTS3.15 OTS0 - OTS3 One-touch tuning data 

DI DI0.00 - DI6.15 DI0 - DI6 External input 

DO DO0.00 - DO4.15 DO0 - DO4 External output 

Note 2) 

DOUBLE WORD DEVICE 

LD LD0.00 - LD1.31 LD0 - LD1 Current position latch data 

Note 2) 

RR RR1.00 - RR4.31 

RR1001.00 - RR100.314 

RR1 - RR4 

RR1001 - RR1004 

The value of the general purpose register 

RD RD1.00 - RD4.31 RD1 - RD4 The value of the general purpose register 

ALD ALD0.00 - ALD1.31 ALD0 - ALD1 Lifetime diagnosis 

TMI TMI0.00 - TMI2.31 TMI0 - TMI2 Input signal for test operation (for test operation) 

Note 1) 

TMO TMO0.00 - TMO0.31 TMO0 Forced output of signal pin (for test operation) 

Note 1) 

TMD TMD0.00 - TMD1.31 

TMD3.00 - TMD3.31 

TMD0 - TMD1 

TMD3 

Set data (for test operation) 

Note 1) 

 

Note 1) Write-only 

Note 2) Read-only 

 

 


